Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 08/12/2010, à 13:17

syl2000

besoin d'aide pour intaller le logiciel sankoré à partir des sources

bonjour à tous


j'avais poster ce message dans la partie eduction,
il a été déplacé dans le café  mais je n'ai pas eu de réponse m'aidant à installer ce logiciel.
je reposte donc en espérant avoir un peu plus d'aide dans cette partie du forum.



je viens de découvrir la libération du TBI(tableau blanc interactif qui permet la réalisation d'exercice numérique) sankoré
http://www.sankore.org/

Le dépôt Subversion de ce projet est accessible de manière anonyme grâce aux commandes suivantes.

svn checkout svn://scm.adullact.net/svnroot/sankore

j'ai réussi à télécharger les sources mais ne n'arrive pas à lancer la compilation

quelqu'un peut il m'expliquer comment faire.
merci

Hors ligne

#2 Le 08/12/2010, à 15:55

xabilon

Re : besoin d'aide pour intaller le logiciel sankoré à partir des sources

Salut

Consulte d'abord cette page :
http://doc.ubuntu-fr.org/tutoriel/compilation
(je te recommande chaudement, pour finaliser l'installation après compilation, d'utiliser checkinstall au lieu de make install)

Si tu as des problèmes ou erreurs, demande.


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#3 Le 08/12/2010, à 21:01

syl2000

Re : besoin d'aide pour intaller le logiciel sankoré à partir des sources

dans le dossier il n'y a pas de fichier configure mais un fichier release.linux.sh

j'ai donc exécuté ce fichier

syl@syl-desktop:~/sankore$ ./release.linux.sh 
svn: La copie de travail '.' est verrouillée
svn : lancer 'svn cleanup' pour enlever les verrous (cf 'svn help cleanup')
bad subversion revision (10:22M)

syl@syl-desktop:~/sankore$ svn cleanup

syl@syl-desktop:~/sankore$ ./release.linux.sh 
A    resources/misc/custom.properties
Segmentation fault
make: *** Pas de règle pour fabriquer la cible « clean ». Arrêt.
./release.linux.sh: 16: /usr/local/Trolltech/Qt-4.6.1/bin/qmake: not found
cat: build/linux/release/version: Aucun fichier ou dossier de ce type
version not found
syl@syl-desktop:~/sankore$ 


voici le fichier

#!/bin/sh

svn update

SVN_REVISION=`svnversion`
# only accept up to date, non modified, non switched svn revisions
if echo $SVN_REVISION | grep -q [:MS]
then
    echo "bad subversion revision ($SVN_REVISION)"
    exit 1
fi

make clean
rm -rf build/linux/release/

/usr/local/Trolltech/Qt-4.6.1/bin/qmake

VERSION=`cat build/linux/release/version`
if [ "$VERSION" = "" ]; then
    echo "version not found"
    exit 1
fi

make release-install

cp resources/linux/run.sh build/linux/release/product
chmod +x build/linux/release/product/run.sh

cp -R /media/UB-DATA/Qt/runtime/linux/4.6.x-uniboard45-lgpl-20100325/* build/linux/release/product

rm -rf install/linux
mkdir -p install/linux

mv build/linux/release/product build/linux/release/Uniboard.$VERSION.$SVN_REVISION
cd build/linux/release

# "Removing .svn directories ..."
find . -name .svn -exec rm -rf {} \; 2> /dev/null
tar cvzf ../../../install/linux/Uniboard.$VERSION.$SVN_REVISION.tar.gz Uniboard.$VERSION.$SVN_REVISION -C .

cd ../../..
#./publish.rb "install/linux/Uniboard.$VERSION.$SVN_REVISION.tar.gz" "$VERSION" "$SVN_REVISION" resources/linux/appcast-linux.xml

cp install/linux/Uniboard.$VERSION.$SVN_REVISION.tar.gz ~/Dropbox/uniboard

Dernière modification par slasher-fun (Le 08/12/2010, à 22:39)

Hors ligne

#4 Le 08/12/2010, à 22:03

xabilon

Re : besoin d'aide pour intaller le logiciel sankoré à partir des sources

Le script devrait s'occuper de compiler et installer ...
Le site de Sankoré ne dit rien quant à l'installation des logiciels ... il n'y a pas un fichier README avec les sources ?

Je vais essayer de le télécharger et tester, mais il doit te manquer pas mal de bibliothèques de développement


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#5 Le 09/12/2010, à 03:07

xabilon

Re : besoin d'aide pour intaller le logiciel sankoré à partir des sources

Bon, ça va pas être du gâteau ...
Tout d'abord il faut installer le paquet qt4-qmake
Puis j'ai modifié le script linux.release.sh (avec gedit) pour mettre le bon chemin vers l'exécutable qmake, en remplaçant :
/usr/local/Trolltech/Qt-4.6.1/bin/qmake
par
/usr/bin/qmake

Ensuite je relance le script, et j'arrive à un beau :
À la révision 22.
bad subversion revision (22M)

J'ai zappé la vérification de la revision, j'arrive à d'autres erreurs ...
Le script ne m'a pas l'air fait pour marcher partout, en plus il n'y a pas d'indication des dépendances nécessaires (mise à part Qt4 et ses bibliothèques de dev)...

Bref, t'es pas sorti de l'auberge. Je serais toi, je demanderais plutôt sur le forum de Sankoré :
https://adullact.net/forum/?group_id=697


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#6 Le 10/12/2010, à 18:19

syl2000

Re : besoin d'aide pour intaller le logiciel sankoré à partir des sources

merci je vais déja faire ce que tu m'indique puis j'irais sur  leur forum

Hors ligne

#7 Le 13/12/2010, à 11:30

francoisa

Re : besoin d'aide pour intaller le logiciel sankoré à partir des sources

Sinon, il y a une version déjà compilée pour Ubuntu 32 et 64 bits ici :
https://redmine.ryxeo.com/projects/lete … kore/files

Nous (le projet AbulEdu) suivons le projet avec intérêt et tâchons de contribuer en proposant des patches et nettoyage du code.


Comment promouvoir l'informatique dans nos écoles ?
AbulEdu, solution logicielle libre http://www.abuledu.org
AbulEdu-fr, association des utilisateurs d'AbulÉdu http://abuledu-fr.org

Hors ligne

#8 Le 14/12/2010, à 00:44

xabilon

Re : besoin d'aide pour intaller le logiciel sankoré à partir des sources

Ben c'est cool pour lui big_smile
Il faudrait peut-être proposer de mettre un lien vers les paquets compilés sur le site de sankoré.


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#9 Le 28/12/2010, à 01:31

houbahop69

Re : besoin d'aide pour intaller le logiciel sankoré à partir des sources

francoisa a écrit :

Sinon, il y a une version déjà compilée pour Ubuntu 32 et 64 bits ici :
https://redmine.ryxeo.com/projects/lete … kore/files

Nous (le projet AbulEdu) suivons le projet avec intérêt et tâchons de contribuer en proposant des patches et nettoyage du code.


Bonjour,
Merci pour le travail exécuté:cool:, vous serait-il possible de contribuer sur la forge Sankoré en expliquant comment parvenir à compiler le code en 64 bits:/. J'ai des machines en Debian (squeeze) et Ubuntu (Maverick) je suppose que la recette doit être extrêmement voisine mais  si les deux versions sont connues ce sera super smile

Je pense que ce logiciel peut faire évoluer la façon d'enseigner et permettre de proposer des multimedia à très forte plus value et très innovants:).

Hors ligne

#10 Le 08/01/2011, à 16:30

totola

Re : besoin d'aide pour intaller le logiciel sankoré à partir des sources

Bonjour,
Avez-vous réussi à installer ce logiciel? J'ai téléchargé l'archive pour ubuntu (je suis sous lucid) et voilà ce que j'obtiens:

./run.sh
./Sankore 3.1: symbol lookup error: ./Sankore 3.1: undefined symbol: _ZN9QListData11detach_growEPii

Merci de votre aide!

Dernière modification par totola (Le 08/01/2011, à 16:30)

Hors ligne

#11 Le 08/01/2011, à 18:00

syl2000

Re : besoin d'aide pour intaller le logiciel sankoré à partir des sources

j'ai réussi mais en passant sur la 10.10 car sur le site de sankore il on fait un deb qui marche bien.

sinon avez vous essayé le lien de françoisa ?

il a tenté de m'aider par mail mais j'avais un problème de lib avec sa version mais vous aurez peut être plus de chance que moi

Hors ligne

#12 Le 08/01/2011, à 20:47

totola

Re : besoin d'aide pour intaller le logiciel sankoré à partir des sources

Bonsoir et merci de la réponse,

Je n'ai pas vu de deb sur le site de sankoré? Je n'ai trouvé que le tar.gz que j'ai téléchargé...
Pourriez-vous me donner le lien exact?

Sinon, j'ai aussi essayé le lien de francoisa, j'ai la même erreur que plus haut...

Merci!

[EDIT] Ce serait parce que je suis en 10.04?? Je n'espère pas car je n'ai pas l'intention de changer! La version LTS me convient parfaitement.

Dernière modification par totola (Le 08/01/2011, à 21:13)

Hors ligne

#13 Le 09/01/2011, à 13:35

totola

Re : besoin d'aide pour intaller le logiciel sankoré à partir des sources

Bon j'ai installé maverick dans virtual box et ça fonctionne effectivement très bien...

Dommage, tous mes postes au lycée son sous lucid, et je n'ai pas l'intention de changer jusqu'à la prochaine LTS...

Dernière modification par totola (Le 09/01/2011, à 13:35)

Hors ligne

#14 Le 12/01/2011, à 08:20

Dortmunter

Re : besoin d'aide pour intaller le logiciel sankoré à partir des sources

Bonjour,

j'ai tenté l'installation avec mon netbook sous 10.10 mais la commande ./run.sh me renvoie :
./Sankore 3.1: error while loading shared librairies: libQtXmlPatternrs.so.4: cannot open shared object file: No such file or directory.

y a-t-il une paquet à télécharger ? Ou changer le répertoire d'install (dans mon home pour le moment)

Merci d'avance

Hors ligne

#15 Le 12/01/2011, à 08:33

Dortmunter

Re : besoin d'aide pour intaller le logiciel sankoré à partir des sources

Oups, je me réponds moi-même, ça m'apprendra à chercher davantage avant de poster. J'avais effectivement un paquet non installé, que je viens de trouver par une recherche plus minutieuse dans synaptic !

Hors ligne

#16 Le 13/01/2011, à 18:06

JosephK

Re : besoin d'aide pour intaller le logiciel sankoré à partir des sources

J'ai fait quelques tests avec la version "ubuntu" qu'on trouve sur Framasoft et  la version "compilée" fournie par Ryxéo (qu'on trouve aussi sur Framasoft en fait).

Première remarque, avec la version Ryxéo on obtient ce message d'erreur sur Maverick et Lucid :

./Sankore 3.1: error while loading shared libraries: libpoppler.so.4: cannot open shared object file: No such file or directory

On peut régler le problème en créant un lien symbolique selon la version de la libpoppler qu'on a :
Sur Maverick

sudo ln -s /usr/lib/libpoppler.so.7.0.0 /usr/lib/libpoppler.so.4

Sur Lucid

sudo ln -s /usr/lib/libpoppler.so.5.0.0 /usr/lib/libpoppler.so.4

Ensuite on obtient exactement les mêmes résultats qu'avec la version "officielle", la seule différence c'est que celle de Ryxéo est en anglais... roll

En exécutant le fichier Sankore 3.1 dans un terminal (le fichier run.sh ne fait que lancer le fichier Sankore donc ça revient exactement au même) on se rend vite compte des dépendances qu'il faut installer (en sélectionnant libqt4-webkit et libqt4-svg ça installe tout ce qu'il faut a priori) :

À installer a écrit :

libqt4-dbus, libqt4-xmlpatterns, libqt4-webkit, libqtcore4, libphonon4, libqt4-xml, libqt4-network, libqt4-designer, libqtgui4, libqt4-script, libaudio2, libqt4-svg

Sur Maverick aucun problème, ça tourne et a priori c'est fait pour.
Par contre sur Lucid on obtient ce message :

./Sankore 3.1: symbol lookup error: ./Sankore 3.1: undefined symbol: _ZN9QListData11detach_growEPii

C'est du à un conflit de version de qt. Sur Maverick c'est la version 4.7 et sur Lucid la version 4.6
Du coup, j'ai tenté de mettre à jour qt à partir des dépôts de maverick. A priori ça marche, mais il faut vérifier que les autres logiciels qui se servent de ces librairies non pas de problèmes (logiciels de l'environnement KDE, Opera, VLC, Midori...).

Bref, pour faire ça, on modifie le fichier /etc/apt/sources.list tout en gardant synaptic ouvert. On remplace lucid par maverick comme pour procéder à une mise à niveau et on enregistre le fichier (pas la peine de le fermer). On "recharge" synaptic et on sélectionne la mise à jour pour libqt4-webkit par exemple et le reste de la librairie et ses dépendances suit.

À installer a écrit :

libmodplug1, libxine1-x, libxine1-misc-plugins, libxcb-xv0, phonon, libjack-jackd2-0, libqtwebkit4, libxine1-bin, liblqr-1-0, libdirectfb-1.2-9, libxcb-shape0, libmagickcore3, phonon-backend-xine, libmagickwand3, libxcb-shm0, libmpcdec6, libxine1-console, libxine1

À mettre à jour a écrit :

libcaca0, libqt4-dbus, libsqlite3-0, libqt4-xmlpatterns, libqt4-webkit, libqtcore4, libqt4-svg, libphonon4, libqt4-xml, libqt4-network, libqt4-designer, libasound2-plugins, libqtgui4, libqt4-script, libmng1

À désinstaller a écrit :

libjack0

On applique les modifications, puis on annule le changement de dépôt dans le fichier sources.list et pour finir on recharge synaptic.
Normalement, les paquets sont considérés comme obsolètes, locaux ou à supprimer... mais tant pis : Sankore fonctionne. smile

Hors ligne

#17 Le 14/01/2011, à 10:16

JosephK

Re : besoin d'aide pour intaller le logiciel sankoré à partir des sources

Je précise que sur le TBI où j'ai fait le test il y avait aussi VLC et Active Inspire et ça n'a pas l'air de les déranger.
Par contre, je n'ai pas trouvé comment configurer le proxy pour le navigateur de Sankoré.
Est-ce que quelqu'un y est déjà parvenu ?

Hors ligne

#18 Le 18/01/2011, à 20:05

totola

Re : besoin d'aide pour intaller le logiciel sankoré à partir des sources

Bonjour,

Merci pour la procédure d'installation sur lucid! Mais en ce qui me concerne j'ai finalement migré sur Maverick...
Bon, j'ai un autre problème: j'essaie de faire une activité interactive et d'après le manuel il faut ouvrir la bibliothèque et choisir l'onglet "générateur d'interactivités" où il est proposé des modèles d'interactivités, seulement je n'ai pas cette onglet! J'ai bien des modèles d'activités toutes faites, mais pas vraiment modifiables....

C'est pareil chez vous??

Dernière modification par totola (Le 18/01/2011, à 20:05)

Hors ligne

#19 Le 25/01/2011, à 19:17

totola

Re : besoin d'aide pour intaller le logiciel sankoré à partir des sources

totola a écrit :

il faut ouvrir la bibliothèque et choisir l'onglet "générateur d'interactivités" où il est proposé des modèles d'interactivités, seulement je n'ai pas cette onglet

Parmis ceux qui ont installé ce logiciel, je suis le seul dans ce cas???

Hors ligne

#20 Le 20/06/2011, à 14:47

scoude

Re : besoin d'aide pour intaller le logiciel sankoré à partir des sources

JosephK a écrit :

J'ai fait quelques tests avec la version "ubuntu" qu'on trouve sur Framasoft et  la version "compilée" fournie par Ryxéo (qu'on trouve aussi sur Framasoft en fait).

Première remarque, avec la version Ryxéo on obtient ce message d'erreur sur Maverick et Lucid :

./Sankore 3.1: error while loading shared libraries: libpoppler.so.4: cannot open shared object file: No such file or directory

On peut régler le problème en créant un lien symbolique selon la version de la libpoppler qu'on a :
Sur Maverick

sudo ln -s /usr/lib/libpoppler.so.7.0.0 /usr/lib/libpoppler.so.4

Sur Lucid

sudo ln -s /usr/lib/libpoppler.so.5.0.0 /usr/lib/libpoppler.so.4

Ensuite on obtient exactement les mêmes résultats qu'avec la version "officielle", la seule différence c'est que celle de Ryxéo est en anglais... roll

En exécutant le fichier Sankore 3.1 dans un terminal (le fichier run.sh ne fait que lancer le fichier Sankore donc ça revient exactement au même) on se rend vite compte des dépendances qu'il faut installer (en sélectionnant libqt4-webkit et libqt4-svg ça installe tout ce qu'il faut a priori) :

À installer a écrit :

libqt4-dbus, libqt4-xmlpatterns, libqt4-webkit, libqtcore4, libphonon4, libqt4-xml, libqt4-network, libqt4-designer, libqtgui4, libqt4-script, libaudio2, libqt4-svg

Sur Maverick aucun problème, ça tourne et a priori c'est fait pour.
Par contre sur Lucid on obtient ce message :

./Sankore 3.1: symbol lookup error: ./Sankore 3.1: undefined symbol: _ZN9QListData11detach_growEPii

C'est du à un conflit de version de qt. Sur Maverick c'est la version 4.7 et sur Lucid la version 4.6
Du coup, j'ai tenté de mettre à jour qt à partir des dépôts de maverick. A priori ça marche, mais il faut vérifier que les autres logiciels qui se servent de ces librairies non pas de problèmes (logiciels de l'environnement KDE, Opera, VLC, Midori...).

Bref, pour faire ça, on modifie le fichier /etc/apt/sources.list tout en gardant synaptic ouvert. On remplace lucid par maverick comme pour procéder à une mise à niveau et on enregistre le fichier (pas la peine de le fermer). On "recharge" synaptic et on sélectionne la mise à jour pour libqt4-webkit par exemple et le reste de la librairie et ses dépendances suit.

À installer a écrit :

libmodplug1, libxine1-x, libxine1-misc-plugins, libxcb-xv0, phonon, libjack-jackd2-0, libqtwebkit4, libxine1-bin, liblqr-1-0, libdirectfb-1.2-9, libxcb-shape0, libmagickcore3, phonon-backend-xine, libmagickwand3, libxcb-shm0, libmpcdec6, libxine1-console, libxine1

À mettre à jour a écrit :

libcaca0, libqt4-dbus, libsqlite3-0, libqt4-xmlpatterns, libqt4-webkit, libqtcore4, libqt4-svg, libphonon4, libqt4-xml, libqt4-network, libqt4-designer, libasound2-plugins, libqtgui4, libqt4-script, libmng1

À désinstaller a écrit :

libjack0

On applique les modifications, puis on annule le changement de dépôt dans le fichier sources.list et pour finir on recharge synaptic.
Normalement, les paquets sont considérés comme obsolètes, locaux ou à supprimer... mais tant pis : Sankore fonctionne. smile

Bonjour,

je viens de réussir à compiler Sankoré 3.1.1 sous Ubuntu 11.04 Natty 32 et 64 bits.

je présente la méthode à cette page :

http://serge.coude.net/code-source/compilations.php5

Cordialement,

Serge COUDÉ

Hors ligne