Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 05/01/2011, à 00:22

Vyrob

Problème avec html-helper-mode pour emacs

Bien le bonsoir,

Voilà, avec toute la bonne volonté du monde, je souhaite me mettre à programmer en XHTML avec emacs. Après un petit

apt-get install html-helper-mode

, je crée et ouvre un nouveau document XHTML. A ma grande surprise, la doctype qui est automatiquement insérée est celle du HTML 4.01. De plus, lorsque j'appuie sur la touche tabulation, emacs refuse tout bonnement d'indenter mon code. J'ai donc voulu bidouiller le fichier de configuration du html-helper-mode pour corriger cela. J'ai donc finalement trouvé un fichier contenant la ligne de la doctype dont j'ai parlé plus haut, il se trouve dans le dossier

/usr/share/emacs/site-lisp/html-helper-mode

j'ai donc modifié ladite ligne, sauvegardé le fichier, et quitté emacs. Je recrée donc un nouveau fichier XHTML, l'ouvre, et constate que malheureusement, la doctype est restée inchangée.

Concrètement, voilà ma question :

=> en ayant installé le html-helper-mode comme je l'ai fait, quel(s) fichier(s) dois-je modifier pour changer le code inséré lors de la création d'un nouveau document XHTML et permettre à la touche tabulation de fonctionner à nouveau comme dans les autres modes ?

En vous remerciant d'avance,

Vyrob.

Dernière modification par Vyrob (Le 05/01/2011, à 00:45)

Hors ligne

#2 Le 05/01/2011, à 00:27

Ypnose

Re : Problème avec html-helper-mode pour emacs

Ayant été à ta place, il y a quelques mois je te conseille d'installer Komodo-Edit qui est un IDE très pratique.

http://doc.ubuntu-fr.org/komodo_edit

Quand à ton problème, je ne peux malheureusement pas t'aider.

#3 Le 06/01/2011, à 00:26

Vyrob

Re : Problème avec html-helper-mode pour emacs

J'apprécie l'intention, merci, mais je tiens réellement à développer avec emacs.

Personne ne connaît la réponse à mon problème ? (Up o/)

Hors ligne

#4 Le 07/01/2011, à 23:30

Vyrob

Re : Problème avec html-helper-mode pour emacs

Up.

Hors ligne

#5 Le 09/01/2011, à 15:38

Vyrob

Re : Problème avec html-helper-mode pour emacs

Up.

Hors ligne

#6 Le 09/01/2011, à 17:06

kamui57

Re : Problème avec html-helper-mode pour emacs

j'ai trouvé ça http://forum.ubuntu-fr.org/viewtopic.ph … 0#p2379590 qui dit que nxhtml c'est bien, le site officiel a l'air d'être http://ourcomments.org/Emacs/nXhtml/doc/nxhtml.html, voici la page du wiki d'emacs qui en parle http://www.emacswiki.org/cgi-bin/wiki/NxhtmlMode

edit : ne l'ayant pas trouvé dans la doc, j'ai commencé une page dans mon espace perso, elle pourrait te servir.
nXhtml pour Emacs

j'ai crée une page dans la doc : nxhtml

Dernière modification par kamui57 (Le 15/01/2011, à 23:07)


Quand le dernier arbre aura été abattu, et le dernier animal exterminé, les hommes se rendront compte que l'argent ne se mange pas (proverbe indien)
Toshiba Satellite L655 4 Go RAM, Archlinux Gnome-shell,LXDE / W7
Toshiba Satellite M30 512 Mo RAM, Archlinux Gnome 3 restreint / Crunchbang LXDE
https://help.ubuntu.com/community/Pastebinit pour poster du texte sur internet en console

Hors ligne

#7 Le 10/01/2011, à 10:55

Vyrob

Re : Problème avec html-helper-mode pour emacs

Merci de ta réponse, je vais regarder ces liens et je reposterai ;-) .

Hors ligne

Haut de page ↑