Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 17/06/2005, à 10:52

eldadou38

[RESOLU] Enemy-territory : Problème de Drivers graphique ?!

Bonjour,

  Voilà, j'ai installé la version 2.60 de ET => Nickel big_smile
  Ubuntu (5.04), Gnome (xorg.conf) sur IBM portable Pentium III 1Ghz, 512 RAM, CG ATI RADEON 16 Mo, DD 30Go.

  Je lance le jeu via 'et' et là, message d'erreur sad

  ...loading libGL.so.1: Initializing OpenGL display
  ...setting mode 4: 800 600
  Using XFree86-VidModeExtension Version 2.2
  XF86DGA Mouse (Version 2.0) initialized
  XFree86-VidModeExtension Activated at 800x600
  Using 8/8/8 Color bits, 16 depth, 0 stencil display.
  Xlib:  extension "XFree86-DRI" missing on display ":0.0".
  GL_RENDERER: Mesa GLX Indirect
  ***********************************************************
   You are using software Mesa (no hardware acceleration)!
   Driver DLL used: libGL.so.1
   If this is intentional, add
       "+set r_allowSoftwareGL 1"
   to the command line when starting the game.
***********************************************************
   ...WARNING: could not set the given mode (4)
   Initializing OpenGL display
   ...setting mode 3: 640 480
   Using XFree86-VidModeExtension Version 2.2
   XF86DGA Mouse (Version 2.0) initialized
   XFree86-VidModeExtension Activated at 640x480
   Received signal 11, exiting...

   J'ai suivi à la lettre toutes les explications fournis sur les sites suivants :

    Installation http://ubuntuforums.org/showthread.php? … +territory
    Drivers Graphiquehttps://wiki.ubuntu.com/BinaryDriverHowto

   Et malgré cela le jeux reste bloqué en 640x480 sur un écran noir.

   Ma carte est trop légére ?? A savoir que sur une autre partition(WinXP), j'ai des jeux comme Quake3, GTA ViceCity, Warcraft 3 et ils marchent tous parfaitement.

   Auriez-vous une solution à mon problème ?

   Merci.

A+
El Dadou tongue

Dernière modification par eldadou38 (Le 17/06/2005, à 16:55)


In Ubuntu I trust

Hors ligne

#2 Le 17/06/2005, à 11:48

eldadou38

Re : [RESOLU] Enemy-territory : Problème de Drivers graphique ?!

...Personne... roll

Allez +1 wink

El Dadou tongue


In Ubuntu I trust

Hors ligne

#3 Le 17/06/2005, à 12:08

Gandhi

Re : [RESOLU] Enemy-territory : Problème de Drivers graphique ?!

J'avais le meme probleme mais c'est seulement quand j'ai suivit le deuxieme tuto du wiki ca a marché à partir de là

Autre version A

et j'usqu'a la derniere astuce

voila j'espere que ca peut t'aider mais je ne suis qu'un debutant sous ubuntu

PS tut peux peut etre poster ton xorg.conf

#4 Le 17/06/2005, à 12:23

eldadou38

Re : [RESOLU] Enemy-territory : Problème de Drivers graphique ?!

Salut Gandhi,

  Voici mon xorg.conf :

    Section "Files"
    FontPath    "unix/:7100"            # local font server
    # if the local font server has problems, we can fall back on these
    FontPath    "/usr/lib/X11/fonts/misc"
    FontPath    "/usr/lib/X11/fonts/cyrillic"
    FontPath    "/usr/lib/X11/fonts/100dpi/:unscaled"
    FontPath    "/usr/lib/X11/fonts/75dpi/:unscaled"
    FontPath    "/usr/lib/X11/fonts/Type1"
    FontPath    "/usr/lib/X11/fonts/CID"
    FontPath    "/usr/lib/X11/fonts/100dpi"
    FontPath    "/usr/lib/X11/fonts/75dpi"
        # paths to defoma fonts
    FontPath    "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    FontPath    "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
    Load    "bitmap"
    Load    "dbe"
    Load    "ddc"
    Load    "dri"
    Load    "extmod"
    Load    "freetype"
    Load    "glx"
    Load    "int10"
    Load    "record"
    Load    "type1"
    Load    "vbe"
EndSection

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "keyboard"
    Option        "CoreKeyboard"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "pc105"
    Option        "XkbLayout"    "fr-latin9"
EndSection

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
    Option        "Device"        "/dev/input/mice"
    Option        "Protocol"        "ImPS/2"
    Option        "Emulate3Buttons"    "true"
    Option        "ZAxisMapping"        "4 5"
EndSection
Section "InputDevice"
        Identifier      "Synaptics Touchpad"
        Driver          "synaptics"
        Option          "SendCoreEvents"        "true"
        Option          "Device"                "/dev/psaux"
        Option          "Protocol"              "auto-dev"
        Option        "HorizScrollDelta"    "0"
EndSection

Section "Device"
    Identifier    "ATI Technologies, Inc. Radeon Mobility 9000 (M6 LY)"
    Driver        "ati"
    #Driver        "fglrx" Fait planter X11 (mode console)
    BusID        "PCI:1:0:0"
EndSection

Section "Monitor"
    Identifier    "Écran générique"
    Option        "DPMS"
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Device        "ATI Technologies, Inc. Radeon Mobility 9000 (M6 LY)"
    Monitor        "Écran générique"
    DefaultDepth    24
    SubSection "Display"
        Depth        1
        Modes        "1400x1050"
    EndSubSection
    SubSection "Display"
        Depth        4
        Modes        "1400x1050"
    EndSubSection
    SubSection "Display"
        Depth        8
        Modes        "1400x1050"
    EndSubSection
    SubSection "Display"
        Depth        15
        Modes        "1400x1050"
    EndSubSection
    SubSection "Display"
        Depth        16
        Modes        "1400x1050"
    EndSubSection
    SubSection "Display"
        Depth        24
        Modes        "1400x1050"
    EndSubSection
EndSection

Section "ServerLayout"
    Identifier    "Default Layout"
    Screen        "Default Screen"
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
    InputDevice    "Synaptics Touchpad"
EndSection

Section "DRI"
    Mode    0666
EndSection

#Section "Extensions"
#        Option "composite" "On"
#EndSection

   Par contre tu parles du deuxième tuto Wiki, t'as un lien ?

   Merci pour ton aide.

El Dadou tongue


In Ubuntu I trust

Hors ligne

#5 Le 17/06/2005, à 16:49

eldadou38

Re : [RESOLU] Enemy-territory : Problème de Drivers graphique ?!

Ok, c'est bon j'ai trouvé et tout marche nickel !!!! lancement du jeu + son.

   La solution pour portable A30p avec ATI RADEON Mobility (bon drivers sur linux, glxgears nickel).
   En fait j'ai suivi betement (c'est vrai que parfois on ne sait pas lire, alors qu'il nous dit tout roll) ce qu'il me disait :

       ***********************************************************
       You are using software Mesa (no hardware acceleration)!
       Driver DLL used: libGL.so.1
       If this is intentional, add
         "+set r_allowSoftwareGL 1"
       to the command line when starting the game.
      ***********************************************************

   Ni une ni deux, # et "+set r_allowSoftwareGL 1" et la .... CA MARCHE !! lol

   Voiloù.

  RAJOUT : J'ai aussi modifier mon xorg.conf en rajoutant, pour chaque subsection Display les formats possibles :

     SubSection "Display"
        Depth        1
        Modes        "1400x1050" "1280x1080" "800x600" etc....
    EndSubSection


A+
El Dadou tongue

Dernière modification par eldadou38 (Le 17/06/2005, à 16:54)


In Ubuntu I trust

Hors ligne

  • Accueil
  • » Forum
  • » Jeux
  • » [RESOLU] Enemy-territory : Problème de Drivers graphique ?!

Haut de page ↑