Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 12/06/2005, à 14:54

Teejee

Pas de fichier SMBPASSWD ....

Bonjour a toute la communauté, alors voila je m'explique, j'ai realisé l'installation de samba grace a l'apt-get. Mon gros probleme actuellement c'est que le fichier smbpasswd n'existe pas.

Je peux tt a faire creer des utilisateurs samba grace a la commande smbpasswd -a user. Le seul probleme c'est que je ne sais pas ou les utilisateurs sont creer.

Je l'ai creer moi meme dans /etc/samba/, j'ai rajouté les lignes suivante dans le fichier smb.conf  : smb passwd file = /etc/samba/smbpasswd
   username map =  /etc/smbusers

yikes Malgré cet ajout, rien a faire, mes utilisateurs sont creer je ne sais trop ou .... Si quelqu'un a deja eu ce probleme, je serai ravi qu'il m'en fasse profiter ..... cool

Merci a vous tous !!!!

{  teejee  }

#2 Le 12/06/2005, à 20:29

Gillaume

Re : Pas de fichier SMBPASSWD ....

regarde dans /etc/samba.

normalement, il y est.
gui


Guili Guili

Hors ligne

#3 Le 14/06/2005, à 00:48

oli-net

Re : Pas de fichier SMBPASSWD ....

Salut à tous,
Moi aussi, j'ai le même soucis! Voici le contenu de mon répertoire /etc/samba/

root@ubuntu:/home/olivier # ls -la /etc/samba/
total 25
drwxr-xr-x    2 root root  1024 2005-06-12 22:47 .
drwxr-xr-x  102 root root  4096 2005-06-13 19:27 ..
-rw-r--r--    1 root root     8 2005-03-22 08:46 gdbcommands
-rw-r--r--    1 root root 10422 2005-06-12 22:26 smb.conf
-rw-r--r--    1 root root  7728 2005-06-12 19:01 smb.conf.bak
root@ubuntu:/home/olivier #

RIEN, aucun des fichiers normaux de SaMBa n'est présent. Je ne vois pas non plus SMBUSERS.
Ma config est OK voici ce que donne un smbclient:

Domain=[TUX-NET] OS=[Unix] Server=[Samba 3.0.14a-Debian]

        Sharename       Type      Comment
        ---------       ----      -------
        netlogon        Disk      Network Logon Service
        print$          Disk      Printer Drivers
        cdrom           Disk      Samba server's CD-ROM
        public          Disk      Partage libre
        videos          Disk      Videos
        IPC$            IPC       IPC Service (Ubuntu Shuttle GNU/Linux)
        ADMIN$          IPC       IPC Service (Ubuntu Shuttle GNU/Linux)
        olivier         Disk      Home Directories
Domain=[TUX-NET] OS=[Unix] Server=[Samba 3.0.14a-Debian]

        Server               Comment
        ---------            -------
        SHUTTLE              Ubuntu Shuttle GNU/Linux

        Workgroup            Master
        ---------            -------
        MS-HOME              DEVSTUDIO
        TUX-NET              SHUTTLE
root@ubuntu:/home/olivier #

J'ai configuré SaMBa en PDC, mais là aussi, impossible de connecter mon XP Pro au domaine TUX-NET. Il me semble qu'un compte machine doit être créé automatiquement, mais ça ne fonctionne pas...

Si quelqu'un à une expérience réussi de SaMBa sous Ubuntu,... je suis preneur

Merci d'avance

Hors ligne

#4 Le 14/06/2005, à 08:28

Gillaume

Re : Pas de fichier SMBPASSWD ....

[global]
workgroup = guigui
netbios name = ftp
hosts allow = 192.168.0.
hosts deny = all
server string = serveur ftp guigui
encrypt passwords = Yes
map to guest = Bad User
obey pam restrictions = Yes
smb passwd file = /etc/samba/smbpasswd %u
log file = /var/log/samba/log.%m
max log size = 50
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
printcap name = cups
dns proxy = No
guest account = smbguest
printer admin = @adm
printing = cups
username map = /etc/samba/smbusers
security = user

[homes]
comment = repertoire personnel de guigui
read only = No
create mask = 0750
directory mask = 0750
browseable = No

voici un smb.conf de base qui fonctionne sur mon réseau.
je ne me suis pas préoccupé de smbpasswd.
qd j'ai créé mon smb.conf, et que j'ai redémarré samba, le smbpasswd %u a été créé !
pour smbusers, j'ai fait :
sudo touch /etc/samba/smbusers
c'est tout.

ya une méthode pour avoir le smbpasswd, si jamais ma solution ne marche pas pour toi :

création de smbpasswd :
dans un term :

se mettre dans /etc

cat passwd | mksmbpasswd.sh > /etc/samba/smbpasswd

sur ubuntu, je pense que j'ai remplacé mksmbpasswd.sh par mkpasswd.
je sais plus.
tiens nous au jus.
gui


Guili Guili

Hors ligne

#5 Le 14/06/2005, à 18:56

Teejee

Re : Pas de fichier SMBPASSWD ....

Je tenais tt d'abord a vous remercier ....... Bon je revenons a mon probleme !!

J'ai crée smbpasswd de la facon presenté mais rien a faire. Le fichier est bien creer correctement, il contient l'ensemble des utilisateurs unix mais n'est absolument pas pris en compte par samba .....

Je peux bien creer mes utilisateurs samba mais dans un fichier inconnu ..... Aucune idée de l'endroit ou se trouve mes utilisateurs ...

Si vous avez une autre proposition, je suis preneur ....

Merci a tous ...

{   Tom   }

#6 Le 15/06/2005, à 01:41

oli-net

Re : Pas de fichier SMBPASSWD ....

Salut à tous,

@ Guillaume :
Merci pour les commandes:
touch /etc/samba/smbusers et sous Ubuntu
cat passwd | mkpasswd > /etc/samba/smbpasswd
Mais mon XP Pro refuse d'entrer sur le domaine que j'ai créé. Si j'utilise root pour faire l'enregistrement, il me dit "accès refusé" et si j'utilise mon login normal, il me dit que "le nom d'utilisateur est introuvable".
Pourtant dans mon smb.conf je n'ai pas mis "invalid users = root" et j'ai créé un compte SaMBa pour root. J'ai aussi redémarré SaMBa.

Je ne comprends plus rien.... Pourtant tout semble OK!
Voici mon smb.conf:

# Global parameters
[global]
        workgroup = TUX-NET
        netbios name = SHUTTLE
        server string = Ubuntu Shuttle GNU/Linux
        interfaces = eth0, lo
        bind interfaces only = Yes
        obey pam restrictions = Yes
        smb passwd file = /etc/samba/smbpasswd %u
        passdb backend = tdbsam, guest
        passwd program = /usr/bin/passwd %u
        passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n .
        username map = /etc/samba/smbusers
        unix password sync = Yes
        log level = 2
        syslog = 3
        log file = /var/log/samba/log.%m
        max log size = 1000
        name resolve order = host wins bcast
        socket options = TCP_NODELAY IPTOS_LOWDELAY SO_KEEPALIVE SO_RCVBUF=8192 SO_SNDBUF=8192
        logon drive = P:
        logon home = \\%L\%u
        domain logons = Yes
        os level = 65
        preferred master = Yes
        domain master = Yes
        dns proxy = No
        wins support = Yes
        panic action = /usr/share/samba/panic-action %d
        valid users = moi même, ..., nobody
        printer admin = @ntadmin
        hosts allow = 192.168.1.0/24, 127.0.0.1
        hosts deny = 0.0.0.0/0
        case sensitive = No
        short preserve case = No
        hide files = /.*/Desktop Folder/ , /.*/Temporary Items/

[homes]
        comment = Home Directories
        read only = No
        create mask = 0700
        directory mask = 0700

[netlogon]
        comment = Network Logon Service
        path = /home/netlogon
        guest ok = Yes
        share modes = No

[cdrom]
        comment = Samba server's CD-ROM
        path = /cdrom
        guest ok = Yes
        locking = No
        preexec = /bin/mount /cdrom
        postexec = /bin/umount /cdrom

Si vous voyez des horreurs, dites le moi, merci

Merci d'avance pour toutes suggestions...

Dernière modification par oli-net (Le 15/06/2005, à 01:52)

Hors ligne

#7 Le 15/06/2005, à 09:26

Gillaume

Re : Pas de fichier SMBPASSWD ....

sudo find / -name smbpasswd
/usr/bin/smbpasswd.

sudo vi /usr/bin/smbpasswd : C'est illlisible !!!

voici ce que je trouve.

par contre, dans mon /etc/samba/smbpasswd %u, il y a les users que j'ai rentré en faisant :
sudo smbpasswd -a guigui

Teejee, il faut bien sur que ton smb.conf, dans [global] , y fasse référence !

smb passwd file = /etc/samba/smbpasswd %u

==> Regarde mon exemple au début de ce post.

gui

Dernière modification par Gillaume (Le 15/06/2005, à 09:26)


Guili Guili

Hors ligne

#8 Le 15/06/2005, à 10:41

Teejee

Re : Pas de fichier SMBPASSWD ....

Ouai GUI, je suis entierement d'accord avec toi. Voici mon fichier smb.conf :

[global]

   workgroup = MSHOME
   netbios name = Ubuntu
   server string = %h server
   wins support = yes
;  wins server = w.x.y.z
;  dns proxy = no
;  name resolve order = lmhosts host wins bcast
   log file = /var/log/samba/log.%m
   max log size = 1000
;  syslog only = no
   syslog = 0
   panic action = /usr/share/samba/panic-action %d


####### Authentication #######


   security = user
   username map = /etc/samba/smbusers
   encrypt passwords = true
   passdb backend = tdbsam guest
   obey pam restrictions = yes
   guest account = invite
   invalid users = root
   unix password sync = yes
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n .
;  pam password change = no
   smb passwd file = /etc/samba/smbpasswd %u

Je ne vois vraiment pas le probleme !!!  Ma version de samba est 3.0.10 .... peut etre devrais-je mettre une version anterieur ?

Gui, peux tu me donner le numero de ta version ?

Merci encore !!!!

{   Tom   }

#9 Le 15/06/2005, à 13:16

Gillaume

Re : Pas de fichier SMBPASSWD ....

Samba version 3.0.10-Ubuntu

qd tu fais vi /etc/samba/smbpasswd %u, ton fichier est vide ??????

C'est ça Tom ???

ne change pa de version !

Gui


Guili Guili

Hors ligne

#10 Le 15/06/2005, à 13:53

Teejee

Re : Pas de fichier SMBPASSWD ....

Oui Gui c'est tt fait ca !!! le fichier smbpasswd reste vite ..... rien a faire ... je ne comprend plus ....

Help me please !!!! Mes utilisateurs doivent bien se trouver quelque par ?

Merci a vous !!!

#11 Le 15/06/2005, à 14:46

Gillaume

Re : Pas de fichier SMBPASSWD ....

qd tu fais sudo smbpasswd -a user, tu as un message d'erreur ???
ou ça se passe bien ?


Guili Guili

Hors ligne

#12 Le 15/06/2005, à 15:25

teejee

Re : Pas de fichier SMBPASSWD ....

Non non ,, tt ce passe trés bien et l'utilisateur fonctionne a merveille ..... Je me egalement le suprrimer smbpasswd -x ...............

Mais pour la gestion des utilisateurs, il est tres embetant de ne pas avoir ce foutu fichier .....


{   Tommm   }

Hors ligne

#13 Le 15/06/2005, à 18:37

teejee

Re : Pas de fichier SMBPASSWD ....

big_smile:D:D:D:D

Alors je crois que le probleme est enfin resolu .... Je suis incapable de vous dire pourquoi. J'ai refais entierement le fichier smb.conf ... le voici :

[global]

netbios name = ubuntu
workgroup = MSHOME
server string = Serveur Samba [%v]
guest account = invite
log file = /var/log/samba/log.%U
username map = /etc/samba/smbusers
security = user
socket options = TCP_NODELAY
encrypt passwords = yes
smb passwd file = /etc/samba/smbpasswd
unix password sync = yes
passwd program = /usr/bin/passwd %u
passwd chat = *New*%n \n *Re*%n \n *pa*
domain master = yes
local master = yes
preferred master = yes
domain logons = yes
wins support = yes
;logon script =
;logon home =

[home]
                                                              
comment = Repertoire Personnel de %u
browseable = no                                               
path =                                                        
writable = yes

Il me semble ne rien avoir fait de different par rapport au fichier d'origine mais apparement ...... Mes utilisateurs sont a present bien enregistré dans le fichier smbpasswd ....

Je tenais a tous vous remercier .... Merci Gui ... Je crois que l'on peut boucler le 'Post' ....

Merci ... Tom


{   Tommm   }

Hors ligne

#14 Le 15/06/2005, à 18:56

Gillaume

Re : Pas de fichier SMBPASSWD ....

muy bien !!!  big_smile
des fois, ça ne tiens qu'à ça !

tu devrais mettre [résolu] devant le titre de ton post.

bonne soirée
gui


Guili Guili

Hors ligne

#15 Le 16/06/2005, à 03:30

oli-net

Re : Pas de fichier SMBPASSWD ....

Salut à tous,

Heureux que ça fonctionne pour teejee big_smile.
Moi, quoique je fasse, mes fichiers smbpasswd et smbusers ne bougent pas. J'ajoute des utilisateurs avec smbpasswd -a user, ça ne fait rien et j'en efface, ça ne fait rien non plus sad.
Pareil pour smbpasswd, il n'existait pas, je l'ai créé à la main, mais depuis, il ne contient RIEN.
Ca me gonfle, tout devrait fonctionner, mais ça foire.

Tout ça me rappelle une citation d'Albert Einstein:
La théorie c'est quand rien ne marche mais on peut tout expliquer,
La pratique c'est quand tout fonctionne mais on ne sait pas pourquoi,
Ici nous avons réuni théorie et pratique:
                   Rien ne fonctionne et personne ne peut l'expliquer''
                                                -- Albert Einstein --

Je finirais par trouver un jour..
A plus!

Hors ligne

#16 Le 16/06/2005, à 11:12

teejee

Re : Pas de fichier SMBPASSWD ....

Salut Oli-net !!!! Tu as essayer de faire un fichier de conf avec le stric necessaire ? Pour ma part seul le fichier de conf etait responsable de ce dysfonctionnement. Quel est ta version de samba ?

Bon j'attend une response !! on vois ca ensemble !!!

Tom


{   Tommm   }

Hors ligne

#17 Le 17/06/2005, à 01:59

oli-net

Re : Pas de fichier SMBPASSWD ....

Salut Teejee,
Merci pour ton aide!
Je vais suivre ton conseil, mais je ne pense pas que la configuration du fichier smb.conf influe sur les fichiers smbusers et smbpasswd.
On aurait dit que la commande smbpasswd n'a aucun effet sur lui. Pourtant la commande s'exécute correctement. N'y a-t-il pas moyen de forcer smbpasswd à écrire dans le bon fichier?
Je fais des essais et je te tiens informé

Merci!

Hors ligne

#18 Le 17/06/2005, à 02:16

YBM

Re : Pas de fichier SMBPASSWD ....

Tu n'aurais pas plutôt un fichier /var/lib/samba/passdb.tdb qui lui se modifie quand tu joues avec smbpasswd ?

Hors ligne

#19 Le 17/06/2005, à 03:01

oli-net

Re : Pas de fichier SMBPASSWD ....

Salut,

@YBM >
Le fichier passdb.tdb existe bien, mais je ne crois pas qu'il est beaucoup bougé.
Un ls donne :
root@ubuntu:/home/olivier # ls -lt /var/lib/samba/passdb.tdb
-rw-------  1 root root 8192 2005-06-12 19:49 /var/lib/samba/passdb.tdb
root@ubuntu:/home/olivier #

Et vu le nombre de fois que j'ai utilisé la commande smbpasswd pour créer/effacer des utilisateurs la date de dernier accès ne correspond pas. Merci quand même.

= = =

J'ai refais à la main mon smbusers comme suit:
olivier = olivier
root = administrator administrateur

J'ai aussi effacé et recréé mon fichier smbpasswd. Et là, miracle.
Un nouveau smbpasswd -a root a réussi à écrire dans le fichier. Ca donne :

root:0:46F7B3ED2A53A51775D51677933A21C9:6A1204D07DAE8D58A66DCBC7E05DD400:[U          ]:LCT-42B22863:
olivier:1000:46F7B3ED2A53A51775D51677933A21C9:6A1204D07DAE8D58A66DCBC7E05DD400:[U          ]:LCT-42B22884:
devstudio$:1002:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:AC0466E4A819BF76144BA7F7783F48AA:[W          ]:LCT-42B228C4:

J'ai pu me connecter au domaine et ma machine XP Pro s'est inscrite automatiquement.

Conclusion : La seule chose de différent que j'ai fais, c'est de virer smbpasswd et smbusers et de les recréer comme je lai fais la première fois.

Ca me ramène encore à Einstein : La pratique c'est quand tout fonctionne mais on ne sait pas pourquoi.

Merci à tous pour le support...

Hors ligne

#20 Le 18/06/2005, à 01:52

oli-net

Re : Pas de fichier SMBPASSWD ....

Salut à tous,

Bizarre quand même, je n'arrivais plus à me connecter au domaine depuis mon XP Pro. Aussi, j'ai effacer le domaine depuis XP, puis j'ai réenregistré la machine sur le domaine et ça re-fonctionne.
Le fichier /etc/samba/smbpasswd doit avoir un soucis.
Enfin, bref,... je sais ce qu'il faut faire au moindre soucis, virer smbpasswd et le recréer...

Merci à tous et bon week-end!

Hors ligne

Haut de page ↑