Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#51 Le 23/05/2011, à 21:26

compte supprimé

Re : [nVidia Optimus] État des lieux

TIMsmith a écrit :

Bonsoir et merci pour vos info

A priori la commande

lspci -v | grep -A 12 VGA

donne la carte utilisée

Si je résume vos dires, il suffit d'installer bumblebee pour que la carte Nvidia soit coupée. On la "remet en route" en lancant Optirun32 (ou 64). Comment la recouper ensuite ?

Merci

TIM

SI j'ai bien pigé ça lance ton jeu dans un serveur X dédié, qui fait appel à ta carte.
Une fois l'app quittée, le serveur X est terminé, la carte cesse de fonctionner.

#52 Le 23/05/2011, à 21:37

TIMsmith

Re : [nVidia Optimus] État des lieux

AAAAHHHHHH OK OK OK OK OK OK

Et si je veux lancer la carte sans lancer une appli ?  Par exemple pour profiter de la sortie HDMI et afficher mon écran sur ma TV? Comment faut faire ? (j'en ai des tas d'autres questions comme ca smile)

TIM
-------------------
EEEPC 1015

Hors ligne

#53 Le 23/05/2011, à 21:43

TIMsmith

Re : [nVidia Optimus] État des lieux

Sur la doc Optimus, je viens de voir un "truc" expérimental qui permet de swicher entre les 2 cartes graphiques. Le pb est que je ne comprends pas grand chose à l'explication.
L'un de vous a--il essayé?

Merci

Hors ligne

#54 Le 23/05/2011, à 23:00

compte supprimé

Re : [nVidia Optimus] État des lieux

Ben ce truc c'est bumblebee justement ! big_smile
Et cbrunos a essayé donc, voir la page précédente de ce sujet. En bref, ça marche bien.

Maintenant, pour le coup de la sortir HDMI : bah euh justement je me demandais. Faudrait voir avec le développeur de bumblebee.
Ce doit être possible. Mais dans ce cas la, l'idée serait de lancer la session X normale avec optirun.

#55 Le 24/05/2011, à 07:43

ouafnico

Re : [nVidia Optimus] État des lieux

C'est tout à fait ça pour le fonctionnement smile
et quand tu lances un jeu tu vois bien la différence, avec le optirun ou pas, ça marche dans mon cas.

Je cherche par contre toujours à vérifier que la carte est bien éteinte le reste du temps, mais mon powertop freeze ^^

par contre la commande :

nicolas@portable-nico:~$ lspci -v | grep -A 12 VGA

00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 18) (prog-if 00 [VGA controller])
    Subsystem: ASUSTeK Computer Inc. Device 1552
    Flags: bus master, fast devsel, latency 0, IRQ 43
    Memory at d3400000 (64-bit, non-prefetchable) [size=4M]
    Memory at b0000000 (64-bit, prefetchable) [size=256M]
    I/O ports at e080 [size=8]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: <access denied>
    Kernel driver in use: i915
    Kernel modules: i915

00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
    Subsystem: ASUSTeK Computer Inc. Device 1197
--
01:00.0 VGA compatible controller: nVidia Corporation Device 0dee (rev a1) (prog-if 00 [VGA controller])
    Subsystem: ASUSTeK Computer Inc. Device 1552
    Flags: bus master, fast devsel, latency 0, IRQ 16
    Memory at d2000000 (32-bit, non-prefetchable) [size=16M]
    Memory at c0000000 (64-bit, prefetchable) [size=256M]
    Memory at d0000000 (64-bit, prefetchable) [size=32M]
    I/O ports at d000 [size=128]
    Expansion ROM at d3000000 [disabled] [size=512K]
    Capabilities: <access denied>
    Kernel driver in use: nvidia
    Kernel modules: nvidia-current, nouveau, nvidiafb

Elle me donne les deux cartes, ça veut dire que c'est la première par défaut ?


EDIT : soyez prudent avec le nettoyeur ubuntu de packages non utilisés, sans faire gaffe ça m'a viré dans le lot virtualgl, du coup le optirun en vrac... En réinstallant Bumblebee,j'ai eu plein d'erreurs bizarres, et au final, OS crashé ! Quand je le démarre maintenant, j'ai plus d'interface graphique, et si je me logue en console, quand je donne un login, il ne me demande pas mon mot de passe et retourne directement à la demande de login... bref ça sent le formattage.
Sur le site de Bumblebee (qui a mis son package a jour dans la nuit) : GIANT BUG... causing /usr to be deleted... so sorry....

Dernière modification par ouafnico (Le 24/05/2011, à 13:20)

Hors ligne

#56 Le 24/05/2011, à 14:11

wido

Hors ligne

#57 Le 24/05/2011, à 14:22

cbrunos

Re : [nVidia Optimus] État des lieux

ouafnico a écrit :

EDIT : soyez prudent avec le nettoyeur ubuntu de packages non utilisés, sans faire gaffe ça m'a viré dans le lot virtualgl, du coup le optirun en vrac... En réinstallant Bumblebee,j'ai eu plein d'erreurs bizarres, et au final, OS crashé ! Quand je le démarre maintenant, j'ai plus d'interface graphique, et si je me logue en console, quand je donne un login, il ne me demande pas mon mot de passe et retourne directement à la demande de login... bref ça sent le formattage.
Sur le site de Bumblebee (qui a mis son package a jour dans la nuit) : GIANT BUG... causing /usr to be deleted... so sorry....

Tu parles computer janitor? Désinsalle cette horreur. Je sais pas comment Canonical peuvent laisser une telle bouse de logiciel (dangereux en plus) par défaut dans Ubuntu. Paraît qu'ils vont le virer pour oneiric.

Concernant la prise hdmi, je vais demander à l'auteur de Bumblebee, je vous tiens au jus.


Je recommande pcubuntoo!

Hors ligne

#58 Le 24/05/2011, à 17:09

ouafnico

Re : [nVidia Optimus] État des lieux

alors pour info, par défaut la carte nvidia n'est pas coupée. Pour gérer l'allumage/arrêt il faut modifier les fichiers /usr/local/bin/bumblebee-disablecard et /usr/local/bin/bumblebee-enablecard.
Je suis en train d'y regarder.

Voici ce que j'ai modifié (par défaut les fichiers sont commentés) :

mon fichier bumblebee-enablecard :

modprobe acpi_call

if ! lsmod | grep -q acpi_call; then
    echo "Error: acpi_call module not loaded"
    exit
fi

acpi_call () {
    echo "$*" > /proc/acpi/call
    result=$(cat /proc/acpi/call)
    case "$result" in
     Error*)
      echo "Enabling nVidia Card failed ($result)."
      ;;
     *)
      echo "Enabling nVidia Card Succeded."
     ;;
    esac
}

echo _PS0 $(acpi_call "\_SB.PCI0.PEG1.GFX0._PS0")
modprobe nvidia-current

le bumblebee-disablecard :

rmmod nvidia

modprobe acpi_call

if ! lsmod | grep -q acpi_call; then
    echo "Error: acpi_call module not loaded"
    exit
fi

acpi_call () {
    echo "$*" > /proc/acpi/call
    result=$(cat /proc/acpi/call)
    case "$result" in
     Error*)
      echo "Disabling nVidia Card failed ($result)."
      ;;
     *)
      echo "Disabling nVidia Card Succeded."
     ;;
    esac
}

echo NVOP $(acpi_call "\_SB.PCI0.PEG1.GFX0.NVOP 0 0x100 0x1A {255,255,255,255}")
echo _PS3 $(acpi_call "\_SB.PCI0.PEG1.GFX0._PS3")

Les principaux trucs à changer sont les "_SB.PCI0.PEG1.GFX0" qui donnent le chemin vers la carte (différent d'un pc à l'autre) :s

Avant tout, il faut avoir le module acpi_call. Pour ceux qui ne savent pas trop où chercher il suffit de faire ça (en root) :

apt-get instal git
git clone http://github.com/mkottman/acpi_call.git
cd acpi_call
make
cp acpi_call.ko /lib/modules/`uname -r`/kernel/drivers/acpi/
depmod

il faut refaire cette manip à chaque changement de noyau..

Dernière modification par ouafnico (Le 24/05/2011, à 19:39)

Hors ligne

#59 Le 24/05/2011, à 21:42

cbrunos

Re : [nVidia Optimus] État des lieux

Normalement tu ne devrais pas avoir à faire ça; ouvre un bug sur le site du projet en donnant le modèle de ton pc ainsi que ta solution histoire que l'auteur puisse l'intégrer à Bumblebee.


Je recommande pcubuntoo!

Hors ligne

#60 Le 24/05/2011, à 21:43

ouafnico

Re : [nVidia Optimus] État des lieux

en effet, mais mon portable n'est pas encore connu, mais j'ai écrit au gars qui fait le programme pour lui transmettre mes fichiers.
tu peux éventuellement me coller le contenu des tiens que je regarde à quoi ils ressemblent ?

Hors ligne

#61 Le 26/05/2011, à 17:15

Segbru

Re : [nVidia Optimus] État des lieux

Bonjour, j'ai installé bumblebee, mais j'ai l'impression qu'il ne marche pas...
rien de grave puisqu'il m'a installé nvidia proprio sur ma carte nvidia et que le boot marche bien... mais quand je lance un

bouddy@Boubou:~$ optirun64 tremulous

je reçoit un

 * Starting Bumblebee X server bumblebee                                 [ OK ] 
tremulous 1.1.0 linux-x86_64 Sep  6 2008
----- FS_Startup -----
Current search path:
/home/bouddy/.tremulous/base
/usr/share/games/tremulous/base/vms-1.1.0.pk3 (4 files)
/usr/share/games/tremulous/base/map-uncreation-1.1.0.pk3 (110 files)
/usr/share/games/tremulous/base/map-tremor-1.1.0.pk3 (45 files)
/usr/share/games/tremulous/base/map-transit-1.1.0.pk3 (135 files)
/usr/share/games/tremulous/base/map-niveus-1.1.0.pk3 (134 files)
/usr/share/games/tremulous/base/map-nexus6-1.1.0.pk3 (151 files)
/usr/share/games/tremulous/base/map-karith-1.1.0.pk3 (118 files)
/usr/share/games/tremulous/base/map-atcs-1.1.0.pk3 (87 files)
/usr/share/games/tremulous/base/map-arachnid2-1.1.0.pk3 (67 files)
/usr/share/games/tremulous/base/data-1.1.0.pk3 (1229 files)
/usr/share/games/tremulous/base
/usr/lib/tremulous/base

----------------------
2080 files in pk3 files
execing default.cfg
execing autogen.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----

------- Input Initialization -------
Joystick is not active.
------------------------------------
...loading libGL.so.1:
Calling SDL_Init(SDL_INIT_VIDEO)...
SDL_Init(SDL_INIT_VIDEO) passed.
Initializing OpenGL display
...setting mode 3: 640 480
[VGL] WARNING: VirtualGL attempted and failed to obtain a Pbuffer-enabled
[VGL]    24-bit visual on the 3D X server :0.  If the application
[VGL]    subsequently fails, then make sure that the 3D X server is configured
[VGL]    for 24-bit color and has accelerated 3D drivers installed.
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
SDL_SetVideoMode failed: Couldn't find matching GLX visual
Couldn't get a visual
...WARNING: could not set the given mode (3)
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
----- CL_Shutdown -----
-----------------------
Sys_Error: GLimp_Init() - could not load OpenGL subsystem

 * Stopping Bumblebee X server bumblebee                                         * .                                                                             * .                                                                             * .                                                                     [ OK ] 

Ce qui me gène c'est cette histoire de GLX visual et le

[VGL] WARNING: VirtualGL attempted and failed to obtain a Pbuffer-enabled
[VGL]    24-bit visual on the 3D X server :0.  If the application
[VGL]    subsequently fails, then make sure that the 3D X server is configured
[VGL]    for 24-bit color and has accelerated 3D drivers installed.

je ne comprend ni ce que ça veut dire ni ce que je dois faire...


EDIT :
autre exemple avec Savage 2 :

 * Starting Bumblebee X server bumblebee                                 [ OK ] 
warning: The VAD has been replaced by a hack pending a complete rewrite
[VGL] WARNING: VirtualGL attempted and failed to obtain a Pbuffer-enabled
[VGL]    24-bit visual on the 3D X server :0.  If the application
[VGL]    subsequently fails, then make sure that the 3D X server is configured
[VGL]    for 24-bit color and has accelerated 3D drivers installed.
Savage2 - Fatal Error: Unable to find an appropriate visual.
 * Stopping Bumblebee X server bumblebee                                         * .                                                                             * .    

Dernière modification par Segbru (Le 26/05/2011, à 17:21)

Hors ligne

#62 Le 26/05/2011, à 17:53

ouafnico

Re : [nVidia Optimus] État des lieux

tu peux regarder à ton fichier /etc/X11/xorg.conf.nvidia ?

Hors ligne

#63 Le 26/05/2011, à 18:18

Segbru

Re : [nVidia Optimus] État des lieux

Voici ce que ça dit :

Section "DRI"
    Mode 0666
EndSection

Section "ServerLayout"
    Identifier     "Layout0"
    Screen         "Screen1"
EndSection

Section "Module"
    Load  "dbe"
    Load  "extmod"
    Load  "glx"
    Load  "record"
    Load  "freetype"
    Load  "type1"
EndSection

Section "Files"
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BusID          "PCI:01:00:0"
    Option         "IgnoreEDID"
    Option        "ConnectedMonitor" "CRT-0"
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "1920x1200" "1920x1080" "1680x1050" "1600x1200" "1440x900" "1280x1024" "1366x768" "1360x768" "1280x800" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Section "Monitor"
    Identifier "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 73.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
    Modeline "1920x1200"  193.25  1920 2056 2256 2592  1200 1203 1209 1245 -hsync +vsync
    Modeline "1920x1080"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
    Modeline "1680x1050"  146.25  1680 1784 1960 2240  1050 1053 1059 1089 -hsync +vsync
    Modeline "1600x1200"  161.00  1600 1712 1880 2160  1200 1203 1207 1245 -hsync +vsync
    Modeline "1440x900"  106.50  1440 1528 1672 1904  900 903 909 934 -hsync +vsync
    Modeline "1368x768"   85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync
    Modeline "1280x800"   83.50  1280 1352 1480 1680  800 803 809 831 -hsync +vsync
    Modeline "1280x1024"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
EndSection

Hors ligne

#64 Le 27/05/2011, à 23:08

TIMsmith

Re : [nVidia Optimus] État des lieux

Bonsoir à tous
Après lecture de divers forum, il semble que l'EEEPC 1015PN n'est pas Optimus.
IL possède qd même les deux cartes graphiques. Bumblebee gère-t-il ce cas?
Sinon, connaissez vous un autre moyen ?

Merci pour votre aide.

Hors ligne

#65 Le 28/05/2011, à 00:46

compte supprimé

Re : [nVidia Optimus] État des lieux

S'il possède deux cartes mais pas d'optimus, ça veut dire que tu dois activer/désactiver l'une des cartes dans le bios.
En clair : petit chanceux ! Tu n'as pas à faire toute ces manips. smile

#66 Le 29/05/2011, à 17:44

compte supprimé

Re : [nVidia Optimus] État des lieux

Petit up pour dire que bumblebee c'est absolument génial ! La carte nvidia de mon asus U35JC marche maintenant !

#67 Le 29/05/2011, à 20:58

ouafnico

Re : [nVidia Optimus] État des lieux

Je viens de tester sur Fedora 15, j'ai un bug quand je lance optirun :s
Par contre du coup j'ai communiqué les modifs pour mon portable au développeur de bumblebee, il a tout rajouté smile

Hors ligne

#68 Le 29/05/2011, à 23:25

TIMsmith

Re : [nVidia Optimus] État des lieux

monsieurweller a écrit :

S'il possède deux cartes mais pas d'optimus, ça veut dire que tu dois activer/désactiver l'une des cartes dans le bios.
En clair : petit chanceux ! Tu n'as pas à faire toute ces manips. smile

J'ai essayé, mais le bios ne propose pas cette option.
De plus, certains sites disent qu'il y a Optimus et d'autres non (???) Il y a-t-il un moyen de verifier directement sur le PC ?

Sinon, j'ai réussi à utiliser la carte Intel en repassant sur Win7, en lancant GraphicSwitch (soft d'ASUS parmettant de basculer d'une carte à l'autre) pour passer sur l'Intel puis en rebootant sur ubuntu. J'ai alors eu un message du style "vous pouvez pas utiliser Unity, donc je démarre en Classic". Là, c'est bien la carte Intel qui est utilisée. Puis je redémarre, et là, pouf il réutilise la Nvidia par défaut mad
Je me demande s'il est possible d'utiliser GraphicSwitch avec wine. Avez-vous testé?

Autre sinon, il y a-t-il un risque à utiliser bumblebee sans avoir Optimus?

Merci

TIM

Hors ligne

#69 Le 29/05/2011, à 23:33

compte supprimé

Re : [nVidia Optimus] État des lieux

TIMsmith a écrit :

Je me demande s'il est possible d'utiliser GraphicSwitch avec wine. Avez-vous testé?

Marchera pas, wine ne peut pas autoriser un accès aux tables acpi.

Autre sinon, il y a-t-il un risque à utiliser bumblebee sans avoir Optimus?

Merci

TIM

De ce que tu décris, il y a de fortes chances que ce soit du optimus.
Donc ouais, teste bumblebee. Ça ne va pas tout te planter, rassure toi. Et il y a un script de désinstallation au cas ou ça ne serve a rien.

#70 Le 30/05/2011, à 20:39

maxou88

Re : [nVidia Optimus] État des lieux

Salut monsieurweller

J'ai le même pc que toi ASUS U35JC et je voulais savoir si tu économises pas mal de batterie avec bumblebee ? combien de temps tu tiens sans recharger  ? Car je suis sous seven mais je voudrais passer sous linux mais si la carte nvidia tourne non stop la batterie sad

Merci d'avance !

Hors ligne

#71 Le 30/05/2011, à 22:48

TIMsmith

Re : [nVidia Optimus] État des lieux

Bon et ben allez zou, j'essaie.
Je vous tiens au courant.

TIM

Hors ligne

#72 Le 30/05/2011, à 23:10

TIMsmith

Re : [nVidia Optimus] État des lieux

ZUT, j'ai un "commande introuvable" quand je lance install.sh. pourtant il est exécutable et je suis bien dans le bon répertoire. idem avec sudo. une idée ?

Dernière modification par TIMsmith (Le 30/05/2011, à 23:11)

Hors ligne

#73 Le 30/05/2011, à 23:59

TIMsmith

Re : [nVidia Optimus] État des lieux

J'ai réussi à lancer install.sh via

sudo ./install.sh

Malheureusement, maintenant Ubuntu ne se lance plus. Il plante avant de démarrer l'interface graphique ...
Comment lancer le script de désinstallation ?

Merci

Hors ligne

#74 Le 31/05/2011, à 09:29

compte supprimé

Re : [nVidia Optimus] État des lieux

maxou88 a écrit :

Salut monsieurweller

J'ai le même pc que toi ASUS U35JC et je voulais savoir si tu économises pas mal de batterie avec bumblebee ? combien de temps tu tiens sans recharger  ? Car je suis sous seven mais je voudrais passer sous linux mais si la carte nvidia tourne non stop la batterie sad

Merci d'avance !

Salut !
Alors, avec acpi_call, qui désactive totalement la carte nvidia, je monte à 7-8 d'autonomie en moyenne (ce qui me permet de partir à la fac le matin et de l'utiliser la journée sans recharger). Désactiver la carte ne fait pas tout, j'ai aussi changé le disque pour un SSD joue aussi (consomme moins qu'un dur classique).
Bon, et avec bumblebee ?
Alors, bumblebee active les deux cartes en fait. Pour allumer/éteindre la carte nvidia, il faut compléter deux scripts, ce dont je n'étais pas capable.
Ces scripts sont une intégration de bumblebee à acpi_call en fait.
Et... Comme je suis assez malin pour faire des rapports de bugs, et que le développeur est réactif... Une nouvelle version de bumblebee ajoute les scripts pour ce portable, et donc, la maintenant, je teste ! smile

#75 Le 31/05/2011, à 14:27

compte supprimé

Re : [nVidia Optimus] État des lieux

Ah oui ça fait une belle économie quand même !!!!

Edit : avec un graphe et des valeurs justes, c'est mieux :
1306854951.png

Commande utilisée :

grep rate /proc/acpi/battery/BAT0/state

Plusieurs mesures à différents temps, moyennées pour l'histogramme.


En bleu : carte nvidia activée en permanence, en plus du chip intel (bumblebee sans les scripts pour acpi_call) ;
En jaune : débit après une session de 5min sur le jeu 3D trine, avec la carte 3D nvidia activée en permanence (bumblebee sans les scripts pour acpi_call);

En orange : carte nvidia désactivée (bumblebee + scripts acpi_call)
En jaune : débit après une session de 5min sur le jeu 3D trine, avec la carte nvidia activée au lancement du jeu et désactivée à la fermeture du jeu (le débit ne décroissant pas immédiatement après l'extinction de la carte, on peut faire la mesure) (bumblebee + acpi_call);



Conclusion : bumblebee, ça marche bien !

Dernière modification par monsieurweller (Le 31/05/2011, à 17:24)

Haut de page ↑