Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 30/05/2011, à 14:10

vincentg-theodo

Problème acpi et carte graphique hybrid ubuntu 11.04

Bonjour,

J'ai recemment fait l'acquisition d'un portable Sony Vaio série S (http://www.sony.fr/product/vn-s-series/ … nicalSpecs) sur lequel j'ai installé Ubuntu 11.04 (kernel 2.6.38-8-generic-pae).

Je rencontre quelques soucis de configuration matériel au niveau des cartes graphiques et de la gestion ACPI (le portable a une carte graphique ATI radeon HD 6470M et une Intel HD).

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: ATI Technologies Inc NI Seymour [AMD Radeon HD 6470M] (rev ff)

Le portable démarre une fois de temps en temps, c'est très aléatoire, quand il ne démarre pas je fais "ctrl + alt + F1" pour voir ce qu'il se passe. Il me sort donc plein lignes de ce style  : [  xxx.xxxxxx] MESSAGE (comme dans l'affichage du dmesg ci-dessous)

Quand il démarre correctement, j'ai ceci quand je fais "dmesg" :

[   74.608685] EXT4-fs (sda5): re-mounted. Opts: errors=remount-ro,commit=0
[   77.093176] r8169 0000:05:00.0: eth0: link up
[   77.093347] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   77.566149] usb 2-1.3: new low speed USB device using ehci_hcd and address 4
[   77.709997] input: LITEON Technology USB Keyboard as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.3/2-1.3:1.0/input/input13
[   77.710112] generic-usb 0003:04CA:0022.0004: input,hidraw3: USB HID v1.10 Keyboard [LITEON Technology USB Keyboard] on usb-0000:00:1d.0-1.3/input0
[   87.320869] eth0: no IPv6 routers present
[   94.527706] [drm:pch_irq_handler] *ERROR* PCH poison interrupt
[  132.580654] iwlagn 0000:02:00.0: RF_KILL bit toggled to disable radio.
[  132.614695] usb 1-1.6: USB disconnect, address 6
[  132.614802] btusb_bulk_complete: hci0 urb f6f7af00 failed to resubmit (19)
[  132.614855] btusb_intr_complete: hci0 urb f6f7ae00 failed to resubmit (19)
[  132.614925] btusb_bulk_complete: hci0 urb f6f7ac80 failed to resubmit (19)
[  132.614966] btusb_send_frame: hci0 urb f6f7ac80 submission failed
[  138.755612] usb 1-1.4: USB disconnect, address 5
[  138.755734] qcserial ttyUSB0: Qualcomm USB modem converter now disconnected from ttyUSB0
[  138.755749] qcserial 1-1.4:1.1: device disconnected
[  145.321748] exe (2550): /proc/2550/oom_adj is deprecated, please use /proc/2550/oom_score_adj instead.

Après pas mal de recherche sur internet, j'ai trouvé qu'il fallait mettre acpi=off lors du boot. A partir de ce moment, le pc démarre "correctement", sauf qu'il y a des effets de bord ...
Le pc ayant 2 cartes graphique, j'ai désactiver la carte ATI au démarrage grace à la commande "echo OFF > /sys/kernel/debug/vgaswitcheroo/switch" dans "/etc/rc.local".
Sauf que dès que je met "acpi=off" au boot, le dossier "/sys/kernel/debug/vgaswitcheroo" n'existe plus ... donc la carte ATI est active, les ventilos tournent à fond, et la batterie ne tient pas ...

Donc en gros, pour résumé :
- Quand acpi=on : démarrage aléatoire, et la carte ATI est bien désactivé
- Quand acpi=off : démarrage ok, mais plus de gestion des cartes graphiques

Si ça peut vous être utile, je n'ai pas réussi à installer les drivers de la carte ATI.
J'ai testé les drivers propriétaires FGLRX (installer via jockey-gtk), dans ce cas la commande "aticonfig --initial" me dit qu'il manque un fichier .so et le fichier "/etc/X1/xorg.conf" contien ceci :

  Section "Screen"
        Identifier    "Default Screen"
      DefaultDepth    24
  EndSection

  Section "Module"
      Load    "glx"
  EndSection

Et avec les drivers catalyst télécharger sur le site d'AMD, la commande "aticonfig --initial" me sort le message "No supported adapters detected" et le "xorg.conf" est le même que ci-dessus.

Si quelqu'un a des idées sur ces problèmes, je suis preneur.

Merci,

Vincent

Dernière modification par vincentg-theodo (Le 30/05/2011, à 14:19)

Hors ligne

#2 Le 30/05/2011, à 14:39

Gillou40

Re : Problème acpi et carte graphique hybrid ubuntu 11.04

Bonjour,

As-tu essayé de désactiver ta puce graphique Intel dans le Bios ?


J'aide la Science avec BOINC en soutenant L'alliance Francophone Libristes et le Calcul Partagé
Mon pseudo: [AF>Libristes] gillou40
Tout sur BOINC:  https://libristes.boinc-af.org/ et http://doc.ubuntu-fr.org/boinc
Mes stats: http://www.boincstats.com/signature/user_7930.gif

Hors ligne

#3 Le 30/05/2011, à 15:18

vincentg-theodo

Re : Problème acpi et carte graphique hybrid ubuntu 11.04

Bonjour,

On ne peut malheureusement pas désactiver la carte dans le bios :-(
Il y a très peu d'option de configuration dans le bios ...

Si ça peut être utile, voici le contenu du fichier "/sys/kernel/debug/vgaswitcheroo/switch"

0:DIS: :Off:0000:01:00.0
1:IGD:+:Pwr:0000:00:02.0

Hors ligne

#4 Le 30/05/2011, à 16:34

Gillou40

Re : Problème acpi et carte graphique hybrid ubuntu 11.04

Je cherche et te recontacte


J'aide la Science avec BOINC en soutenant L'alliance Francophone Libristes et le Calcul Partagé
Mon pseudo: [AF>Libristes] gillou40
Tout sur BOINC:  https://libristes.boinc-af.org/ et http://doc.ubuntu-fr.org/boinc
Mes stats: http://www.boincstats.com/signature/user_7930.gif

Hors ligne

#5 Le 30/05/2011, à 17:12

vincentg-theodo

Re : Problème acpi et carte graphique hybrid ubuntu 11.04

Parfais, merci beaucoup.

Hors ligne

#6 Le 30/05/2011, à 17:36

Gillou40

Re : Problème acpi et carte graphique hybrid ubuntu 11.04

As-tu essayé de passer par le Pilotes Supplémentaires ?

Système Admin Pilotes Supplémentaires

et d'activer ta carte graphique ?


J'aide la Science avec BOINC en soutenant L'alliance Francophone Libristes et le Calcul Partagé
Mon pseudo: [AF>Libristes] gillou40
Tout sur BOINC:  https://libristes.boinc-af.org/ et http://doc.ubuntu-fr.org/boinc
Mes stats: http://www.boincstats.com/signature/user_7930.gif

Hors ligne

#7 Le 30/05/2011, à 19:06

vincentg-theodo

Re : Problème acpi et carte graphique hybrid ubuntu 11.04

J'ai essayé, mais malheureusement aucun résultat ... :-(

Hors ligne

#8 Le 30/05/2011, à 22:33

Gillou40

Re : Problème acpi et carte graphique hybrid ubuntu 11.04

J'ai trouvé une doc en anglais pour le switch VGA, à creuser :

Hybrid Graphics

Dernière modification par Gillou40 (Le 30/05/2011, à 22:34)


J'aide la Science avec BOINC en soutenant L'alliance Francophone Libristes et le Calcul Partagé
Mon pseudo: [AF>Libristes] gillou40
Tout sur BOINC:  https://libristes.boinc-af.org/ et http://doc.ubuntu-fr.org/boinc
Mes stats: http://www.boincstats.com/signature/user_7930.gif

Hors ligne

#9 Le 31/05/2011, à 09:48

vincentg-theodo

Re : Problème acpi et carte graphique hybrid ubuntu 11.04

Merci pour la doc, je vais voir ce que je peux faire avec ça puis je te tiens au courant.

Au sujet du problème lié à ACPI, je pense qu'il est résolu (je n'ai plus de soucis au démarrage). J'ai mis à jour le kernel (je suis passé au 2.6.39-3-generic-pae) et j'ai installé acpi_call pour me permettre de désactiver la carte ATI au démarrage.

Pour ceux que ça intéresse, voici la procédure que j'ai suivi pour installer acpi_call :

Pour ceux qui n'ont pas git d'installer :

$ sudo apt-get install git
$ git clone http://github.com/mkottman/acpi_call.git
$ cd acpi_call/
$ make
$ sudo insmod acpi_call.ko

Une fois acpi_call installé, vous pouvez exécuter le script suivant qui va vous permettre d'obtenir des informations pour désactiver la bonne carte au démarrage :

$ ./test_off.sh 

De mon coté, le script m'a retourné ceci :

Trying \_SB.PCI0.P0P1.VGA._OFF: failed
Trying \_SB.PCI0.P0P2.VGA._OFF: failed
Trying \_SB_.PCI0.OVGA.ATPX: failed
Trying \_SB_.PCI0.OVGA.XTPX: failed
Trying \_SB.PCI0.P0P3.PEGP._OFF: failed
Trying \_SB.PCI0.P0P2.PEGP._OFF: failed
Trying \_SB.PCI0.P0P1.PEGP._OFF: failed
Trying \_SB.PCI0.MXR0.MXM0._OFF: failed
Trying \_SB.PCI0.PEG1.GFX0._OFF: failed
Trying \_SB.PCI0.PEG0.GFX0.DOFF: failed
Trying \_SB.PCI0.PEG1.GFX0.DOFF: failed
Trying \_SB.PCI0.PEG0.PEGP._OFF: works!

Enfin, j'ai mis à jour mon fichier "/etc/rc.local" :

insmod /home/vincent/Tools/acpi_call/acpi_call.ko
echo '\_SB.PCI0.PEG0.PEGP._OFF' > /proc/acpi/call # Cette ligne correspond à celle où j'ai le "works!" de la commande exécuté précédemment

exit 0

Il vous reste plus qu'à redémarrer !


Je vais maintenant voir du coté de mon problème d'installation des drivers ...

Vincent

Hors ligne

#10 Le 31/05/2011, à 13:34

compte supprimé

Re : Problème acpi et carte graphique hybrid ubuntu 11.04

Salut !
Donc en fait, acpi_call ta testé pleins de lignes pour désactiver la carte ATi par l'acpi. La bonne a été la dernière :

SB.PCI0.PEG0.PEGP._OFF

Pour que la désactivation de la carte soit effective à chaque démarrage, n'oublie pas mettre la ligne dans /etc/rc.local ! smile :

echo '\_SB.PCI0.PEG0.PEGP._OFF' > /proc/acpi/call

Et rendre ce script exécutable car par défaut rc.local ne fait rien (chmod +x ...)

Maintenant, je pensais qu'avec les cartes ATi ça marchait mieux. Il faudrait chercher du côté de vga_switcheroo, et je crois que l'application "ubuntu-control-center" propose une interface graphique au switch.

#11 Le 15/08/2011, à 13:11

Beurt

Re : Problème acpi et carte graphique hybrid ubuntu 11.04

Salut !

Après ces correctifs que tu nous présente ici, et après quelques mois d'utilisation que penses tu de ton série S sous Linux ? Je me demande si je ne vais pas acheter un série SA ou SB pour l'utiliser quasi exclusivement sous Linux et je me demande si c'est une bonne idée.

Qu'en penses-tu ?

Hors ligne

#12 Le 16/08/2011, à 10:57

vincentg-theodo

Re : Problème acpi et carte graphique hybrid ubuntu 11.04

Salut,

Après plusieurs semaines de tentative, j'ai décidé de changer de PC.
Je suis resté chez Sony avec un série Z (dernière génération), qui lui n'a pas de système de carte hybride en natif.

Si comme moi, tu ne maîtrises pas totalement les rouages subtiles des distrib Linux, je te conseilles de bien te renseigner avant de faire l'acquisition d'un portable (où tu veux installer un Linux). J'ai fais l'erreur d'acheter un pc à l'aveugle alors maintenant, je me suis bien renseigné avant de faire mon nouvel achat. J'ai fais attention qu'il n'y ai pas de carte graphique hybride (ce qui n'est pas utile pour moi) et à la compatibilité du matériel.

Vincent

Hors ligne

#13 Le 16/08/2011, à 11:20

Beurt

Re : Problème acpi et carte graphique hybrid ubuntu 11.04

vincentg-theodo a écrit :

Après plusieurs semaines de tentative, j'ai décidé de changer de PC.
Je suis resté chez Sony avec un série Z (dernière génération), qui lui n'a pas de système de carte hybride en natif.

Carrément ! Pourtant tu avais l'air bien avancé dans ta démarche de résolution des problèmes !

vincentg-theodo a écrit :

Si comme moi, tu ne maîtrises pas totalement les rouages subtiles des distrib Linux, je te conseilles de bien te renseigner avant de faire l'acquisition d'un portable (où tu veux installer un Linux). J'ai fais l'erreur d'acheter un pc à l'aveugle alors maintenant, je me suis bien renseigné avant de faire mon nouvel achat. J'ai fais attention qu'il n'y ai pas de carte graphique hybride (ce qui n'est pas utile pour moi) et à la compatibilité du matériel.

C'est bien pour ça que je postais ce message pour savoir à quel point on pouvait utiliser cette série de portables sous Linux. Pour l'instant, ça semble un peu compromis... Le problème de la recherche de ce portable commence à ressembler à la quadrature du cercle: portable 13", puissant (i5/i7 Sandy Bridge), avec si possible lecteur optique, une bonne batterie et une bonne finition (attention notamment à l'écran). Compatible Linux... Et bien sûr à un prix tolérable... C'est là que la série Z est exclue pour moi !

Merci beaucoup pour ta réponse rapide !

Hors ligne

#14 Le 16/08/2011, à 14:31

vincentg-theodo

Re : Problème acpi et carte graphique hybrid ubuntu 11.04

J'ai préféré changé le pc, car je passai mon temps à réinstaller Ubuntu à cause de "plantage chronique" ... J'ai donc fais une heureuse en passant le portable à ma copine qui elle est sous windows.

C'est vrai que le série Z est assez cher, mais à long terme je pense que c'est un bon investissement. Tu peux aller voir du coté des ThinkPad, à 1200 euros tu peux avoir un portable correct (après tout dépend de l'utilisation que tu en as).

Hors ligne

#15 Le 06/09/2011, à 11:16

seblem

Re : Problème acpi et carte graphique hybrid ubuntu 11.04

Bonjour à tous,

J'ai rencontré les mêmes problèmes sur mon Hp DV6. Ils sont quasi résolus en appliquant la méthode
acpi_call. J'ai aussi ajouté l'option suivante radeon.modeset=0 dans Grub afin d'eviter des problemes d'ecran noir
aléatoirement au démarrage et au retour de veille.

Me reste un dernier souci , au retour de veille le reseau ne monte plus. la référence à eth0 a disparu du network manager. Seul le wifi reste fonctionnel.
A noter que le problème apparaît aussi simplement en débranchant et rebranchant le cable. Peu etre une coincidence, peut etre qu'auparavant je n'avais pas
preté attention a ce dysfonctionnement me connectant alors par wifi.

Avez vous rencontré ce problème ?

Aussi comment etre certain que la carte Ati ne soit plus alimenté. (je ne sais pour quelle raison mais le temps de décharge est inconnu par la commande acpi).

Hors ligne

#16 Le 20/09/2011, à 14:30

Srede

Re : Problème acpi et carte graphique hybrid ubuntu 11.04

Bonjour,

Comme seblem, j'ai un HP Pavilion dv6 et j'ai des soucis avec le driver de ATI. Ma carte graphique c'est la ATI Radeon HD 6470m et j'ai aussi ces problèmes d'écran noir soit au démarrage soit à la sorti de la mise en veille...

Je travail avec 2 écrans, ce qui multiplie encore les problèmes, il y a souvent des bugs avec les résolutions et si je change de résolution, l'écran reste noir... Enfin bref je suis à la recherche d'une solution à mon problème...

Je suis débutant avec Linux alors si quelqu'un pouvait m'aider ça serait sympa..

Merci

Hors ligne

#17 Le 04/10/2011, à 09:04

seblem

Re : Problème acpi et carte graphique hybrid ubuntu 11.04

Bonjour,

@Srede :Mes probèmes ont été résolus en appliquant certaines solutions proposées sur ce blog :
-Régler les écrans noir au démarrage et l'éclairage : mais sans ajouter acpi_osi=Linux qui concerne le réglage de la luminosité fonctionnel sur mon dv6.
-Régler le drainage de la batterie

Ces deux actions ont réglé mes problèmes. Et je précise que je n'ai plus de problèmes réseau (je ne sais pas pourquoi).
Il n'y a que l'estimation de charge en heure qui ne fonctionne pas (par contre en % ça fonctionne).

J'ajoute que dans ce cas je me passe volontiers des performance 3d de la carte ATI. Si tu souhaitais l'utiliser il faut utiliser switcheroo.
Dans un premier temps fais tes tests peut être avec un seul écran.

Dernière modification par seblem (Le 04/10/2011, à 09:08)

Hors ligne

#18 Le 04/10/2011, à 17:58

Srede

Re : Problème acpi et carte graphique hybrid ubuntu 11.04

Bonjour,

je te remercie de ta réponse, je suivrai les tutos de ce blog demain et je vous redirai ce qu'il en est !

Sinon je n'ai pas trop de problème d'écran noir au démarrage, c'est juste qu'avec mon double screen, je dois brancher le VGA avant de booter le PC sinon impossible d'utiliser les 2 écrans... et au retour de mise en veille aussi j'ai des bugs mais ça serait peut-être résolu grâce au blog !

Après pour la 3d c'est pas grave, j'en ai pas besoin, c'était surtout la batterie qui tenait à peine 1h45 pour un pc neuf...

Merci en tout cas !

Hors ligne

#19 Le 05/10/2011, à 13:56

Srede

Re : Problème acpi et carte graphique hybrid ubuntu 11.04

Voilà. J'ai suivi le tuto et ça a l'air d'avoir marché, maintenant je peux sans autre brancher et débrancher mon second écran sans devoir rebooter, et je n'ai eu aucun écran noir à la reprise de la mise en veille...

Pour la batterie aussi ça a fonctionné, maintenant à 98% mon PC indique 7h02 restantes et avant c'était 2h10 à 100%...

Donc merci à vous!

Hors ligne

Haut de page ↑