Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 29/07/2005, à 13:09

genma

Double boot sur un disque de 300 Giga : Windows marche pas.

Bonjour à tous,

Dans le cadre professionnel, on a installé sur plusieurs machines un double boot Windows XP Pro / Debian. Windows s'installe correctement, on fait les mises à jour (SP1 + SP2). On installe Debian, tout se passe bien.

On redémmarre la machine et elle ne veut plus booter sous Windows.
Ca démarre et on a un écran bleu avec des blablas windowsiens :

"Un problème a été détecté et Windows a été arrêté afin de prévenir tout domage sur votre ordinateur.
(...)
*** stop 0x0000007B(0xF7C8463C, 0XC00000F,0X0000000, 0X00000000)"

J'ai googlé, j'ai testé l'option rootnoverify dans Grub (
Exemple :
Title Windows
rootnoverify (hd1,0)
makeactive
chainloader +1)

Mais rien n'y fait. Quelqu'un aurait déjà-t-il eu ce problème et aurait-il une solution?

Le disque dur est un disque de 300 Giga partionné en plusieurs partitions FAT32 (3*30 giga) et le reste en ext3 (/, /home) et swap.
Le problème ne viendrait-il pas de là?

#2 Le 29/07/2005, à 13:30

cep

Re : Double boot sur un disque de 300 Giga : Windows marche pas.

rootnoverify (hd1,0)

Un seul disque ? dans ce cas pourquoi (hd1,0) ?

Quelques recherches sur le forum devraient donner des pistes de solutions.
Voir le plan des partitions, Xp Pro ayant été installé en premier s'attend à trouver son boot.ini sur la première partition du premier disque (sauf installation spéciale).
Si ce n'est plus le cas, il faudra jouer avec l'option map de grub et aussi renseigner boot.ini sur le numéro de partition, s'il ne correspond plus.

/Mode HS : en environnement professionnel, je n'aurais pas fait de dual boot, ou si nécessaire, j'aurais privilégié une installation sur deux disques différents. /
Cordialement.
cep

Hors ligne

#3 Le 29/07/2005, à 13:41

genma

Re : Double boot sur un disque de 300 Giga : Windows marche pas.

L'exemple pour GRUB est un exemple. Il y a un seul disque IDE et donc, évidemment, c'est bien hd0 et pas hd1.

Le problème n'est-il pas dans la taille du disque ou dans l'installation de GRUB?

En effet, Windows est installé tout seul en premier et il fonctionne parfaitement, même après plusieurs boot et même avec les services packs (SP1 et SP2). Ca plante après installation de Debian et de GRUB pour le double boot...

#4 Le 29/07/2005, à 13:44

genma

Re : Double boot sur un disque de 300 Giga : Windows marche pas.

Apropos de l'environement profesionnel, ici, c'est le CNRS. Les chercheurs ont des besoins bien particuliers avec des outils sous Windows et d'autres sous Linux. Les machines sont livrées avec un seul disque.
On va pas faire n installations de Windows et Debian. On en fait une seule et après on clone le disque.

#5 Le 29/07/2005, à 14:21

cep

Re : Double boot sur un disque de 300 Giga : Windows marche pas.

Je présume que grub est installé sur le mbr.
Le boot sur debian fonctionne ? pas de message de grub ?
Si oui, la taille du disque ne devrait pas jouer.
Il serait interessant, sous système linux, de faire un fdisk -l (en root) pour voir le plan des partitions.
Ensuite, éditer /boot/grub/menu.lst et device.map pour voir comment tout cela a été configuré.
Si tout semble normal, refaire cette fois un sfdisk -l pour vérifier que la table des partitions n'a pas de chevauchements qui donnerait de mauvaises indications à Xp lors du boot. Non conformité entre ce qu'indique le bios, et ce que voit l'os lors du boot.
Et, si tout est normal, voir s'il ne serait pas possible d'utiliser un autre bootloader, sur disquette par exemple si la configuration materielle le permet.
Tout ceci en partant du principe que le disque est réglé en lba et que le bios est un bios récent.

/edit : Et si rien de tout cela ne fonctionne, je referais toutes les partitions :
1 primaire de 1 Go Fat 32 sur laquelle Xp mettrait son bootloader
1 primaire de 100 Mo en ext3 pour la partition /boot
1 primaire de X Go ou xp serait installé (système)
1 étendue avec toutes les logiques

Dernière modification par cep (Le 29/07/2005, à 14:35)

Hors ligne

#6 Le 29/07/2005, à 14:33

genma

Re : Double boot sur un disque de 300 Giga : Windows marche pas.

Sous Linux, la table des partitions est correcte.

Pour l'option LBA, c'est quoi exactement? Tu peux m'en dire plus s'il te plait?

#7 Le 29/07/2005, à 14:38

cep

Re : Double boot sur un disque de 300 Giga : Windows marche pas.

Correcte même sous sfdisk ?

Logical Block Adressing (option du bios)

Dans ce cas, tout repartitionner comme dit plus haut, afin d'avoir une partition de boot vers les débuts du disque.

Au fait :

On en fait une seule et après on clone le disque.

c'est bien sûr l'installation originale qui foire ? smile

Dernière modification par cep (Le 29/07/2005, à 14:45)

Hors ligne

#8 Le 29/07/2005, à 14:48

genma

Re : Double boot sur un disque de 300 Giga : Windows marche pas.

genma:/home/genma# fdisk -l /dev/hda

Disk /dev/hda: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1        3824    30716248+   c  W95 FAT32 (LBA)
/dev/hda2            3825       30367   213206647+   f  W95 Ext'd (LBA)
/dev/hda3           30368       30401      273105   83  Linux
/dev/hda5            3825        7648    30716248+   b  W95 FAT32
/dev/hda6            7649       11472    30716248+   b  W95 FAT32
/dev/hda7           11473       12080     4883728+  83  Linux
/dev/hda8           12081       12445     2931831   83  Linux
/dev/hda9           12446       12783     2714953+  82  Linux swap / Solaris
/dev/hda10          12784       12832      393561   83  Linux
/dev/hda11          12833       30367   140849856   83  Linux

genma:/home/genma# sfdisk -l /dev/hda

Disk /dev/hda: 30401 cylinders, 255 heads, 63 sectors/track
Units = cylinders of 8225280 bytes, blocks of 1024 bytes, counting from 0

   Device Boot Start     End   #cyls    #blocks   Id  System
/dev/hda1   *      0+   3823    3824-  30716248+   c  W95 FAT32 (LBA)
/dev/hda2       3824   30366   26543  213206647+   f  W95 Ext'd (LBA)
                start: (c,h,s) expected (1023,254,63) found (1023,0,1)
/dev/hda3      30367   30400      34     273105   83  Linux
/dev/hda4          0       -       0          0    0  Empty
/dev/hda5       3824+   7647    3824-  30716248+   b  W95 FAT32
                start: (c,h,s) expected (1023,254,63) found (1023,1,1)
/dev/hda6       7648+  11471    3824-  30716248+   b  W95 FAT32
                start: (c,h,s) expected (1023,254,63) found (1023,1,1)
/dev/hda7      11472+  12079     608-   4883728+  83  Linux
/dev/hda8      12080+  12444     365-   2931831   83  Linux
/dev/hda9      12445+  12782     338-   2714953+  82  Linux swap / Solaris
/dev/hda10     12783+  12831      49-    393561   83  Linux
/dev/hda11     12832+  30366   17535- 140849856   83  Linux

#9 Le 29/07/2005, à 14:50

genma

Re : Double boot sur un disque de 300 Giga : Windows marche pas.

Pour l'instant, on essait d'avoir une machine qui marche et après on la clonera.

#10 Le 29/07/2005, à 15:01

cep

Re : Double boot sur un disque de 300 Giga : Windows marche pas.

Ok. Pour autant, d'après ce que j'ai compris, grub fait demarrer xp, et c'est ensuite xp qui plante.

Il y a donc une indication qui lui manque ou qui est fausse.

La table des partitions, donc les partitions à monter par xp pourrait être une piste.

Eventuellement voir ceci :
http://forum.ubuntu-fr.org/viewtopic.php?id=5457

Hors ligne

Haut de page ↑