Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 17/08/2011, à 11:56

kaoul

[résolu]Reprise de veille impossible

Bonjour,

Je ne sais pas si c'est la mise en veille ou la reprise de veille qui ne fonctionne pas, mais sur mon Toshiba C660 : Obligé d'éteindre mon ordinateur avec le bouton pendant plusieurs secondes.
Étant donné que ma diode de caps-lock clignote sans arrête après la mise en veille et que le retro-elcairage s’allume. Je soupçonne que le problème vienne du driver nvidia.

Existe-t-il par exemple un moyen de mettre en veille en ligne de commande si on se met en console (ctrl+alt+f1) ?

Dernière modification par kaoul (Le 03/09/2011, à 14:03)


Mon entreprise de référencement ecommerce

Hors ligne

#2 Le 17/08/2011, à 12:30

Ayral

Re : [résolu]Reprise de veille impossible

Il y a de nombreux posts sur ce sujet, certains résolus, je te conseille d'y jeter un œil. C'est souvent une difficulté provenant des réglages de la carte graphique, de choix d'un pilote, etc.

Hors ligne

#3 Le 18/08/2011, à 16:25

kaoul

Re : [résolu]Reprise de veille impossible

Merci je sais bien et j'ai déjà parcouru de nombreux posts. Aucun ne résoud mon problème. J'ai déjà passé mon xorg.confg à vesa pour voir si cela aidait, ce n'est pas le cas.

Il y a-t-il un moyen de mettre en veille ubuntu à partir d'une console, un echo 1 /proc/acpi/bon-fichier-pour-mettre-en-veille tongue ?


Mon entreprise de référencement ecommerce

Hors ligne

#4 Le 20/08/2011, à 12:57

rouflak

Re : [résolu]Reprise de veille impossible

Bonjour,
Je rencontre exactement le même problème que vous.
J'ai déjà essayé un autre driver pour ma carte graphique (une version plus ancienne pour voir) mais rien n'y fait.
Pour ma part, je me demande si c'est un problème de carte graphique ou d'acpi. Je ne peux malheureusement faire aucune configuration dans le bios sur l'acpi donc aucun test possible. J'ai également essayé de démarré ubuntu avec l'option nomodeset dans grub... Mais cela ne change rien.
Les forums sont nombreux mais ne correspondent pas exactement au problème que je rencontre... Si quelqu'un a une idée.

Ma config :
PC : Asus k50in
RAM : 4GB
Proc : Intel Pentium T4300 Dual Core 2.3GHz
Système : Ubuntu 11.04

Hors ligne

#5 Le 21/08/2011, à 19:37

rouflak

Re : [résolu]Reprise de veille impossible

Bonjour,
J'ai trouvé un début de réponse quant au problème... Il semblerait que cela vienne du noyau. En effet, en revenant à un noyau plus ancien(2.6.38-8-generic), le problème ne survient pas. Si cela peut aider à trouver un début de solution... Je suis pas expert dans les problèmes linux. Je ne sais pas trop quoi poster comme log mais si quelqu'un souhaite que je lui donne un log en particulier, j'essayerai de le poster... Ceci dit, cela m'obligera à faire un hard reboot alors pas trop de demande s'il vous plait big_smile

Hors ligne

#6 Le 22/08/2011, à 23:22

rouflak

Re : [résolu]Reprise de veille impossible

Bon,
Finalement, le problème est réapparu avec le noyau 2.6.38-8-generic.
Je ne sais pas du tout vers quel piste me diriger et le nombre de réponses est plutôt léger.
Help Please !!!

Hors ligne

#7 Le 24/08/2011, à 19:50

rouflak

Re : [résolu]Reprise de veille impossible

Voici les dernières lignes de mon syslog lorsque je met le pc en veille (si ca peut aider et si quelqu'un vient pour lire big_smile) :

Aug 22 23:27:14 ubuntu-K50IN dbus-daemon: [system] Reloaded configuration
Aug 22 23:27:25 ubuntu-K50IN anacron[2209]: Anacron 2.3 started on 2011-08-22
Aug 22 23:27:25 ubuntu-K50IN anacron[2209]: Normal exit (0 jobs run)
Aug 22 23:27:25 ubuntu-K50IN kernel: [ 2143.265232] EXT4-fs (sda2): re-mounted. Opts: errors=remount-ro,commit=0
Aug 22 23:27:25 ubuntu-K50IN kernel: [ 2143.492697] EXT4-fs (sda4): re-mounted. Opts: commit=0
Aug 22 23:27:26 ubuntu-K50IN NetworkManager[834]: <info> sleep requested (sleeping: no  enabled: yes)
Aug 22 23:27:26 ubuntu-K50IN NetworkManager[834]: <info> sleeping or disabling...
Aug 22 23:27:26 ubuntu-K50IN NetworkManager[834]: <info> (eth0): now unmanaged
Aug 22 23:27:26 ubuntu-K50IN NetworkManager[834]: <info> (eth0): device state change: 2 -> 1 (reason 37)
Aug 22 23:27:26 ubuntu-K50IN NetworkManager[834]: <info> (eth0): cleaning up...
Aug 22 23:27:26 ubuntu-K50IN NetworkManager[834]: <info> (eth0): taking down device.
Aug 22 23:27:27 ubuntu-K50IN NetworkManager[834]: <info> (wlan0): now unmanaged
Aug 22 23:27:27 ubuntu-K50IN NetworkManager[834]: <info> (wlan0): device state change: 8 -> 1 (reason 37)
Aug 22 23:27:27 ubuntu-K50IN NetworkManager[834]: <info> (wlan0): deactivating device (reason: 37).
Aug 22 23:27:27 ubuntu-K50IN NetworkManager[834]: <info> (wlan0): canceled DHCP transaction, DHCP client pid 1657
Aug 22 23:27:27 ubuntu-K50IN NetworkManager[834]: <info> (wlan0): cleaning up...
Aug 22 23:27:27 ubuntu-K50IN NetworkManager[834]: <info> (wlan0): taking down device.
Aug 22 23:27:27 ubuntu-K50IN kernel: [ 2144.744463] wlan0: deauthenticating from a6:15:ea:b9:3f:24 by local choice (reason=3)
Aug 22 23:27:27 ubuntu-K50IN kernel: [ 2144.794500] cfg80211: All devices are disconnected, going to restore regulatory settings
Aug 22 23:27:27 ubuntu-K50IN kernel: [ 2144.794507] cfg80211: Restoring regulatory settings
Aug 22 23:27:27 ubuntu-K50IN kernel: [ 2144.794527] cfg80211: Calling CRDA to update world regulatory domain
Aug 22 23:27:27 ubuntu-K50IN kernel: [ 2144.799367] cfg80211: Ignoring regulatory request Set by core since the driver uses its own custom regulatory domain 
Aug 22 23:27:27 ubuntu-K50IN kernel: [ 2144.799375] cfg80211: World regulatory domain updated:
Aug 22 23:27:27 ubuntu-K50IN kernel: [ 2144.799377] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Aug 22 23:27:27 ubuntu-K50IN kernel: [ 2144.799380] cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Aug 22 23:27:27 ubuntu-K50IN kernel: [ 2144.799383] cfg80211:     (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Aug 22 23:27:27 ubuntu-K50IN kernel: [ 2144.799385] cfg80211:     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Aug 22 23:27:27 ubuntu-K50IN kernel: [ 2144.799388] cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Aug 22 23:27:27 ubuntu-K50IN kernel: [ 2144.799391] cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Aug 22 23:27:27 ubuntu-K50IN wpa_supplicant[1006]: CTRL-EVENT-DISCONNECTED bssid=00:00:00:00:00:00 reason=0

Hors ligne

#8 Le 30/08/2011, à 17:00

upRIlIon

Re : [résolu]Reprise de veille impossible

J'ai exactement le même problème. Sauf que j'ai un netbook avec un chipset graphique intel... donc le problème ne vient pas du pilote nvidia hmm

Hors ligne

#9 Le 03/09/2011, à 11:26

kaoul

Re : [résolu]Reprise de veille impossible

Bonjour upRlllon et rouflak bonne idée ton syslog, comment fait tu pour récupérer cette partie stp que l'on puisse comparer avec le mien ?

Voici ce que j'ai testé : http://www.absolutelytech.com/2010/10/1 … shortcuts/

J'ai fait Alt+ctrl+F1, j'ai coupé gdm (/etc/init.d/gdm stop) et ensuite en root :

pm-suspend

C'est la question que je posais au début : Comment mettre en veille en ligne de commande pour voir si ça passe.

Réponse : Ça ne marche pas. Même problème, le retro-éclairage de mon écran reste allumé et la diode capslock clignote.

Rouflak où en es-tu avec tes essais sur les kernel ? Personnellement, je soupçonne une incompatibilité kernel/acpi effectivement qui pourrait être résolue d'ici un an dans les prochains ubuntu. De quand datent vos ordinateurs ? Moi, quelques mois d'où son incompatibilité partielle avec linux à mon avis (on est habitués aux problèmes sur du nouveau matériel).


Mon entreprise de référencement ecommerce

Hors ligne

#10 Le 03/09/2011, à 12:08

kaoul

Re : [résolu]Reprise de veille impossible

Bonne nouvelle de mon côté, le problème est logiciel et semble pouvoir être résolu. En effet, capslock clignotant signifie kernel panic (merci : http://wiki.debian.org/Suspend )


Donc pour limiter les effets de personnalisation de mon installation (modules supplémentaires, pilotes et updates de kernel), j'ai booté sur le live cd 11.04.

Résultat : Suspend qui marche parfaitement. Un uname -r m'a confirmé que la version du live cd est un 2.6.38-8-generic.

Pour résumer les pistes que j'ai :
- un kernel 38-8 pourrait résoudre le problème (j'ai un 2.6.38-11-generic-pae)
- le module kernel de virtualbox 4.1 pouvait aussi être la cause du problème (et la solution serait d'utiliser virtualbox 4.0)
Je continue les recherches.

Dernière modification par kaoul (Le 03/09/2011, à 12:09)


Mon entreprise de référencement ecommerce

Hors ligne

#11 Le 03/09/2011, à 12:42

kaoul

Re : [résolu]Reprise de veille impossible

Nouveau test :
- avec un kernel-38-8, pas mieux ça ne suspend pas
- avec un kernel-38-8 en choisissant le mode de récupération de ubuntu, ça suspend bien (mais pas de reprise du rétroéclairage, je suis obligé de faire alt-ctrl-del mais pas grâve à mon avis)
- avec un kernel-38-11 en choisissant le mode de récupération de ubuntu, ça suspend bien aussi

Et chez vous ? Un test rapide : Booter en restant appuyé sur la touche shift, choisir dans grub le 38-11 de récupération et dans le menu de récupération, choisir "root admin console" (ou quelque chose comme ça). Taper "pm-suspend" et voir si ça se met en veille.


Mon entreprise de référencement ecommerce

Hors ligne

#12 Le 03/09/2011, à 14:02

kaoul

Re : [résolu]Reprise de veille impossible

Solution trouvée ! En fait il y avait deux problèmes :
1) Bug du module virtualbox 4.1 comme j'avais vu sur un forum anglais, j'ai donc créé ce fichier :

root@tshb:/usr/lib/pm-utils/sleep.d# cat 54virtualhook
#!/bin/sh
# Unload vboxdrv for a bug workaround on suspend on ubuntu 11.04

. "${PM_FUNCTIONS}"

suspend_vb()
{
    service vboxdrv stop
}

resume_vb()
{
    service vboxdrv start
}

case "$1" in
    hibernate|suspend)
        suspend_vb
        ;;
    thaw|resume)
        resume_vb
        ;;
    *) exit $NA
        ;;
esac

Ensuite un chmod +x sur ce fichier permet aux scripts de veille d'ubuntu d'appeler mon script (apparemment, ça marche bien héhé).

2) Il reste un bug très bizarre, si je clique sur veille et que je ne touche pas la souri. Lors de la reprise (le resume), l'écran reste noir et je ne peux qu'éteindre l'ordinateur. Si par contre je bouge la souri juste après avoir cliqué sur veille, le prompt "écran verrouillé" s'affiche quelques secondes et la reprise fonctionne. Pour celle-là, je n'ai pas d'explications et j'essaierai de penser à bouger la souris. Je ne sais pas comment changer le texte de "Mettre en veille" par "Mettre en veille (bouger la souri)" dans locale-langpack/fr/LC_MESSAGES/gnome-power-manager.mo qui est un fichier binaire tongue

Bon courage.


Mon entreprise de référencement ecommerce

Hors ligne

#13 Le 04/09/2011, à 12:55

drefhill

Re : [résolu]Reprise de veille impossible

kaoul a écrit :

en console (ctrl+alt+f1) ?

Comment fait on pour revenir a Ubuntu sur le bureau ?
Exit ne fait que me deloguer.


Linux Mint 13 32bits    sur   HP mini 2140                                               
Puce graphique Mobile Intel GMA 950          Chipset Mobile Intel 945GSE Express        CPU intel Atom N270 32bits
Disque dur SEAGATE 2,5'' 250 go + 4 go ssd 32 mo 7200 tr/min - hybride/sata ii - momentus xt
LinuxMint 13 64bits + Cinnamon

Hors ligne

#14 Le 05/09/2011, à 10:22

kaoul

Re : [résolu]Reprise de veille impossible

ctrl+alt+f7 (et si ca marche pas, ctrl+alt+f8)


Mon entreprise de référencement ecommerce

Hors ligne

#15 Le 31/10/2011, à 19:26

ludotek78

Re : [résolu]Reprise de veille impossible

Chers tous

Pour moi aussi, les mises en veille et hibernation se font dans la douleur :
    - au bout de quelques secondes après le lancement de la commande de mise en veille / hibernation, apparaît le fond d'écran de log in sans aucune fenêtre. La souris est fonctionnelle, mais pas de possibilité de reprendre la main (Ctrl+Alt+f1-8 ou ctrl-alt-suppr marchent pas), donc hard reboot.
    - la diode caps-lock ne clignote pas
    - pm-suspend.log ne donne pas de piste sur la cause du soucis

J'ai testé, sans succès :
- l'ajout de nomodeset dans le grub 2
- l'ajout du /etc/pm/sleep.d/20_custom-ehci_hcd
(cf http://thecodecentral.com/2011/01/18/fi … rking-bug)
- démarrage avec un noyau plus récent (du 2.6.35-30 vers le 2.6.38-12) = X ne démarre plus

Matos :
Sur lucid (10.04 LTS) - 2.6.35-30-generic
MSI-Wind U100 (netbook avec un chipset graphique intel "poulsbo", testé ok pour veille & hibernation sur http://doc.ubuntu-fr.org/veille_et_hibernation)

Z'avez des pistes ?
Merci d'avance !

Ludo

Ci-dessous, des infos supplémentaires

ludotek@ludotek-msi:~$ lspci
00:00.0 Host bridge: Intel Corporation System Controller Hub (SCH Poulsbo) (rev 07)
00:02.0 VGA compatible controller: Intel Corporation System Controller Hub (SCH Poulsbo) Graphics Controller (rev 07)
00:1b.0 Audio device: Intel Corporation System Controller Hub (SCH Poulsbo) HD Audio Controller (rev 07)
00:1c.0 PCI bridge: Intel Corporation System Controller Hub (SCH Poulsbo) PCI Express Port 1 (rev 07)
00:1c.1 PCI bridge: Intel Corporation System Controller Hub (SCH Poulsbo) PCI Express Port 2 (rev 07)
00:1d.0 USB Controller: Intel Corporation System Controller Hub (SCH Poulsbo) USB UHCI #1 (rev 07)
00:1d.1 USB Controller: Intel Corporation System Controller Hub (SCH Poulsbo) USB UHCI #2 (rev 07)
00:1d.2 USB Controller: Intel Corporation System Controller Hub (SCH Poulsbo) USB UHCI #3 (rev 07)
00:1d.7 USB Controller: Intel Corporation System Controller Hub (SCH Poulsbo) USB EHCI #1 (rev 07)
00:1f.0 ISA bridge: Intel Corporation System Controller Hub (SCH Poulsbo) LPC Bridge (rev 07)
00:1f.1 IDE interface: Intel Corporation System Controller Hub (SCH Poulsbo) IDE Controller (rev 07)
01:00.0 Mass storage controller: Silicon Image, Inc. Sil 3531 [SATALink/SATARaid] Serial ATA Controller (rev 01)
02:00.0 Network controller: RaLink RT2860

pm-suspend.log (tail, après un hibernate foireux)
/usr/lib/pm-utils/sleep.d/00powersave hibernate hibernate:success.
/usr/lib/pm-utils/sleep.d/01PulseAudio hibernate hibernate:success.
/etc/pm/sleep.d/10_grub-common hibernate hibernate:success.
/etc/pm/sleep.d/10_unattended-upgrades-hibernate hibernate hibernate:success.
/etc/pm/sleep.d/20_custom-ehci_hcd hibernate hibernate:0000:00:1d.7ls: cannot access /sys/bus/pci/drivers/xhci_hcd: No such file or directory
success.
/usr/lib/pm-utils/sleep.d/49bluetooth hibernate hibernate:not applicable.
/usr/lib/pm-utils/sleep.d/55NetworkManager hibernate hibernate:success.
/usr/lib/pm-utils/sleep.d/75modules hibernate hibernate:not applicable.
/usr/lib/pm-utils/sleep.d/90clock hibernate hibernate:not applicable.
/usr/lib/pm-utils/sleep.d/94cpufreq hibernate hibernate:success.
/usr/lib/pm-utils/sleep.d/95anacron hibernate hibernate:stop: Unknown instance: 
success.
/usr/lib/pm-utils/sleep.d/95led hibernate hibernate:not applicable.
/usr/lib/pm-utils/sleep.d/98video-quirk-db-handler hibernate hibernate:success.
/usr/lib/pm-utils/sleep.d/99video hibernate hibernate:success.
/etc/pm/sleep.d/action_wpa hibernate hibernate:success.
Mon Oct 31 17:45:13 CET 2011: performing hibernate


ludotek@ludotek-msi:~$ cat /etc/default/grub 
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT="0"
GRUB_HIDDEN_TIMEOUT="0"
GRUB_HIDDEN_TIMEOUT_QUIET="true"
GRUB_TIMEOUT="10"
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
GRUB_CMDLINE_LINUX=""

Lucid sur msi wind U100
Raring sur Dell XPS m1330

Hors ligne

#16 Le 04/11/2011, à 22:49

ludotek78

Re : [résolu]Reprise de veille impossible

non ?


Lucid sur msi wind U100
Raring sur Dell XPS m1330

Hors ligne

#17 Le 05/11/2011, à 10:23

fedeneck

Re : [résolu]Reprise de veille impossible

Salut à tous
Je suis un bleu mais j'avais le même problème et je l'ai résolu par la gestion énergie j'ai mis ne rien faire à la fermeture du capot et ne pas mettre en veille. Je pense que le problème est que le système arrête les disques au bout d'un certain temps d'inactivité.
Bonne chance.

Hors ligne

#18 Le 06/11/2011, à 17:48

ludotek78

Re : [résolu]Reprise de veille impossible

Oui, effectivement, c'est un début.:)
Mais bon, j'aimerais bien que ma veille / mon hibernation fonctionne quand même.

D'autres pistes ?


Lucid sur msi wind U100
Raring sur Dell XPS m1330

Hors ligne

#19 Le 08/11/2011, à 21:18

fedeneck

Re : [résolu]Reprise de veille impossible

essaie de modifier les temps d'attente avant la mise en veille/hibernation automatique ou les façons de le faire:capot,batterie critique etc...
Cad: Si tu mets en veille, par exemple, et que au bout de 10mn l'ordi passe automatiquement en hibernation (parce que resté sans activité) avec arrêt des disques ça démarre plus (c'est ce qui m'arrivait). Arrange toi pour que les actions ne se chevauchent pas .
Si j'ai pu t'être utile et clair......:cool:

Hors ligne

#20 Le 08/11/2011, à 21:50

ludotek78

Re : [résolu]Reprise de veille impossible

Merci pour ton aide Fedeneck.

Dans mon cas, que ça soit veille ou hibernation, déclanchée automatiquement ou manuellement, ça provoque le problème évoqué plus haut. Dans mon gestionnaire de l'énergie, je n'ai pas coché la case "arrêt des disques durs"...

J'ai l'impression que le problème est plus profond que ça...


Lucid sur msi wind U100
Raring sur Dell XPS m1330

Hors ligne

#21 Le 09/11/2011, à 20:34

fedeneck

Re : [résolu]Reprise de veille impossible

Ben désolé hmm moi je n'ai pus de problèmes de ce coté là mais la maj 11.10 m'a mis un sacré bazar, je crois que je vais formater et repasser à l'ancienne version en attendant que les bugs soit corrigés sad

Hors ligne

#22 Le 14/11/2011, à 20:30

ludotek78

Re : [résolu]Reprise de veille impossible

Yep.

Bon, dernier petit up sur mon problème très ennuyant (cf msg n°15).

:-)


Lucid sur msi wind U100
Raring sur Dell XPS m1330

Hors ligne

Haut de page ↑