Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 03/08/2005, à 23:32

PDemong

[Réglé] MPlayer et son pluggin pas capable de lire un .avi, .wmv

Bonjour,

je suis nouveau depuis quelques heures sur Ubuntu et je suis de plus en plus émerveillé de voir mes périphériques fonctionner.

J'ai suivi la méthode pour installer MPlayer et son pluggin pour Mozilla-firefox. Tout semble correctement installé, je suis même en mesure de lancer gmplayer, même si le sablier de Gnome semble stagner environ 15s alors que l'interface graphique est là.

Puis j'ouvre un fichier avi de mon disque dur et je tente de le lire. Et là ça fige. Pareil sous Firefox, si je tente de lire une page web avec une vidéo, ca commence à charger puis ca reste figer en écran noir au lieu de la vidéo.

Si je lance gmplayer depuis le mode console, voici ce qui s'affiche quand ca se lance et se fige :

gmplayer blowupcamp.wmv
MPlayer 1.0pre6-3.3.5 (C) 2000-2004 MPlayer Team
CPU: Intel Pentium 4/Xeon/Celeron Foster (Family: 8, Stepping: 7)
Detected cache-line size is 64 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for Debian.



vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission non accordée
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : Aucun fichier ou répertoire de ce type
Can't init input joystick
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: Aucun fichier ou répertoire de ce type
Failed to open LIRC support.
You will not be able to use your remote control.
Playing /home/pat/blowupcamp.wmv.
ASF file format detected.
VIDEO:  [WMV2]  320x240  24bpp  1000,000 fps    0,0 kbps ( 0,0 kbyte/s)
==========================================================================
Trying to force audio codec driver family libmad...
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 32000 Hz, 2 ch, 16 bit (0x10), ratio: 6000->128000 (48,0 kbit)
Selected audio codec: [ffwmav2] afm:ffmpeg (DivX audio v2 (ffmpeg))
==========================================================================
Xv: could not grab port 61
==========================================================================
Opening video decoder: [dshow] DirectShow video codecs
Decoder supports the following YUV formats: YUY2 IYUV UYVY YV12 YVYU I420 YVU9
Decoder is capable of YUV output (flags 0x7f)
VDec: vo config request - 320 x 240 (preferred csp: Packed YUY2)
[PP] Using codec's postprocessing, max q = 4.
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
VO: [xv] 320x240 => 320x240 Planar YV12
Selected video codec: [wmv8] vfm:dshow (Windows Media Video 8)
==========================================================================
Checking audio filter chain for 32000Hz/2ch/16bit -> 32000Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 32000 hz, little endian signed int
AF_pre: 32000Hz 2ch Signed 16-bit (Little-Endian)
alsa-init: got device=0, subdevice=0
alsa-init: 1 soundcard found, using: default

Bon alors par contre, je m'aperçois que Totem se porte comme un charme et me lit mes fichiers vidéos, amis el son est pourri et le flux irrégulier. Je viens de monde Suse+KDE, je connais mal Gnome. Y aurait-il une incompatibité entre MPlayer et Gnome ?

Cela ne me dérange pas de changer mes habitudes et d'abandonner Mplayer au profit de Totem si ce dernier marche systématiquement. Mais avant de m'orienter vers Totem, je me demande si MPlayer marche bien pour vous autre, et si vous avez une idée sur mon problème...

Dernière modification par PDemong (Le 04/08/2005, à 19:42)

Hors ligne

#2 Le 04/08/2005, à 02:15

PDemong

Re : [Réglé] MPlayer et son pluggin pas capable de lire un .avi, .wmv

Whoa! Je viens de découvrir xine-ui et de l'installer. C'est prodigieux et remplace avantageusement MPlayer pour la lecture des DVDs. J'ai même l'interface pour choisir mes chapitres.

Je crois que je peux me passer de MPlayer finalement lol

Il me reste à trouver une façon de visualiser la vidéo sous firefox, mais je crois qu'il y a une extension qui permet de lire le multimedia sans avoir mplayer. Je regarderai cela plus tard.

En attendant, si quelqu'un comprend pourquoi MPlayer ne roule pas, je suis toujours preneur.

Hors ligne

#3 Le 04/08/2005, à 02:29

Julian

Re : [Réglé] MPlayer et son pluggin pas capable de lire un .avi, .wmv

Salut et bienvenu à toi,

Pour mplayer essaie avec le driver video x11.

Sinon si tu aimes xine, t'as kaffeine qui est interface graphique (frontend) de xine, bien foutu, et paramétrable facilement.

@ +
Julian.


julian@jabber.fr

Hors ligne

#4 Le 04/08/2005, à 02:34

PDemong

Re : [Réglé] MPlayer et son pluggin pas capable de lire un .avi, .wmv

Je trouve deja l'interface graphique de xine magnifique. Mais j'essaierai dès que possible kaffeine...

Pour MPlayer, même en modifiant le driver vidéo sur x11 cela ne fonctionne pas.

Hors ligne

#5 Le 04/08/2005, à 06:43

AlexandreP

Re : [Réglé] MPlayer et son pluggin pas capable de lire un .avi, .wmv

Attention, Kaffeine utilise les bibliothèques Qt.  Il est probable qu'il ne soit pas très joli sous Gnome.

Sinon, Totem peut aussi utiliser Xine, au lieu de gstreamer.  Rechercher 'totem-xine' dans Synaptic.


«La capacité d'apprendre est un don; La faculté d'apprendre est un talent; La volonté d'apprendre est un choix.» -Frank Herbert
93,8% des gens sont capables d'inventer des statistiques sans fournir d'études à l'appui.

Hors ligne

#6 Le 04/08/2005, à 10:21

dawar

Re : [Réglé] MPlayer et son pluggin pas capable de lire un .avi, .wmv

Surement l'eternel problème avec ESD, essai de lancer mplayer avec l'option -ao esd


S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadoks)

Hors ligne

#7 Le 04/08/2005, à 17:09

PDemong

Re : [Réglé] MPlayer et son pluggin pas capable de lire un .avi, .wmv

Dawar,

je viens de trouver ma solution et en voulant la poster, je vois que tu me l'avais donné : il faut effectivement utiliser le module son esound.

J'avais les mêmes symptomes avec XMMS et c'est en choisissant esound comme pluggin de sortie que j'ai pu débloquer XMMS.
Du coup, je suis aller dans les préférences de MPlayer et j'ai sélectionné dans l'onglet Audio le driver esound. Et là aussi cela a débloqué mon gmplayer/MPlayer.


Je vais ouvrir un autre Topic pour vous demander comment on sélectionne sa gestion de son dans Ubuntu et lequel est conseillé. J'imagine que cela dépend des players qu'on utilise... les player de Gnome semblent tous utiliser par défaut esound. Sans doute pour cela qu'il n'y avait qu'eux qui fonctionnait.

Je vais voir si je peux débloquer mon skype avec cette info. En attendant, merci beaucoup.

Par contre, mon pluggin mozilla marche toujours pas. Vous avez une idée pourquoi ?

Hors ligne

#8 Le 04/08/2005, à 19:42

PDemong

Re : [Réglé] MPlayer et son pluggin pas capable de lire un .avi, .wmv

J'ai trouvé !
Le problème du pluggin venait de ESD, j'utilise maintenant ALSA et tout fonctionne. J'ai suivi ce tuto à la section  Comment configurer correctement le son ?.

Tout fonctionne désormais, XMMS et MPlayer et Skype! Vive ALSA!

Hors ligne

Haut de page ↑