Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 25/12/2006, à 00:38

darkweaver87

[Résolu] Rectangles sur emacs lors du passage sur Edgy

Salut tout le monde,

Bon c'est juste un post histoire de répondre aux interrogations de certaines personnes conçernant le fonctionnement bizarre de Emacs.
En effet, ce problème est survenu lorsque j'ai converti ma voisine à Ubuntu.
Vous imaginez sans peine que, du coup, ça ne lui a pas fait une bonne première impression.
J'ai donc tenté de lui réparer ça mais le temps me manquer car j'avais des projets informatiques à rendre.
Après, j'ai oublié ...
Jusqu'au jour où, aprés avoir réinstallé notre cher Ubuntu sur mon pc portable (pour refaire le partionnement de mon disque), j'ai eu le même problème qu'elle.
Aucun post n'a pu le résoudre.
Puis, j'ai compris d'où il venais : le serveur X.
En effet, je ne sais pas pourquoi (peut être à cause l'installation du paquet nvidia-glx), mais mon xorg.conf avait changé de tête.
Ainsi, le serveur X n'allait pas charger les polices au bon endroit.
Par conséquent, Emacs ne pouvait trouver ces polices et affichait donc des rectangles.
Pour vous en convaincre, faites un

emacs -nw toto.txt

et vous verrez bien que en non graphique, ça fonctionne !!
Pour régler le problème il faut donc dire au server X, où aller chercher ces polices.
Pour celà, remplacez simplement les "X11/fonts"par "fonts/X11" via la commande Emacs M-x replace-string.

sudo emacs -nw /etc/X11/xorg.conf

Ainsi votre section "Files" devrait ressembler à ça :

Section "Files"
	FontPath	"/usr/share/fonts/X11/misc"
	FontPath	"/usr/share/fonts/X11/cyrillic"
	FontPath	"/usr/share/fonts/X11/100dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/75dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/Type1"
	FontPath	"/usr/share/fonts/X11/100dpi"
	FontPath	"/usr/share/fonts/X11/75dpi"
	FontPath	"/usr/share/fonts/X11/misc"
	# path to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Enregistrer les modification sur le fichier via C-x C-s et redemarrez le server X.

/etc/init.d/gdm restart

(pour gnome)
Emacs fonctionne !!

Dernière modification par darkweaver87 (Le 02/01/2007, à 13:58)


Gentoo noyau 2.6.34-r6

Hors ligne

#2 Le 26/12/2006, à 11:46

7he

Re : [Résolu] Rectangles sur emacs lors du passage sur Edgy

MAGNIFIQUE!

J'avais aussi un problème de fonts avec Emacs, ceci l'a résolu!
Serait il possible d'épingler ce sujet?
Merci!!

7he

Hors ligne

#3 Le 23/01/2007, à 13:27

usman

Re : [Résolu] Rectangles sur emacs lors du passage sur Edgy

Bonjour,

J'ai le même problème avec emacs et cela fait plusieurs fois que je lis cette solution sur les forums (qui semble efficace pour les autres)
Le probleme c'est que moi à la base dans "section files" il n'y avait rien, pas trop embêtant j'ai rajouté les dites lignes : sans effet...
J'ai alors verifié le chemin et decouvert que moi j'avais un dossier wine et non X11 dans /usr/share/fonts/
J'ai donc essayé de remplacer la solution intelligemment en mettant wine à la place de X11 dans le ficher xorg.conf : sans effet ...

Voilà un peu mon problème si qq pouvait m'aider je voudreztravailler sur emacs car c'est avec ca que je travail à la faculté.

Merci.

Dernière modification par usman (Le 23/01/2007, à 13:28)

Hors ligne

Haut de page ↑