Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 25/12/2006, à 12:28

Wakinyan

[Résolu]Où se procurer UN SEUL paquet Feisty ?

Bonjour,

pour permettre l'importation des photos de mon appareil sur mon pc, j'ai besoin de passer de la version libgphoto2 2.2 à la version libgphoto2 (2.3.0-0ubuntu1). Or, ce paquet n'est disponible que pour Feisty et je suis sous Edgy.

Savez-vous comment procéder pour récupérer ce paquet ?

Merci d'avance et joyeuses fêtes smile

Dernière modification par Wakinyan (Le 03/01/2007, à 11:12)

Hors ligne

#2 Le 25/12/2006, à 14:31

csat18

Re : [Résolu]Où se procurer UN SEUL paquet Feisty ?

http://packages.ubuntu.com/

Pour trouver ton bonheur

Hors ligne

#3 Le 29/12/2006, à 12:40

Wakinyan

Re : [Résolu]Où se procurer UN SEUL paquet Feisty ?

Merci de l'info, je conserve ce lien smile

Dernière modification par Wakinyan (Le 29/12/2006, à 12:54)

Hors ligne

#4 Le 29/12/2006, à 12:48

Smarter

Re : [Résolu]Où se procurer UN SEUL paquet Feisty ?

Faut que tu le recompiles, il est compilé avec la libc6 et est donc incompatible.
Pour la recompilation tu peux tenter de rajouter le dépot main de feisty à ton sources.list mais uniquement avec la ligne deb-src, mais il faudra bidouiller dans les fichiers de compilation pour changer les dépendances.

Hors ligne

#5 Le 29/12/2006, à 13:12

Wakinyan

Re : [Résolu]Où se procurer UN SEUL paquet Feisty ?

Arfff! hmm

Merci du conseil Smarter. J'étais en train de télécharger le .deb et de m'apercevoir des problèmes de dépendance.

Sinon, ne serait-il pas plus simple de demander (où et à qui) un portage du paquet dans les backports ? Vu le nombre de personnes affectée sous Edgy, je pense que la demande serait pertinente non ?

Hors ligne

#6 Le 29/12/2006, à 21:28

bertrand0

Re : [Résolu]Où se procurer UN SEUL paquet Feisty ?

C'est rapide à obtenir, après avoir ajouté la ligne deb-src adéquate dans sources.list.
1) installer l'outil d'aide à la compilation:
sudo aptitude install apt-src
2) installer les sources du paquet:
mkdir ~/src
cd ~/src
apt-src install libgphoto2
3) compiler
apt-src build libgphoto2
4) installer les deux paquets binaires
sudo dpkg -i  libgphoto2-2_2.3.0-0ubuntu1_i386.deb libgphoto2-port0_2.3.0-0ubuntu1_i386.deb

Je confirme que ça s'installe sans problème de cette façon sur edgy.


Ceux qui écrivent comme ils parlent, quoiqu'ils parlent très bien, écrivent mal.
                                                            Buffon, Discours sur le style

Hors ligne

#7 Le 03/01/2007, à 11:11

Wakinyan

Re : [Résolu]Où se procurer UN SEUL paquet Feisty ?

Super !!!!

Je peux enfin importer tranquillement les images de mon Powershot a630 sur ma Edgy !

Merci beaucoup de votre aide big_smile:D:D


Edit : la ligne à ajouter dans le sources.list est

deb-src http://fr.archive.ubuntu.com/ubuntu/ feisty main

Il faut juste rapatrier le paquet voulu et vite commenter cette ligne. Entre temps il ne faut faire aucune mise à jour sinon de gros problèmes peuvent survenir.

Dernière modification par Wakinyan (Le 11/01/2007, à 19:40)

Hors ligne

#8 Le 03/01/2007, à 23:08

gilles

Re : [Résolu]Où se procurer UN SEUL paquet Feisty ?

Ca marche pas chez moi sad

Pourquoi ?
Le chargement des photos fonctionnait il y a une heure. Une mise à jour et hop... J'ai sui obligé de passer sur la session windows. Grand moment de tristesse.

gilles@gilles-laptop:~/src$ sudo dpkg -i libgphoto2-2_2.3.0-0ubuntu1_i386.deb libgphoto2-port0_2.3.0-0ubuntu1_i386.deb
dpkg : erreur de traitement de libgphoto2-2_2.3.0-0ubuntu1_i386.deb (--install) :
 ne peut pas accéder à l'archive: Aucun fichier ou répertoire de ce type
dpkg : erreur de traitement de libgphoto2-port0_2.3.0-0ubuntu1_i386.deb (--install) :
 ne peut pas accéder à l'archive: Aucun fichier ou répertoire de ce type
Des erreurs ont été rencontrées pendant l'exécution :
 libgphoto2-2_2.3.0-0ubuntu1_i386.deb
 libgphoto2-port0_2.3.0-0ubuntu1_i386.deb

Hors ligne

#9 Le 04/01/2007, à 12:01

Wakinyan

Re : [Résolu]Où se procurer UN SEUL paquet Feisty ?

Salut,

et en double cliquant directement sur les .deb générés ? Tu pourras peut-être les installer en cliquant sur le bouton "installer" du gestionnaire de paquet.

Hors ligne

#10 Le 04/01/2007, à 15:12

bertrand0

Re : [Résolu]Où se procurer UN SEUL paquet Feisty ?

Est-ce que tu es sûr que l'étape build s'est déroulée sans erreur ? Vérifie si apt-src ne te parle pas d'un paquet manquant pour la compilation.
Si c'est le cas, tu peux essayer la commande "sudo apt-get build-dep libgphoto2"

Dernière modification par bertrand0 (Le 04/01/2007, à 15:13)


Ceux qui écrivent comme ils parlent, quoiqu'ils parlent très bien, écrivent mal.
                                                            Buffon, Discours sur le style

Hors ligne

#11 Le 08/01/2007, à 15:48

pat

Re : [Résolu]Où se procurer UN SEUL paquet Feisty ?

bertrand0 a écrit

C'est rapide à obtenir, après avoir ajouté la ligne deb-src adéquate dans sources.list.

1)je fais donc sudo gedit /etc/apt/sources.list

2)vais sur
http://packages.ubuntu.com/
3) je tape feisty puis libgphoto.On est d'accord mais comment j'obtiens la ligne deb-src adequate????
Désolé....je ne l'ai js fait !
Pour être + simple je marque quoi dans mon sources.list ?
Merci.
Ps: la question est un peu bête mais c'est la seule façon d'apprendre

Hors ligne

#12 Le 08/01/2007, à 16:38

bertrand0

Re : [Résolu]Où se procurer UN SEUL paquet Feisty ?

Mettons que tu veuilles le paquet source de libgphoto2-2. C'est un paquet du dépôt principal (main). Tu as deux possibilités, une jolie, une moche:
1) tu coches "Système/Administration/Synaptic/Catégories/Dépôts/Ubuntu 6.10/Code Source" ou bien "Système/Administration/Sources de mise à jour/Ubuntu 6.10/Code source"
Dans ce cas, synaptic se chargera de rajouter la ligne adéquate dans sources.list, il y a juste à recharger la liste des paquets, comme indiqué par synaptic dans un petit message.

2) tu édites à la main sources.list. Tu repères les lignes qui contiennent edgy, edgy-security, edgy-updates, edgy-backports et qui ne sont pas commentées (#). Tu les recopies en remplaçant le "deb" en début de ligne par "deb-src"

EDIT:J'ai oublié, dans les deux cas, il faut ensuite éditer le fichier sources.list, et remplacer UNIQUEMENT dans les lignes deb-src toutes les occurences de edgy par feisty.

Dernière modification par bertrand0 (Le 08/01/2007, à 20:27)


Ceux qui écrivent comme ils parlent, quoiqu'ils parlent très bien, écrivent mal.
                                                            Buffon, Discours sur le style

Hors ligne

#13 Le 08/01/2007, à 18:40

pat

Re : [Résolu]Où se procurer UN SEUL paquet Feisty ?

re
je viens de faire la 1ere méthode ...Maintenant je vais essayer smile
On verra.!
Merci de l'aide

Hors ligne

#14 Le 08/01/2007, à 19:16

pat

Re : [Résolu]Où se procurer UN SEUL paquet Feisty ?

Même message que gilles.
Enfin ce n'est pas tres grave mais j'aurais bien aimé comprendre

Hors ligne

#15 Le 08/01/2007, à 19:43

bertrand0

Re : [Résolu]Où se procurer UN SEUL paquet Feisty ?

J'explique: Le message indique "Fichier non trouvé". Ceci signifie que c'est l'étape précédente qui a raté. Donc je ne peux rien dire de plus si je ne vois pas le message renvoyé lors de la compilation. J'ai fait la supposition que c'était une dépendance manquante, et j'ai donc proposé la commmande avec build-dep. En l'absence de réponse de gilles, je ne peux rien faire de plus.


Ceux qui écrivent comme ils parlent, quoiqu'ils parlent très bien, écrivent mal.
                                                            Buffon, Discours sur le style

Hors ligne

#16 Le 08/01/2007, à 19:55

pat

Re : [Résolu]Où se procurer UN SEUL paquet Feisty ?

Ok et merci.
Ne te prends pas la tête... smile je ne me suis pas cassé une jambe !

Pour mémoire


oatrick@vegas:~$ sudo apt-get build-dep libgphoto2
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Reading state information... Fait       
Les NOUVEAUX paquets suivants seront installés :
  libdbus-1-dev libhal-dev
Les paquets suivants seront mis à jour :
  libc6 libc6-dev libc6-i686 libdbus-1-3 libhal1
5 mis à jour, 2 nouvellement installés, 0 à enlever et 732 non mis à jour.
Il est nécessaire de prendre 9476ko dans les archives.
Après dépaquetage, 6025ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
Réception de : 1 http://archive.ubuntu.com feisty/main libc6-dev 2.5-0ubuntu8 [3019kB]
Réception de : 2 http://archive.ubuntu.com feisty/main libc6 2.5-0ubuntu8 [4098kB]
Réception de : 3 http://archive.ubuntu.com feisty/main libc6-i686 2.5-0ubuntu8 [1182kB]
Réception de : 4 http://archive.ubuntu.com feisty/main libdbus-1-3 1.0.2-1ubuntu2 [269kB]
Réception de : 5 http://archive.ubuntu.com feisty/main libdbus-1-dev 1.0.2-1ubuntu2 [335kB]
Réception de : 6 http://archive.ubuntu.com feisty/main libhal1 0.5.8.1-4ubuntu1 [285kB]
Réception de : 7 http://archive.ubuntu.com feisty/main libhal-dev 0.5.8.1-4ubuntu1 [288kB]
9476ko réceptionnés en 37s (255ko/s)                                           
(Lecture de la base de données... 107282 fichiers et répertoires déjà installés.)
Préparation du remplacement de libc6-dev 2.4-1ubuntu12 (en utilisant .../libc6-dev_2.5-0ubuntu8_i386.deb) ...
Dépaquetage de la mise à jour de libc6-dev ...
Préparation du remplacement de libc6 2.4-1ubuntu12 (en utilisant .../libc6_2.5-0ubuntu8_i386.deb) ...
Dépaquetage de la mise à jour de libc6 ...
Paramétrage de libc6 (2.5-0ubuntu8) ...
Installation de la nouvelle version du fichier de configuration /etc/init.d/glibc.sh ...

(Lecture de la base de données... 107299 fichiers et répertoires déjà installés.)
Préparation du remplacement de libc6-i686 2.4-1ubuntu12 (en utilisant .../libc6-i686_2.5-0ubuntu8_i386.deb) ...
Dépaquetage de la mise à jour de libc6-i686 ...
Préparation du remplacement de libdbus-1-3 0.93-0ubuntu3.1 (en utilisant .../libdbus-1-3_1.0.2-1ubuntu2_i386.deb) ...
Dépaquetage de la mise à jour de libdbus-1-3 ...
Sélection du paquet libdbus-1-dev précédemment désélectionné.
Dépaquetage de libdbus-1-dev (à partir de .../libdbus-1-dev_1.0.2-1ubuntu2_i386.deb) ...
Préparation du remplacement de libhal1 0.5.7.1-0ubuntu17 (en utilisant .../libhal1_0.5.8.1-4ubuntu1_i386.deb) ...
Dépaquetage de la mise à jour de libhal1 ...
Sélection du paquet libhal-dev précédemment désélectionné.
Dépaquetage de libhal-dev (à partir de .../libhal-dev_0.5.8.1-4ubuntu1_i386.deb) ...
Paramétrage de libc6-dev (2.5-0ubuntu8) ...
Paramétrage de libc6-i686 (2.5-0ubuntu8) ...

Paramétrage de libdbus-1-3 (1.0.2-1ubuntu2) ...

Paramétrage de libdbus-1-dev (1.0.2-1ubuntu2) ...
Paramétrage de libhal1 (0.5.8.1-4ubuntu1) ...

Paramétrage de libhal-dev (0.5.8.1-4ubuntu1) ...
oatrick@vegas:~$

De toute façon je peux charger mes photos et films par Mandriva

Hors ligne

#17 Le 08/01/2007, à 20:07

bertrand0

Re : [Résolu]Où se procurer UN SEUL paquet Feisty ?

Manifestement, il manquait des dépendances. Il suffit de reprendre à partir de apt-src build. (En se plaçant au préalable dans ~/src bien sûr.)

pat a écrit :

Réception de : 1 http://archive.ubuntu.com feisty/main libc6-dev 2.5-0ubuntu8 [3019kB]
Réception de : 2 http://archive.ubuntu.com feisty/main libc6 2.5-0ubuntu8 [4098kB]
...

???
Attention dans ton sources.list, seules les lignes deb-src peuvent être mises en feisty. Ne mets surtout pas de ligne deb en feisty, ou tu risques de chambouler ta config.

Dernière modification par bertrand0 (Le 08/01/2007, à 20:17)


Ceux qui écrivent comme ils parlent, quoiqu'ils parlent très bien, écrivent mal.
                                                            Buffon, Discours sur le style

Hors ligne

#18 Le 09/01/2007, à 18:30

pat

Re : [Résolu]Où se procurer UN SEUL paquet Feisty ?

Salut
C'est nickel chrome smile)Malheureusement pas vu ton dernier post à temps
voir ce lien
http://forum.ubuntu-fr.org/viewtopic.php?pid=682828#p682828
Néanmoins ce n'est pas tres grave sauf que je me suis levé à 3h30 du mat pour réinstaller tellement cela m'énervait mais c'est aussi parceque je ne dormais pas .
Cependant, heureusement que j'ai l'habitude de faire des sauvegardes.

Merci pour l'aide smile) et au moins cela m'a permis de faire ma 1ere compil. et d'avancer un petit peu

Hors ligne

#19 Le 05/02/2007, à 22:11

badzil

Re : [Résolu]Où se procurer UN SEUL paquet Feisty ?

J'ai créé une page dans le wiki pour expliquer la manipulation d'installation de la libgphoto2 de Feisty.

http://doc.ubuntu-fr.org/libgphoto2

Merci d'aller y jeter un coup d'oeil et de faire des corrections si nécessaire. J'ai également proposé de lister les appareils pour qui la manipulation a marché. Si vous le voulez bien, vous pouvez rajouter le vôtre.

Dernière modification par badzil (Le 05/02/2007, à 22:11)

Hors ligne

#20 Le 06/02/2007, à 18:20

bertrand0

Re : [Résolu]Où se procurer UN SEUL paquet Feisty ?

tu as oublié le "install" de apt-src install libgphoto2


Ceux qui écrivent comme ils parlent, quoiqu'ils parlent très bien, écrivent mal.
                                                            Buffon, Discours sur le style

Hors ligne

#21 Le 06/02/2007, à 18:31

pat

Re : [Résolu]Où se procurer UN SEUL paquet Feisty ?

Compiler les sources :

sudo apt-src build libgphoto2

oui  sudo apt-get install src build libgphoto2 ( ça devrait -être cela smile
Maintenant pour rajouter mon appareil photo peux -tu me dire comment j'édite la page stp ?
Merci

Hors ligne

#22 Le 06/02/2007, à 18:57

bertrand0

Re : [Résolu]Où se procurer UN SEUL paquet Feisty ?

Il faut avoir un compte sur le wiki.


Ceux qui écrivent comme ils parlent, quoiqu'ils parlent très bien, écrivent mal.
                                                            Buffon, Discours sur le style

Hors ligne

#23 Le 06/02/2007, à 19:58

pat

Re : [Résolu]Où se procurer UN SEUL paquet Feisty ?

bertrand0 a écrit :

Il faut avoir un compte sur le wiki.

Ok .Je verrais ça + tard car j'ai plein de boulot.
Mon appareil photo est un Canon Digital Ixus 900 TI.
Je l'ai peu utilisé mais il semble tres performant

Hors ligne

#24 Le 07/02/2007, à 00:25

badzil

Re : [Résolu]Où se procurer UN SEUL paquet Feisty ?

Merci pour la correction pat. J'ai également rajouté ton appareil sur la page.

Hors ligne