Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 20/03/2011, à 19:26

macg

Mon écran reste éteint...... (problème de sortie de veille)

Bonjour,

J'ai de plus en plus de problème avec mon ubuntu, et la ça devient insupportable.

J'ai toujours eu des problème de sortie de veille. Avant il sortait de veille une fois sur deux environ, puis un jour une super Màj du kernel est venue foutre la merde, parce que maintenant mon ordi sort tout le temps de veille.Mais depuis, l'écran ne se rallume plus, lorsqu'il est s'éteint pour cause d'inactivité. Il suffit que l'écran ai le malheur de s'atteindre, pour des raison d'économie d'énergie, pour je soit obliger de redémarre (avec les sysRq car l'ecran reste noir). Autre fais encore plus drôle, l'écran se rallume lors de la sortie de veille.

J'ai regarder les divers log je n'ai rien trouvé désintéressement, j'ai chercher sur google en vain......

En bref, je sais plus quoi faire....

Ordinateur Acer Aspire, Core i3, Radeon HD5650 (avec drivers proprio), Ubuntu 10.10 64bit

Un autre fait étrange de temps en temps le disque dur s'emballe lors de la sortie de veille, et celle-ci peu alors durée plusieurs minutes ( plus long qu'un démarrage normal). J'ai essayer de déterminer le processus responsable de ça avec iotpo mais en vain....

En espérant que vous ayez quelques idée de piste a me donner.
Merci pour votre aide.

Dernière modification par macg (Le 25/04/2011, à 13:18)

Hors ligne

#2 Le 20/03/2011, à 20:37

sauthess

Re : Mon écran reste éteint...... (problème de sortie de veille)

Bonjour,

Je suis d'accord avec toi, des fois l'hibernation et la veille sous linux.... (au moins avant de trouver pourquoi ça plante...)

Mais avec le temps, j'ai appris à trouver des solutions

as-tu des erreurs ACPI dans dmesg ? (à chaque nouvelle installation de pc, je passe du temps à trouver les bons paramètres noyau pour que le pc marche bien et en générale je joue avec des acpi_osi=Linux acpi=strict acpi_os_name="Windows 2009" ....)
-> dmesg  | grep -2i acpi

Ces erreurs sont souvent dûes aux constructeurs qui maintiennent des tables DSDT (pour l'acpi) buggées et spécifiques à Windows (quand bien même ceux qui définissent les norment sont intel, microsoft, HP....)
Il faut donc trouver les bons paramètres pour que le pc devienne stable et le reste à chaque mise à jour noyau (en générale, je galère pour tout optimiser la première fois puis je n'y touche plus des années et pourtant je n'utilise que linux...)

Si tu peux me fournir :
- le résultat de dmesg
- le résultat de cat /proc/acpi/dsdt > dsdt.out je pourrais peux être voir ce qui cloche

PS : peut-être que je me trompe (dans ce cas milles excuses) mais souvent c'est la source du problème..


Serveur : Debian openvz, Portable 1 : Arch linux, Portable 2 et 3 : Ubuntu

Hors ligne

#3 Le 20/03/2011, à 21:44

sauthess

Re : Mon écran reste éteint...... (problème de sortie de veille)

Autre chose à laquelle je viens de penser :

as-tu regardé les logs /var/log/pm-*, elles contiennent tes logs pour la veille et l'hibernation. Peut-être verras-tu quelque chose...

Il est possible qu'un module  supporte mal la mise en veille...


Serveur : Debian openvz, Portable 1 : Arch linux, Portable 2 et 3 : Ubuntu

Hors ligne

#4 Le 20/03/2011, à 23:40

macg

Re : Mon écran reste éteint...... (problème de sortie de veille)

Bon alors j'ai verifier les log, mais j'ai rien trouver...

$dmesg | grep -2i acpi a écrit :

[    0.000000]  BIOS-e820: 00000000bf3e2000 - 00000000bf40f000 (reserved)
[    0.000000]  BIOS-e820: 00000000bf40f000 - 00000000bf46f000 (usable)
[    0.000000]  BIOS-e820: 00000000bf46f000 - 00000000bf4f0000 (ACPI NVS)
[    0.000000]  BIOS-e820: 00000000bf4f0000 - 00000000bf70f000 (reserved)
[    0.000000]  BIOS-e820: 00000000bf70f000 - 00000000bf717000 (usable)
[    0.000000]  BIOS-e820: 00000000bf717000 - 00000000bf71f000 (reserved)
[    0.000000]  BIOS-e820: 00000000bf71f000 - 00000000bf77d000 (usable)
[    0.000000]  BIOS-e820: 00000000bf77d000 - 00000000bf79f000 (ACPI NVS)
[    0.000000]  BIOS-e820: 00000000bf79f000 - 00000000bf7e1000 (usable)
[    0.000000]  BIOS-e820: 00000000bf7e1000 - 00000000bf7ff000 (ACPI data)
[    0.000000]  BIOS-e820: 00000000bf7ff000 - 00000000bf800000 (usable)
[    0.000000]  BIOS-e820: 00000000bf800000 - 00000000c0000000 (reserved)
--
[    0.000000]  modified: 00000000bf3e2000 - 00000000bf40f000 (reserved)
[    0.000000]  modified: 00000000bf40f000 - 00000000bf46f000 (usable)
[    0.000000]  modified: 00000000bf46f000 - 00000000bf4f0000 (ACPI NVS)
[    0.000000]  modified: 00000000bf4f0000 - 00000000bf70f000 (reserved)
[    0.000000]  modified: 00000000bf70f000 - 00000000bf717000 (usable)
[    0.000000]  modified: 00000000bf717000 - 00000000bf71f000 (reserved)
[    0.000000]  modified: 00000000bf71f000 - 00000000bf77d000 (usable)
[    0.000000]  modified: 00000000bf77d000 - 00000000bf79f000 (ACPI NVS)
[    0.000000]  modified: 00000000bf79f000 - 00000000bf7e1000 (usable)
[    0.000000]  modified: 00000000bf7e1000 - 00000000bf7ff000 (ACPI data)
[    0.000000]  modified: 00000000bf7ff000 - 00000000bf800000 (usable)
[    0.000000]  modified: 00000000bf800000 - 00000000c0000000 (reserved)
--
[    0.000000] kernel direct mapping tables up to 138000000 @ 18000-1e000
[    0.000000] RAMDISK: 37570000 - 37ff0000
[    0.000000] ACPI: RSDP 00000000000f6a20 00024 (v02 PTLTD )
[    0.000000] ACPI: XSDT 00000000bf7f2bda 0005C (v01 ACRSYS ACRPRDCT 06040000 INNA 00000000)
[    0.000000] ACPI: FACP 00000000bf7e3000 000F4 (v03 INTEL  CALPELLA 06040000 PTEC 00000001)
[    0.000000] ACPI: DSDT 00000000bf7e4000 0BF94 (v02 Intel  CALPELLA 06040000 INTL 20060912)
[    0.000000] ACPI: FACS 00000000bf79afc0 00040
[    0.000000] ACPI: HPET 00000000bf7fed6a 00038 (v01 INTEL  CALPELLA 06040000 PTEC 00000001)
[    0.000000] ACPI: MCFG 00000000bf7feda2 0003C (v01 INTEL  CALPELLA 06040000 PTEC 00000001)
[    0.000000] ACPI: SLIC 00000000bf7fedde 00176 (v01 ACRSYS ACRPRDCT 06040000 ANNI 00000001)
[    0.000000] ACPI: APIC 00000000bf7fef54 00084 (v01 PTLTD  ? APIC   06040000  LTP 00000000)
[    0.000000] ACPI: BOOT 00000000bf7fefd8 00028 (v01 PTLTD  $SBFTBL$ 06040000  LTP 00000001)
[    0.000000] ACPI: SSDT 00000000bf7e2000 009F1 (v01  PmRef    CpuPm 00003000 INTL 20051117)
[    0.000000] ACPI: Local APIC address 0xfee00000
[    0.000000] No NUMA configuration found
[    0.000000] Faking a node at 0000000000000000-0000000138000000
--
[    0.000000]   Normal zone: 3136 pages used for memmap
[    0.000000]   Normal zone: 226240 pages, LIFO batch:31
[    0.000000] ACPI: PM-Timer IO Port: 0x408
[    0.000000] ACPI: Local APIC address 0xfee00000
[    0.000000] ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
[    0.000000] ACPI: LAPIC (acpi_id[0x01] lapic_id[0x04] enabled)
[    0.000000] ACPI: LAPIC (acpi_id[0x02] lapic_id[0x01] enabled)
[    0.000000] ACPI: LAPIC (acpi_id[0x03] lapic_id[0x05] enabled)
[    0.000000] ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
[    0.000000] ACPI: LAPIC_NMI (acpi_id[0x01] high edge lint[0x1])
[    0.000000] ACPI: LAPIC_NMI (acpi_id[0x02] high edge lint[0x1])
[    0.000000] ACPI: LAPIC_NMI (acpi_id[0x03] high edge lint[0x1])
[    0.000000] ACPI: IOAPIC (id[0x02] address[0xfec00000] gsi_base[0])
[    0.000000] IOAPIC[0]: apic_id 2, version 32, address 0xfec00000, GSI 0-23
[    0.000000] ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 high edge)
[    0.000000] ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 high level)
[    0.000000] ACPI: IRQ0 used by override.
[    0.000000] ACPI: IRQ2 used by override.
[    0.000000] ACPI: IRQ9 used by override.
[    0.000000] Using ACPI (MADT) for SMP configuration information
[    0.000000] ACPI: HPET id: 0x8086a701 base: 0xfed00000
[    0.000000] SMP: Allowing 4 CPUs, 0 hotplug CPUs
[    0.000000] nr_irqs_gsi: 40
--
[    0.000000]   #8 [000009c971 - 000009cadd]    MP-table mpc
[    0.000000]   #9 [0000010000 - 0000012000]      TRAMPOLINE
[    0.000000]   #10 [0000012000 - 0000016000]     ACPI WAKEUP
[    0.000000]   #11 [0000016000 - 0000018000]         PGTABLE
[    0.000000]   #12 [0000018000 - 0000019000]         PGTABLE
--
[    0.002164] ... fixed-purpose events:   3
[    0.002165] ... event mask:             000000070000000f
[    0.004446] ACPI: Core revision 20100428
[    0.027788] ftrace: converting mcount calls to 0f 1f 44 00 00
[    0.027793] ftrace: allocating 22688 entries in 89 pages
--
[    0.791874] NET: Registered protocol family 16
[    0.791969] Trying to unpack rootfs image as initramfs...
[    0.791983] ACPI: bus type pci registered
[    0.792061] PCI: MMCONFIG for domain 0000 [bus 00-ff] at [mem 0xe0000000-0xefffffff] (base 0xe0000000)
[    0.792064] PCI: MMCONFIG at [mem 0xe0000000-0xefffffff] reserved in E820
[    0.858175] PCI: Using configuration type 1 for base access
[    0.858973] bio: create slab <bio-0> at 0
[    0.861005] ACPI: EC: Look up EC in DSDT
[    0.870279] ACPI: BIOS _OSI(Linux) query ignored
[    0.871581] ACPI: SSDT 00000000bf71ac18 003A0 (v01  PmRef  Cpu0Ist 00003000 INTL 20051117)
[    0.872133] ACPI: Dynamic OEM Table Load:
[    0.872136] ACPI: SSDT (null) 003A0 (v01  PmRef  Cpu0Ist 00003000 INTL 20051117)
[    0.872473] ACPI: SSDT 00000000bf718618 005CD (v01  PmRef  Cpu0Cst 00003001 INTL 20051117)
[    0.872997] ACPI: Dynamic OEM Table Load:
[    0.872999] ACPI: SSDT (null) 005CD (v01  PmRef  Cpu0Cst 00003001 INTL 20051117)
[    0.873615] ACPI: SSDT 00000000bf719a98 00303 (v01  PmRef    ApIst 00003000 INTL 20051117)
[    0.874212] ACPI: Dynamic OEM Table Load:
[    0.874215] ACPI: SSDT (null) 00303 (v01  PmRef    ApIst 00003000 INTL 20051117)
[    0.874422] ACPI: SSDT 00000000bf717d98 00119 (v01  PmRef    ApCst 00003000 INTL 20051117)
[    0.874978] ACPI: Dynamic OEM Table Load:
[    0.874981] ACPI: SSDT (null) 00119 (v01  PmRef    ApCst 00003000 INTL 20051117)
[    1.036957] Freeing initrd memory: 10752k freed
[    1.389480] ACPI: Interpreter enabled
[    1.389485] ACPI: (supports S0 S3 S4 S5)
[    1.389513] ACPI: Using IOAPIC for interrupt routing
[    1.405856] ACPI: EC: GPE = 0x17, I/O: command/status = 0x66, data = 0x62
[    1.406142] ACPI: No dock devices found.
[    1.406145] PCI: Using host bridge windows from ACPI; if necessary, use "pci=nocrs" and report a bug
[    1.407129] \_SB_.PCI0:_OSC invalid UUID
[    1.407131] _OSC request data:1 8 1f
[    1.407136] ACPI: PCI Root Bridge [PCI0] (domain 0000 [bus 00-fe])
[    1.408598] pci_root PNP0A08:00: host bridge window [io  0x0000-0x0cf7]
[    1.408601] pci_root PNP0A08:00: host bridge window [io  0x0d00-0xffff]
--
[    1.429036] pci 0000:00:1e.0:   bridge window [mem 0x000e0000-0x000e3fff] (subtractive decode)
[    1.429039] pci 0000:00:1e.0:   bridge window [mem 0xc0000000-0xfeafffff] (subtractive decode)
[    1.429059] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
[    1.429343] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P2._PRT]
[    1.429503] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P1._PRT]
[    1.429752] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.RP01._PRT]
[    1.429906] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.RP02._PRT]
[    1.430223] \_SB_.PCI0:_OSC invalid UUID
[    1.430225] _OSC request data:1 1f 1f
[    1.443363] ACPI: PCI Root Bridge [CPBG] (domain 0000 [bus ff])
[    1.443896] ACPI: PCI Interrupt Link [LNKA] (IRQs 1 3 4 5 6 7 10 12 14 15) *11
[    1.444030] ACPI: PCI Interrupt Link [LNKB] (IRQs 1 3 4 5 6 7 11 12 14 15) *10
[    1.444162] ACPI: PCI Interrupt Link [LNKC] (IRQs 1 3 4 5 6 7 *10 12 14 15)
[    1.444292] ACPI: PCI Interrupt Link [LNKD] (IRQs 1 3 4 *5 6 7 11 12 14 15)
[    1.444423] ACPI: PCI Interrupt Link [LNKE] (IRQs 1 3 4 5 6 7 10 12 14 15) *0, disabled.
[    1.444558] ACPI: PCI Interrupt Link [LNKF] (IRQs 1 3 4 5 6 7 11 12 14 15) *0, disabled.
[    1.444690] ACPI: PCI Interrupt Link [LNKG] (IRQs 1 3 4 5 6 *7 10 12 14 15)
[    1.444822] ACPI: PCI Interrupt Link [LNKH] (IRQs 1 3 4 5 6 7 *11 12 14 15)
[    1.444882] HEST: Table is not found!
[    1.444958] vgaarb: device added: PCI:0000:02:00.0,decodes=io+mem,owns=io+mem,locks=none
--
[    1.445251] usbcore: registered new interface driver hub
[    1.445274] usbcore: registered new device driver usb
[    1.445604] ACPI: WMI: Mapper loaded
[    1.445606] PCI: Using ACPI for IRQ routing
[    1.445609] PCI: pci_cache_line_size set to 64 bytes
[    1.445705] reserve RAM buffer: 000000000009c400 - 000000000009ffff
--
[    1.447891] Switching to clocksource tsc
[    1.455619] AppArmor: AppArmor Filesystem Enabled
[    1.455636] pnp: PnP ACPI init
[    1.455654] ACPI: bus type pnp registered
[    1.458519] pnp: PnP ACPI: found 11 devices
[    1.458521] ACPI: ACPI bus type pnp unregistered
[    1.458534] system 00:05: [io  0x0500-0x050f] has been reserved
[    1.458537] system 00:05: [io  0xffff] has been reserved
--
[    1.490093] intel_idle: v0.4 model 0x25
[    1.490094] intel_idle: lapic_timer_reliable_states 0xffffffff
[    1.491038] ACPI: AC Adapter [ADP1] (on-line)
[    1.491135] input: Lid Switch as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input0
[    1.492649] ACPI: Lid Switch [LID0]
[    1.492690] input: Sleep Button as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input1
[    1.492695] ACPI: Sleep Button [SLPB]
[    1.492727] input: Power Button as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input2
[    1.492730] ACPI: Power Button [PWRF]
[    1.493321] ACPI: acpi_idle yielding to intel_idle
[    1.511259] thermal LNXTHERM:01: registered as thermal_zone0
[    1.511266] ACPI: Thermal Zone [TZS0] (56 C)
[    1.518910] thermal LNXTHERM:02: registered as thermal_zone1
[    1.518916] ACPI: Thermal Zone [TZS1] (29 C)
[    1.518991] ERST: Table is not found!
[    1.520343] Linux agpgart interface v0.103
--
[    1.612271] registered taskstats version 1
[    1.612566]   Magic number: 3:329:197
[    1.612610] acpi device:52: hash matches
[    1.612631] acpi PNP0100:00: hash matches
[    1.612720] rtc_cmos 00:06: setting system clock to 2011-03-20 21:10:20 UTC (1300655420)
[    1.612723] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
--
[    1.703770] ahci 0000:00:1f.2: irq 43 for MSI/MSI-X
[    1.703808] ahci: SSS flag set, parallel bus scan disabled
[    1.712395] ACPI: Battery Slot [BAT0] (battery present)
[    1.729584] ahci 0000:00:1f.2: AHCI 0001.0300 32 slots 4 ports 3 Gbps 0x33 impl SATA mode
[    1.729590] ahci 0000:00:1f.2: flags: 64bit ncq sntf ilck stag pm led clo pio slum part ems sxs apst
--
[   23.925501] intel ips 0000:00:1f.6: failed to get i915 symbols, graphics turbo disabled
[   23.925658] intel ips 0000:00:1f.6: IPS driver initialized, MCP temp limit 0
[   23.931002] acer-wmi: Acer Laptop ACPI-WMI Extras
[   23.936524] acer-wmi: Unable to detect available WMID devices
[   24.229833] Linux video capture interface: v2.00
--
[   24.307518] USB Video Class driver (v0.1.0)
[   24.423448] lp: driver loaded but no devices found
[   24.439705] acpi device:02: registered as cooling_device4
[   24.439939] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:00/LNXVIDEO:00/input/input6
[   24.440004] ACPI: Video Device [PEGP] (multi-head: yes  rom: no  post: no)
[   24.717006] cfg80211: Calling CRDA to update world regulatory domain
[   24.720984] cfg80211: World regulatory domain updated:

Pour le fichier dst : http://ubuntuone.com/p/ick/

pour les logs : logs /var/log/pm-*, j'ai vérifier mais j'ai rien trouvé, mis a part ça "Having NetworkManager wake interfaces back up...Failed." mais bon ça n'a rien a voir....

Merci pour ton aide smile

Hors ligne

#5 Le 21/03/2011, à 22:33

sauthess

Re : Mon écran reste éteint...... (problème de sortie de veille)

Bonsoir,

Je ne vois pas grand chose comme erreur (à part \_SB_.PCI0:_OSC invalid UUID mais j'ai la même à la maison wink)

La table dsdt recompilée montre une erreur (pas top mais je pense que linux doit pouvoir faire avec).
Tu peux tenter de la recompiler et de l'intégrer mais à mon avis il y a plus simple...

As-tu essayé les options au démarrage du noyau  ?
Par exemple extrait de mon /etc/default/grub : (c'est celui qui semble le mieux marcher pour moi il faut faire des tests et voir ce qui est le mieux...)
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vga=791"
GRUB_CMDLINE_LINUX="acpi_osi=Linux acpi=strict"

tu peux aussi jouer avec acpi_os_name="Windows 2009" (qui fera croire à ton bios que c'est Win7 qui a booté...). Les différentes options dans ton cas (tiré du fichier dsdt que tu as fournis) :
"Windows 2001"
"Windows 2001 SP1"
"Windows 2001 SP2"
"Windows 2006"
"Windows 2009"
"Linux"


(ne pas oublier update-grub après l'édition)

c'est peut être le module fglrx qui n'aime pas la mise en veille...As-tu essayé en utilisant le pilote libre ??

Regarde le fichier : /etc/default/acpi-support, il y a des options qui peuvent peut être aider (sur d'autres portable que j'ai eu ces options m'ont aidées)

De rien (tu me remercieras si on arrive à trouver quelque chose d'utile wink )

PS : tu es chanceux, tu peux utiliser le driver proprio, moi la carte ATI je ne peux l'utiliser car pas d'option de désactivation de la carte intel dans mon bios ...


Serveur : Debian openvz, Portable 1 : Arch linux, Portable 2 et 3 : Ubuntu

Hors ligne

#6 Le 22/03/2011, à 16:52

macg

Re : Mon écran reste éteint...... (problème de sortie de veille)

Bon j'ai ajouter

GRUB_CMDLINE_LINUX="acpi_osi=Linux acpi=strict"

a mon fichier /etc/default/grub, et ca semble être bon smile

Merci. ça fait plaisir d'avoir un écran qui se rallume quand on en a besoin smile

Hors ligne

#7 Le 25/04/2011, à 13:17

macg

Re : Mon écran reste éteint...... (problème de sortie de veille)

Bon je relance ce fils de discussion, car maintenant mon ordi met environ 3 minutes a sortir de veille (et c'est particulièrement insupportable).

Donc lorsque je le sort de veille un "processus fou" (ou module kernel je sais pas) utilise le disque dur de manière anormal. Le disque dur et en pleine activité et bloque complètement la sortie de veille. Ce problème semble survenir lorsque mon système utilise un grande partie de la RAM disponible càd, lorsque j'ai plus de 2Go de RAM utilisé (mon ordi est équipé de 4Go de RAM). Et la ou ça devient intéressant c'est qu'il me semble qu'il met en SAWP yikes.

Je m'explique, je met en veille mon ordi avec un peu plus de 2Go de RAM utilisé, la swap et complètement vide (ou alors c'est négligeable). Je sors mon ordi de veille le disque dur s'emballe, la sortie de veille dure plusieurs minutes et là magie j'ai plus de 800Mo de swap utilisé. De plus les application sont extrêmement lente du fait qu'elle semble avoir été déplacé en swap...  (bon sa c'est pas le problème, juste le temps que le système sorte les donnée de la swap et c'est bon smile ).

J'ai donc utilisé iotop pour essayer d'identifier un processus ayant recours de manière anormal au disque dur pendant la sortie de veille. Et j'ai identifier une commande nommée "--channel~XXXXXXX" (les X sont des chiffres) qui utilise le disque dur de manière intensive. Cependant je ne sais pas a quoi cette commande correspond sad

Je tire de cela plusieurs possible raison du problème :
[*]un process/script  qui a une fuite de mémoire et force le kernel a déplacer les applications en swap[/*]
[*]Un bug du kernel (mais ça me paraîtrais etrange)[/*]
[*]Un option pourrie du BIOS (je me méfie de ACER)[/*]

Je m'explique pour la dernière proposition qui peut paraître étrange, mais le comportement de mon ordi l'est aussi.
Sous Windows lorsque je fais mettre en veille et que je le laisse en veille durant une longue période et bien magie, lorsque
je veux m'en servire celui-ci n'est plus en veille mais en veille prolongée (hibernation) yikes:o. Je soupçonne donc une
option pourrie dans le BIOS pour gérer ça.

Voila, je ne vois absolument pas comment résoudre ce problème sad, donc si quelqu'un aurais une petite idée....

Hors ligne

#8 Le 09/05/2011, à 19:28

Pascal94

Re : Mon écran reste éteint...... (problème de sortie de veille)

bonjour tout le monde tongue

moi qui pensais être le seul à avoir des soucis pour sortir de veille hmm

voici le résultat de la commande   dmesg  | grep -2i acpi

[    0.000000]  BIOS-e820: 00000000000e4000 - 0000000000100000 (reserved)
[    0.000000]  BIOS-e820: 0000000000100000 - 00000000df690000 (usable)
[    0.000000]  BIOS-e820: 00000000df690000 - 00000000df69e000 (ACPI data)
[    0.000000]  BIOS-e820: 00000000df69e000 - 00000000df6d0000 (ACPI NVS)
[    0.000000]  BIOS-e820: 00000000df6d0000 - 00000000df6de000 (reserved)
[    0.000000]  BIOS-e820: 00000000df6e0000 - 00000000df700000 (reserved)
--
[    0.000000] kernel direct mapping tables up to 120000000 @ df68a000-df690000
[    0.000000] RAMDISK: 366e2000 - 37369000
[    0.000000] ACPI: RSDP 00000000000fb7f0 00014 (v00 ACPIAM)
[    0.000000] ACPI: RSDT 00000000df690000 0003C (v01 A_M_I_ OEMRSDT  08001020 MSFT 00000097)
[    0.000000] ACPI: FACP 00000000df690200 00084 (v02 A_M_I_ OEMFACP  08001020 MSFT 00000097)
[    0.000000] ACPI: DSDT 00000000df6905c0 08A54 (v01  A1350 A1350000 00000000 INTL 20060113)
[    0.000000] ACPI: FACS 00000000df69e000 00040
[    0.000000] ACPI: APIC 00000000df690390 0006C (v01 A_M_I_ OEMAPIC  08001020 MSFT 00000097)
[    0.000000] ACPI: MCFG 00000000df690400 0003C (v01 A_M_I_ OEMMCFG  08001020 MSFT 00000097)
[    0.000000] ACPI: OEMB 00000000df69e040 00080 (v01 A_M_I_ AMI_OEM  08001020 MSFT 00000097)
[    0.000000] ACPI: HPET 00000000df699020 00038 (v01 A_M_I_ OEMHPET  08001020 MSFT 00000097)
[    0.000000] ACPI: GSCI 00000000df69e0c0 02024 (v01 A_M_I_ GMCHSCI  08001020 MSFT 00000097)
[    0.000000] ACPI: Local APIC address 0xfee00000
[    0.000000] No NUMA configuration found
[    0.000000] Faking a node at 0000000000000000-0000000120000000
--
[    0.000000]   Normal zone: 1792 pages used for memmap
[    0.000000]   Normal zone: 129280 pages, LIFO batch:31
[    0.000000] ACPI: PM-Timer IO Port: 0x808
[    0.000000] ACPI: Local APIC address 0xfee00000
[    0.000000] ACPI: LAPIC (acpi_id[0x01] lapic_id[0x00] enabled)
[    0.000000] ACPI: LAPIC (acpi_id[0x02] lapic_id[0x01] enabled)
[    0.000000] ACPI: LAPIC (acpi_id[0x03] lapic_id[0x02] enabled)
[    0.000000] ACPI: LAPIC (acpi_id[0x04] lapic_id[0x03] enabled)
[    0.000000] ACPI: IOAPIC (id[0x04] address[0xfec00000] gsi_base[0])
[    0.000000] IOAPIC[0]: apic_id 4, version 32, address 0xfec00000, GSI 0-23
[    0.000000] ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
[    0.000000] ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 high level)
[    0.000000] ACPI: IRQ0 used by override.
[    0.000000] ACPI: IRQ2 used by override.
[    0.000000] ACPI: IRQ9 used by override.
[    0.000000] Using ACPI (MADT) for SMP configuration information
[    0.000000] ACPI: HPET id: 0x8086a201 base: 0xfed00000
[    0.000000] SMP: Allowing 4 CPUs, 0 hotplug CPUs
[    0.000000] nr_irqs_gsi: 40
--
[    0.012247] CPU0: Thermal monitoring enabled (TM1)
[    0.012251] using mwait in idle threads.
[    0.014239] ACPI: Core revision 20110112
[    0.020011] ftrace: allocating 24316 entries in 96 pages
[    0.030037] Setting APIC routing to flat
--
[    0.642818] NET: Registered protocol family 16
[    0.642818] Trying to unpack rootfs image as initramfs...
[    0.642818] ACPI: bus type pci registered
[    0.642818] PCI: MMCONFIG for domain 0000 [bus 00-3f] at [mem 0xf0000000-0xf3ffffff] (base 0xf0000000)
[    0.642818] PCI: not using MMCONFIG
[    0.642818] PCI: Using configuration type 1 for base access
[    0.660607] bio: create slab <bio-0> at 0
[    0.661342] ACPI: EC: Look up EC in DSDT
[    0.661897] ACPI: Executed 1 blocks of module-level executable AML code
[    0.720792] ACPI: SSDT 00000000df6a00f0 001D2 (v01    AMI   CPU1PM 00000001 INTL 20060113)
[    0.721012] ACPI: Dynamic OEM Table Load:
[    0.721015] ACPI: SSDT           (null) 001D2 (v01    AMI   CPU1PM 00000001 INTL 20060113)
[    0.721147] ACPI: SSDT 00000000df6a02d0 00143 (v01    AMI   CPU2PM 00000001 INTL 20060113)
[    0.721363] ACPI: Dynamic OEM Table Load:
[    0.721365] ACPI: SSDT           (null) 00143 (v01    AMI   CPU2PM 00000001 INTL 20060113)
[    0.721495] ACPI: SSDT 00000000df6a0420 00143 (v01    AMI   CPU3PM 00000001 INTL 20060113)
[    0.721713] ACPI: Dynamic OEM Table Load:
[    0.721715] ACPI: SSDT           (null) 00143 (v01    AMI   CPU3PM 00000001 INTL 20060113)
[    0.721843] ACPI: SSDT 00000000df6a0570 00143 (v01    AMI   CPU4PM 00000001 INTL 20060113)
[    0.722060] ACPI: Dynamic OEM Table Load:
[    0.722063] ACPI: SSDT           (null) 00143 (v01    AMI   CPU4PM 00000001 INTL 20060113)
[    0.722232] ACPI: Interpreter enabled
[    0.722235] ACPI: (supports S0 S1 S3 S4 S5)
[    0.722252] ACPI: Using IOAPIC for interrupt routing
[    0.722273] PCI: MMCONFIG for domain 0000 [bus 00-3f] at [mem 0xf0000000-0xf3ffffff] (base 0xf0000000)
[    0.723055] PCI: MMCONFIG at [mem 0xf0000000-0xf3ffffff] reserved in ACPI motherboard resources
[    0.734160] ACPI: No dock devices found.
[    0.734162] HEST: Table not found.
[    0.734164] PCI: Using host bridge windows from ACPI; if necessary, use "pci=nocrs" and report a bug
[    0.734210] ACPI: PCI Root Bridge [PCI0] (domain 0000 [bus 00-ff])
[    0.734308] pci_root PNP0A08:00: host bridge window [io  0x0000-0x0cf7]
[    0.734310] pci_root PNP0A08:00: host bridge window [io  0x0d00-0xffff]
--
[    0.735526] pci 0000:00:1e.0:   bridge window [mem 0x000d0000-0x000dffff] (subtractive decode)
[    0.735527] pci 0000:00:1e.0:   bridge window [mem 0xdf700000-0xffffffff] (subtractive decode)
[    0.735539] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
[    0.735599] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P1._PRT]
[    0.735640] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P4._PRT]
[    0.735661] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P5._PRT]
[    0.735692]  pci0000:00: Requesting ACPI _OSC control (0x1d)
[    0.739032] ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 6 7 *10 11 12 14 15)
[    0.739067] ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 6 7 10 *11 12 14 15)
[    0.739101] ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 5 6 7 10 11 12 14 *15)
[    0.739134] ACPI: PCI Interrupt Link [LNKD] (IRQs *3 4 5 6 7 10 11 12 14 15)
[    0.739168] ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 5 6 7 10 11 12 14 15) *0, disabled.
[    0.739202] ACPI: PCI Interrupt Link [LNKF] (IRQs 3 4 5 6 7 10 11 12 14 15) *0, disabled.
[    0.739237] ACPI: PCI Interrupt Link [LNKG] (IRQs 3 4 5 6 7 10 11 12 14 15) *0, disabled.
[    0.739271] ACPI: PCI Interrupt Link [LNKH] (IRQs 3 4 *5 6 7 10 11 12 14 15)
[    0.739346] vgaarb: device added: PCI:0000:00:02.0,decodes=io+mem,owns=io+mem,locks=none
[    0.739353] vgaarb: loaded
--
[    0.739539] usbcore: registered new device driver usb
[    0.739539] wmi: Mapper loaded
[    0.739539] PCI: Using ACPI for IRQ routing
[    0.739539] PCI: pci_cache_line_size set to 64 bytes
[    0.739539] reserve RAM buffer: 000000000009fc00 - 000000000009ffff
--
[    0.770029] Switching to clocksource hpet
[    0.775678] AppArmor: AppArmor Filesystem Enabled
[    0.775704] pnp: PnP ACPI init
[    0.775719] ACPI: bus type pnp registered
[    0.775805] pnp 00:00: [bus 00-ff]
[    0.775807] pnp 00:00: [io  0x0cf8-0x0cff]
--
[    0.775813] pnp 00:00: [mem 0x000d0000-0x000dffff window]
[    0.775815] pnp 00:00: [mem 0xdf700000-0xffffffff window]
[    0.775857] pnp 00:00: Plug and Play ACPI device, IDs PNP0a08 PNP0a03 (active)
[    0.775865] pnp 00:01: [mem 0xfed14000-0xfed19fff]
[    0.775907] system 00:01: [mem 0xfed14000-0xfed19fff] has been reserved
[    0.775910] system 00:01: Plug and Play ACPI device, IDs PNP0c01 (active)
[    0.775935] pnp 00:02: [dma 4]
[    0.775936] pnp 00:02: [io  0x0000-0x000f]
--
[    0.775942] pnp 00:02: [io  0x008f]
[    0.775943] pnp 00:02: [io  0x00c0-0x00df]
[    0.775962] pnp 00:02: Plug and Play ACPI device, IDs PNP0200 (active)
[    0.775970] pnp 00:03: [io  0x0070-0x0071]
[    0.775979] pnp 00:03: [irq 8]
[    0.776000] pnp 00:03: Plug and Play ACPI device, IDs PNP0b00 (active)
[    0.776006] pnp 00:04: [io  0x0061]
[    0.776023] pnp 00:04: Plug and Play ACPI device, IDs PNP0800 (active)
[    0.776030] pnp 00:05: [io  0x00f0-0x00ff]
[    0.776033] pnp 00:05: [irq 13]
[    0.776054] pnp 00:05: Plug and Play ACPI device, IDs PNP0c04 (active)
[    0.776316] pnp 00:06: [irq 7]
[    0.776318] pnp 00:06: [dma 3]
[    0.776319] pnp 00:06: [io  0x0378-0x037f]
[    0.776321] pnp 00:06: [io  0x0778-0x077f]
[    0.776424] pnp 00:06: Plug and Play ACPI device, IDs PNP0401 (active)
[    0.776447] pnp 00:07: [io  0x0000-0xffffffffffffffff disabled]
[    0.776448] pnp 00:07: [io  0x0000-0xffffffffffffffff disabled]
[    0.776450] pnp 00:07: [io  0x0290-0x0297]
[    0.776481] system 00:07: [io  0x0290-0x0297] has been reserved
[    0.776484] system 00:07: Plug and Play ACPI device, IDs PNP0c02 (active)
[    0.776551] pnp 00:08: [io  0x0010-0x001f]
[    0.776552] pnp 00:08: [io  0x0022-0x003f]
--
[    0.776618] system 00:08: [mem 0xfed1c000-0xfed1ffff] has been reserved
[    0.776620] system 00:08: [mem 0xfed20000-0xfed8ffff] has been reserved
[    0.776622] system 00:08: Plug and Play ACPI device, IDs PNP0c02 (active)
[    0.776669] pnp 00:09: [mem 0xfed00000-0xfed003ff]
[    0.776691] pnp 00:09: Plug and Play ACPI device, IDs PNP0103 (active)
[    0.776726] pnp 00:0a: [mem 0xffb00000-0xffbfffff]
[    0.776727] pnp 00:0a: [mem 0xfff00000-0xffffffff]
[    0.776747] pnp 00:0a: Plug and Play ACPI device, IDs INT0800 (active)
[    0.776775] pnp 00:0b: [mem 0xffc00000-0xffefffff]
[    0.776805] system 00:0b: [mem 0xffc00000-0xffefffff] has been reserved
[    0.776807] system 00:0b: Plug and Play ACPI device, IDs PNP0c02 (active)
[    0.776840] pnp 00:0c: [mem 0xfec00000-0xfec00fff]
[    0.776841] pnp 00:0c: [mem 0xfee00000-0xfee00fff]
[    0.776871] system 00:0c: [mem 0xfec00000-0xfec00fff] could not be reserved
[    0.776874] system 00:0c: [mem 0xfee00000-0xfee00fff] has been reserved
[    0.776876] system 00:0c: Plug and Play ACPI device, IDs PNP0c02 (active)
[    0.777077] pnp 00:0d: [irq 4]
[    0.777078] pnp 00:0d: [dma 0 disabled]
[    0.777080] pnp 00:0d: [io  0x03f8-0x03ff]
[    0.777128] pnp 00:0d: Plug and Play ACPI device, IDs PNP0501 (active)
[    0.777151] pnp 00:0e: [mem 0xf0000000-0xf3ffffff]
[    0.777181] system 00:0e: [mem 0xf0000000-0xf3ffffff] has been reserved
[    0.777183] system 00:0e: Plug and Play ACPI device, IDs PNP0c02 (active)
[    0.777293] pnp 00:0f: [mem 0x00000000-0x0009ffff]
[    0.777294] pnp 00:0f: [mem 0x000c0000-0x000cffff]
--
[    0.777339] system 00:0f: [mem 0x000e0000-0x000fffff] could not be reserved
[    0.777341] system 00:0f: [mem 0x00100000-0xdf6fffff] could not be reserved
[    0.777343] system 00:0f: Plug and Play ACPI device, IDs PNP0c01 (active)
[    0.777437] pnp: PnP ACPI: found 16 devices
[    0.777438] ACPI: ACPI bus type pnp unregistered
[    0.779805] Switched to NOHz mode on CPU #0
[    0.779851] Switched to NOHz mode on CPU #3
--
[    0.800644] intel_idle: does not run on family 6 model 23
[    0.800723] input: Power Button as /devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input0
[    0.800727] ACPI: Power Button [PWRB]
[    0.800761] input: Power Button as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input1
[    0.800764] ACPI: Power Button [PWRF]
[    0.800875] ACPI: acpi_idle registered with cpuidle
[    0.801905] ERST: Table is not found!
[    0.801944] Serial: 8250/16550 driver, 32 ports, IRQ sharing enabled
--
[    8.686465] type=1400 audit(1304959770.084:3): apparmor="STATUS" operation="profile_load" name="/usr/lib/NetworkManager/nm-dhcp-client.action" pid=512 comm="apparmor_parser"
[    8.686854] type=1400 audit(1304959770.084:4): apparmor="STATUS" operation="profile_load" name="/usr/lib/connman/scripts/dhclient-script" pid=512 comm="apparmor_parser"
[    8.723278] parport_pc 00:06: reported by Plug and Play ACPI
[    8.723376] parport0: PC-style at 0x378 (0x778), irq 7
[    8.723519] i915 0000:00:02.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
--
[    8.867135] fb0: inteldrmfb frame buffer device
[    8.867136] drm: registered panic notifier
[    8.867145] No ACPI video bus found
[    8.867490] [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
[    8.867522] HDA Intel 0000:00:1b.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16

je ne vous cache pas que je suis novice sous Linux, et je ne sais pas où chercher wink

Hors ligne

#9 Le 01/11/2011, à 13:32

www.rzr.online.fr

Re : Mon écran reste éteint...... (problème de sortie de veille)

Salut sur lenovo g470 j ai aussi

"\_SB_.PCI0:_OSC invalid UUID"

Avez vous reussi a fixer cette erreur ds la DSDT ?

Mes logs si besoin :

http://rzr.online.fr/q/dmesg


# http://identi.ca/rzr # tel mobiles sous linux ca rulez ! (maemo, openmoko, android etc)
# http://rzr.online.fr/q/apt # svp testez mes .deb's         
# http://rzr.online.fr/q/unicorn.fr # BeWan USB gris : (marche sur dapper)
# http://go.cur.lv/files# files to be shared or email me

Hors ligne

#10 Le 05/11/2011, à 12:34

Bybeu

Re : Mon écran reste éteint...... (problème de sortie de veille)

Ouf, les gars, je crois que je viens de trouver la bonne page big_smile et en français en plus!
J'ai le même problème que vous. J'ai mon fichier pm-suspend.log qui finit comme ça:

Sat Nov  5 10:42:10 CET 2011: performing suspend

C'est assez révélateur non?
Et comme erreurs j'ai ça

foo@foo-Amilo-M7405:~$ cat /var/log/pm-suspend.log | grep -i5 fail
/etc/pm/sleep.d/10_unattended-upgrades-hibernate suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/49bluetooth suspend suspend:

/usr/lib/pm-utils/sleep.d/49bluetooth suspend suspend: not applicable.
Running hook /usr/lib/pm-utils/sleep.d/55NetworkManager suspend suspend:
Having NetworkManager put all interaces to sleep...Failed.

/usr/lib/pm-utils/sleep.d/55NetworkManager suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/60_wpa_supplicant suspend suspend:
Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or directory

/usr/lib/pm-utils/sleep.d/60_wpa_supplicant suspend suspend: success.
Running hook /usr/lib/pm-utils/sleep.d/75modules suspend suspend:

/usr/lib/pm-utils/sleep.d/75modules suspend suspend: not applicable.

mais dans mon PC y'a pas de fichier dsdt

foo@foo-Amilo-M7405:~$ cat /proc/acpi/dsdt
cat: /proc/acpi/dsdt: Aucun fichier ou dossier de ce type

Y'aurait une âme charitable qui me donnerait un petit coup de pouce?
Merci et à +

Hors ligne

#11 Le 25/11/2011, à 10:56

Bybeu

Re : Mon écran reste éteint...... (problème de sortie de veille)

Salut les gô
J'ai fini par trouver un truc : c'est grub2 qui fout la pagaille : j'ai fait des install propres sur un disque vierge en rab que j'ai récupéré dans un pc hs, depuis Gutsy jusqu'à Oneiric. Ça a commencé à plus marcher depuis Karmic (j'ai découvert plus tard que grub2 s'est invité officiellement pour la première fois dans Karmic). J'ai donc tout reformaté pour refaire une install propre et fraîche de Oneiric (3.0.0-13, puis 14 par la mise à jour), et j'ai même installé le kernel 3.2rc2 sur conseil de lauchpad. Évidemment ça marchait toujours pas!
Ensuite sur le disque Oneiric (sda1+ swap sda5 de ~1Go), j'ai installé Jaunty à côté (~moitié/moitié pour le disque), et le liveCD me l'a casé en sda6 + swap sda7 de ~400Mo.
Dès ce moment, c'est l'ancien grub qui est devenu le gestionnaire de boot pour les 2 installations.
Et là, Jaunty continue de fonctionner en sortie de veille (normal), mais Oneiric aussi yikes
Alors j'ai fais sudo update-grub /dev/sda depuis Oneiric pour remettre grub2 comme gestionnaire de boot, et là, Oneiric replante en sortie de veille comme sur une install fraîche (défaut déjà constaté), mais Jaunty présente alors aussi le même défaut !!!! C'est donc GRUB2 qui est la cause du problème (au passage, je me demande bien ce que grub a à faire dans la sortie de veille ????).
Maintenant je voudrait basculer mon disque de travail sur grub1, mais d'abord je voudrais faire un test avec le disque d'essai sur lequel j'ai actuellement les 2 OS.
J'ai fait la manip indiquée ici : https://help.ubuntu.com/community/Grub2 … RUB_Legacy qui marche, mais je voudrais qu'il me détecte l'installation de Jaunty car sur mon disque de travail, j'ai aussi un Windows.
Malheureusement, grub1 ne détecte pas les autres OS installés dans d'autres partitions sad :

sudo os-prober
[sudo] password for moi: 
/dev/sda6:Ubuntu 9.04 (9.04):Ubuntu:linux
moi@moi-Amilo-M7405:~$ sudo update-grub
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /boot/vmlinuz-3.0.0-13-generic
Found kernel: /boot/vmlinuz-3.0.0-12-generic
Found kernel: /boot/memtest86+.bin
Updating /boot/grub/menu.lst ... done

Comment faire pour lui faire détecter?
Merci

Hors ligne

#12 Le 28/11/2011, à 07:48

Le Chap

Re : Mon écran reste éteint...... (problème de sortie de veille)

Moi je suis passé sous gnome shell, viré Unity et surtout Compiz. Et la sortie de veille fonctionne maintenant wink

Hors ligne

#13 Le 08/12/2011, à 23:25

Bybeu

Re : Mon écran reste éteint...... (problème de sortie de veille)

SAlut le Chap
Moi je crois pas que j'ai unity/compiz, j'ai un chip video i855gm non compatible opengl 1.4 alors c'est tout en 2D, j'ai mis gnome-panel. C'est différent gnome-shell?

Hors ligne

#14 Le 09/12/2011, à 13:35

Bybeu

Re : Mon écran reste éteint...... (problème de sortie de veille)

Mauvaise astuce, ça marche pas. Même ça vire ubuntu-desktop

Hors ligne

#15 Le 18/03/2012, à 12:13

Bybeu

Re : Mon écran reste éteint...... (problème de sortie de veille)

C'est bon, réglé pour moi en suivant la doc grub legacy de ce site. ensuite rajouté à la mano tout à la fin de menu.lst après #END AUTOMAGIC machin.... les lignes qui vont bien pour windows.

Dernière modification par Bybeu (Le 18/03/2012, à 12:15)

Hors ligne

#16 Le 28/03/2012, à 11:32

Bybeu

Re : Mon écran reste éteint...... (problème de sortie de veille)

J'ai testé aujourd'hui le kernel 3.3.0.999 120325 0407 generic i386 : ça semble résolu smile adieu grub-legacy
Enfin, pas si vite... : vous savez quel kernel va être livré dans la prochaine LTS?

Dernière modification par Bybeu (Le 28/03/2012, à 11:32)

Hors ligne