Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 13/11/2011, à 13:15

abelthorne

Les applis en admin ne prennent pas le thème Gtk

Bonjour,
J'ai installé une Ubuntu custom basée sur OpenBox, que je "construis" au fur et à mesure. J'ai un problème que je n'arrive pas à résoudre : les applis lancées en admin (par exemple Synaptic via Gksu ou pkexec) ne prennent pas le thème Gtk. Ce dernier est réglé via LXAppearance.

Je ne sais pas trop dans quelle direction chercher : paquet manquant ? problème avec Policykit ? config de LXAppearance non prise en charge par les applis lancées en admin ?...

Dernière modification par abelthorne (Le 13/11/2011, à 13:18)

Hors ligne

#2 Le 13/11/2011, à 14:06

Arcans

Re : Les applis en admin ne prennent pas le thème Gtk

Les applis lancées en admin prennent le thème GTK défini pour root et pas pour l’user. Lance LXAppearance en admin pour mettre celui que tu veux. wink
Du moins, c’est comme ça que j’ai réglé ça chez moi, et l’explication que j’en ai tiré. ^^

Perso, je préfère justement utiliser un thème différent pour ne pas manquer le fait que je suis en admin, mais c’est vrai que celui par défaut a du mal à s’intégrer dans un “joli” OB. big_smile


« Mais je ne suis pas spécialement mécontent de ne pas être cela dit. »
     — Arcans
« Axiome de base de la théorie des ensembles : s'il existe dans un ensemble X un élément x ayant des propriétés potentiellement casse-couille, c'est de la faute d'Arcans. »
    — Le Rouge

Hors ligne

#3 Le 13/11/2011, à 14:17

abelthorne

Re : Les applis en admin ne prennent pas le thème Gtk

Ça me paraît curieux, ça. Normalement, les applis en admin devraient récupérer le thème courant (puisque c'est une élévation des droits et pas un changement d'utilisateur).
D'autant que les distros/environnements non-GNOME qui reposent sur Gtk pour leur thème (Xubuntu, Lubuntu...) n'ont pas ce problème.

Hors ligne

#4 Le 13/11/2011, à 14:21

Arcans

Re : Les applis en admin ne prennent pas le thème Gtk

Ouais, mais j’imagine que les DE (NB : au risque d’enfoncer une porte ouverte, OB est un WM pas un DE) ont un daemon pour gérer ça. Mais j’ignore lequel.


« Mais je ne suis pas spécialement mécontent de ne pas être cela dit. »
     — Arcans
« Axiome de base de la théorie des ensembles : s'il existe dans un ensemble X un élément x ayant des propriétés potentiellement casse-couille, c'est de la faute d'Arcans. »
    — Le Rouge

Hors ligne

#5 Le 13/11/2011, à 15:06

fredr

Re : Les applis en admin ne prennent pas le thème Gtk

Bonjour,

Sous gnome le daemon est gnoem-settings-daemon.

Si tu veux avoir le même thème pour les applis admin, la solution la plus simple est d'utilsier un fichier .gtkrc-2.0. Tu crées ce fichier dans ton home et dans le rtép /root tu crées un lien symbolique vers ton .gtkrc-2.0.

Il existe des utilitaires comem gtkswitch (de mémoire) qui créent le gtkrc pour toi.

fred


MacBook Pro, Ubuntu 14.04 Unity
L'optimiste pense que nous vivons dans le meilleur des mondes. Et le pessimiste craint que ce ne soit exact...

Hors ligne

#6 Le 13/11/2011, à 15:59

abelthorne

Re : Les applis en admin ne prennent pas le thème Gtk

fredr a écrit :

Sous gnome le daemon est gnome-settings-daemon.

Il me semble que ça a changé avec GNOME 3 mais peu importe. Sous Xubuntu et Lubuntu, ce serait un démon (éventuellement celui de GNOME) qui tournerait ? Ça m'étonne un peu, étant donné qu'il est très lié à un certain nombre d'éléments de GNOME qui ne sont pas installés sur ces variantes. S'il y a un démon Gtk indépendant de tout DE, ça m'intéresse...

Si tu veux avoir le même thème pour les applis admin, la solution la plus simple est d'utilsier un fichier .gtkrc-2.0. Tu crées ce fichier dans ton home et dans le rtép /root tu crées un lien symbolique vers ton .gtkrc-2.0.

Il existe des utilitaires comem gtkswitch (de mémoire) qui créent le gtkrc pour toi.

C'est pas le problème de créer le gtkrc, c'est ce que fait LXAppearance. Mais faire un lien symbolique depuis root vers un dossier utilisateur n'est pas une bonne solution pour moi. Je cherche une solution propre, sûre et indépendante de l'utilisateur.

Hors ligne

#7 Le 13/11/2011, à 16:04

Arcans

Re : Les applis en admin ne prennent pas le thème Gtk

Je pense que xfce a un démon indépendant (genre xfce4-settings-daemon), mais sans certitude, ça fait un bon moment que je n’ai plus touché à Xfce, j’vais essayer de demander à un utilisateur plus averti, car il me semble qu’en général les trucs Xfce sont moins chargés en dépendance. Et aucune idée de ce que ça pourrait être.


« Mais je ne suis pas spécialement mécontent de ne pas être cela dit. »
     — Arcans
« Axiome de base de la théorie des ensembles : s'il existe dans un ensemble X un élément x ayant des propriétés potentiellement casse-couille, c'est de la faute d'Arcans. »
    — Le Rouge

Hors ligne

#8 Le 13/11/2011, à 16:09

abelthorne

Re : Les applis en admin ne prennent pas le thème Gtk

Idéalement, je cherche à savoir comment ça se passe sous Lubuntu, vu que ce dernier utilise aussi OpenBox. Peut-être un démon spécifique à LXDE ?

Hors ligne

#9 Le 13/11/2011, à 16:11

Arcans

Re : Les applis en admin ne prennent pas le thème Gtk

Apparemment en tout cas, il existe un lxde-settings-manager : http://doc.ubuntu-fr.org/lxde#gerer_la_corbeille. wink


« Mais je ne suis pas spécialement mécontent de ne pas être cela dit. »
     — Arcans
« Axiome de base de la théorie des ensembles : s'il existe dans un ensemble X un élément x ayant des propriétés potentiellement casse-couille, c'est de la faute d'Arcans. »
    — Le Rouge

Hors ligne

#10 Le 13/11/2011, à 16:12

chibbata

Re : Les applis en admin ne prennent pas le thème Gtk

salut
normalement,ça doit marcher en executant lxappearance en root

gksudo lxappearance

Hors ligne

#11 Le 13/11/2011, à 16:21

abelthorne

Re : Les applis en admin ne prennent pas le thème Gtk

Cf plus haut : je ne veux pas m'amuser à gérer un gtkrc pour root (qu'il faudrait refaire manuellement à chaque fois que mon utilisateur change de thème). Je ne veux pas non plus faire de lien symbolique entre root et un utilisateur (c'est pas propre). Je cherche ce qui doit tourner en tâche de fond (un démon) ou quel réglage faire au niveau de la gestion des droits (Policykit...) pour que le thème admin suive le thème de l'utilisateur courant de façon transparente.

Il y a bien un lxde-settings-daemon qui traîne dans les dépôts, je vais regarder ça. Par contre, je ne trouve rien pour XFCE...

EDIT : je viens de tester le démon de LXDE. Première constatation : ça marche pour Synaptic qui prend bien le thème. Deuxième constatation : il me met un thème par défaut (il n'utilise donc pas mon gtkrc) et ne veut pas le changer avec LXAppearance.
Je vais essayer de tripatouiller dans tout ça...

Dernière modification par abelthorne (Le 13/11/2011, à 16:25)

Hors ligne

#12 Le 13/11/2011, à 16:33

abelthorne

Re : Les applis en admin ne prennent pas le thème Gtk

Bon, rien à faire : j'ai viré mon gtkrc et rebooté pour partir sur quelque chose de propre mais lxde-settings-daemon refuse de me laisser changer son apparence par défaut (Clearlooks + icônes GNOME). LXAppearance ne permet pas de changer le thème (quand j'en choisis un autre, il change bien dans la fenêtre de LXAppearance mais pas en-dehors)...

Hors ligne

#13 Le 13/11/2011, à 16:41

The Uploader

Re : Les applis en admin ne prennent pas le thème Gtk

xfce4-settings-helper ou lancer "gksu xfce4-settings-manager" n'y changent rien.

Il faut faire un fichier /root/.gtkrc-2.0 contenant (les noms sont pour l'exemple) :

gtk-theme-name="Shiki-Wine"
gtk-icon-theme-name="gnome-wine"
gtk-cursor-theme-name="whiteglass"
gtk-font-theme-name="ubuntu"
gtk-font-size="9"

Et copier les dossiers ~/.themes et ~/.icons dans /root si ce sont des thèmes qui ne sont pas présents dans /usr/share (ou les copier leurs contenu dans /usr/share/themes et /usr/share/icons respectivement, c'est pareil j'présume)

Source : http://ubuntuforums.org/showpost.php?p= … ostcount=4

Testé à l'instant et approuvé.

Dernière modification par The Uploader (Le 13/11/2011, à 17:08)


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS
Archlinux + KDE sur ASUS N56VV.
ALSA, SysV,  DBus, Xorg = Windows 98 !
systemd, kdbus, ALSA + PulseAudio, Wayland = modern OS (10 years after Windows, but still...) !  Deal with it !

Hors ligne

#14 Le 13/11/2011, à 16:46

abelthorne

Re : Les applis en admin ne prennent pas le thème Gtk

Et sans gtkrc spécifique à root ? Parce que ça, pour moi, ce n'est pas acceptable. Lubuntu le fait apparemment proprement, donc je ne vois pas pourquoi il faudrait en passer par des bidouilles de ce genre.

EDIT : après vérification : Lubuntu n'utilise même pas lxde-settings-daemon. En revanche, le thème a l'air lié à ~/.config/lxsession/Lubuntu/desktop.conf. En faisant quelques recherches, je suis tombé sur des références à ce fichier dans le wiki d'ArchLinux.
Après, est-ce que c'est lié à une session LXDE, à LXDM, etc. et donc pas forcément portable à un aurte environnement... ?

Dernière modification par abelthorne (Le 13/11/2011, à 16:54)

Hors ligne

#15 Le 13/11/2011, à 16:59

The Uploader

Re : Les applis en admin ne prennent pas le thème Gtk

Je ne connais pas d'autre solution, mise à part cette variante (tout aussi peu propres pour toi) : http://doc.ubuntu-fr.org/integration_qt … es_en_root


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS
Archlinux + KDE sur ASUS N56VV.
ALSA, SysV,  DBus, Xorg = Windows 98 !
systemd, kdbus, ALSA + PulseAudio, Wayland = modern OS (10 years after Windows, but still...) !  Deal with it !

Hors ligne

#16 Le 13/11/2011, à 17:00

abelthorne

Re : Les applis en admin ne prennent pas le thème Gtk

Ouaip, c'est pas propre non plus.

EDIT : un autre truc que j'ai remarqué et qui est peut-être lié à tout ça : si je lance LXAppearance, il me crée, en plus du ~/.gtkrc-2.0, un dossier ~/gtkrc-3.0. J'ai vu un rapport de bug sur Launchpad qui identifie ça comme un bug nécessitant une nouvelle version du soft ; apparemment, il devrait créer un fichier ~/.config/.gtkrc-3.0 au lieu de ce dossier. Or, dans Lubuntu, qui a logiquement les mêmes dépôts et donc la même version de LXAppearance, il ne crée pas ce dossier, tout se fait dans le fichier desktop.conf que je cite un peu plus haut. Il doit y avoir des réglages de session à faire pour les softs de LXDE mais reste à savoir s'ils sont fait depuis LXDM (le gestionnaire de connexion) ou si on peut les faire manuellement...

Dernière modification par abelthorne (Le 13/11/2011, à 17:08)

Hors ligne

#17 Le 14/11/2011, à 01:36

Elzen

Re : Les applis en admin ne prennent pas le thème Gtk

Pour Xfce, ç't'ait pas xfce-mcs-manager ?

Mais sinon, le principe de base, c'est que su/sudo/gksu/gksudo, ç'n'est précisément pas une « élévation des droits » : c'est faire un truc en tant qu'un autre utilisateur (le root par défaut, mais on peut en demander d'autres). Or qui dit truc lancé en tant qu'un autre utilisateur dit conf de l'autre utilisateur en question, c'est juste logique.

Les solutions à base de daemons sont juste moches, mais je doute qu'il puisse y avoir une solution « élégante » autre que de partager la conf entre les utilisateurs (lien symbolique ou autre), puisque par définition, ce sont des trucs bien séparés, bien cloisonnés.

Enfin, t'façon, en ce qui me concerne, j'ai un thème graphique pour mon root différent de mon thème graphique pour mon compte utilisateur, parce que j'aime bien les trucs pas tous pareils.

En ligne

#18 Le 14/11/2011, à 01:39

The Uploader

Re : Les applis en admin ne prennent pas le thème Gtk

ArkSeth a écrit :

Pour Xfce, ç't'ait pas xfce-mcs-manager ?

D'abord ce serait xfce4-quelquechose. ^^
Ensuite non, c'est xfce4-settings-manager. wink

ArkSeth a écrit :

Mais sinon, le principe de base, c'est que su/sudo/gksu/gksudo, ç'n'est précisément pas une « élévation des droits » : c'est faire un truc en tant qu'un autre utilisateur (le root par défaut, mais on peut en demander d'autres). Or qui dit truc lancé en tant qu'un autre utilisateur dit conf de l'autre utilisateur en question, c'est juste logique.

Les solutions à base de daemons sont juste moches, mais je doute qu'il puisse y avoir une solution « élégante » autre que de partager la conf entre les utilisateurs (lien symbolique ou autre), puisque par définition, ce sont des trucs bien séparés, bien cloisonnés.

Enfin, t'façon, en ce qui me concerne, j'ai un thème graphique pour mon root différent de mon thème graphique pour mon compte utilisateur, parce que j'aime bien les trucs pas tous pareils.

+1.


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS
Archlinux + KDE sur ASUS N56VV.
ALSA, SysV,  DBus, Xorg = Windows 98 !
systemd, kdbus, ALSA + PulseAudio, Wayland = modern OS (10 years after Windows, but still...) !  Deal with it !

Hors ligne

#19 Le 18/01/2012, à 15:36

abelthorne

Re : Les applis en admin ne prennent pas le thème Gtk

Bon, un petit point sur le sujet parce que la situation est un tout petit peu plus compliquée que ce que je pensais. Au début, je croyais que c'était les applis en admin qui paumaient le thème. Puis j'ai remarqué que j'avais en fait le problème avec d'autres applis, vraisemblablement parce qu'elles étaient en gtk3 (GDebi, Evolution...)
J'ai trouvé quelques infos que je résume ici, en prenant en compte 1) que je n'ai pas tellement envie d'utiliser le démon de GNOME et 2) que j'utilise LXAppearance (qui prend en compte Gtk3 dans sa version actuelle).
- Il faut bien sûr utiliser un thème Gtk qui propose à la fois une version Gtk2 et une Gtk3. Il commence à y en avoir quelques-uns. J'utilise pour ma part Zukitwo.
- Il faut savoir que LXAppearance range son thème n'importe où (les spécifications parlent de /home/machin/.config alors qu'il met son dossier gtk-3.0 directement dans /home/machin). J'ai vu que le bug avait été rapporté sur Launchpad, on peut donc espérer un correctif. En attendant, il faut déplacer manuellement le dossier gtk-3.0 dans .config
- Il faut savoir que LXAppearance génère un fichier de config buggé (là encore, il ne suit apparemment pas les spécifications). Il faut l'éditer (~/.config/gtk-3.0/settings.ini) et virer tous les guillemets autour du nom des options. Il faut à priori aussi virer la dernière ligne, qui importe le fichier ~/.gtkrc-2.0

Une fois les conneries de LXAppearance corrigées, j'ai enfin une apparence normale pour les applis Gtk3. En revanche, pour celles qui se lancent en admin (je n'ai testé que Synaptic), je reste sans thème. Je suppose que c'est parce que là, il faudrait un démon qui gère l'application du thème à la volée...

Hors ligne

#20 Le 18/01/2012, à 22:04

maman

Re : Les applis en admin ne prennent pas le thème Gtk

bonjour,
j'ai le thème Zukitwo qui fonctionne sous gtk2 et gtk3. Je n'ai pas Gnome et je n'utilise pas LXappearance mais gtk-chtheme.
Du coup, j'ai recopié le contenu de mon ".gtkrc-2.0.mine" dans ".config/gtk-3.0/settings.ini"
Ça donne :

[Settings]
gtk-theme-name= Zukitwo
gtk-icon-theme-name= Humanity-Sky
gtk-font-name= Gentium 10
gtk-cursor-theme-name= ComixCursors-LH-Opaque-White-Regular
gtk-cursor-theme-size= 0
gtk-toolbar-style= GTK_TOOLBAR_ICONS
gtk-toolbar-icon-size= GTK_ICON_SIZE_LARGE_TOOLBAR
gtk-button-images= 0
gtk-menu-images= 1
gtk-enable-event-sounds= 1
gtk-enable-input-feedback-sounds= 1
gtk-xft-antialias= 1
gtk-xft-hinting= 1
gtk-xft-hintstyle= hintfull
gtk-xft-rgba= rgb

J'ai jamais cherché pour le thme de root. Mais en fait, je préfère qu'il soit différent de celui de l'user.


90% of teens today would die if Facebook was completely destroyed. If you are one of the 10% that would be laughing, copy and paste this to your signature.

En ligne

Haut de page ↑