Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#26 Le 15/11/2010, à 20:35

sinbad83

Re : [Résolu] Pb partage répertoire Samba

Dommage effectivement que Testparm n'ait pas vu. Personnellement, je fais la chasse à tous les accents et aux espaces dans les noms de fichier ou de répertoire. On ne voit pas toujours l'avantage immédiat, mais cela évite bien des problèmes sans savoir à quoi on échappe.


La connaissance n'est pas une denrée rare, il faut la partager avec les autres.
Linux registered #484707
Site: www.coursinforev.org/doku.php
Desktop Quad8800 Ubuntu 14.04.1 et Seven,  Samsung N150 U14.04.1 et Seven, HP Pavillon G6 U14.04.1 et Seven, Serveurs Ubuntu 14.04.1, Serveur virtualisation Proxmox

Hors ligne

#27 Le 15/11/2010, à 21:16

junior76

Re : [Résolu] Pb partage répertoire Samba

sinbad83 a écrit :

Dommage effectivement que Testparm n'ait pas vu. Personnellement, je fais la chasse à tous les accents et aux espaces dans les noms de fichier ou de répertoire. On ne voit pas toujours l'avantage immédiat, mais cela évite bien des problèmes sans savoir à quoi on échappe.

C'est ce que je fais aussi -> aucun nom de fichier ou de répertoire n'avaient d'accents -> ce sont les "Comment de chaque partage qui en avait (du texte, quoi !!!).

Hors ligne

#28 Le 16/11/2010, à 11:30

sinbad83

Re : [Résolu] Pb partage répertoire Samba

C'est bon à savoir. Tu as dû chercher pas mal. Bravo.
Je me demande s'il n'y a pas un paramétrage dans smb.conf (que je ne connais d'ailleurs pas) pour le charset. Quelque chose comme dos charset = ??, display charset = ??, unix charset = ??


La connaissance n'est pas une denrée rare, il faut la partager avec les autres.
Linux registered #484707
Site: www.coursinforev.org/doku.php
Desktop Quad8800 Ubuntu 14.04.1 et Seven,  Samsung N150 U14.04.1 et Seven, HP Pavillon G6 U14.04.1 et Seven, Serveurs Ubuntu 14.04.1, Serveur virtualisation Proxmox

Hors ligne

#29 Le 16/11/2010, à 11:38

junior76

Re : [Résolu] Pb partage répertoire Samba

C'est clair que j'ai cherché TRES TRES longtemps !!!!!!!!

J'avoue que là, je n'ai plus trop envie de perdre de temps sur ça. Si quelqu'un à le courage de faire l'essai, je serais intéressé par le résultat.

A+

Hors ligne

#30 Le 16/11/2010, à 22:21

MrWaloo

Re : [Résolu] Pb partage répertoire Samba

Dans le retour de testparm, on voit que les accents sont mal interprétés... bizarre, je gère 2 serveurs (8.10 et 10.04) et celui sous 10.04 a une config avec des accents (que je viens d'ajouter...) dans les commentaires de partage sans soucis...

Je pense que l'encodage de ton fichier smb.conf est mauvais (?)
chez moi (sur le serveur avec les accents dans les commentaires) :

user@mulet:~$ file -i /etc/samba/smb.conf
/etc/samba/smb.conf: text/plain; charset=us-ascii

En sachant que :

user@mulet:~$ locale
LANG=fr_CH.UTF-8
LC_CTYPE="fr_CH.UTF-8"
LC_NUMERIC="fr_CH.UTF-8"
LC_TIME="fr_CH.UTF-8"
LC_COLLATE="fr_CH.UTF-8"
LC_MONETARY="fr_CH.UTF-8"
LC_MESSAGES="fr_CH.UTF-8"
LC_PAPER="fr_CH.UTF-8"
LC_NAME="fr_CH.UTF-8"
LC_ADDRESS="fr_CH.UTF-8"
LC_TELEPHONE="fr_CH.UTF-8"
LC_MEASUREMENT="fr_CH.UTF-8"
LC_IDENTIFICATION="fr_CH.UTF-8"
LC_ALL=

Et donc :

user@mulet:~$ testparm -s
Load smb config files from /etc/samba/smb.conf
rlimit_max: rlimit_max (1024) below minimum Windows limit (16384)
Processing section "[printers]"
Processing section "[print$]"
Processing section "[Archives]"
Processing section "[Documentation]"
Processing section "[Software]"
Processing section "[Divers]"
Loaded services file OK.
WARNING: You have some share names that are longer than 12 characters.
These may not be accessible to some older clients.
(Eg. Windows9x, WindowsMe, and smbclient prior to Samba 3.0.)
Server role: ROLE_STANDALONE
[global]
        workgroup = ARCADE
        server string = Celui qu'on charge
        interfaces = 192.168.1.251
        map to guest = Bad User
        obey pam restrictions = Yes
        syslog = 0
        log file = /var/log/samba/log.%m
        max log size = 1000
        printcap name = cups
        dns proxy = No
        panic action = /usr/share/samba/panic-action %d
        valid users = @user, root
        create mask = 0664
        directory mask = 0775

[printers]
        comment = All Printers
        path = /var/spool/samba
        guest ok = Yes
        printable = Yes
        browseable = No
        browsable = No

[print$]
        comment = Printer Drivers
        path = /var/lib/samba/printers
        write list = root

[Archives]
        comment = Archives des anciens serveurs
        path = /srv/data/Archives
        valid users = @user
        write list = ef, hos

[Documentation]
        comment = Documentation technique
        path = /srv/data/Documentation
        valid users = @user
        read only = No

[Software]
        comment = Logiciels
        path = /srv/data/Software
        valid users = @user
        read only = No

[Divers]
        comment = Tout ce qu'on peut mettre sur un mulet éàè
        path = /srv/data/Divers
        valid users = @user
        read only = No

Le partage Divers fonctionne et les clients windows voient le commentaire avec les accents...


"De tous ceux qui n'ont rien à dire, les plus agréables sont ceux qui se taisent !!" (Desproges)
UNIX is an operating system, OS/2 is half an operating system, Windows is a shell, MS-DOS is a boot sector virus.

Hors ligne

#31 Le 09/12/2010, à 17:41

PacThePac

Re : [Résolu] Pb partage répertoire Samba

Même problème que toi et résolu grâce à ton thread.
Bizarre quand même car sur d'autres serveurs samba, les accents dans les "comment =" ne posent pas de problème.

Hors ligne

#32 Le 14/06/2011, à 13:47

darkan

Re : [Résolu] Pb partage répertoire Samba

junior76 a écrit :

J'avoue que là, je n'ai plus trop envie de perdre de temps sur ça. Si quelqu'un à le courage de faire l'essai, je serais intéressé par le résultat.

Merci de m'avoir épargné 3 jours de recherche  wink en lançant ce post !
Et merci à MrWaloo pour la solution de l'encodage.

Donc comme voici ma petit contrib pour le temps gagné, avec ce petit HowTo concernant l'encodage du fichier qui est bien la source du pb ( vérifier sous serveur 10.04=) :

1 - le plus simple si Gedit est installé :
     ouvrez votre fichier < /etc/samba/smb.conf > avec Gedit, puis faîtes « enregistrer-sous » puis, dans la fenêtre qui s’ouvre, choisissez dans « codage des caractères » : UTF-8.

2 - Sinon, vous pouvez également utiliser le terminal :

   pour connaitre  l'encodage d'origine :
       

sudo file -i /etc/samba/smb.conf

        réponse :
       

/etc/samba/smb.conf: text/plain; charset=us-ascii

   on renome le fichier source :
       

sudo mv 'smb.conf' 'smb_org.conf'

   on copie/convertit le fichier :
         

sudo iconv -f us-ascii -t utf8 smb_org.conf > smb.conf

        -f veut dire « from » : encodage d’origine de smb_org.conf
        -t veut dire « to » : encodage souhaité pour smb.conf

Voilà, les accent dans les commentaires du fichier smb.conf, même créés à partir de webmin, ne seront plus un problème...

Hors ligne

#33 Le 29/11/2011, à 18:46

Alex10336

Re : [Résolu] Pb partage répertoire Samba

junior76 a écrit :

Et là, je me suis dis -> et si c'était les accents qui posaient problème. Je modifie mon fichier smb.conf, relance samba et là :

CA MARCHE

J'ai perdu plus de 3 jours pour une histoire d'accents !!!!!!!!!!!!!!!!!!!!!!!!  Ca m'énerve sachant que testparm ne m'a pas signalé l'erreur !!!!!!!

Tout ça pour dire que j'ai résolu tout mes problèmes !!!!!!!!!

Merci encore à tous ceux qui ont pris de leur temps pour m'aider, et j'espère que ce post aidera d'autres SAMBAïste.

A+

Je t'aime <3

connerie de fu*** accents. Même problème sur un pauvre "è" ><

edit: j’utilise webmin/ssh aussi

alex@nas:~$ sudo file -i /etc/samba/smb.conf
/etc/samba/smb.conf: text/plain; charset=us-ascii

Dernière modification par Alex10336 (Le 29/11/2011, à 21:33)


- Dual Windope 7 et Kubuntu Raring.
- Ubuntu 10.04.3 LTS Serveur (NAS).
- Lubuntu 13.04 i368 Serveur ZoneMinder / desktop
- Etc...

Hors ligne

Haut de page ↑