Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 20/12/2011, à 18:05

Votezblanc

[résolu] Grub installé sur la mauvaise partition

Bonjour,
Je viens de faire une (grosse) bêtise sur mon PC:
Lors de l'installation d'Ubuntu j'ai sélectionné la partition contenant le chargeur de windows (sda1) pour l'installation de grub...
Au premier redémarrage cela n'a pas marché (grub error, je ne sais plus vraiment ce que cela disait)
J'ai donc tenté de réinstaller Ubuntu, cette fois sans modifier le lieu d'installation de grub.
Cette fois l'ordi démarre normalement avec ubuntu, mais lorsque je sélectionne windows dans grub un nouveau grub apparaît (probablement celui que j'ai précédemment installé sur sda1) et si je re-sélectionne windows dans ce second grub, je reviens à ce grub... impossible donc de redémarrer avec windows (ne rigolez pas, j'en ai vraiment besoin...)

Je ne sais pas si j'ai été bien clair, en bref je dois supprimer le grub de sda1 et je ne sais pas du tout comment faire...
J'ai essayé super-grub-disk qui me permet de réinstaller le mbr d'origine à la place du grub sur sda mais pas de virer celui sur sda1.
J'ai scruté un peu partout mais n'ai trouvé aucune solution
(PS: je n'ai pas le disque d'installation de windows, ce qui je pense aurai arrangé pas mal de choses)

Merci pour votre aide

PS: ma table de partition sur sda
sda1 > windows loader
sda2 > windows
sda3 > ubuntu /
sda5 > ubuntu swap
sda6 > ubuntu /home

Dernière modification par Votezblanc (Le 21/12/2011, à 10:49)

Hors ligne

#2 Le 20/12/2011, à 20:20

plexus

Re : [résolu] Grub installé sur la mauvaise partition

Bonjour,

je t'encourage à regarder ces posts :

http://forum.ubuntu-fr.org/viewtopic.php?id=614071

ou celui-ci

http://forum.ubuntu-fr.org/viewtopic.ph … 1#p7503061
dont ce post :
Il va falloir que tu répares de démarrage de Windows 7 afin que cet amorceur de grub qui n'a rien à faire là (il ne peut pas fonctionner) soit remplacé par l'amorceur de Windows 7 dans le MBR de sda. Tu peux utiliser ce post pour cela : http://forum.ubuntu-fr.org/viewtopic.ph … 2#p3845512

peut-être cela te donnera-t'il des idées.

Hors ligne

#3 Le 20/12/2011, à 20:47

Votezblanc

Re : [résolu] Grub installé sur la mauvaise partition

Salut Plexus et merci pour ta réponse.
Je suis tombé sur ses sujets dans ma recherche, seuleument je ne sais pas trop si Boot-repair peut restaurer le démarage de windows sur sda1... et j'ai un peu peur de faire une autre bétise.
De plus n'ayant pas de disque de windows je ne peux pas utiliser la solution du second sujet.
J'ai noté l'url fourni par une analyse boot-repair : http://paste.ubuntu.com/776655/
Est-ce que quelqu'un a une solution?
Boot-repair peut-il réparer une partition de démarage de windows (sda1 dans mon cas)?

Hors ligne

#4 Le 20/12/2011, à 21:36

malbo

Re : [résolu] Grub installé sur la mauvaise partition

Tu peux utiliser ce post : http://forum.ubuntu-fr.org/viewtopic.ph … 1#p7201291

Dernière modification par malbo (Le 20/12/2011, à 21:38)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#5 Le 21/12/2011, à 10:52

Votezblanc

Re : [résolu] Grub installé sur la mauvaise partition

Merci Malbo!
Le cd de réparation de Windows et la commande bootrec /fixboot ont résolu mon problème.

Hors ligne

Haut de page ↑