Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 11/05/2011, à 14:09

demonipuch

Régler le probleme de dépendance libcupsys2 avec les pilotes Canon

Bonjour

J'ai écrit un petit script (basé sur les infos trouvées dans le post http://forum.ubuntu-fr.org/viewtopic.php?id=269086 et sur le blog http://www.kakesa.net/linux/drivers-can … oala/521#) qui va "réparer" le problème de dépendance avec libcupsys2 lors de l'installation des pilotes d'imprimante Canon et vous proposez d'installer le paquet "réparé". Le script force également l'installation sur les systèmes 64 bits.

Le script a été testé avec Ubuntu 10.04 et les pilotes pour Canon iP series et MP series.

L'utilisation du script est simple :
Téléchargez le :

wget http://demonipuch.free.fr/rebuildeb_canon.sh

Accordez lui le droit exécution

chmod +x rebuildeb_canon.sh

Lancez le script :

./rebuildeb_canon.sh /chemin/vers/fichier/cnijfilter-xxxxx_xxxxx_i386.deb

Screenshots :
Erreur d'installation du paquet fourni par canon :
1305118719.png
Réparation et installation du paquet sur système 32 bits :
1305118919.png

Contenu du code :

#!/bin/bash
# Fix libcupsys2 dependancy issue with Canon printers and force installation for amd64 computers
#
# ./rebuildeb_canon.sh /path/to/file/cnijfilter-xxxxx_xxxxx_i386.deb

PACKAGE=$1
NAME=`basename $PACKAGE`
TMP_DIR=`echo $PACKAGE | cut -d"_" -f1 | cut -d"-" -f2`
ARCHITECTURE=`uname -m`

read -p "Rebuild this package? $NAME [y/n] " ANSWER
while [[ $ANSWER != "y" ]] && [[ $ANSWER != "n" ]] ; do
    read -p "Rebuild this package? $NAME [y/n] " ANSWER
done 
    if [[ $ANSWER == "n" ]] ; then
        exit 0
    else 
        dpkg-deb -x $PACKAGE $TMP_DIR
        dpkg-deb --control $PACKAGE
        sed -i 's/libcupsys2 (>= 1.2.1)/libcupsys2 (>= 1.2.1) | libcups2/' DEBIAN/control
        mv DEBIAN/ $TMP_DIR
        sudo chown -R root:root $TMP_DIR
        rm $PACKAGE
        dpkg -b $TMP_DIR $PACKAGE
        sudo rm -rf $TMP_DIR
        echo "New package built..."
    fi
read -p "Install new package? [y/n] " ANSWER
while [[ $ANSWER != "y" ]] && [[ $ANSWER != "n" ]] ; do
    read -p "Install new package? [y/n] " ANSWER
done
    if [[ $ANSWER == "n" ]] && [[ $ARCHITECTURE != "x86_64" ]] ; then
        echo -e "To install the package later, run this command :\nsudo dpkg -i $PACKAGE"
        exit 0
    elif [[ $ANSWER == "n" ]] && [[ $ARCHITECTURE == "x86_64" ]] ; then
        echo -e "To install the package later, run this command :\nsudo dpkg -i --force-architecture $PACKAGE"
        exit 0
    elif [[ $ANSWER == "y" ]] && [[ $ARCHITECTURE == "x86_64" ]] ; then
        sudo dpkg -i --force-architecture $PACKAGE
    else
        sudo dpkg -i $PACKAGE
    fi
exit 0

Dernière modification par demonipuch (Le 01/10/2011, à 12:28)

Hors ligne

#2 Le 02/06/2011, à 09:54

ThierryM

Re : Régler le probleme de dépendance libcupsys2 avec les pilotes Canon

Bonjour Demonipush,
et merci beaucoup pour ce script qui m'a permis d'installer sous Natty 11.04 le pilote "officiel" (version 2.80 qui permet d'imprimer avec des couleurs plus claires et fidèles, contrairement au pilote fourni avec Ubuntu) de Canon pour l'imprimante Pixma iP4500.
Attention à la ligne changeant les droits où il manque un "l" à rebuildeb :

chmod +x rebuildeb_canon.sh

Ma manip pour la Canon PIXMA iP4500, si ça peut aider un débutant, dans une console (ligne de commande) :
- créer un dossier dans son dossier personnel (home):

mkdir pilote_ip4500

- se placer dans ce dossier :

cd pilote_ip4500/

- télécharger le script (il se mettra dans notre dossier "pilote_ip4500") :

wget http://demonipuch.free.fr/wp-content/downloads/rebuildeb_canon.sh

- donner les droits d'exécution à ce fichier de script :

chmod +x rebuildeb_canon.sh

- télécharger l'archive des pilotes sur le site de Canon en allant sur cette adresse : http://fr.software.canon-europe.com/pro … 010484.asp et choisir Linux en OS, récupérer la version Debian en 2.80 et la décompresser dans notre dossier "pilote-ip4500"
- Exécuter 2 fois le script :

./rebuildeb_canon.sh cnijfilter-common_2.80-1_i386.deb
./rebuildeb_canon.sh cnijfilter-ip4500series_2.80-1_i386.deb

Ça y est, lors de l'installation de l'imprimante, le nouveau pilote apparaîtra dans la liste des pilotes Canon (attention lors de votre choix, il y aura désormais 2 pilotes disponibles pour l'iP4500 : celui fourni de base par Ubuntu et celui que l'on vient d'installer, faire défiler la liste pour les repérer).

Cordialement,

Thierry


Ubuntu 12.04 / portable ASUS M70Vn

Hors ligne

#3 Le 02/06/2011, à 10:21

demonipuch

Re : Régler le probleme de dépendance libcupsys2 avec les pilotes Canon

ThierryM a écrit :

Bonjour Demonipush,
et merci beaucoup pour ce script qui m'a permis d'installer sous Natty 11.04 le pilote "officiel" (version 2.80 qui permet d'imprimer avec des couleurs plus claires et fidèles, contrairement au pilote fourni avec Ubuntu) de Canon pour l'imprimante Pixma iP4500.
Attention à la ligne changeant les droits où il manque un "l" à rebuildeb :

chmod +x rebuildeb_canon.sh

Bonjour

J'ai modifié la faute de frappe dans mon message.
Merci

Hors ligne

#4 Le 02/06/2011, à 13:03

Coakette

Re : Régler le probleme de dépendance libcupsys2 avec les pilotes Canon

Merci, ça fait trois plombes que je cherchais !!!!

Hors ligne

#5 Le 20/06/2011, à 23:58

Nico2610

Re : Régler le probleme de dépendance libcupsys2 avec les pilotes Canon

Bonsoir,

Je suis nouveau linuxien depuis quelques semaines, je cherche à installer l'imprimante canon mp 190, surtout installer libcupsys2...j'ai été sur cette page : http://doc.ubuntu-fr.org/imprimante_canon_pixma_mp190 , j'ai donc essayé d'installer ce paquet libcupsys2, mais je ne sais pas lequel choisir...ensuite je suis arrivé sur cette page et j'ai suivi les indications de demonipuch, j'ai donc suivi les 2 premieres commandes et la 3e lors du script

./rebuildeb_canon.sh /chemin/vers/fichier/cnijfilter-xxxxx_xxxxx_i386.deb

le terminal me met des messages d'erreurs : aucun fichier ou dossier de ce type,etc...

je ne sais pas si il est vraiment installé ce paquet et quelle commande peut on faire pour le trouver ?

Merci beaucoup
Nico

Hors ligne

#6 Le 21/06/2011, à 00:05

demonipuch

Re : Régler le probleme de dépendance libcupsys2 avec les pilotes Canon

Bonsoir

Dans quel dossier se trouve le script et dans quel dossier se trouvent les paquets à installer?

Sinon pour savoir si un paquet est installé vous pouvez utiliser la commande suivante :

dpkg -l nom_du_paquet | grep ^i

Hors ligne

#7 Le 22/06/2011, à 18:56

Nico2610

Re : Régler le probleme de dépendance libcupsys2 avec les pilotes Canon

Bonjour, j'ai fait la commande indiquée mais voilà ce qu'elle indique :

nico@ubuntu:~$ dpkg -l libcupsys2 | grep ^i
nico@ubuntu:~$
je ne sais pas où trouver les scripts...

merci
ordinateur acer aspire one 250, 1giga ram
ubuntu 11.04

Hors ligne

#8 Le 22/06/2011, à 23:04

demonipuch

Re : Régler le probleme de dépendance libcupsys2 avec les pilotes Canon

Bonsoir

Avez vous essayer la procédure d'installation issue de la doc?

Dernière modification par demonipuch (Le 22/06/2011, à 23:04)

Hors ligne

#9 Le 22/06/2011, à 23:23

Nico2610

Re : Régler le probleme de dépendance libcupsys2 avec les pilotes Canon

Oui, à partir de cette page : http://doc.ubuntu-fr.org/imprimante_canon_pixma_mp190 et en tapant libcupsys2 sur google mais je n'arrive pas à trouver le libcupsys2 qui convient au pc, avec aussi les liens utilisés sur cette discussion.. mon processeur est un intel, dc i386...mais linstallation ne se fait pas à partir de la logitheque...

Hors ligne

#10 Le 11/11/2011, à 12:21

jacabo

Re : Régler le probleme de dépendance libcupsys2 avec les pilotes Canon

Cette manip a marché sur ubuntu Oneric le Vendredi 11 Novembre, sans aucun problème pour installer les paquets concernats l'imprimante canon pixma mp240 big_smile

Tu es precieux, demonipunch, et ton script plus encore XD


-----BEGIN GEEK CODE BLOCK-----
  GCS d-- s+:+ a+ c++++ C++++ B+++ 7---- w--- L+ M-- u++ W+++ H++++ Z++  F--- PS- PE+ Y+ PGP T+++ S++++ J++ R+++ m+++ tv-- b++++ DI++ D++
  e+++ h---- A-- r+++ y+++
------END GEEK CODE BLOCK------ ___________ \o/_____________

Hors ligne

#11 Le 04/12/2011, à 19:46

frounchi

Re : Régler le probleme de dépendance libcupsys2 avec les pilotes Canon

Bonjour à tous,

je cherche à installer une canon mp640 series en wifi et je n'y arrive pas.

J'ai essayé le tuto de la doc (en modifiant install.sh pour forcer l'archtecture) sans succès,
puis j'ai téléchargé et installé le script de demonipuch, sans plus de succès voici le message d'erreur dans le terminal :

mathilde@Mathilde:~$ ./rebuildeb_canon.sh /home/mathilde/cnijfilter-common_3.20-1_i386.deb
Rebuild this package? cnijfilter-common_3.20-1_i386.deb [y/n] y
dpkg-deb : construction du paquet « cnijfilter-common:i386 » dans « /home/mathilde/cnijfilter-common_3.20-1_i386.deb ».
New package built...
Install new package? [y/n] y
Sélection du paquet cnijfilter-common:i386 précédemment désélectionné.
(Lecture de la base de données... 181107 fichiers et répertoires déjà installés.)
Dépaquetage de cnijfilter-common:i386 (à partir de .../cnijfilter-common_3.20-1_i386.deb) ...
dpkg : des problèmes de dépendances empêchent la configuration de cnijfilter-common:i386 :
 cnijfilter-common:i386 dépend de libpopt0 (>= 1.7).
dpkg : erreur de traitement de cnijfilter-common:i386 (--install) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 cnijfilter-common:i386

J'ai vérifié que j'avais bien libpopt0 dans la logithèque ubuntu, je l'ai bien avec la version suivante : libpopt0 1.16-1

Je n'ai pas une grande expérience de linux (et encore moins de la console et des scripts) et suis donc démuni pour faire fonctionner mon imprimante.

Merci de votre aide.

Hors ligne

#12 Le 04/12/2011, à 20:43

demonipuch

Re : Régler le probleme de dépendance libcupsys2 avec les pilotes Canon

Bonsoir

Vous devriez pouvoir installer votre imprimante avec ces commandes :

sudo add-apt-repository ppa:michael-gruz/canon
sudo apt-get update
sudo apt-get install cnijfilter-common cnijfilter-mp640series

Hors ligne

#13 Le 20/12/2011, à 21:26

kaxak

Re : Régler le probleme de dépendance libcupsys2 avec les pilotes Canon

bonjour,

Merci beaucoup pour ce script qui fonctionne sur ma MP140.

cool

Hors ligne

#14 Le 24/12/2011, à 17:36

vivienfr

Re : Régler le probleme de dépendance libcupsys2 avec les pilotes Canon

Félicitations, ce script fonctionne parfaitement pour mon imprimante Canon MP520 sous Ubuntu 11.10 32bits.

A noter qu'il faut commencer par le fichier cnijfilter-common_2.80-1_i386.deb puis faire le fichier cnijfilter-mp520series_2.80-1_i386.deb

Je confirme que la qualité est supérieur avec les drivers canon 2.80 qu'avec les drivers interne à Ubuntu (je n'ai pas testé avec les dernières version d'Ubuntu le drivers interne, mais par le passé les tests montraient une différence certaine sur les photos)


Old-Linux.com : Iso d'anciennes versions de Linux. ex: Redhat 5.1(1998), Ubuntu 5.04(2006), Lubuntu 10.04(2010)

Hors ligne

#15 Le 27/12/2011, à 20:02

Olmèque

Re : Régler le probleme de dépendance libcupsys2 avec les pilotes Canon

Au poil ce script!

Pas de souci non plus avec une MP240 sur l'OS 11.10

Encore bravo et merci!

ps : Qui se sent d'intégrer ça au tutoriel pour imprimante Canon ?


Rock'n'Roll vita est...

Hors ligne

#16 Le 27/05/2012, à 10:11

jdt37b

Re : Régler le probleme de dépendance libcupsys2 avec les pilotes Canon

Bonjour,

Un énorme merci à Demonipuch et Thierry M sans lesquels je ne serais jamais sorti de ce bourbier libcupsys2 pour ma MP540 : j'envisageais de changer d'OS !

Avec ce script tout est Ok.

Bravo Messieurs.
(une note "Peut mieux faire" à Canon)


Shuttle SB61V40 - Pentium 4 à 2Ghz - 1Mo - Carte Intel 82865g Graphics Controller
Xubuntu 12.04 et Voyager 14.04 HD -  32 bits

Hors ligne

#17 Le 10/06/2012, à 16:53

vivienfr

Re : Régler le probleme de dépendance libcupsys2 avec les pilotes Canon

Avec Ubuntu 12.04 il y a un nouveau problème de dépendance : libpopt0 (en plus de libcupsys2 que le script de demonipuch permet de résoudre)

# dpkg -i --force-architecture cnijfilter-common_2.80-1_i386.deb
(Lecture de la base de données... 204150 fichiers et répertoires déjà installés.)
Préparation du remplacement de cnijfilter-common:i386 2.80-1 (en utilisant cnijfilter-common_2.80-1_i386.deb) ...
Dépaquetage de la mise à jour de cnijfilter-common:i386 ...
dpkg : des problèmes de dépendances empêchent la configuration de cnijfilter-common:i386 :
 cnijfilter-common:i386 dépend de libpopt0 (>= 1.7) ; cependant :
  Le paquet libpopt0:i386 n'est pas installé.
dpkg : erreur de traitement de cnijfilter-common:i386 (--install) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 cnijfilter-common:i386

Old-Linux.com : Iso d'anciennes versions de Linux. ex: Redhat 5.1(1998), Ubuntu 5.04(2006), Lubuntu 10.04(2010)

Hors ligne

#18 Le 10/06/2012, à 22:15

demonipuch

Re : Régler le probleme de dépendance libcupsys2 avec les pilotes Canon

J'essayerais de mettre à jour le script dès que possible.

Hors ligne

#19 Le 21/08/2012, à 19:00

projetman

Re : Régler le probleme de dépendance libcupsys2 avec les pilotes Canon

Bonsoir,

ce scrpt m'a permis d'installer ma MP240 sur Xubuntu 12.04 64bits !!!

Merci beaucoup, je galérais à chercher libcupsys2, merci Canon pour pas mettre à jour vos pilotes Linux...heureusement que la communauté Ubuntu est active cool

Hors ligne

#20 Le 23/09/2012, à 17:04

stephd

Re : Régler le probleme de dépendance libcupsys2 avec les pilotes Canon

trop fort !
Notez le Pb perdure depuis au moins la précédente LTS donc oui effectivement merci Canon ... mais surtout demonipuch

Hors ligne

#21 Le 07/10/2012, à 22:26

Mat35

Re : Régler le probleme de dépendance libcupsys2 avec les pilotes Canon

Bonjour,

J'ai toujours un souci avec ma Canon MP520.

Résumé de la situation, chronologiquement :
1. Après installation d'Ubuntu 12.04, aucun souci de reconnaissance (imprimante + scanner).
2. Pour impression photo : résultat colorimétrique catastrophique.
3. Tentatives d'installation des nouveaux drivers.
4. Impression photo : mieux au niveau des couleurs mais précision très faible.
5. Autres tentatives (cf. le site Le Libriste notamment).
6. Les documents .odt sont imprimés, les images non !

J'ai testé le script ci-dessus qui me semblait avoir fonctionné.
Mais je n'ai aucun paquet libcupsys2  (et n'arrive pas à le trouver).

Bref, je tourne en rond...

Merci pour votre aide.
Mat

PS : Lorsque je rebranche l'imprimante, je ne vois pas comment choisir entre deux pilotes comme indiqué dans un post. En revanche, il y a bien une différence entre les deux installations car des onglets "disparaissent" avec la nouvelle installation (qualité de l'image...).

Dernière modification par Mat35 (Le 07/10/2012, à 22:32)

Hors ligne

#22 Le 08/10/2012, à 10:08

alca94

Re : Régler le probleme de dépendance libcupsys2 avec les pilotes Canon

bonjour
depuis le script du libriste il faut changer la première ligne

sudo add-apt-repository ppa:michael-gruz/canon

par

sudo add-apt-repository ppa:michael-gruz/canon-trunk

PS : Erreur de ma part marquez "trunck" au lieu de "trunk"

Dernière modification par alca94 (Le 08/10/2012, à 10:18)

Hors ligne

#23 Le 08/10/2012, à 19:49

Mat35

Re : Régler le probleme de dépendance libcupsys2 avec les pilotes Canon

Bonsoir,

J'ai déjà ajouté les deux dépôts (avec et sans trunk : d'ailleurs, c'est bien trunk sans C).
Je ne vois donc pas comment avoir une bonne qualité d'impression photo sans passer par Photoprint.
Je l'ai quand même installé à l'essai car j'avais besoin de photos bien tirées rapidement (très bon résultats d'ailleurs), mais j'aimerais m'en passer par la suite.

Mat

Hors ligne

#24 Le 16/02/2013, à 18:43

michelarbre

Re : Régler le probleme de dépendance libcupsys2 avec les pilotes Canon

Bonjour et bravo pour votre travail
Je suis novice sur linux et ubuntu j ai une imprimant ip4600 impossible de l installer j ai suivi les tutos et bien télécharger les pilotes deb de canon mais rien y fait
merci d avance pour une aide éventuel

Hors ligne

#25 Le 16/02/2013, à 19:26

demonipuch

Re : Régler le probleme de dépendance libcupsys2 avec les pilotes Canon

Bonsoir

Pouvez vous être plus précis sur les commandes utilisées et les messages d'erreur éventuels?

Hors ligne

Haut de page ↑