Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 31/08/2005, à 08:12

HERETIC666

Pb disque firewire (hotplug et ieee1394 ?)

Salut les pingouins,

Ca va faire 24 heures que je cherche sur google une solution à mon problème de firewire sous Ubuntu 5.04 et toujours rien donc dans le désespoir, je poste cette annonce avant de me tirer une balle...
Je ne suis pourtant plus trop débutant sous Linux (3 ans d'expérience quotidienne) et j'ai essayé pas mal de solutions proposées mais rien n'y fait. Mon problème : quand je connecte mon disque externe Firewire à Ubuntu, rien ne se passe alors que hotplug est sensé se manifester. Voici les messages que m'envoie mon noyau :

$ dmesg | tail -10
ip_tables: (C) 2000-2002 Netfilter core team
powernow-k8: Found 1 AMD Athlon 64 / Opteron processors (version 1.00.09e)
powernow-k8:    0 : fid 0x0 (800 MHz), vid 0x12 (1100 mV)
powernow-k8:    1 : fid 0x8 (1600 MHz), vid 0x6 (1400 mV)
powernow-k8:    2 : fid 0xa (1800 MHz), vid 0x2 (1500 mV)
cpu_init done, current fid 0x0, vid 0x12
eth0: no IPv6 routers present
ieee1394: Node added: ID:BUS[0-00:1023]  GUID[0030e00e00000000]
ieee1394: Node changed: 0-00:1023 -> 0-01:1023
ieee1394: unsolicited response packet received - no tlabel match

En principe, si ma mémoire est bonne, hotplug ou sbp2 devraient prendre le relais et "m'attacher" mon disque en /dev/sda. Un rescan-scsi-bus.sh ne change rien (0 new device found) et j'ai bien les modules ohci1394 ieee1394 et sbp2 actifs. J'ai même fait un modprobe sd_mod mais ça change rien...

Bref, je n'ai pas d'autre solution... J'ai bien un script /etc/hotplug/ieee1394.agent mais je n'ai pas de répertoire /etc/hotplug/ieee1394 et le répertoire /etc/hotplug.d/ieee1394 ne contient aucun script (il est vide). D'autre part, la commande "/etc/init.d/hotplug status" ne retourne rien.

Si quelqu'un a déjà eu ce genre de problème, n'hésitez pas à m'en faire part avant que je ne me défenestre, d'autant que le site www.linux1394.org semble être innaccessible...

Décidément, c'est pas mon jour...

Merci

#2 Le 31/08/2005, à 10:29

HERETIC666

Re : Pb disque firewire (hotplug et ieee1394 ?)

J'ai trouvé une "solution" de dépannage : le connecter en USB2.
Référence du modèle : ARGOSY HD360C USB2/Firewire

#3 Le 31/08/2005, à 10:33

dylhoxic

Re : Pb disque firewire (hotplug et ieee1394 ?)

Salut

Je te conseillerais sinon d'essayer avec une distribution live comme knoppix ou autre et voir si ton disque est reconnu.... sinon il me semble que le noyau 2.6.12 réglait des problèmes liés à la gestion du firewire....


Kubuntu++

Hors ligne

#4 Le 31/08/2005, à 12:08

HERETIC666

Re : Pb disque firewire (hotplug et ieee1394 ?)

En fait, je viens de migrer de ma Mandrake 10.0 vieillissante vers Ubuntu Hoary car j'avais entendu beaucoup de bien sur cette distrib, et je confirme qu'elle est vraiment géniale. J'avais essayé il y a quelques mois déjà avec une Knoppix mais le FireWire ne marchait pas non plus. Il n'y avait que Mandrake qui arrivait à me le faire fonctionner, c'est pour ça que j'avais choisi Mandrake d'ailleurs.
Mais le noyau de Mandrake 10 ne gère pas le PowerNow de mon AMD64 (c'est sur un laptop) donc je voulais essayer Ubuntu pour ne pas avoir à recompiler mon noyau, chose que je sais faire, mais qui reste néanmoins une opération délicate et à ne pas aborder à la légère (choix des modules notamment).
Grâce à Ubuntu, je tourne enfin en 1800 MHz (au max) et non plus en 800MHz constant.

Merci quand même, dylhoxic, pour ta proposition, mais finalement l'USB2 fonctionne convenablement. Le seul inconvénient est que ça m'occupe un port USB en plus...

Haut de page ↑