Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 28/11/2011, à 14:57

z0u

lexmark x2670

bonjour

je suis passé hier de la version 10.4 à la version 11.10, et c'est pas évident, je suis bien paumé avec cette nouvelle interface... et puis autre problème au moment d'installer les pilotes de mon imprimante (une lexmark x2670): le pilote fourni par lexmark et qui marchait avec les versions précédentes ne se lance pas, et ubuntu ne me propose pas d'alternative. Comment puis-je faire fonctionner ce driver, ou bien où en trouver un qui marche ?

Hors ligne

#2 Le 28/11/2011, à 15:18

demonipuch

Re : lexmark x2670

Bonjour

le pilote fourni par lexmark et qui marchait avec les versions précédentes ne se lance pas

C'est-à-dire? Avez-vous plus d'infos ou un message d'erreur?

Dernière modification par demonipuch (Le 28/11/2011, à 15:19)

Hors ligne

#3 Le 28/11/2011, à 16:56

z0u

Re : lexmark x2670

il  s'agit du driver lexmark-inkjet-08-driver-1.0-1.i386.deb.sh.
quant au message d'erreur, je ne l'ai pas relevé sur le moment, mais quand j'essaie de relancer l'installation, je me retrouve juste avec une fenêtre blanche de gedit qui se grise puis redevient blanche... et puis rien de plus.

Hors ligne

#4 Le 28/11/2011, à 17:04

demonipuch

Re : lexmark x2670

z0u a écrit :

il  s'agit du driver lexmark-inkjet-08-driver-1.0-1.i386.deb.sh.
quant au message d'erreur, je ne l'ai pas relevé sur le moment, mais quand j'essaie de relancer l'installation, je me retrouve juste avec une fenêtre blanche de gedit qui se grise puis redevient blanche... et puis rien de plus.

Ok pour le driver, c'est bien celui-ci qu'il faut installer.

Comment essayez-vous d'installer le pilote?

edit :

Et quelle version d'Ubuntu utilisez-vous? 32 bits ou 64 bits?

Dernière modification par demonipuch (Le 28/11/2011, à 17:05)

Hors ligne

#5 Le 28/11/2011, à 17:21

z0u

Re : lexmark x2670

merci pour votre aide.
la version installée est la version 32 bits (justement parce que ce driver ne passe pas avec la version 64 bits). j'ai essayé d'installer le driver en double-cliquant directement sur l'icone, et également en le lançant à partir d'un terminal.

Dernière modification par z0u (Le 28/11/2011, à 17:22)

Hors ligne

#6 Le 28/11/2011, à 17:24

demonipuch

Re : lexmark x2670

Ouvrez un terminal (Ctrl+Alt+T), placez vous dans le dossier où vous avez téléchargé le driver et tapez la commande :

sudo ./lexmark-inkjet-08-driver-1.0-1.i386.deb.sh

edit :

Il est possible d'installer le driver sur un système 64 bits mais il y a quelques manips à faire.

Dernière modification par demonipuch (Le 28/11/2011, à 17:25)

Hors ligne

#7 Le 28/11/2011, à 17:35

z0u

Re : lexmark x2670

j'ai toujours la même réponse dans le terminal : "command not found"

Hors ligne

#8 Le 28/11/2011, à 17:40

demonipuch

Re : lexmark x2670

Dans quel répertoire se trouve le fichier lexmark-inkjet-08-driver-1.0-1.i386.deb.sh?

Hors ligne

#9 Le 28/11/2011, à 18:21

z0u

Re : lexmark x2670

sur le bureau.
En général, en faisant glisser l'icone directement dans le terminal ça marche...

Hors ligne

#10 Le 28/11/2011, à 18:32

demonipuch

Re : lexmark x2670

cd ~/Bureau
sudo ./lexmark-inkjet-08-driver-1.0-1.i386.deb.sh

Hors ligne

#11 Le 28/11/2011, à 18:41

z0u

Re : lexmark x2670

même problème : toujours ce message "command not found"...

Hors ligne

#12 Le 28/11/2011, à 18:47

demonipuch

Re : lexmark x2670

Euh que dit la commande suivante :

ls -l lexmark-inkjet-08-driver-1.0-1.i386.deb.sh*

Hors ligne

#13 Le 28/11/2011, à 18:54

z0u

Re : lexmark x2670

ça dit :

ls: impossible d'accéder à lexmark-inkjet-08-driver-1.0-1.i386.deb.sh*: Aucun fichier ou dossier de ce type

Hors ligne

#14 Le 28/11/2011, à 18:55

demonipuch

Re : lexmark x2670

Oups au temps pour moi j'avais zappé que le fichier devait se trouver sur le bureau. La commande est :

ls -l ~/Bureau/lexmark-inkjet-08-driver-1.0-1.i386.deb.sh*

Hors ligne

#15 Le 28/11/2011, à 20:20

z0u

Re : lexmark x2670

là ça marche smile

ça dit ça :

-rw-r--r-- 1 basile basile 31366535 2009-05-19 06:58 /home/basile/Bureau/lexmark-inkjet-08-driver-1.0-1.i386.deb.sh

Hors ligne

#16 Le 28/11/2011, à 20:28

demonipuch

Re : lexmark x2670

Le fichier n'est pas exécutable.

chmod +x ~/Bureau/lexmark-inkjet-08-driver-1.0-1.i386.deb.sh
sudo ~/Bureau/lexmark-inkjet-08-driver-1.0-1.i386.deb.sh

Hors ligne

#17 Le 28/11/2011, à 21:28

z0u

Re : lexmark x2670

super, merci !
le driver semble s'être bien installé, mais quand je veux imprimer j'ai un message qui me signale une erreur, avec "Stopping job because the scheduler could not execute a filter"

Hors ligne

#18 Le 28/11/2011, à 21:52

demonipuch

Re : lexmark x2670

Essayez ceci :

sudo chown -Rh root:root /usr/local/lexmark

Dernière modification par demonipuch (Le 28/11/2011, à 21:54)

Hors ligne

#19 Le 29/11/2011, à 10:14

z0u

Re : lexmark x2670

j'ai essayé, mais ça ne marche toujours pas. Quand le dépanneur d'impression s'affiche, j'ai un message intitulé "serveur sans export d'imprimantes" qui s'affiche et qui me dit d'activer l'option "publier les imprimantes publiées connectées à ce système" dans les paramètres du serveur, en utilisant l'outil d'administration de l'impression. Ensuite il me donne le chemin avec GNOME classic pour y arriver roll . Dans l'interface que j'ai réussi à trouver pour l'impression, je n'ai par contre pas trouvé cette option...

Hors ligne

#20 Le 29/11/2011, à 13:39

demonipuch

Re : lexmark x2670

Vous avez regardé du coté de l'interface web de CUPS? http://localhost:631

Hors ligne

#21 Le 13/12/2011, à 18:28

alinoe13

Re : lexmark x2670

demonipuch a écrit :

Il est possible d'installer le driver sur un système 64 bits mais il y a quelques manips à faire.

ah bon ?
je peux savoir quelle est cette fameuse manip' ??

Hors ligne

#22 Le 13/12/2011, à 19:41

demonipuch

Re : lexmark x2670

Bonsoir

Téléchargez le fichier zip (lexmark-inkjet-08-driver-1.0-1.i386.deb.sh.zip) contenant les pilotes de votre imprimante sur le site de Lexmark. Dézippez le fichier.

Ensuite lancez les commandes suivantes :

./lexmark-inkjet-08-driver-1.0-1.i386.deb.sh --noexec --target lexmark
cd lexmark
tar xvf instarchive_all --lzma

Vous obtiendrez un fichier .deb qu'il faudra intsaller avec la commande suivante :

sudo dpkg -i --force-all lexmark-inkjet-08-driver-1.0-1.i386.deb

Hors ligne

#23 Le 28/01/2012, à 03:17

leYB

Re : lexmark x2670

demonipuch a écrit :

Bonsoir

Téléchargez le fichier zip (lexmark-inkjet-08-driver-1.0-1.i386.deb.sh.zip) contenant les pilotes de votre imprimante sur le site de Lexmark. Dézippez le fichier.

Ensuite lancez les commandes suivantes :

./lexmark-inkjet-08-driver-1.0-1.i386.deb.sh --noexec --target lexmark
cd lexmark
tar xvf instarchive_all --lzma

Vous obtiendrez un fichier .deb qu'il faudra intsaller avec la commande suivante :

sudo dpkg -i --force-all lexmark-inkjet-08-driver-1.0-1.i386.deb

Bonjour!

Venant de passer à 11.10, je me retrouve encore une fois avec un problème avec cette X2670.
Les lignes de commande fonctionnent bien mais impossible d'utiliser mon imprimante quand même!!
Je me retrouve avec le message suivant dans /var/logs/cups/error_log:

E [28/Jan/2012:03:06:40 +0100] Lexmark_2600_Series: File "/usr/local/lexmark/lxk08/bin/printdriver" has insecure permissions (0100775/uid=0/gid=2).
E [28/Jan/2012:03:06:40 +0100] [Job 3] Unable to start filter "/usr/local/lexmark/lxk08/bin/printdriver" - Success.
E [28/Jan/2012:03:06:40 +0100] [Job 3] Stopping job because the scheduler could not execute a filter.
E [28/Jan/2012:03:11:41 +0100] [Job 3] Stopping unresponsive job!

Je ne suis pas le seul apparemment au vu de cette page: Permission refusée pour lexmark 2600 series et jusqu'aujourd'hui, aucune réponse ne semble être la bonne pour résoudre ce problème.

Quelqu'un aurait-il la solution détaillée pour le noob que je suis?

Merci d'avance!

Hors ligne

#24 Le 28/01/2012, à 03:28

demonipuch

Re : lexmark x2670

Avec cette commande, ça devrait rentrer dans l'ordre :

sudo chmod 755 /usr/local/lexmark/lxk08/bin/printdriver

Hors ligne

#25 Le 28/01/2012, à 10:11

leYB

Re : lexmark x2670

demonipuch a écrit :

Avec cette commande, ça devrait rentrer dans l'ordre :

sudo chmod 755 /usr/local/lexmark/lxk08/bin/printdriver

Déjà tenté sans succès!

J'ai tapé la commande, puis suis allé réimprimer via Paramètres système>Imprimantes: Imprimer la page de test.
Pour le même résultat, négatif.

Ai-je loupé quelque chose? Voyez-vous autre chose à proposer? Si ça peut vous aider, il semble que le souci ne vienne pas d'apparmor d'après mes lectures et que ce soit lié aux nouvelles permissions de CUPS.

Hors ligne

Haut de page ↑