Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 08/11/2011, à 17:39

malbo

[Tuto] mises à jour en "mode de dépannage" de Ubuntu 11.10

ça devient compliqué de dépanner Ubuntu.
Procédure :
1) dans le menu Grub, démarrer sur la deuxième entrée du menu (mode de dépannage)

2) dans la fenêtre "Recovery Menu (limited read-only menu)", sélectionner "remount" et valider par la touche Entrée. Il faut encore appuyer sur la touche Entrée quand le montage est terminé.

3) dans la fenêtre "Menu de récupération" qui s'ouvre, sélectionner "netroot"

4) Connexion réseau : c'est là que ça devient chiant.
Si on passe la commande :

ifconfig

il n'y a aucune réponse. Ce comportement peu sympathique fait l'objet du rapport de bug #868748 dans lequel j'ai trouvé la solution suivante (dhclient eth0). Pour s'en sortir, il faut donc demander une adresse IP par DHCP en passant la commande suivante si vous êtes en connexion filaire Ethernet (si vous êtes en WIFI, je ne sais pas comment il faut faire : remplacer simplement  eth0 par wlan0 ne fonctionne pas) :

dhclient eth0  

Après cela, si on repasse la commande :

ifconfig

Là on obtient une réponse avec toute sa configuration réseau, son adresse IP et tout et tout. Ce qui est très bon signe pour faire ses mises à jour.

4) Mises à jour
On passe les commandes habituelles (validation par la touche Entrée après chaque commande):

apt-get update
apt-get upgrade
apt-get dist-upgrade

5) on ressort en tapant :

exit

puis validation par la touche Entrée
Puis on choisit "resume"

EDIT : j'ai rajouté une note dans le doc "Mode de récupération (recovery mode)" à ce sujet : http://doc.ubuntu-fr.org/recovery_mode? … _du_reseau

Dernière modification par malbo (Le 08/11/2011, à 19:02)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#2 Le 05/02/2012, à 14:11

aquassarim

Re : [Tuto] mises à jour en "mode de dépannage" de Ubuntu 11.10

malbo...

... Je t'aime !!!
Je commençais sérieusement à désespérer de pouvoir réparer mon système quand je suis tombé sur ton post.
Un immense merci à toi smile !!! Grâce à toi j'ai pu à nouveau accéder aux dépôts et réinstaller les pilotes de ma
carte graphique que j'avais scratchés en voulant m'essayer à OpenCL...

Un grand grand merci smile !

Hors ligne

#3 Le 25/02/2012, à 12:02

syca

Re : [Tuto] mises à jour en "mode de dépannage" de Ubuntu 11.10

Pareil pour moi,

Grand merci smile

Hors ligne

#4 Le 25/03/2012, à 23:52

badaboom

Re : [Tuto] mises à jour en "mode de dépannage" de Ubuntu 11.10

j'ai réussi a le faire une fois par wifi mais la je réessaye en vain, si quelqu’un a une idée d’où ça vient
voila ce que je fais

pour connaitre la carte wifi

lspci | grep -i network

je charge le module avec

modprobe wl

je vérifie, la carte est bien reconnue en eth1 quand je fais

iwconfig

et liste bien les réseaux sans fil a proximité avec

 iwlist eth1 scan

après je devrais me connecter en rentrant

iwconfig eth1 essid Mon_ESSID
iwconfig eth1 key Ma_Cle
ifconfig eth1 up
dhclient eth1

mais quand je rentre la key j'ai un message d'erreur
error for wireless request "set encode" (8b2a)
set failed on device eth1: invalid argument

voila si ça peu aider quelqu'un a trouver une solution
j'ai pas encore essayé car pas accès au routeur pour le moment, mais je pense qu'en désactivant le wpa ça devrait se connecter

Hors ligne

Haut de page ↑