Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 04/04/2007, à 18:45

chnapsy

-bash: XX.sh : /bin/sh^M : mauvais interpréteur: Aucun fichier

Salutà tous,

Je sais pas si ca se fait de mettre comme ca une erreur en topic, mais ca me paraissait
un bon moyen de montrer mon probleme et c'est plus parlant qu'un topic "pb d'interpreteur
sh" ...

Voila donc depuis un certain temps, je n'arrive plus a executer de scripts sur ma machine
j'ai toujours cette meme erreur.
A savoir donc:

{19:39:00}[root@smith](/home/web/stats/mrtg)#./scripts/mem.sh
-bash: ./scripts/mem.sh : /bin/sh^M : mauvais interpréteur: Aucun fichier ou répertoire de ce type

Ce qui est par contre assez drole c'est que si j'enleve le #!/bin/sh du début du script, la je n'ai plus
l'erreur (logique me direz vous) mais en plus le script fonctionne mais me remonte des petites erreurs
qui apparement n'ont pas trop d'incidence sur le bon fonctionnement

Exemple:

{19:42:11}[root@smith](/home/web/stats/mrtg)# env LANG=C /usr/bin/mrtg mrtg.conf
: not foundtats/mrtg/scripts/mem.sh: 6:
: not foundtats/mrtg/scripts/mem.sh: 7:
: not foundtats/mrtg/scripts/mem.sh: 8:
: not foundtats/mrtg/scripts/mem.sh: 9:

Moila si quelqun a une petite idée ce serai sympa de la partager avec moi smile
Merci d'avance

Hors ligne

#2 Le 04/04/2007, à 20:19

"-"

Re : -bash: XX.sh : /bin/sh^M : mauvais interpréteur: Aucun fichier

Fais un

dos2unix

sur ton fichier.

A noter qu'exécuter des scripts shell en root, c'est mal.

"-".

#3 Le 04/04/2007, à 20:41

lefred21

Re : -bash: XX.sh : /bin/sh^M : mauvais interpréteur: Aucun fichier

en principe le ^M en fin ligne est symptomatique du retour chariot qui n'est pas le même sous Dos/Windows(CR/LF) et sous Unix(LF seul).

Exemple :
-Edition d'un fichier texte sous Windows
-copie binaire de celui-ci sous Unix
-vi du fichier sous Unix : plein de ^M en fin de lignes...

> il faut copier les fichiers texte windows vers unix en précisant le mode ASCII, qui transforme les CR/LF{chr(13)chr(10)} en LF simples {chr(10)}.

Dernière modification par lefred21 (Le 04/04/2007, à 20:42)

Hors ligne

#4 Le 04/04/2007, à 20:51

tylhdar

Re : -bash: XX.sh : /bin/sh^M : mauvais interpréteur: Aucun fichier

j'ai eu le même probléme (enfin y'a longtemsp)

si tu utilise scite pour ecrire tes scripts dans le menu option>line end caracter > LF

Dernière modification par tylhdar (Le 04/04/2007, à 20:53)


un matériel non compatible linux est un matériel défectueux
ubuntu 10.4 sur pc1 ; debian squeeze sur pc2

Hors ligne