Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 21/06/2011, à 08:26

Pympc

AVERMEDIA hybrid Volar HX et message d'erreur

Bonjour à tous

Petit soucis lors de l'installation des pilotes linux de l'avermédia (carte TV sur port USB compatible linux...). Lors de l'installation voici ce que j'ai comme message d'erreur :

Installer failed to prepare driver installation
This may be due to:

l. The kernel source of the running kernel is not installed. The package of kernel source is named like ''kernel-source'' or ''kernel-devel''  Please consult your system manual.

2. You have selected a wrong distribution. Try another one.

3. Your kernel is not supported by our driver. If this is the case ''Expert'' mode installation might be an option.

The installer have an error log which might help you identify the issue. Do you want to see it?

Je ne comprend pas grand chose à la langue de Shakespeare mais je pense qu'il y a un soucis avec le kernel. u'en pensez-vous ?

Pour infos ma config est la suivante

Ubuntu 11.04 (natty) - 2.6.38-8-generic - Gnome 2.32.1
Processeur AMD Athlon(tm) II X2 250 Processor - 4Go RAM -


D'avance merci

Hors ligne

#2 Le 01/07/2011, à 11:34

damien200

Re : AVERMEDIA hybrid Volar HX et message d'erreur

Bonjour,
Ayant moi même acheté le même récepteur TNT et ayant aussi une erreur (sûrement le même problème), je poste l'erreur que j'obtiens en passant par la méthode "Expert" (faire un make soi même) :

make -C /lib/modules/2.6.38-8-generic/source O=/lib/modules/2.6.38-8-generic/build SUBDIRS=`pwd` 
make[1]: entrant dans le répertoire « /usr/src/linux-headers-2.6.38-8-generic »
  CC [M]  /H826D-expert-install/aver/averusb-mod.o
In file included from /H826D-expert-install/aver/averusb-mod.c:128:0:
/H826D-expert-install/aver/osdep.c: In function ‘AVerH826D_SysSemInit’:
/H826D-expert-install/aver/osdep.c:435:3: error: implicit declaration of function ‘init_MUTEX’
/H826D-expert-install/aver/osdep.c:439:3: error: implicit declaration of function ‘init_MUTEX_LOCKED’
make[3]: *** [/H826D-expert-install/aver/averusb-mod.o] Erreur 1
make[2]: *** [_module_/H826D-expert-install] Erreur 2
make[1]: *** [sub-make] Erreur 2
make[1]: quittant le répertoire « /usr/src/linux-headers-2.6.38-8-generic »
make: *** [default] Erreur 2

Si quelqu'un a une idée pour nous aider...

Hors ligne

#3 Le 01/07/2011, à 12:00

damien200

Re : AVERMEDIA hybrid Volar HX et message d'erreur

J'ai une piste, il faut essayer les solutions de ce site.
Prend les instructions correspondant à ton noyau.
Pour ma part je vais tester et je vais dire ce qu'il en est.

edit : j'ai toujours un pb en compilant :

could not find /H826D-expert-install/aver/.osdep_dvb.o.cmd for /H826D-expert-install/aver/osdep_dvb.o

Dernière modification par damien200 (Le 01/07/2011, à 14:14)

Hors ligne

#4 Le 15/07/2011, à 15:32

Pympc

Re : AVERMEDIA hybrid Volar HX et message d'erreur

Ouh là là, ça dépasse, et de loin, mes maigres compétences yikes

Hors ligne

#5 Le 08/03/2012, à 21:37

saugeais25

Re : AVERMEDIA hybrid Volar HX et message d'erreur

meme probleme que vous les gars... sous natty....

quelqu'un a la solution ?

Hors ligne

#6 Le 08/03/2012, à 21:45

saugeais25

Re : AVERMEDIA hybrid Volar HX et message d'erreur

j'ai peux etre trouvé quelque chose ici : http://lhddt.wordpress.com/tag/11-10/

"This USB DVB-T device (Volar HX A827) has been unsupported since ubuntu 9.10. The latest driver available for download is 0.10beta, which is not compatible for modern linux kernel shipped in Ubuntu 11.04 (that’s 2 years’ advance!)"
....
explications à la suite..en anglais

bon j'ai trouvé ca :
http://askubuntu.com/questions/103005/h … d-volar-hx

j'ai appliqué la methode en modifiant quelques lignes car je suis en X86  (et non pas en X64 comme dans l'exemple)

ma clé semble marcher, elle s'est allumée en bleue, et est reconnue par le module "pilotes de peripherique" de ubuntu
j'ai installé kaffeine,

regardé le tuto sur doc.ubuntu,
et ca marche


edit 28 -0 4- 2012 : la solution differe suivant le kernel...(donc votre version de ubuntu) ....
se referer ici suivant votre kernel : http://linuxtv.org/wiki/index.php/AVerM … %28A827%29

Dernière modification par saugeais25 (Le 28/04/2012, à 12:36)

Hors ligne

Haut de page ↑