Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 20/04/2007, à 15:59

ploop

Firefox plante !

Salut, je vais sur site qui utilise le plugin java, donc ,je télécharge les paquets utiles pour tout faire marcher. Pour que tout marche bien, je redemarre firefox et je vais sur la site, l'applet java se charge puis :
min-39688-Capture.png

Donc je suis obliger de redémarrer firefox à chaque fois qu'il y'a cet applet java sad

Comment faire hmm

#2 Le 23/04/2007, à 22:49

zebuntu

Re : Firefox plante !

[ubuntu 7.04 Feisty Fawn]

Salut !

J'ai exactement le même problème :
Je vais sur mon site (le même que toi, ploop - j'reconnais le screenshot) pour gérer son contenu au travers d'un applet java.
Mais l'applet ne se lance pas, et firefox se fige.

La console java me retourne ceci :

Java Plug-in 1.6.0
Utilisation de la version JRE 1.6.0 Java HotSpot(TM) Client VM
Répertoire d'accueil de l'utilisateur = /home/zebuntu
...
java.security.AccessControlException: access denied (java.io.FilePermission http://image.ifrance.com/iftp/gfx/status.gif read)
	at java.security.AccessControlContext.checkPermission(AccessControlContext.java:323)
	at java.security.AccessController.checkPermission(AccessController.java:546)
	at java.lang.SecurityManager.checkPermission(SecurityManager.java:532)
	at java.lang.SecurityManager.checkRead(SecurityManager.java:871)
	at sun.awt.SunToolkit.getImageFromHash(SunToolkit.java:837)
	at sun.awt.SunToolkit.getImage(SunToolkit.java:851)
	at javax.swing.ImageIcon.<init>(ImageIcon.java:81)
	at javax.swing.ImageIcon.<init>(ImageIcon.java:107)
	at ErrorDialog.createDialog(ErrorDialog.java:46)
	at ErrorDialog.<init>(ErrorDialog.java:19)
	at entryPoint.init(entryPoint.java:53)
	at sun.applet.AppletPanel.run(AppletPanel.java:417)
	at java.lang.Thread.run(Thread.java:619)

Pourtant, dans les prefs de firefox, java est activé.
Si quelqu'un a une idée... (ou une question pour infos supplémentaires)

Dernière modification par zebuntu (Le 23/04/2007, à 22:56)


http://zebulon.biniou.net    #biniou@irc.freenode.net

Hors ligne

#3 Le 23/04/2007, à 23:00

Anexia

Re : Firefox plante !

Salut,

Ouvrez une console et tapez :

java -version

puis donnez le résultat ici wink

Hors ligne

#4 Le 23/04/2007, à 23:03

zebuntu

Re : Firefox plante !

Salut Anexia,

Voici donc :

zebuntu@ubuntu:~$ java -version
java version "1.6.0"
Java(TM) SE Runtime Environment (build 1.6.0-b105)
Java HotSpot(TM) Client VM (build 1.6.0-b105, mixed mode, sharing)

++

Dernière modification par zebuntu (Le 23/04/2007, à 23:10)


http://zebulon.biniou.net    #biniou@irc.freenode.net

Hors ligne

#5 Le 24/04/2007, à 10:05

Burnallover

Re : Firefox plante !

up!!!

Hors ligne

#6 Le 24/04/2007, à 10:36

Anexia

Re : Firefox plante !

Burnallover a écrit :

up!!!

Euh !! Molo.... en journée il y en a qui bosse, et au boulôt je suis pas sous linux sad donc je peut rien faire pour vous aider avant ce soir  (et je doit pas être le seul)...

Donc fait comme nous... dors au bureau et réveil toi ce soir lol

Hors ligne

#7 Le 24/04/2007, à 11:48

Burnallover

Re : Firefox plante !

du calme j'ai remonté le poste juste au cas ou quelqu'un d'autre pouvais repondre je ne pense pas que tu soit le seul sur ce forum a pouvoir répondre au post

Hors ligne

#8 Le 24/04/2007, à 12:47

zebuntu

Re : Firefox plante !

Re,
Pendant qu'j'y suis, autant donner les infos de firefox aussi - des fois que...

FireFox 2.0.0.3
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20061201 Firefox/2.0.0.3 (Ubuntu-feisty)

Vue cette ligne (dans la console Java)

java.security.AccessControlException: access denied

je soupçonne une histoire de droits à régler quelquepart !? mais où neutral


http://zebulon.biniou.net    #biniou@irc.freenode.net

Hors ligne

#9 Le 24/04/2007, à 13:04

Anexia

Re : Firefox plante !

Burnallover a écrit :

du calme j'ai remonté le poste juste au cas ou quelqu'un d'autre pouvais repondre je ne pense pas que tu soit le seul sur ce forum a pouvoir répondre au post

Je comprend bien, là n'était pas le but de mon message... mais remonter un post à moins de 24h c'est inutile, surtout en matinée, il y a de forte chance que ceux qui peuvent aider pour ce problème travail en journée. Il y a plus de chance d'avoir des réponses en soirée, donc je voulais juste dire... patience Burnallover wink

et pour preuve que c'était pas méchant mon post, j'avais terminé par :

Donc fait comme nous... dors au bureau et réveil toi ce soir lol

Hors ligne

#10 Le 24/04/2007, à 13:23

Burnallover

Re : Firefox plante !

pas de soucis suffit juste de m'expliqué pourquoi. maintenant je vai attendre patiemment

bonne journée euh... (bonne sieste lol )

Dernière modification par Burnallover (Le 24/04/2007, à 13:24)

Hors ligne

#11 Le 24/04/2007, à 16:16

Anexia

Re : Firefox plante !

Bon je suis de retour chez moi (sous Ubuntu)....

Comme je n'ai pas de compte chez ifrance je ne peux pas tester directement sur le même site que vous... hmm

Avez vous un autre site (public) où vous avez aussi cette erreur java ?

Sinon avez vous installé les paquets suivants : via Synaptic...

sun-java5-bin
sun-java5-jre
sun-java5-plugin
sun-java6-bin
sun-java6-jre
sun-java6-plugin

Hors ligne

#12 Le 24/04/2007, à 16:28

zebuntu

Re : Firefox plante !

Re,
Bon, il se trouve que j'ai aussi ce problème là coté Windows XP, dans FireFox.
Après avoir cherché un moment, j'ai réussi à régler le problème (côté Windows uniquement, pour l'instant). Voici comment :

- Aller dans le Panneau de configuration Java, onglet Avancé, dérouler/ouvrir la rubrique Java par défaut des navigateurs.
- Vérifier que la ligne Famille Mozilla est bien cochée. La cocher si ce n'est pas le cas.
- Cliquer sur Appliquer puis fermer la fenêtre, ou cliquer sur Ok.
- Faire une mise à jour de Java (pour être sûr)
- Relancer FireFox, une éventuelle mises à jour de java peut se faire

Finalement, l'applet Java qui posait problème apparait et fonctionne.

J'ai plus qu'à vérifier ça coté ubuntu et ça devrait être réglé sous peu.

++

Dernière modification par zebuntu (Le 24/04/2007, à 16:29)


http://zebulon.biniou.net    #biniou@irc.freenode.net

Hors ligne

#13 Le 24/04/2007, à 16:33

Anexia

Re : Firefox plante !

zebuntu a écrit :

Re,
Bon, il se trouve que j'ai aussi ce problème là coté Windows XP, dans FireFox.
Après avoir cherché un moment, j'ai réussi à régler le problème (côté Windows uniquement, pour l'instant). Voici comment :

- Aller dans le Panneau de configuration Java, onglet Avancé, dérouler/ouvrir la rubrique Java par défaut des navigateurs.
- Vérifier que la ligne Famille Mozilla est bien cochée. La cocher si ce n'est pas le cas.
- Cliquer sur Appliquer puis fermer la fenêtre, ou cliquer sur Ok.
- Faire une mise à jour de Java (pour être sûr)
- Relancer FireFox, une éventuelle mises à jour de java peut se faire

Finalement, l'applet Java qui posait problème apparait et fonctionne.

J'ai plus qu'à vérifier ça coté ubuntu et ça devrait être réglé sous peu.

++

Ah ok, donc c'est bien le plugin pour mozilla qui pose problème... perso, je n'ai pas pû tester, j'ai pas trouvé de site en java qui me provoque cette erreur.

Hors ligne

#14 Le 24/04/2007, à 17:12

zebuntu

Re : Firefox plante !

Bon, côté ubuntu c'est pas encore gagné, mais il y a un petit mieux - firefox ne se fige plus, déjà en faisant ça : (dans ubuntu, ce coup-ci)
- aller dans le menu (en haut) Système/Préférences/Sun Java 6 Plugin Control Panel
- Panneau de configuration Java, onglet Avancé, rubrique Commande de lancement du navigateur par défaut. J'avais /usr/bin/mozilla. J'ai remplacé par /usr/bin/firefox. Refermer par Ok.
- Relancer FireFox.

L'applet ne se lance toujours pas, mais FireFox ne se fige plus aprés. C'est déjà un début tongue

de retour dès qu'j'ai du nouveau


http://zebulon.biniou.net    #biniou@irc.freenode.net

Hors ligne

#15 Le 25/04/2007, à 13:41

zebuntu

Re : Firefox plante !

de retour...

Ben, en fait, ma petite manip ne change rien... j'ai bien eu quelques tentatives qui ont échoué sans que Firefox reste tout bloqué (comme un chien à l'arrêt), mais depuis, rebelote : Firefox se bloque à nouveau, avec le même contenu (que cité plus haut) dans la console Java.

Par contre j'ai remarqué ceci :

- côté Windows XP, le système utilise Java 1.6.0 (build 1.6.0_01-b06) et l'animation (d'attente pendant un chargement d'un applet Java) ressemble à ça :
http://uzy.ifrance.com/winxp.jpg
ça mouline... ça mouline... puis j'ai bien mon applet Java :
http://uzy.ifrance.com/winxp2.jpg

- côté Ubuntu (7.04), le système utilise Java 1.6.0 (build 1.6.0-b105) et l'animation ressemble à ça (comme avant sous Windows XP, quand ça plantait aussi, avant une mise la jour de Java) :
http://uzy.ifrance.com/ubuntu.png
ça mouline... ça mouline... puis plus rien. n'est tout bloqué :[

Il semblerait donc que Ubuntu utilise une version plus ancienne (malgré avoir fait des sudo apt-get update/upgrade/dist-upgrade) que Windows XP (pourquoi ça !?).

Faut il attendre une version plus récente de Java pour Ubuntu Feisty - qui ne serait pas encore prête ? :\

P.S. : je m'aperçois aussi que les images que je viens d'inclure dans ce post n'apparaissent pas chez moi, bien que j'ai utilisé la balise img. si je remplace par une balise url (e.g. http://uzy.ifrance.com/winxp.jpg), j'ai pas toujours l'image, mais des fois j'ai une erreur 403 (accès non autorisé) !? çe peut être lié aussi à mon problème initial ?

Dernière modification par zebuntu (Le 28/04/2007, à 17:19)


http://zebulon.biniou.net    #biniou@irc.freenode.net

Hors ligne

#16 Le 25/04/2007, à 14:40

Anexia

Re : Firefox plante !

zebuntu a écrit :

P.S. : je m'aperçois aussi que les images que je viens d'inclure dans ce post n'apparaissent pas chez moi, bien que j'ai utilisé la balise img. si je remplace par une balise url (e.g. http://uzy.ifrance.com/winxp.jpg), j'ai pas toujours l'image, mais des fois j'ai une erreur 403 (accès non autorisé) !? çe peut être lié aussi à mon problème initial ?

Euh non, là je pense que ifrance n'accepte pas les liens externes (anti-leech)... en gros tu peux voir tes images sur ton propre site, mais si tu veux faire un lien sur un site externe... tu es dans la m...e mad
Va voir dans les différente option de ton hébergement s'il n'y a pas une option qui te permet de désactiver cette restriction.

Anti-leech
Système de protection de fichier qui permet de cacher le chemin ou l'URL réelle du fichier que vous souhaitez proposer au téléchargement. Un antileech est un script qui permet d'eviter qu'un site web fasse des liens vers les fichiers d'un autre site.

Les systèmes anti-leech permettent d'éviter que d'autres webmasters copient des liens vers vos fichiers pour les employer sur leurs propres sites.

Source : www.dicodu net.com

Hors ligne

#17 Le 26/04/2007, à 13:22

zebuntu

Re : Firefox plante !

Merci Anexia,
Je comprends mieux maintenant... toutefois, j'ai remarqué qu'en tapant l'url de ces images dans la barre d'adresse de Firefox, on arrive à y accéder finalement...


http://zebulon.biniou.net    #biniou@irc.freenode.net

Hors ligne

#18 Le 26/04/2007, à 13:33

Anexia

Re : Firefox plante !

zebuntu a écrit :

Merci Anexia,
Je comprends mieux maintenant... toutefois, j'ai remarqué qu'en tapant l'url de ces images dans la barre d'adresse de Firefox, on arrive à y accéder finalement...

Oui car c'est un accès direct.... et non pas par référant.

Le script vérifie d'où viens la requête d'afficher l'image :

En tapant l'adresse directe dans firefox, c'est un accès direct à ton site (en peu comme si tu été déjà en train de surfer sur ton site)...

Par contre, un lien d'un site A vers ton site B, A devient référant de B, et le script le détecte, il bloque donc l'accès à tes ressources (images, fichiers, etc...) wink

Dernière modification par Anexia (Le 26/04/2007, à 13:34)

Hors ligne