Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 05/05/2012, à 11:14

ouzmoutous

[Gestionnaire de fichiers] Nautilus par défaut Lubuntu

Bonjour.
J'aimerai savoir s'il était possible de modifier le gestionnaire de fichier par défaut sous Lubuntu 12.04 ?

Pourquoi Nautilus :
-PCManfm n'affiche pas la prévisualisation des photos
-Il est moins user-friendly que nautilus et plus jolie
-Le raccourcis "F3" est sympa (mais pas nécessaire)

Je veux rester sur Lubuntu car ce PC est pour des gens habitués à Windows et donc le menu en bas à droite, et car plus reactif que Ubuntu (sachant que Unity n'est pas envisageable).

Bref, j'ai essayé de faire un lien symbolique entre Nautilus et PCMan sauf que au redémarrage, j'ai tout le "bureau" qui est inaccessible (impossible de faire un clic droit, d'y ajouter un raccourcis, pertes des icônes et le fond d'écran c'est le logo Lubuntu avec les petits points comme pour le démarrage).

J'ai aussi essayé de supprimer le paquet "pcmanfm" sauf que ça enlève des dépendances importantes (lubuntu-core lubuntu-default-settings lubuntu-desktop).

Sur mon bureau j'ai un dossier et j'ai essayé de faire : clic droit >> ouvrir avec >> Accessoire >> Dossier personnel (nautilus) >> coché "Sélectionner l'application par défaut à utiliser pour ouvrir ce type de fichiers" >> valider. Cela m'ouvre bien avec nautilus mais lorsque je réssai c'est comme ci je n'avai rien fait et ça réouvre avec PCMan...

Une solution ?


Si c'est par les erreurs qu'on apprend, je vais devenir surdoué

Hors ligne

#2 Le 05/05/2012, à 18:21

primesautier

Re : [Gestionnaire de fichiers] Nautilus par défaut Lubuntu

Créer le fichier:
sudo gedit /etc/xdg/autostart/nautilus-autostart.desktop

Copier son contenu:

[Desktop Entry]
Type=Application
Name=Files
Exec=nautilus -n
#OnlyShowIn=GNOME;Unity;
AutostartCondition=GSettings org.gnome.desktop.background show-desktop-icons
NoDisplay=true
X-Ubuntu-Gettext-Domain=nautilus

Désactive pcman
Exemple:
cd /etc/xdg/autostart/
sudo mv pcman pcman.disable

Dernière modification par primesautier (Le 05/05/2012, à 18:22)

Hors ligne

#3 Le 05/05/2012, à 19:06

Pierrot86

Re : [Gestionnaire de fichiers] Nautilus par défaut Lubuntu

Je sais que ça ne répond pas à ta question, mais je voulais juste signaler qu'il est tout à fait possible d'avoir les mignatures d'images avec PCManFM. Dans préférences, on peut régler la taille limite du fichier à partir de laquelle il ne génère pas d'aperçu.

Hors ligne

#4 Le 06/05/2012, à 13:59

ouzmoutous

Re : [Gestionnaire de fichiers] Nautilus par défaut Lubuntu

Bonjour.
@ primesautier
J'avais déjà le /etc/xdg/autostart/nautilus-autostart.desktop avec la même configuration que tu m'as donnée exepté le "OnlyShowIn=GNOME;Unity" qui n'était pas commenté. Je l'ai commenté mais après je  n'ai pas de pcman :

$ ls
blueman.desktop                  nautilus-autostart.desktop
gdu-notification-daemon.desktop  nm-applet.desktop
gnome-keyring-gpg.desktop        notification-daemon.desktop
gnome-keyring-pkcs11.desktop     polkit-gnome-authentication-agent-1.desktop
gnome-keyring-secrets.desktop    print-applet.desktop
gnome-keyring-ssh.desktop        update-notifier.desktop
gsettings-data-convert.desktop   xfce4-power-manager.desktop
jockey-gtk.desktop               zeitgeist-datahub.desktop

Et le fait que je dé-commente la ligne ne change rien, le dossier sur mon bureau s'ouvre toujours avec PCMan

@ Pierrot86
Oui merci je n'avais pas chercher à trouver cette option car je voulais vraiment mettre Nautilus.

Dernière modification par ouzmoutous (Le 06/05/2012, à 14:03)


Si c'est par les erreurs qu'on apprend, je vais devenir surdoué

Hors ligne

#5 Le 21/01/2013, à 01:16

NorSi

Re : [Gestionnaire de fichiers] Nautilus par défaut Lubuntu

Bonjour,

J'ai récemment remplacé Ubuntu 12.04 par Lubuntu 12.10 car mon petit ordi Compaq Pesario C500 (bientôt 6 ans et avec 1 Go de RAM et un modeste Celeron M) commençait à "ramer" un peu. Je suis étonné de la vitesse obtenue avec LUBUNTU: tout simplement génial, une fusée ! Mais moi aussi j'ai regretté le gestionnaire de fichiers Nautilus et j'ai cherché le moyen de le mettre en place et lieu de PCManFM ... et je viens de trouver la solution en lisant cette aide : http://askubuntu.com/questions/155897/h … er-in-lxde

Ce que j'ai fait:
1- Menu --> Accessoires --> Gestionnaire de fichiers --> click droit et choisir propriétés
2- Remplacer la Commande existante par : nautilus %U

Enfin, dans le tableau de bord (partie basse de l'écran), Click droit --> sélectionner "ajouter/enlever des éléments au tableau de bord
--> onglet "avancé" de Préférences du tableau de bord : on doit avoir "nautilus %s" dans Gestionnaire de fichiers


*** LUBUNTU : génial pour un ordinateur peu puissant ! ***

Hors ligne

  • Accueil
  • » Forum
  • » LXDE
  • » [Gestionnaire de fichiers] Nautilus par défaut Lubuntu

Haut de page ↑