Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 26/04/2012, à 17:24

salloum

[Résolu] Problème lors de la mise à niveau de Kubuntu 11.10 à 12.04

Bonjour,
J'utilise Ubuntu 11.10 avec KDE desktop. Apper me propose d'effectuer une mise à niveau vers Kubuntu 12.04 . Il a téléchargé un peu plus de 1 Go de données. Ensuite, lorsqu'il a commencé l'installation, il a buggé, en m'affichant une notification qui disait à peu près Upgrade exited with code 1. J'ai oublié le texte exact puisque je ne pouvais plus rien faire, à part cliquer. Je ne peux plus écrire. J'ai redémarré. C'est toujours Ubuntu 11.10 à l'accueil (lors de la saisie de l'identifiant et du mot de passe), sauf qu'après le démarrage, le clavier ne marche toujours pas! le tableau de bord est complètement désordonné, il y a des icônes rouges avec une croix blanche, des zones vides. Cliquer dessus ne fait rien du tout.

J'ai dû me connecter sur Windows pour pouvoir envoyer ce message.

Si quelqu'un peut m'aider à remédier à ce problème (en rétablissant l'ordre dans mon bon vieux 11.10 ou en m'aidant à effectuer la mise à niveau proprement) je lui serai très reconnaissante.

Merci d'avance! smile

S.B.

Dernière modification par salloum (Le 27/04/2012, à 23:09)

Hors ligne

#2 Le 26/04/2012, à 23:58

jajaX

Re : [Résolu] Problème lors de la mise à niveau de Kubuntu 11.10 à 12.04

salut

tu n'aurais pas du redémarrer....
démarres en mode "récupération" et tente les classiques :

sudo apt-get install -f
sudo dpkg --configure --a
sudo apt-get dist-upgrade

une fois fini, redémarre normalement.

si ça marche toujours pas, ça sent la réinstallation...


@+ jajaX [Membre de Breizhtux : LUG de Saint Brieuc]
ACER Aspire 8930G 904G50Bn & HP dv7 2230f sous Kubuntu 14.04 The Trusty Tahr (64 bits) & KDE SC 4.13.2/Amarok 2.8
ACER Aspire 5612 WLMI & HP Compaq NX6310 sous kubuntu 14.04 The Trusty Tahr (32 bits) & KDE SC 4.13.2/Amarok 2.8

Hors ligne

#3 Le 27/04/2012, à 00:55

Olivier-Gérard

Re : [Résolu] Problème lors de la mise à niveau de Kubuntu 11.10 à 12.04

jajaX a écrit :

salut

tu n'aurais pas du redémarrer....
démarres en mode "récupération" et tente les classiques :

sudo apt-get install -f
sudo dpkg --configure --a
sudo apt-get dist-upgrade

une fois fini, redémarre normalement.

si ça marche toujours pas, ça sent la réinstallation...

Salut jajaX

Pour le second ce ne serait pas ça plutôt wink

sudo dpkg --configure -a

A+Olivier
PC Fixe : Core 2 Duo E8500 - 3.16GHz - FSB 1333Mhz - 8GODDR3 1333Mhz ATI HD6450.
Kubuntu14.04 64 bits, Cairo Dock, Guayadeque, HandBrake, OpenShot, Avidemux, Qarte, Opera.
Portable ACER TravelMate 5742G-374G32Mnss, Core i3 370M 2x 2048MB • ATI Mobility Radeon HD 5470 512MB • 320GB

Hors ligne

#4 Le 27/04/2012, à 01:12

salloum

Re : [Résolu] Problème lors de la mise à niveau de Kubuntu 11.10 à 12.04

Bonsoir et merci à vous jajaX et Olivier-Gérard pour vos réponses.
J'ai pu ouvrir Ubuntu (Gnome) mais il est très bizarre, il n'y a quasiment aucun menu, j'ai dû tout lancer depuis le terminal, que j'ai ouvert grâce à un raccourci clavier.. ça marche.. mes fichiers sont toujours là mais c'est loin d'être pratique!
J'ai tapé ces trois commandes, mais il me semble que seule la deuxième (corrigée) marche (mais je n'en suis pas très sure).
Les deux autres donnent:

apt-get: error while loading shared libraries: libapt-pkg.so.4.12: cannot open shared object file: No such file or directory

est-ce vraiment irrécupérable?? hmm

voici en détails ce que me donne la deuxième commande (à savoir:

sudo dpkg --configure -a
dpkg : des problèmes de dépendances empêchent la configuration de empathy :
 empathy dépend de libebook-1.2-12 (>= 3.2.3) ; cependant :
  Le paquet libebook-1.2-12 n'est pas installé.
 empathy dépend de libfolks-telepathy25 (>= 0.6.6) ; cependant :
  La version de libfolks-telepathy25 sur le système est 0.6.3.2-0ubuntu1.
 empathy dépend de libgnome-keyring0 (>= 3.2.2-2~) ; cependant :
  La version de libgnome-keyring0 sur le système est 3.2.0-0ubuntu1.
 empathy dépend de libgnutls26 (>= 2.12.6.1-0) ; cependant :
  La version de libgnutls26 sur le système est 2.10.5-1ubuntu3.1.
 empathy dépend de libgoa-1.0-0 (>= 3.3.0) ; cependant :
  La version de libgoa-1.0-0 sur le système est 3.2.1-0ubuntu1.
 empathy dépend de libgtk-3-0 (>= 3.3.6) ; cependant :
  La version de libgtk-3-0 sur le système est 3.2.0-0ubuntu6.
 empathy dépend de libtelepathy-farstream2 (>= 0.2.1) ; cependant :
  Le paquet libtelepathy-farstream2 n'est pas installé.
 empathy dépend de libtelepathy-glib0 (>= 0.17.5) ; cependant :
  La version de libtelepathy-glib0 sur le système est 0.15.5-1ubuntu1.
 empathy dépend de libunity9 (>= 3.4.6) ; cependant :
  Le paquet libunity9 n'est pas installé.
 empathy dépend de empathy-common (= 3.4.1-0ubuntu1) ; cependant :
  La version de empathy-common sur le système est 3.2.0.1-0ubuntu1.1.
dpkg : erreur de traitement de empathy (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : erreur de traitement de libfreetype6 (--configure) :
 libfreetype6:amd64 2.4.8-1ubuntu2 cannot be configured because libfreetype6:i386 is in a different version (2.4.4-2ubuntu1.2)
dpkg : erreur de traitement de libfreetype6:i386 (--configure) :
 libfreetype6:i386 2.4.4-2ubuntu1.2 cannot be configured because libfreetype6:amd64 is in a different version (2.4.8-1ubuntu2)
dpkg : des problèmes de dépendances empêchent la configuration de libpango-perl :
 libpango-perl dépend de perl (>= 5.14.2-3) ; cependant :
  La version de perl sur le système est 5.12.4-4.
 libpango-perl dépend de perlapi-5.14.2 ; cependant :
  Le paquet perlapi-5.14.2 n'est pas installé.
dpkg : erreur de traitement de libpango-perl (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de kde-window-manager :
 kde-window-manager dépend de libkactivities6 (>= 4.7.90) ; cependant :
  Le paquet libkactivities6 n'est pas installé.
 kde-window-manager dépend de libkdeclarative5 (>= 4:4.7.0) ; cependant :
  Le paquet libkdeclarative5 n'est pas installé.
 kde-window-manager dépend de libkdecorations4 (= 4:4.8.2a-0ubuntu4) ; cependant :
  La version de libkdecorations4 sur le système est 4:4.7.4-0ubuntu0.1.
 kde-window-manager dépend de libkdecore5 (>= 4:4.8.1) ; cependant :
  La version de libkdecore5 sur le système est 4:4.7.4-0ubuntu0.1.
 kde-window-manager dépend de libkdeui5 (>= 4:4.8.1) ; cependant :
  La version de libkdeui5 sur le système est 4:4.7.4-0ubuntu0.1.
 kde-window-manager dépend de libkephal4abi1 (= 4:4.8.2a-0ubuntu4) ; cependant :
  La version de libkephal4abi1 sur le système est 4:4.7.4-0ubuntu0.1.
 kde-window-manager dépend de libkwineffects1abi3 (= 4:4.8.2a-0ubuntu4) ; cependant :
  Le paquet libkwineffects1abi3 n'est pas installé.
 kde-window-manager dépend de libkwinglutils1 (= 4:4.8.2a-0ubuntu4) ; cependant :
  Le paquet libkwinglutils1 n'est pas installé.
 kde-window-manager dépend de libkworkspace4abi1 (= 4:4.8.2a-0ubuntu4) ; cependant :
  Le paquet libkworkspace4abi1 n'est pas installé.
 kde-window-manager dépend de libplasma3 (>= 4:4.8.1) ; cependant :
  La version de libplasma3 sur le système est 4:4.7.4-0ubuntu0.1.
 kde-window-manager dépend de libqtgui4 (>= 4:4.8.0) ; cependant :
  La version de libqtgui4 sur le système est 4:4.7.4-0ubuntu8.1.
 kde-window-manager dépend de kde-window-manager-common (= 4:4.8.2a-0ubuntu4) ; cependant :
  Le paquet kde-window-manager-common n'est pas installé.
 kde-window-manager dépend de libkwinnvidiahack4 (= 4:4.8.2a-0ubuntu4) ; cependant :
  Le paquet libkwinnvidiahack4 n'est pas installé.
dpkg : erreur de traitement de kde-window-manager (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de libsdl1.2debian :
 libsdl1.2debian dépend de libx11-6 (>= 2:1.4.99.1) ; cependant :
  La version de libx11-6 sur le système est 2:1.4.4-2ubuntu1.
dpkg : erreur de traitement de libsdl1.2debian (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : erreur de traitement de libuuid1 (--configure) :
 libuuid1:amd64 2.19.1-2ubuntu3 cannot be configured because libuuid1:i386 is in a different version (2.20.1-1ubuntu3)
dpkg : erreur de traitement de libuuid1:i386 (--configure) :
 libuuid1:i386 2.20.1-1ubuntu3 cannot be configured because libuuid1:amd64 is in a different version (2.19.1-2ubuntu3)
dpkg : des problèmes de dépendances empêchent la configuration de libedataserver-1.2-15 :
 libedataserver-1.2-15 dépend de gconf-service ; cependant :
  Le paquet gconf-service n'est pas installé.
 libedataserver-1.2-15 dépend de libgconf-2-4 (>= 2.31.1) ; cependant :
  Le paquet libgconf-2-4 n'est pas installé.
dpkg : erreur de traitement de libedataserver-1.2-15 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de libgail-3-0 :
 libgail-3-0 dépend de libgtk-3-0 (= 3.4.1-0ubuntu1) ; cependant :
  La version de libgtk-3-0 sur le système est 3.2.0-0ubuntu6.
dpkg : erreur de traitement de libgail-3-0 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de unity-services :
 unity-services dépend de gconf-service ; cependant :
  Le paquet gconf-service n'est pas installé.
 unity-services dépend de libgconf-2-4 (>= 2.31.1) ; cependant :
  Le paquet libgconf-2-4 n'est pas installé.
 unity-services dépend de libgtk-3-0 (>= 3.3.8) ; cependant :
  La version de libgtk-3-0 sur le système est 3.2.0-0ubuntu6.
 unity-services dépend de libindicator3-7 ; cependant :
  Le paquet libindicator3-7 n'est pas installé.
dpkg : erreur de traitement de unity-services (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de apt :
 apt dépend de libapt-pkg4.12 (>= 0.8.16~exp12ubuntu10) ; cependant :
  Le paquet libapt-pkg4.12 n'est pas installé.
dpkg : erreur de traitement de apt (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de grub-common :
 grub-common dépend de libfreetype6 (>= 2.2.1) ; cependant :
 Le paquet libfreetype6 n'est pas encore configuré.
dpkg : erreur de traitement de grub-common (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de ntfs-3g :
 ntfs-3g dépend de fuse-utils ; cependant :
  Le paquet fuse-utils n'est pas installé.
dpkg : erreur de traitement de ntfs-3g (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de grub-pc-bin :
 grub-pc-bin dépend de grub-common (= 1.99-21ubuntu3) ; cependant :
 Le paquet grub-common n'est pas encore configuré.
dpkg : erreur de traitement de grub-pc-bin (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de libsdl-image1.2 :
 libsdl-image1.2 dépend de libsdl1.2debian (>= 1.2.10-1) ; cependant :
 Le paquet libsdl1.2debian n'est pas encore configuré.
dpkg : erreur de traitement de libsdl-image1.2 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de libapt-pkg-perl :
 libapt-pkg-perl dépend de perl-base (>= 5.14.2-6ubuntu1) ; cependant :
  La version de perl-base sur le système est 5.12.4-4.
 libapt-pkg-perl dépend de perlapi-5.14.2 ; cependant :
  Le paquet perlapi-5.14.2 n'est pas installé.
 libapt-pkg-perl dépend de libapt-pkg4.12 (>= 0.8.0) ; cependant :
  Le paquet libapt-pkg4.12 n'est pas installé.
dpkg : erreur de traitement de libapt-pkg-perl (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de libkcalcore4 :
 libkcalcore4 dépend de libuuid1 (>= 2.16) ; cependant :
 Le paquet libuuid1 n'est pas encore configuré.
dpkg : erreur de traitement de libkcalcore4 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : erreur de traitement de libgcc1 (--configure) :
 libgcc1:amd64 1:4.6.1-9ubuntu3 cannot be configured because libgcc1:i386 is in a different version (1:4.6.3-1ubuntu5)
dpkg : erreur de traitement de libgcc1:i386 (--configure) :
 libgcc1:i386 1:4.6.3-1ubuntu5 cannot be configured because libgcc1:amd64 is in a different version (1:4.6.1-9ubuntu3)
dpkg : des problèmes de dépendances empêchent la configuration de kdepim-kresources :
 kdepim-kresources dépend de libkabc4 (>= 4:4.8.1) ; cependant :
  La version de libkabc4 sur le système est 4:4.7.4-0ubuntu0.1.
 kdepim-kresources dépend de libkblog4 (>= 4:4.8.1) ; cependant :
  La version de libkblog4 sur le système est 4:4.7.4-0ubuntu0.1.
 kdepim-kresources dépend de libkcal4 (>= 4:4.8.1) ; cependant :
  La version de libkcal4 sur le système est 4:4.7.4-0ubuntu0.1.
 kdepim-kresources dépend de libkdecore5 (>= 4:4.8.1) ; cependant :
  La version de libkdecore5 sur le système est 4:4.7.4-0ubuntu0.1.
 kdepim-kresources dépend de libkdepim4 (= 4:4.8.2-0ubuntu2) ; cependant :
  La version de libkdepim4 sur le système est 4:4.7.4+git111222-0ubuntu0.1.
 kdepim-kresources dépend de libkdeui5 (>= 4:4.8.1) ; cependant :
  La version de libkdeui5 sur le système est 4:4.7.4-0ubuntu0.1.
 kdepim-kresources dépend de libkio5 (>= 4:4.8.1) ; cependant :
  La version de libkio5 sur le système est 4:4.7.4-0ubuntu0.1.
 kdepim-kresources dépend de libkresources4 (>= 4:4.8.1) ; cependant :
  La version de libkresources4 sur le système est 4:4.7.4-0ubuntu0.1.
dpkg : erreur de traitement de kdepim-kresources (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de kaddressbook :
 kaddressbook dépend de libakonadi-contact4 (>= 4:4.8.2) ; cependant :
  La version de libakonadi-contact4 sur le système est 4:4.7.4-0ubuntu0.1.
 kaddressbook dépend de libakonadi-kde4 (>= 4:4.8.1) ; cependant :
  La version de libakonadi-kde4 sur le système est 4:4.7.4-0ubuntu0.1.
 kaddressbook dépend de libgcc1 (>= 1:4.1.1) ; cependant :
 Le paquet libgcc1 n'est pas encore configuré.
 kaddressbook dépend de libgpgme++2 (>= 4:4.8.1) ; cependant :
  La version de libgpgme++2 sur le système est 4:4.7.4-0ubuntu0.1.
 kaddressbook dépend de libkabc4 (>= 4:4.8.1) ; cependant :
  La version de libkabc4 sur le système est 4:4.7.4-0ubuntu0.1.
 kaddressbook dépend de libkcmutils4 (>= 4:4.8.1) ; cependant :
  La version de libkcmutils4 sur le système est 4:4.7.4-0ubuntu0.1.
 kaddressbook dépend de libkdecore5 (>= 4:4.8.1) ; cependant :
  La version de libkdecore5 sur le système est 4:4.7.4-0ubuntu0.1.
 kaddressbook dépend de libkdepim4 (= 4:4.8.2-0ubuntu2) ; cependant :
  La version de libkdepim4 sur le système est 4:4.7.4+git111222-0ubuntu0.1.
 kaddressbook dépend de libkdeui5 (>= 4:4.8.1) ; cependant :
  La version de libkdeui5 sur le système est 4:4.7.4-0ubuntu0.1.
 kaddressbook dépend de libkio5 (>= 4:4.8.1) ; cependant :
  La version de libkio5 sur le système est 4:4.7.4-0ubuntu0.1.
 kaddressbook dépend de libkldap4 (>= 4:4.8.1) ; cependant :
  La version de libkldap4 sur le système est 4:4.7.4-0ubuntu0.1.
 kaddressbook dépend de libkleo4 (= 4:4.8.2-0ubuntu2) ; cependant :
  La version de libkleo4 sur le système est 4:4.7.4+git111222-0ubuntu0.1.
 kaddressbook dépend de libkontactinterface4 (>= 4:4.8.1) ; cependant :
  La version de libkontactinterface4 sur le système est 4:4.7.4-0ubuntu0.1.
 kaddressbook dépend de libkparts4 (>= 4:4.8.1) ; cependant :
  La version de libkparts4 sur le système est 4:4.7.4-0ubuntu0.1.
 kaddressbook dépend de libkpimidentities4 (>= 4:4.8.1) ; cependant :
  La version de libkpimidentities4 sur le système est 4:4.7.4-0ubuntu0.1.
 kaddressbook dépend de libqgpgme1 (>= 4:4.8.1) ; cependant :
  La version de libqgpgme1 sur le système est 4:4.7.4-0ubuntu0.1.
 kaddressbook dépend de libqtgui4 (>= 4:4.8.0) ; cependant :
  La version de libqtgui4 sur le système est 4:4.7.4-0ubuntu8.1.
dpkg : erreur de traitement de kaddressbook (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de libpango1.0-0 :
 libpango1.0-0 dépend de libfreetype6 (>= 2.2.1) ; cependant :
 Le paquet libfreetype6 n'est pas encore configuré.
dpkg : erreur de traitement de libpango1.0-0 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de libpango1.0-0:i386 :
 libpango1.0-0:i386 dépend de libcairo2 (>= 1.8.10-3).
 libpango1.0-0:i386 dépend de libfreetype6 (>= 2.2.1) ; cependant :
 Le paquet libfreetype6:i386 n'est pas encore configuré.
 libpango1.0-0:i386 dépend de libthai0 (>= 0.1.12) ; cependant :
 libpango1.0-0:i386 dépend de libxft2 (>> 2.1.1) ; cependant :
dpkg : erreur de traitement de libpango1.0-0:i386 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de odbcinst1debian2 :
 odbcinst1debian2 dépend de libltdl7 (>= 2.4.2) ; cependant :
  La version de libltdl7 sur le système est 2.4-2ubuntu1.
dpkg : erreur de traitement de odbcinst1debian2 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de unattended-upgrades :
 unattended-upgrades dépend de apt ; cependant :
 Le paquet apt n'est pas encore configuré.
dpkg : erreur de traitement de unattended-upgrades (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de fuse :
 fuse dépend de libfuse2 (= 2.8.6-2ubuntu2) ; cependant :
  La version de libfuse2 sur le système est 2.8.4-1.4ubuntu1.
dpkg : erreur de traitement de fuse (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de plymouth-label :
 plymouth-label dépend de libpango1.0-0 (>= 1.14.0) ; cependant :
 Le paquet libpango1.0-0 n'est pas encore configuré.
dpkg : erreur de traitement de plymouth-label (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de plasma-widget-kimpanel :
 plasma-widget-kimpanel dépend de libkdecore5 (>= 4:4.8.1) ; cependant :
  La version de libkdecore5 sur le système est 4:4.7.4-0ubuntu0.1.
 plasma-widget-kimpanel dépend de libkdeui5 (>= 4:4.8.1) ; cependant :
  La version de libkdeui5 sur le système est 4:4.7.4-0ubuntu0.1.
 plasma-widget-kimpanel dépend de libkio5 (>= 4:4.8.1) ; cependant :
  La version de libkio5 sur le système est 4:4.7.4-0ubuntu0.1.
 plasma-widget-kimpanel dépend de libplasma3 (>= 4:4.8.1) ; cependant :
  La version de libplasma3 sur le système est 4:4.7.4-0ubuntu0.1.
dpkg : erreur de traitement de plasma-widget-kimpanel (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : erreur de traitement de libsasl2-modules (--configure) :
 libsasl2-modules:amd64 2.1.24~rc1.dfsg1+cvs2011-05-23-4ubuntu2 cannot be configured because libsasl2-modules:i386 is in a different version (2.1.25.dfsg1-3)
dpkg : erreur de traitement de libsasl2-modules:i386 (--configure) :
 libsasl2-modules:i386 2.1.25.dfsg1-3 cannot be configured because libsasl2-modules:amd64 is in a different version (2.1.24~rc1.dfsg1+cvs2011-05-23-4ubuntu2)
dpkg : des problèmes de dépendances empêchent la configuration de vlc-nox :
 vlc-nox dépend de libfreetype6 (>= 2.2.1) ; cependant :
 Le paquet libfreetype6 n'est pas encore configuré.
 vlc-nox dépend de libgcc1 (>= 1:4.1.1) ; cependant :
 Le paquet libgcc1 n'est pas encore configuré.
 vlc-nox dépend de libvlccore4 (>= 1.1.0) ; cependant :
  Le paquet libvlccore4 n'est pas installé.
 vlc-data (2.0.1-4) casse vlc-nox (<< 2.0.1-3) et est installé.
  La version de vlc-nox à configurer est 1.1.12-2~oneiric1.
dpkg : erreur de traitement de vlc-nox (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : erreur de traitement de libacl1 (--configure) :
 libacl1:amd64 2.2.51-3 cannot be configured because libacl1:i386 is in a different version (2.2.51-5ubuntu1)
dpkg : erreur de traitement de libacl1:i386 (--configure) :
 libacl1:i386 2.2.51-5ubuntu1 cannot be configured because libacl1:amd64 is in a different version (2.2.51-3)
dpkg : des problèmes de dépendances empêchent la configuration de python-gi-cairo :
 python-gi-cairo dépend de python-gi (= 3.2.0-3) ; cependant :
  Le paquet python-gi n'est pas installé.
dpkg : erreur de traitement de python-gi-cairo (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de gnomine :
 gnomine dépend de libgtk-3-0 (>= 3.3.11) ; cependant :
  La version de libgtk-3-0 sur le système est 3.2.0-0ubuntu6.
 gnomine dépend de libpango1.0-0 (>= 1.14.0) ; cependant :
 Le paquet libpango1.0-0 n'est pas encore configuré.
dpkg : erreur de traitement de gnomine (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : erreur de traitement de libdb5.1 (--configure) :
 libdb5.1:amd64 5.1.25-11 cannot be configured because libdb5.1:i386 is in a different version (5.1.25-11build1)
dpkg : erreur de traitement de libdb5.1:i386 (--configure) :
 libdb5.1:i386 5.1.25-11build1 cannot be configured because libdb5.1:amd64 is in a different version (5.1.25-11)
dpkg : des problèmes de dépendances empêchent la configuration de grub-pc :
 grub-pc dépend de grub-common ; cependant :
 Le paquet grub-common n'est pas encore configuré.
 grub-pc dépend de grub-pc-bin (= 1.99-21ubuntu3) ; cependant :
 Le paquet grub-pc-bin n'est pas encore configuré.
dpkg : erreur de traitement de grub-pc (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de libnet-ssleay-perl :
 libnet-ssleay-perl dépend de perl (>= 5.14.2-3build1) ; cependant :
  La version de perl sur le système est 5.12.4-4.
 libnet-ssleay-perl dépend de perlapi-5.14.2 ; cependant :
  Le paquet perlapi-5.14.2 n'est pas installé.
dpkg : erreur de traitement de libnet-ssleay-perl (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de gir1.2-unity-5.0 :
 gir1.2-unity-5.0 dépend de gir1.2-dee-1.0 ; cependant :
  Le paquet gir1.2-dee-1.0 n'est pas installé.
 gir1.2-unity-5.0 dépend de libunity9 (>= 5.2.0) ; cependant :
  Le paquet libunity9 n'est pas installé.
dpkg : erreur de traitement de gir1.2-unity-5.0 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de libkdesu5 :
 libkdesu5 dépend de libkdecore5 (= 4:4.8.2-0ubuntu1) ; cependant :
  La version de libkdecore5 sur le système est 4:4.7.4-0ubuntu0.1.
 libkdesu5 dépend de libkpty4 (= 4:4.8.2-0ubuntu1) ; cependant :
  La version de libkpty4 sur le système est 4:4.7.4-0ubuntu0.1.
dpkg : erreur de traitement de libkdesu5 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de grub2-common :
 grub2-common dépend de grub-common (= 1.99-21ubuntu3) ; cependant :
 Le paquet grub-common n'est pas encore configuré.
dpkg : erreur de traitement de grub2-common (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de libapparmor-perl :
 libapparmor-perl dépend de perl (>= 5.14.2-6ubuntu2) ; cependant :
  La version de perl sur le système est 5.12.4-4.
 libapparmor-perl dépend de perlapi-5.14.2 ; cependant :
  Le paquet perlapi-5.14.2 n'est pas installé.
dpkg : erreur de traitement de libapparmor-perl (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de gvfs-fuse :
 gvfs-fuse dépend de fuse-utils (>= 2.8.4) ; cependant :
  Le paquet fuse-utils n'est pas installé.
dpkg : erreur de traitement de gvfs-fuse (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de libecal-1.2-10 :
 libecal-1.2-10 dépend de gconf-service ; cependant :
  Le paquet gconf-service n'est pas installé.
 libecal-1.2-10 dépend de libedataserver-1.2-15 (>= 3.2.3) ; cependant :
 Le paquet libedataserver-1.2-15 n'est pas encore configuré.
 libecal-1.2-10 dépend de libgconf-2-4 (>= 2.31.1) ; cependant :
  Le paquet libgconf-2-4 n'est pas installé.
dpkg : erreur de traitement de libecal-1.2-10 (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de liblockfile1 :
 liblockfile1 dépend de liblockfile-bin (>= 1.09-3) ; cependant :
  Le paquet liblockfile-bin n'est pas installé.
dpkg : erreur de traitement de liblockfile1 (--configure) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 empathy
 libfreetype6
 libfreetype6:i386
 libpango-perl
 kde-window-manager
 libsdl1.2debian
 libuuid1
 libuuid1:i386
 libedataserver-1.2-15
 libgail-3-0
 unity-services
 apt
 grub-common
 ntfs-3g
 grub-pc-bin
 libsdl-image1.2
 libapt-pkg-perl
 libkcalcore4
 libgcc1
 libgcc1:i386
 kdepim-kresources
 kaddressbook
 libpango1.0-0
 libpango1.0-0:i386
 odbcinst1debian2
 unattended-upgrades
 fuse
 plymouth-label
 plasma-widget-kimpanel
 libsasl2-modules
 libsasl2-modules:i386
 vlc-nox
 libacl1
 libacl1:i386
 python-gi-cairo
 gnomine
 libdb5.1
 libdb5.1:i386
 grub-pc
 libnet-ssleay-perl
 gir1.2-unity-5.0
 libkdesu5
 grub2-common
 libapparmor-perl
 gvfs-fuse
 libecal-1.2-10
 liblockfile1

Dernière modification par salloum (Le 27/04/2012, à 01:14)

Hors ligne

#5 Le 27/04/2012, à 08:13

regisg

Re : [Résolu] Problème lors de la mise à niveau de Kubuntu 11.10 à 12.04

Je rencontre exactement le même problème que salloum. J'ai essayer de palier à l'absence de libapt-p kg.so.4.12 par un lien symbolique vers libapt-pkg.so.4.11, sans succès.

Hors ligne

#6 Le 27/04/2012, à 08:38

bruno

Re : [Résolu] Problème lors de la mise à niveau de Kubuntu 11.10 à 12.04

Si c'est ce paquet qui pose problème, en dernier recours, on peut tenter de forcer son installation :

dpkg -i --force-all libapt-pkg4.12

puis retenter une mise à niveau.

Dernière modification par bruno (Le 27/04/2012, à 08:39)

Hors ligne

#7 Le 27/04/2012, à 09:55

regisg

Re : [Résolu] Problème lors de la mise à niveau de Kubuntu 11.10 à 12.04

Bon apparemment, ça s'arrange ...
J'ai d'abord forcé l'installation du paquet  gcc trouvé ici

sudo dpkg -i --force-all gcc-4.6_4.6.3-1ubuntu5_i386.deb

puis le paquet libapt trouva

sudo dpkg -i --force-all libapt-pkg4.12_0.8.16~exp12ubuntu10_i386.deb

ensuite

sudo apt-get install -f
sudo apt-get upgrade

Hors ligne

#8 Le 27/04/2012, à 10:19

jajaX

Re : [Résolu] Problème lors de la mise à niveau de Kubuntu 11.10 à 12.04

oups, oui faute de frappe, désolé wink


@+ jajaX [Membre de Breizhtux : LUG de Saint Brieuc]
ACER Aspire 8930G 904G50Bn & HP dv7 2230f sous Kubuntu 14.04 The Trusty Tahr (64 bits) & KDE SC 4.13.2/Amarok 2.8
ACER Aspire 5612 WLMI & HP Compaq NX6310 sous kubuntu 14.04 The Trusty Tahr (32 bits) & KDE SC 4.13.2/Amarok 2.8

Hors ligne

#9 Le 27/04/2012, à 14:10

salloum

Re : [Résolu] Problème lors de la mise à niveau de Kubuntu 11.10 à 12.04

Bonjour,
ah ça ne marche toujours pas ... Voilà ce qu'il me dit lorsque je tape la commande

sudo dpkg -i --force-all gcc-4.6_4.6.3-1ubuntu5_i386.deb

dpkg : erreur de traitement de gcc-4.6_4.6.3-1ubuntu5_i386.deb (--install) :
 ne peut pas accéder à l'archive: Aucun fichier ou dossier de ce type
Des erreurs ont été rencontrées pendant l'exécution :
 gcc-4.6_4.6.3-1ubuntu5_i386.deb

J'ai l'impression qu'il ne reste quasiment rien dans mon système!

Hors ligne

#10 Le 27/04/2012, à 14:23

Pierrot_Rennes

Re : [Résolu] Problème lors de la mise à niveau de Kubuntu 11.10 à 12.04

Bonjour,

Dans la série des problèmes avec Ubuntu...
Mise à jour ce matin et la session redémarre bien avec une 12.04 installée, la session est stable (hormis Nepomuk (voir plus bas)) mais...

- Muon me dit que des paquets sont cassés :
1204paquetscasses.png
- Quand je lance la mise à niveau, au bout d'un long moment, Muon me répond qu'une autre application utilise le système de paquetage :
1205paquetscasses2.png
- En mode console, quand je fais : sudo apt-get install (après upgrade), j'ai l'erreur suivante : E : Internal error, no file name for libgcc1
- Et pour finir, Nepomuk m'informe que le serveur Virtuoso RDF n'est pas trouvé

Cela fait un peu beaucoup pour une mise à jour d'autant plus que Muon ne veut plus les faire et tourne dans le vide indéfiniment

Si vous avez une idée de ou des solutions, merci d'avance

Dernière modification par Pierrot_Rennes (Le 27/04/2012, à 14:28)


Pierrot - Rennes (35)
Kubuntu 12.04 - Gnome - Libre Office 3.5
Linux converti depuis 7 ans
Et un peu  moins de choses à apprendre !!! ;-))

Hors ligne

#11 Le 27/04/2012, à 16:10

korrigan-kubuntu

Re : [Résolu] Problème lors de la mise à niveau de Kubuntu 11.10 à 12.04

Bonjour,

Exactement le même problème que Pierrot_Rennes ci-dessus. Même déroulement, même message d'erreur E : Internal error, no file name for libgcc1. J'ai essayé les solutions présentées avant, mais le problème ne semble pas tout à fait le même.

Si quelqu'un avait une idée, je lui serais très reconnaissant, je ne peux plus travailler...(ça m'apprendra à faire les mises à jour trop vite!).

Je suis également sous Kubuntu.

Merci par avance,

Hors ligne

#12 Le 27/04/2012, à 17:42

gaaamin

Re : [Résolu] Problème lors de la mise à niveau de Kubuntu 11.10 à 12.04

Salut à tous, j'avais déjà eu ce problème de "code 1" lors de la mise à jour vers la 11.10, ça devient une habitude! Impossible de faire une migration correcte, même en utilisant uniquement les dépôts officiels... j'avais réinstallé le système complet, au moins, cela fonctionne toujours.
Du coup j'attend la suite avant de me lancer.
Bon courage à vous.


Intel i5 750 ATI HD5770 Win7, Dell Inspiron 1764 Dual boot.
Kubuntu 12.04
KDE is good for you!

Hors ligne

#13 Le 27/04/2012, à 18:15

pch

Re : [Résolu] Problème lors de la mise à niveau de Kubuntu 11.10 à 12.04

Même problème pour moi sad
Je l'ai résolu en installant apt, libapt-pkg4 et liblzma5 avec dpkg -i pour que apt-get refonctionne.
Puis en appliquant la solution donnée dans 3eme commentaire de ce bug:
https://bugs.launchpad.net/ubuntu/+sour … bug/983543

Hors ligne

#14 Le 27/04/2012, à 18:45

salloum

Re : [Résolu] Problème lors de la mise à niveau de Kubuntu 11.10 à 12.04

Quand j'essaie d'installer un de ces paquets, la logithèque s'ouvre en me disant "architecture i386 incorrecte". Il n'y a qu'une autre architecture disponible, AMD. Or mon processeur est un intel pentium..
En plus, en fouillant un peu dans la logithèque, j'ai voulu installer quelque chose, mais il m'a proposé des réparations.. J'ai accepté et maintenant, la commande:

sudo dpkg --configure -a

ne génère plus d'erreur.
J'ai ensuite tapé la commande

sudo apt-get dist-upgrade

ah bah non, après tout ce temps c'est fini avec cette erreur:

Rebuilding /usr/share/applications/bamf.index...
Des erreurs ont été rencontrées pendant l'exécution :
 librsvg2-common:i386
 ia32-libs-multiarch:i386
 ia32-libs
E: Sub-process /usr/bin/dpkg returned an error code (1)

Dernière modification par salloum (Le 27/04/2012, à 18:54)

Hors ligne

#15 Le 27/04/2012, à 19:08

salloum

Re : [Résolu] Problème lors de la mise à niveau de Kubuntu 11.10 à 12.04

pch a écrit :

Même problème pour moi sad
Je l'ai résolu en installant apt, libapt-pkg4 et liblzma5 avec dpkg -i pour que apt-get refonctionne.
Puis en appliquant la solution donnée dans 3eme commentaire de ce bug:
https://bugs.launchpad.net/ubuntu/+sour … bug/983543

Merci pch, les librairies ont l'air d'être installées dans mon ordinateur. Quant au 3ème commentaire du bug,

sudo dpkg -i /var/cache/apt/archives/*.deb

ne marche pas
et

sudo apt-get dist-upgrade

, ça donne ça:

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
  unity-scope-musicstores
0 mis à jour, 0 nouvellement installés, 0 à enlever et 1 non mis à jour.

Je redémarre? ou je vais acheter un CD...?

Hors ligne

#16 Le 27/04/2012, à 21:01

jajaX

Re : [Résolu] Problème lors de la mise à niveau de Kubuntu 11.10 à 12.04

salut

j'applique les commandes de la réponse #3 du rapport e bug

apt-get update
 apt-get clean
 apt-get install -fy
 dpkg -i /var/cache/apt/archives/*.deb
 dpkg --configure -a
 apt-get install -fy
 apt-get dist-upgrade

(mettre "sudo" devant chaque commande)

j'en suis à la dernière étape-là et ça à l'air de bien se passer.

note: mise à jour de mon mediacenter en cours wink

edit : j'ai bien sûr eu les mêmes messages d'erreur sinon je posterais pas...

edit2: erreur pour un paquet de libre-office :

sudo apt-get install -f

et ça passe !

c'est reparti pour un

sudo apt-get dist-upgrade

....

Dernière modification par jajaX (Le 27/04/2012, à 21:15)


@+ jajaX [Membre de Breizhtux : LUG de Saint Brieuc]
ACER Aspire 8930G 904G50Bn & HP dv7 2230f sous Kubuntu 14.04 The Trusty Tahr (64 bits) & KDE SC 4.13.2/Amarok 2.8
ACER Aspire 5612 WLMI & HP Compaq NX6310 sous kubuntu 14.04 The Trusty Tahr (32 bits) & KDE SC 4.13.2/Amarok 2.8

Hors ligne

#17 Le 27/04/2012, à 21:47

salloum

Re : [Résolu] Problème lors de la mise à niveau de Kubuntu 11.10 à 12.04

Bonsoir,
ça a marché! j'ai même démarré avec KDE et c'est bon tout marche à merveille!!
J'ai juste redémarré après ce que je j'ai écrit dans mon dernier message.

Edit: j'avais des problèmes avec le tableau de bord, je l'ai supprimé et ai créé un nouveau..

Un grand merci à tous pour votre aide précieuse! smile

Dernière modification par salloum (Le 27/04/2012, à 22:24)

Hors ligne

#18 Le 27/04/2012, à 23:06

jajaX

Re : [Résolu] Problème lors de la mise à niveau de Kubuntu 11.10 à 12.04

mise à jour finie et réussie pour ma part également !

le pc fixe va attendre, trop de ppa à vérifier (surtout celui de akonadi-google) pour cause de prise en charge de precise.... mais il y a avoir droit aussi big_smile

edit : salloum content pour toi wink

un petit [résolu] dans le titre de ton sujet, merci smile

Dernière modification par jajaX (Le 27/04/2012, à 23:07)


@+ jajaX [Membre de Breizhtux : LUG de Saint Brieuc]
ACER Aspire 8930G 904G50Bn & HP dv7 2230f sous Kubuntu 14.04 The Trusty Tahr (64 bits) & KDE SC 4.13.2/Amarok 2.8
ACER Aspire 5612 WLMI & HP Compaq NX6310 sous kubuntu 14.04 The Trusty Tahr (32 bits) & KDE SC 4.13.2/Amarok 2.8

Hors ligne

#19 Le 28/04/2012, à 15:21

Pierrot_Rennes

Re : [Résolu] Problème lors de la mise à niveau de Kubuntu 11.10 à 12.04

jajaX a écrit :

salut

j'applique les commandes de la réponse #3 du rapport e bug

apt-get update
 apt-get clean
 apt-get install -fy
 dpkg -i /var/cache/apt/archives/*.deb
 dpkg --configure -a
 apt-get install -fy
 apt-get dist-upgrade

(mettre "sudo" devant chaque commande)
...

Bonjour,

+1 pour ces commandes car cela a résolu mon blocage de Muon ce matin
J'ai appliqué en mode console (très long processus)
Après redémarrage, c'est ok
Donc à noter précieusement pour ceux qui auraient des problèmes similaires
Merci et bon WE


Pierrot - Rennes (35)
Kubuntu 12.04 - Gnome - Libre Office 3.5
Linux converti depuis 7 ans
Et un peu  moins de choses à apprendre !!! ;-))

Hors ligne

#20 Le 30/04/2012, à 05:08

marronsuisse

Re : [Résolu] Problème lors de la mise à niveau de Kubuntu 11.10 à 12.04

Même symptômes chez moi après la mise à jour, résolu grâce aux commandes
apt-get update
apt-get clean
apt-get install -fy
dpkg -i /var/cache/apt/archives/*.deb
dpkg --configure -a
apt-get install -fy
apt-get dist-upgrade

A noter que j'ai du boucler plusieurs fois dpkg dpkg puis apt-get install -fy avant que les problèmes ne soient résolus, j'en ai eu pour la journée entière. A chaque boucle, quelques éléments nouveaux sont installés.
Au final, j'ai l'impression que tout est revenu à la normal.

Un grand merci à vous !

Hors ligne

#21 Le 30/04/2012, à 10:36

Tromzy95

Re : [Résolu] Problème lors de la mise à niveau de Kubuntu 11.10 à 12.04

Pareil pour moi, échec des mises à jour avec Muon, les commandes ci-dessus m'ont permis d'achever correctement mon passage en 12.04. Merci à tous. smile

Hors ligne

#22 Le 30/04/2012, à 14:36

jajaX

Re : [Résolu] Problème lors de la mise à niveau de Kubuntu 11.10 à 12.04

cool smile


@+ jajaX [Membre de Breizhtux : LUG de Saint Brieuc]
ACER Aspire 8930G 904G50Bn & HP dv7 2230f sous Kubuntu 14.04 The Trusty Tahr (64 bits) & KDE SC 4.13.2/Amarok 2.8
ACER Aspire 5612 WLMI & HP Compaq NX6310 sous kubuntu 14.04 The Trusty Tahr (32 bits) & KDE SC 4.13.2/Amarok 2.8

Hors ligne

#23 Le 06/05/2012, à 15:44

fangstergangsta

Re : [Résolu] Problème lors de la mise à niveau de Kubuntu 11.10 à 12.04

salut,
J'ai fait la mise à jour avec synaptic et j'ai eu aussi un problème de blocage lors de l'installation, et j'ai eu la mauvaise idée de redémarrer mon portable car il était totalement bloqué!

or, au redémarrage cela semble se lancer correctement sauf pour tout ce qui est des drivers, je n'est ni le wifi, ni l'ethernet, ni même mon touchpad qui marche du coup je ne peut pas lancer les commandes écrites au dessus...
avez vous une idée pour résoudre mon problème au moins de driver wifi ou ethernet afin que je puisse tenter les commandes citées au dessus?

merci d'avance


"Some people make the world more special just by being in it!"

Hors ligne

#24 Le 06/05/2012, à 18:02

fangstergangsta

Re : [Résolu] Problème lors de la mise à niveau de Kubuntu 11.10 à 12.04

problème résolu avec le recovery et dpkg merci quand même!


"Some people make the world more special just by being in it!"

Hors ligne

#25 Le 16/05/2012, à 16:42

mattax63

Re : [Résolu] Problème lors de la mise à niveau de Kubuntu 11.10 à 12.04

Bonjour, moi aussi j'ai eu le même problème , j'avais une erreur apres apt-get install -fy  sur le paquet  libapt-pkg4.12 mais avec votre méthode cela l'a installé , puis j'ai eu le paquet libmount1 qui ne voulait plus rien faire .

j'ai trouver sur un autre post la méthode

sudo apt-get download libmount1 && sudo dpkg --install libmount1*.deb

et la miracle la commande apt-get install -fy a fonctionné correctement
j'attends la fin mais en tout cas c'est bien partie

pour info cela marche sur d'autre paquets cassé eu aussi

sudo apt-get download xxx && sudo dpkg --install xxx*.deb

AMD 64 nvidia 7600gs
Kubuntu 12.04 64bits
compiz , cairo-dock

Hors ligne

  • Accueil
  • » Forum
  • » KDE
  • » [Résolu] Problème lors de la mise à niveau de Kubuntu 11.10 à 12.04

Haut de page ↑