Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 04/03/2005, à 17:51

laurentb

[Info] install réussi ubuntu 4.1 sur ultraportable compaq nc4010

Salut à tous,

Après quelques petites galères, 3 installations successives, quelques recherches sur le net et pleins de visite dans les différents forums du site, j'ai enfin une install quasi nickelle de mon ultra portable compaq.

l'appareil :

pc portable

pentium IV M 1,6 GHz
512 Mo DDR, un slot vide en plus.
HD 40 Go
écran 12 TFT
lecteur sdcard, 2 USB 2.0, S-VHS, VGA, 1 pcmcia 32 bits, lan 1000 TX, modem 56K, ati radeon igp 340M intégrée, son ali 5145...infrarouge et wifi a/b/g dans le capot en atheros.

autonomie entre 4h et 8h selon activités, poids = 1,7 kg

install facile, sauf que pas de floppy, pas de cd-rom, et boot bridé hard disk ou usb.

avec un lecteur/graveur dvd usb, install nickelle, sauf carte réseau eth0, un broadcom BCM5705M qui est reconnue par lspci et lsmod mais ne fonctionne pas. je vais creuser.
en attendant une carte pcmcia 100 TX fait l'affaire.

wifi nickel au premier coup, très bon débit avec sa double antenne.

pas de 3D, le chipset ne la prend pas bien en charge.

acpi nickel et complet, setpspeed ok, powernow ok.

en gros, ça a été un plaisir de virer windows XP pro...

@ plus, et encore merci pour toutes vos contributions. big_smile

Laurent Bellegarde,
professeur de SVT
le libre à l'école : www.abuledu.org

Dernière modification par laurentb (Le 04/03/2005, à 22:47)


Laurent Bellegarde, professeur de SVT, 64 Bayonne, France
GNU/Linux a l'ecole : www.abuledu.org
lprod.org, Montage audio et vidéo libre
Lugs : www.euskalug.org, www.abul.org

Hors ligne

#2 Le 04/03/2005, à 18:43

nikola

Re : [Info] install réussi ubuntu 4.1 sur ultraportable compaq nc4010

C'est tout de même con pour la 3D... C'et quoi comme chip ?


Venez prendre un café :)

Hors ligne

#3 Le 04/03/2005, à 22:57

laurentb

Re : [Info] install réussi ubuntu 4.1 sur ultraportable compaq nc4010

Bonsoir,

le chip vidéo est une ati radeon igp 340M avec 32 piochés dans les 512 de ram.

en fait je me suis emballé un peu vite...  hmm j'ai éteint l'appareil, puis 3 h après je boot normal, et il se bloque lors de l'activation de hotplug, la carte pcmcia s'active mais ne trouve plus de réseau, le wifi non plus, et tjrs pas de broadcom, il reste bloqué là.

après plusieurs modifs de fichiers, modules et l'invalidation avec chmod 000 sur hotplug, le pc boot complet, très vite, le réseau fonctionne mais plus le wifi.

j'ai repéré le driver gpl de la carte réseau interne sur le site du fabricant, mais j'arrive pas à l'installer à partir du tgz...c'est ici : http://www.broadcom.com/drivers/downloaddrivers.php

le fichier zip donne : bcm5700-7.3.5 # ls
DISTRIB.TXT  LICENSE  network_install  patches  README.TXT  RELEASE.TXT  src

et les fichiers txt disent cd src puis make qui me renvoit :

root@ubuntuultraportable:/home/laurent/bcm5700-7.3.5/src # make
make -C  SUBDIRS=/home/laurent/bcm5700-7.3.5/src modules
make: *** SUBDIRS=/home/laurent/bcm5700-7.3.5/src: Aucun fichier ou répertoire de ce type. Arrêt.
make: *** [default] Erreur 2
root@ubuntuultraportable:/home/laurent/bcm5700-7.3.5/src #

ça vous parle ???

j'arrive pas à trouver le kernel source dans l'aborescence debian (j'arrive de mandrake tongue

comment savoir pourquoi hotplug "pète les plombs" ? si je le réactive...

@ plus, laurent.


Laurent Bellegarde, professeur de SVT, 64 Bayonne, France
GNU/Linux a l'ecole : www.abuledu.org
lprod.org, Montage audio et vidéo libre
Lugs : www.euskalug.org, www.abul.org

Hors ligne

#4 Le 04/03/2005, à 23:24

laurentb

Re : [Info] install réussi ubuntu 4.1 sur ultraportable compaq nc4010

Encore moi roll

en remettant les droits qui vont bien sur hotplug avec chmod 755, et un /etc/init.d/hotplug start, je récupère le wifi, la sd card, le bluetooh et divers autres outils sans perdre la config réseau avec eth1.

est-ce que cela veut dire qu'il faut que je colle hotplug en fin de séquence de boot plutôt que là où il est ?

j'attends vos avis, j'ai quand même de quoi avancer...

Bonne nuit, laurent wink


Laurent Bellegarde, professeur de SVT, 64 Bayonne, France
GNU/Linux a l'ecole : www.abuledu.org
lprod.org, Montage audio et vidéo libre
Lugs : www.euskalug.org, www.abul.org

Hors ligne

Haut de page ↑