Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 22/06/2012, à 12:25

toutafai

[Résolu]12.04 et gnome shell = bureau vide, pas de tableau de bord

Bonjour a toutes et a tous,

Je fais appel à vous car, comme le sujet l'indique, si j'ouvre ma session en choisissant gnome shell (gnome tout court dans le choix des environnements au login), je me retrouve avec un bureau vide = aucune icone du bureau, pas de menu, rien, que dalle, nada ...

Si j'ouvre en choisissant un autre environnement, la aucun problème.

Un peu de détails sur ma configuration : Portable IBM ThinkPad R60, Ubuntu 12.04 32 bits (une vrai installation, pas un upgrade), compiz installé (je me pose la question savoir si c'est pas lui le responsable), système à jour,  contrôleur graphique intégré au portable (Intel Corporation Mobile 945GM/GMS, donc pas de pilote proprio).

Avez vous une idée pour me dépanner ?

D'avance merci.

Ps : si vous avez besoin de plus d'info, n'hésitez pas à demander

EDIT : Petit résumé pour ceux qui ne veulent pas lire tous ce fil : mon problème à été contourné, il s'agit d'un problème dans mon profil...plutôt que de cherché (le themes, ou le . conf responsable), j'ai créer un nouveau compte dans lequel j'ai transféré mes documents

Dernière modification par toutafai (Le 28/06/2012, à 11:27)


Ubuntu Server 12.04 x32 sur IBM P4. - XP / Seven / Ubuntu 14.04 x64 sur Lenovo ThinkPad. Purée d'unity...difficile de s'y faire - canon MG5350 - Logitech Quickcam 3000 - TNT Intuix S800 - Freebox v6 révolution (Trop de la balle !!!)
Utilisateur d'Ubuntu depuis novembre 2006.
23 PC libérés grâce aux OS libres...et de 24 et quel 24 ...car pc au taff et pour le taff ^^

Hors ligne

#2 Le 22/06/2012, à 17:29

yzeew

Re : [Résolu]12.04 et gnome shell = bureau vide, pas de tableau de bord

salut
essaye ceci , ouvrir gconf-editor via un terminal

gconf-editor

Puis aller dans apps > panel > global
Et décocher la valeur locked_down


<==============================| Linux in the blood | Linux For Life |==================================>
<====================| OS Hôte: #! CrunchBang | OS VM: Back|Track 5 RC1 Vision OpenBox |=====================>

Hors ligne

#3 Le 22/06/2012, à 17:45

toutafai

Re : [Résolu]12.04 et gnome shell = bureau vide, pas de tableau de bord

Merci pour ta réponse. la valeur n’était pas coché. j'ai donc fait le test, je coche la valeur, j'ouvre un session en gnome shell : toujours pareil. je reboot, j'ouvre la session en gnome classic, je décoche la valeur, j'ouvre la session en gnome shell : toujours pareil....

Je vais faire le test avec un autre utilisateur dès fois que cela viendrait de mon profil.... si j'édite pas ce message d'ici 5 minutes, c'est que cela fait pareil avec un autre utilisateur.

EDIT : Cela vient bien de mon profil, puisqu'avec un autre utilisateur, j'ai bien l’environnement gnome-shell....reste à savoir ou est le problème dans mon profil.

Dernière modification par toutafai (Le 22/06/2012, à 17:54)


Ubuntu Server 12.04 x32 sur IBM P4. - XP / Seven / Ubuntu 14.04 x64 sur Lenovo ThinkPad. Purée d'unity...difficile de s'y faire - canon MG5350 - Logitech Quickcam 3000 - TNT Intuix S800 - Freebox v6 révolution (Trop de la balle !!!)
Utilisateur d'Ubuntu depuis novembre 2006.
23 PC libérés grâce aux OS libres...et de 24 et quel 24 ...car pc au taff et pour le taff ^^

Hors ligne

#4 Le 22/06/2012, à 17:55

misaine

Re : [Résolu]12.04 et gnome shell = bureau vide, pas de tableau de bord

probablement une extension ou un thème non compatible


la roue tourne...c'est sûr! c'est même pour ça qu'on l'a inventée.

Hors ligne

#5 Le 22/06/2012, à 18:07

toutafai

Re : [Résolu]12.04 et gnome shell = bureau vide, pas de tableau de bord

Ok, merci pour cette piste que je vais creuser...mais pas 10 ans, au pire je créer un nouvel utilisateur, et je transfert mon données dessus


Ubuntu Server 12.04 x32 sur IBM P4. - XP / Seven / Ubuntu 14.04 x64 sur Lenovo ThinkPad. Purée d'unity...difficile de s'y faire - canon MG5350 - Logitech Quickcam 3000 - TNT Intuix S800 - Freebox v6 révolution (Trop de la balle !!!)
Utilisateur d'Ubuntu depuis novembre 2006.
23 PC libérés grâce aux OS libres...et de 24 et quel 24 ...car pc au taff et pour le taff ^^

Hors ligne

#6 Le 22/06/2012, à 18:12

misaine

Re : [Résolu]12.04 et gnome shell = bureau vide, pas de tableau de bord

commence par simplement désactiver toutes tes extensions
pour le thème tu dois bien savoir ce que tu as installé !?


la roue tourne...c'est sûr! c'est même pour ça qu'on l'a inventée.

Hors ligne

#7 Le 22/06/2012, à 18:43

Major Grubert

Re : [Résolu]12.04 et gnome shell = bureau vide, pas de tableau de bord

Je ne connais pas ce type de problème, mais déjà : ce n'est pas la faute de compiz car il n'est pas chargé sous Gnome-shell (même s'il est installé).
Crée un nouvel utilisateur et essaye de te logguer sous GS, ou en mode "invité".
As-tu déjà réussi à faire tourner GS avant ?
Si oui as-tu installé des extensions et lesquelles ?


Pour en savoir plus sur Gnome Shell.
. Lenovo Yoga 13 : Windows 8.1 / Ubuntu Gnome 14.04
. Asus x7010 : Ubuntu 14.04 (Gnome Shell)
. Asus Eeepc : Xubuntu 14.04 (32b)

Hors ligne

#8 Le 22/06/2012, à 18:53

misaine

Re : [Résolu]12.04 et gnome shell = bureau vide, pas de tableau de bord

toutafai a écrit :

Je vais faire le test avec un autre utilisateur dès fois que cela viendrait de mon profil.... si j'édite pas ce message d'ici 5 minutes, c'est que cela fait pareil avec un autre utilisateur.

Cela vient bien de mon profil, puisqu'avec un autre utilisateur, j'ai bien l’environnement gnome-shell....reste à savoir ou est le problème dans mon profil.

wink
renomme ou efface le fichier /home/ton_user/.themes  # remplacer ton_user par ce qui va bien

Dernière modification par misaine (Le 22/06/2012, à 18:56)


la roue tourne...c'est sûr! c'est même pour ça qu'on l'a inventée.

Hors ligne

#9 Le 22/06/2012, à 19:00

Major Grubert

Re : [Résolu]12.04 et gnome shell = bureau vide, pas de tableau de bord

Tu peux repartir à zéro à partir de l'autre profil en virant les extensions : lance nautilus en administrateur (sudo nautilus) et rends toi dans le /home de ton utilisateur principal et dans .local/share/gnome-shell/extensions/ tu verras les répertoires des extensions que tu as installées depuis le site gnome.
Tu peux les virer une par une ou toutes et voir si ça remarche.
Si jamais tu en as installées bien sûr.
Sinon ça vient d'ailleurs.
Mais dis-nous celles que tu te rappelles avoir installées, ça peut nous aider.


Pour en savoir plus sur Gnome Shell.
. Lenovo Yoga 13 : Windows 8.1 / Ubuntu Gnome 14.04
. Asus x7010 : Ubuntu 14.04 (Gnome Shell)
. Asus Eeepc : Xubuntu 14.04 (32b)

Hors ligne

#10 Le 22/06/2012, à 22:48

toutafai

Re : [Résolu]12.04 et gnome shell = bureau vide, pas de tableau de bord

Merci à vous 2 pour ces pistes. je n'ai aucune exgensions dans .local/share/gnome-shell/extensions/ (bizarre car voir plus bas)

Ce qui a été installé (ayant pris l'habitude de toujours faire dans un terminalf, ca va etre facile avec history :-) ) :
gnome-shell et gnome-shell-extensions issu du dépot ppa webupd8team/gnome3


Concernant le theme, effectivement, il est personnalisé....si cela vient de ça, cela voudrait dire (arretez moi si je me trompe) qu'un element utilisé dans mon themes personnalisé ne serait pas compatible gnome3/gtk3 ?

Enfin avec un nouvel utilisateur, cela fonctionne nickel.

Dernière modification par toutafai (Le 22/06/2012, à 22:48)


Ubuntu Server 12.04 x32 sur IBM P4. - XP / Seven / Ubuntu 14.04 x64 sur Lenovo ThinkPad. Purée d'unity...difficile de s'y faire - canon MG5350 - Logitech Quickcam 3000 - TNT Intuix S800 - Freebox v6 révolution (Trop de la balle !!!)
Utilisateur d'Ubuntu depuis novembre 2006.
23 PC libérés grâce aux OS libres...et de 24 et quel 24 ...car pc au taff et pour le taff ^^

Hors ligne

#11 Le 22/06/2012, à 23:24

misaine

Re : [Résolu]12.04 et gnome shell = bureau vide, pas de tableau de bord

j'ai vu des mises en garde sur gnome-look disant que certain thème gtk3 font planter gnome-shell selon les versions 3.0, 3.2 ou 3.4


la roue tourne...c'est sûr! c'est même pour ça qu'on l'a inventée.

Hors ligne

#12 Le 22/06/2012, à 23:27

toutafai

Re : [Résolu]12.04 et gnome shell = bureau vide, pas de tableau de bord

ok, merci pour cette info


Ubuntu Server 12.04 x32 sur IBM P4. - XP / Seven / Ubuntu 14.04 x64 sur Lenovo ThinkPad. Purée d'unity...difficile de s'y faire - canon MG5350 - Logitech Quickcam 3000 - TNT Intuix S800 - Freebox v6 révolution (Trop de la balle !!!)
Utilisateur d'Ubuntu depuis novembre 2006.
23 PC libérés grâce aux OS libres...et de 24 et quel 24 ...car pc au taff et pour le taff ^^

Hors ligne

#13 Le 23/06/2012, à 01:48

Major Grubert

Re : [Résolu]12.04 et gnome shell = bureau vide, pas de tableau de bord

Bizarre. Gnome-shell-extensions est totalement compatible si tu n'installes rien d'autre. Je ne pige pas.


Pour en savoir plus sur Gnome Shell.
. Lenovo Yoga 13 : Windows 8.1 / Ubuntu Gnome 14.04
. Asus x7010 : Ubuntu 14.04 (Gnome Shell)
. Asus Eeepc : Xubuntu 14.04 (32b)

Hors ligne

#14 Le 09/08/2012, à 13:58

Applejuice

Re : [Résolu]12.04 et gnome shell = bureau vide, pas de tableau de bord

OK.
Je confirme.
Le changement de profil marche pour moi aussi avec 12.04.

Profil1: c'est la M...
Profil2: C'est Byzance. tongue

Ca fait un petit temps que je cherchais le moyen de passer sur Gnome-shell ("Gnome" dans l'écran de changement de session) avec les même problèmes que toutafai.
Là, avec un nouvel utilisateur, ça marche, j'ai un Gnome-shell tout neuf, tout beau et, comme c'est la première fois que je l'utilise, je n'ai aucune extensions installée dessus. smile

Maintenant, ce que je me demande, c'est "Comment transférer tout mon matos de mon profil1 à profil2 ?"
Mais c'est probablement une autre histoire.

Hors ligne

#15 Le 09/08/2012, à 19:27

Major Grubert

Re : [Résolu]12.04 et gnome shell = bureau vide, pas de tableau de bord

Peut-être qu'il faudrait virer les fichiers de personnalisation de ton premier profil pour retrouver GS par défaut.
Faut les trouver quoi...


Pour en savoir plus sur Gnome Shell.
. Lenovo Yoga 13 : Windows 8.1 / Ubuntu Gnome 14.04
. Asus x7010 : Ubuntu 14.04 (Gnome Shell)
. Asus Eeepc : Xubuntu 14.04 (32b)

Hors ligne

#16 Le 17/08/2012, à 04:13

anakore

Re : [Résolu]12.04 et gnome shell = bureau vide, pas de tableau de bord

Ouvre un terminal et tape :

gnome-panel

Si ça fonctionne , reboot ton système pour voir si tu as besoin ou non d'insérer cette commande dans " Applications au démarrage " ^^


AMD FX-8320 (oc 4.8ghz) / 8gb DDR3 HyperX Beast 1866Mhz / Crossfire (2x Sapphire R9 280x Tri-X OC 3Gb) / Seven 64bit+Debian 64bit ^^
AMD Phenom II x4 (oc 4.1ghz) / 16go DDR3 1600mhz / Crossfire (2x Sapphire Radeon hd 7850 OC 2gb) / Seven 64bit+Ubuntu 10.10 64bit
AMD Athlon II x2 (2.9ghz) / 8go DDR2 1066mhz / Sapphire Radeon hd 4670 1gb / Ubuntu 10.10 64bit

Hors ligne

#17 Le 17/08/2012, à 04:19

anakore

Re : [Résolu]12.04 et gnome shell = bureau vide, pas de tableau de bord

Applejuice a écrit :

OK.
Maintenant, ce que je me demande, c'est "Comment transférer tout mon matos de mon profil1 à profil2 ?"
Mais c'est probablement une autre histoire.

Tout ton matos ? documents ? configurations ?
-> Peut être qu'un simple "cp" et "chown" afin de changer le propriétaire pour le nouvel utilisateur suffit wink


AMD FX-8320 (oc 4.8ghz) / 8gb DDR3 HyperX Beast 1866Mhz / Crossfire (2x Sapphire R9 280x Tri-X OC 3Gb) / Seven 64bit+Debian 64bit ^^
AMD Phenom II x4 (oc 4.1ghz) / 16go DDR3 1600mhz / Crossfire (2x Sapphire Radeon hd 7850 OC 2gb) / Seven 64bit+Ubuntu 10.10 64bit
AMD Athlon II x2 (2.9ghz) / 8go DDR2 1066mhz / Sapphire Radeon hd 4670 1gb / Ubuntu 10.10 64bit

Hors ligne

Haut de page ↑