Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 02/07/2012, à 00:28

KingSavate

Perte de connexion filaire / Souci DNS ?

Bonjour, je suis sur une Ubuntu 12.04 en dual boot avec un windows 8 et je perds ma connexion systématiquement après un reboot. Une réinstall depuis le live CD me permet de la retrouver, mais je la re-perds ensuite, sans arriver à la retrouver.

Lorsque je boot, sur un ifconfig, je n'ai plus la ligne inet (plus d'IPv4 ?). Puis lorsque je configure ma connexion via le network-manager, je retrouve ma ligne inet sur ifconfig, il me dit que je suis connecté, et pourtant pas moyen de pinger quoi que ce soit, via le nom de domaine ou l'IP.

Je tiens à préciser que la connexion fonctionne toujours depuis windows.

Voici mon /etc/network/interfaces :

auto lo
iface lo inet loopback

/etc/resolv.conf :

nameserver 127.0.0.1
search 192.168.0.254

Voila, je ne sais pas trop comment faire. Ah oui, je tiens aussi à préciser que je suis un gros noob, et que je ne saisdonc pas trop quoi rentrer dans les DNS et les search domains dans le network-manager. J'ai essayé avec 8.8.8.8 et 8.8.4.4, et 192.168.0.254 sans résultat.

Merci d'avance pour toute aide.
S'il vous manque des infos, demandez et je vous fournirais ça.
Merci. smile

Dernière modification par KingSavate (Le 02/07/2012, à 00:28)

Hors ligne

#2 Le 02/07/2012, à 07:21

LRDP

Re : Perte de connexion filaire / Souci DNS ?

Bonjour,
Quelle box est utilisée?
J'ai le même problème depuis de ongues semaines: le réseau s'éteind à chaque reboot. Il faut essayer les solutions qui se trouvent à la fin de la page : http://doc.ubuntu-fr.org/network-manager . Mais ces solutions n'ont pas résolu le problème. En restaurant /etc et /var d'une sauvegarde dont le réseau marchait, j'ai pu rétablir la situation; mais s'il faut restaurer à chaque reboot roll .... Des mises à jour cherchent à s'installer et j'ai cru comprendre que les mises à jour de Network Manager excluent les clefs WPA peu sécurisées ; or ma box est une Bouygues dont la WPA est la même que la WEP, donc peu sécurisée et j'avais remarqué que les plantages de la Bbox démolissaient mon réseau, alors que sur d'autres machines, le réseau ne bougeait pas au reboot de la box. Le problème existe depuis longtemps que sur certaines configurations, à en croire tous les posts à ce sujet. La solution, à mon avis, est de changer la clef WPA de la box en créant un code alphanumérique d'une bonne douzaine de chiffres.
Affaire à suivre


Ubuntu 14.04 Mate, disque racine SSD 120Go, 8Go RAM, AMD FX 6100 6core M3+, MSI 990FXA, ASUS 550 Ti, 3 WD 2To, 1WD 550Go

Hors ligne

#3 Le 02/07/2012, à 11:36

KingSavate

Re : Perte de connexion filaire / Souci DNS ?

Bonjour et merci de t'intéresser à mon problème smile

Je suis chez free. Avec une freebox revolution v6.
Ma clé WPA est normalement assez sécure (un alphanumérique aléatoire de 10 caractères).

Je pense que je vais tenter de réinstaller une énième fois, et de sauvegarder la config lorsque tout fonctionne.

Hors ligne

#4 Le 02/07/2012, à 23:09

KingSavate

Re : Perte de connexion filaire / Souci DNS ?

Re-bonjour.

Bon, j'ai tenté la réinstallation, mais même depuis le liveCD, la connexion ne fonctionne pas. sad
Je ne comprends vraiment plus d'où celà peut-il venir. Ou chercher?
Sur la configuration de ma freebox ? La configuration du réseau sur ma partition windows ?

Hors ligne

#5 Le 03/07/2012, à 04:53

LRDP

Re : Perte de connexion filaire / Souci DNS ?

Bonjour,
Si une réinstallation complète à partir du live-cd ne permet pas de connexion, il peut s'agir d'un problème matériel : carte réseau, câble ou récepteur wifi. Mais si la connexion Windows marche sur le même ordinateur, c'est bien un problème Linux sad . Il faut essayer les manips du forum : http://forum.ubuntu-fr.org/viewtopic.php?id=431964  et http://forum.ubuntu-fr.org/viewtopic.php?id=308020 . Si rien ne marche, soit réinstaller /etc et /var à partir d'une sauvegarde, sinon, formater en ayant copier /home quelque part, ainsi que les profils du navigateur et de la messagerie (chercher "profile" dans Nautilus) et réinstaller à partir d'une image stable. Bon courage, car j'ai un problème similaire à chaqque reboot et je n'ai pas trouvé de solution définitive, malgré de grosses recherches et plusieurs posts sur le forum de la communauté.
Vérifiez quand même le réseau (système/administration/réseau) On doit avoir rien dans l'onglet général, dans l'onglet DNS à la première ligne (Serveur DNS) : l'adresse de la box, dans Domaines de recherche le mot "lan", et dans l'onglet Hôtes l'adresse IP 127.0.0.1 alias localhost et en-dessous l'adresse IP 127.0.1.1 alias  "nom de l'utilisateur" Dans certains posts, on conseille de mettre 127.0.0.1 locahost "nom de l'utilisateur", mais je n'ai pas vu de différence. Si çà marche, il y a plusieurs choses qui s'inscrivent ensuite dans l'onglet Hôtes dépendant de ip6, apparemment sans conséquences. A suivre!

Dernière modification par LRDP (Le 03/07/2012, à 04:53)


Ubuntu 14.04 Mate, disque racine SSD 120Go, 8Go RAM, AMD FX 6100 6core M3+, MSI 990FXA, ASUS 550 Ti, 3 WD 2To, 1WD 550Go

Hors ligne

#6 Le 03/07/2012, à 09:33

KingSavate

Re : Perte de connexion filaire / Souci DNS ?

Bonjour et merci de la réponse.

Bon, j'ai finalement réussi à me connecter hier soir.
Pour que cela fonctionne, je me suis attribué la même adresse IP que sur ma partition windows: 192.168.0.22. Cette même adresse IP qui figure dans les Baux DHCP statiques sur ma freebox.
Avant je me donnais une autre adresse IP du genre 192.168.0.25.

C'est bizarre car d'autres PC/Pads sont connectés sur ma freebox, en wifi, et cela fonctionne très bien sans toucher à rien.
Bref, pour l'instant ça fonctionne.

smile

Hors ligne

#7 Le 25/02/2013, à 22:18

bins61

Re : Perte de connexion filaire / Souci DNS ?

Bonjour,
il est très imprudent de copier ton adresse ip. Evite à l'avenir.

Hors ligne

#8 Le 26/02/2013, à 08:33

Brunod

Re : Perte de connexion filaire / Souci DNS ?

bins61 a écrit :

Bonjour,
il est très imprudent de copier ton adresse ip. Evite à l'avenir.

Faux, c'est de l'ip locale. Je te donne les miennes et t'autorise à les utiliser comme bon te semblera:
192.168.0.1: router
192.168.0.111: nas
192.168.0.167: smartphone
192.168.0.169 : portable 1
Tu verras très vite que tu ne sauras rien en tirer.
wink

Dernière modification par Brunod (Le 26/02/2013, à 08:40)


Wanted : emploi dans la sécurité informatique et réseau
Windows est un système d'exploitation de l'homme par l'ordinateur. Linux, c'est le contraire...
36 pc linux convertis

Hors ligne

#9 Le 26/02/2013, à 08:35

Brunod

Re : Perte de connexion filaire / Souci DNS ?

@kingsavate : voir si il n'y a pas couplage dans la box des ip statiques avec l'adresse mac.
Le pc qui reboote avec la même mac mais une autre ip que quand il est sous win lui déplairait peut-être.


Wanted : emploi dans la sécurité informatique et réseau
Windows est un système d'exploitation de l'homme par l'ordinateur. Linux, c'est le contraire...
36 pc linux convertis

Hors ligne

Haut de page ↑