Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 11/01/2014, à 10:49

jcd78

Problème de connexion à mon NAS

Bonjour,

Je voudrais monter automatiquement un dossier de mon NAS lors de l'ouverture de la session (donc en ajoutant une ligne dans le fstab), mais j'ai toujours le même message

mount error(13): Permission denied

La ligne entrée dans le fstab (j'ai suivi les recommandations de la documentation Ubuntu), est :

//192.168.1.160/Dossier_perso_JC /media/NAS-DatasJCD cifs credentials=/root/.smbcredentials,iocharset=utf8,rw,gid=1000,uid=1000,sec=ntlmv2	0	0

J'ai tenté aussi, mais sans succès :

//192.168.1.160/Dossier_perso_JC /media/NAS-DatasJCD cifs credentials=/root/.smbcredentials,iocharset=utf8,rw,gid=jcd,uid=jcd,sec=ntlmv2	0	0

Bien sûr, j'ai installé un fichier .smbcredentials dans /root.
J'ai essayé de monter manuellement mon NAS, avec la commande :

sudo mount.cifs //192.168.1.160/Dossier_perso_JC /media/NAS-DatasJCD -o username=admin

et en entrant le mot de passe du NAS, et là ça marche bien.

Auriez-vous une idée SVP ?
Merci d'avance pour vos réponses.
Cordialement.
jcd78

Hors ligne

#2 Le 11/01/2014, à 11:24

bruno

Re : Problème de connexion à mon NAS

Est-ce que cette commande fonctionne ?

sudo mount -t cifs //192.168.1.160/Dossier_perso_JC /media/NAS-DatasJCD-o credentials=/root/.smbcredentials,iocharset=utf8,uid=1000,gid=1000

N.B. : le paramètre sec= est peut-être à ajuster aussi (sec=ntlmssp) cf. man mount.cifs

Si elle échoue, vérifie la structure de ton fichier .smbcredentials :

username=utilisateu
password=mot_de_passe
domain=domaine

Dernière modification par bruno (Le 11/01/2014, à 11:26)

Hors ligne

#3 Le 11/01/2014, à 18:48

jcd78

Re : Problème de connexion à mon NAS

Merci Bruno pour ta réponse.

Alors c'est très curieux.
D'abord, la ligne de commande que tu m'as proposée

sudo mount -t cifs //192.168.1.160/Dossier_perso_JC /media/NAS-DatasJCD -o credentials=/root/.smbcredentials,iocharset=utf8,uid=1000,gid=1000

ne marche pas non plus (même erreur).
Ensuite j'ai essayé tous les paramètres possibles de sec=, d'après la doc (cf. man mount.cifs). Tous génèrent une erreur (pas toujours la même).
Enfin, le problème semble effectivement venir du fichier /root/.smbcredentials. Pourtant il est bien structuré comme tu me l'indiques. J'ai même vérifié le username et password en les utilisant en copier/coller dans une connexion manuelle à mon NAS et ça fonctionne bien !
J'ai aussi essayé de supprimer la ligne domain, mais même problèmes... Je suis très perplexe,... et très embêté.

Hors ligne

#4 Le 11/01/2014, à 19:33

bruno

Re : Problème de connexion à mon NAS

Étrange en effet. Si la commande de montage marche avec username=ton_utilisateur password=ton_pass et échoue avec credentials=*** c'est bien que le problème se situe au niveau de ce fichier.
Le meiux est de na pas spécifier sec=*** puisque cela marche sans

Il faut aussi essayer des combinaisons du style :

username=domain\username

Hors ligne

#5 Le 12/01/2014, à 18:28

jcd78

Re : Problème de connexion à mon NAS

Merci Bruno.

Je suis toujours dans la "mouise" !

J'ai essayé cette ligne dans le fstab :

//192.168.1.160/Dossier_perso_JC /media/NAS-DatasJCD cifs user=admin,password=xxxxxxxx,iocharset=utf8,rw,gid=1000,uid=1000	0	0

... et là ça marche... Mais je ne veux pas mettre le mot de passe en clair !
Le problème semble bien venir du fichier /root/.smbcredentials, mais je ne vois vraiment pas ce qu'il a.
Je l'ai même visualisé dans un éditeur hexa afin de voir s'il n'avait pas de caractère bizarre... mais rien ! Il est parfait.
J'ai essayé de le déplacer dans un autre dossier, le changer de nom,... toujours l'erreur "error(13): Permission denied"


Je ne sais vraiment plus quoi faire... sad

Hors ligne

#6 Le 12/01/2014, à 18:46

bruno

Re : Problème de connexion à mon NAS

Quels sont les droits sur ce fichier ?
Et dans le fstab n'oublie pas de mettre le paramètre _netdev :

//192.168.1.160/Dossier_perso_JC /media/NAS-DatasJCD cifs _netdev, credentials=.....

Dernière modification par bruno (Le 12/01/2014, à 18:47)

Hors ligne

#7 Le 18/01/2014, à 17:47

Valezan

Re : Problème de connexion à mon NAS

Bonjour,
Je me permets d'intervenir dans ce file de discussion car je crois avoir le même problème.
J'ai modifié le montage de mon NAS dans mon fstab pour qu'il ne soit monté que lorsque j'en ai besoin. J'ai remplacé :

#Montage du NAS LaCie
//192.168.0.12/OpenShare /media/OpenShare cifs _netdev,rw,users,file_mode=0777,dir_mode=0777,iocharset=utf8,credentials=/root/.smbcredentials 0 0

par :

#Montage du NAS LaCie
//192.168.0.12/OpenShare /media/OpenShare cifs _netdev,rw,users,noauto,exec,cache=none,uid=1000,iocharset=utf8,file_mode=0777,dir_mode=0777,credentials=/root/.smbcredentials 0 0

Ça fonctionne très bien. Tellement bien que j'ai voulu faire pareil sur un autre ordinateur de la maison mais là, impossible de monter le NAS !
J'ai le message :

error 13 (permission denied) opening credential file /root/.smbcredentials

J'ai essayé d'ajouter "sec=ntlmv2" ou "sec=ntlmssp" ou encore "sec=lanman". Rien n'y fait.
C'est comme si, le montage, alors que la session utilisateur est ouverte, était interdit car le fichier .smbcredentials ne pouvait pas être lu...

Hors ligne

#8 Le 19/01/2014, à 09:56

bruno

Re : Problème de connexion à mon NAS

Avec l'option users c'est l'utilisateur actif qui effectue le montage et non root. Or le dossier /root n'est accessible qu'à root. Le fichier /root/.credentials n'est donc pas accessible lorsque c'est un utilisateur qui effectue le montage.

Pour vérifier mon hypothèse il faudrait placer le fichier.credentials dans un autre dossier accessible en lecture à tous les utilisateurs, par exemple dans /media

Hors ligne

#9 Le 19/01/2014, à 11:05

Valezan

Re : Problème de connexion à mon NAS

Merci de ton aide Bruno.
Je comprends cette explication pourtant...
Premièrement cette ligne fonctionne parfaitement bien sur un des ordinateurs de la maison (et pour tous les comptes utilisateurs).
Deuxièmement, la ligne fstab qui monte le NAS automatiquement (et qui continue de fonctionner sur tous les ordinateurs) utilise, elle aussi, "users" et "credentials=/root/.smbcredentials".
J'ai vérifié, sur les deux ordinateurs le fichier .smbcredentials est le même, avec les mêmes droits (-rw-r--r--).
Je ne comprends donc pas pourquoi cela fonctionne sur un ordinateur (Ubuntu 13.10) et pas sur un autre (Ubuntu 13.10 aussi). Cordialement

Hors ligne

#10 Le 19/01/2014, à 15:24

bruno

Re : Problème de connexion à mon NAS

Si le montage est automatique (pas d'option noauto), il est effectué par root au démarrage, avec les options noauto et users il effectué à la demande par l'utilisateur connecté.

Ton fichier .smbcredentials est peut être en mode +r pour tout le monde mais le dossier root lui est lisible uniquement par root (drwx------) et donc les fichiers qu'il contient ne sont accessibles qu'à root quels que soient leurs droits propres.
À moins que les droits sur le dossier /root n'aient été modifiés (très mauvaise chose) sur l'un de tes ordinateurs la ligne avec noauto  et le fichier .smbcredentails dans /root ne devrait marcher sur aucune de tes machines.

Dernière modification par bruno (Le 20/01/2014, à 08:15)

Hors ligne

#11 Le 19/01/2014, à 17:41

Valezan

Re : Problème de connexion à mon NAS

Flûte ! Tu as raison Bruno, les droits sur le dossier /root de mon ordinateur n'étaient plus corrects, je viens de les remettre à (drwx------). Du coup, j'ai remis le NAS en montage automatique au démarrage dans le fstab. C'est dommage, le montage à la demande me paraîtrait préférable pour les portables de la maisonnée. Mon intervention n'aura malheureusement pas aidée jcd78 mais j'ai au moins pu réparer cette grave erreur grâce à toi. Encore un grand merci pour ton aide et ta perspicacité.

Hors ligne