Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 15/05/2014, à 14:27

yeKcim

[Résolu] NE PAS installer les imprimantes réseau automatiquement

Ubuntu installe automatiquement les imprimantes réseau, mais là ou je travaille il y a énormément d’imprimantes et du coup je ne trouve plus mon imprimante dans la longue liste. Si je supprime les imprimantes, elles réapparaissent si je redémarre, mais je ne veux pas ! Sauriez vous comment désactiver l’installation automatique d’imprimante ?

Dernière modification par yeKcim (Le 19/10/2015, à 13:45)


Participer à un projet libre est un jeu... Et toi, à quoi tu joues ?
http://yeknan.free.fr

Hors ligne

#2 Le 15/05/2014, à 15:04

yeKcim

Re : [Résolu] NE PAS installer les imprimantes réseau automatiquement

Petite précision, il y a bien moyen de les cacher dans système→imprimantes (il suffit d’aller dans le menu Voir→Imprimantes trouvées) mais elles sont toujours visibles dans la liste des imprimantes dans Fichier→Imprimer


Participer à un projet libre est un jeu... Et toi, à quoi tu joues ?
http://yeknan.free.fr

Hors ligne

#3 Le 16/05/2014, à 19:56

tiramiseb

Re : [Résolu] NE PAS installer les imprimantes réseau automatiquement

Salut,

En graphique je ne sais pas. Mais en terminal je peux t'aider... tongue

Que donne la commande suivante ?

grep Browse /etc/cups/*

Hors ligne

#4 Le 21/05/2014, à 08:01

pierrepo

Re : [Résolu] NE PAS installer les imprimantes réseau automatiquement

Bonjour yeKcim,

J'ai exactement le même souci, la même demande, si vous me le permettez je m'insère dans cet échange…
--
Bonjour tiramiseb,

Voici le résultat de la commande…

└─ $ ▶ grep Browse /etc/cups/*
grep: /etc/cups/classes.conf: Permission non accordée
/etc/cups/cups-browsed.conf:BrowseRemoteProtocols dnssd cups
/etc/cups/cups-browsed.conf:# BrowseLocalProtocols none
/etc/cups/cups-browsed.conf:# Settings of this directive apply to both BrowseRemoteProtocols and
/etc/cups/cups-browsed.conf:# BrowseLocalProtocols.
/etc/cups/cups-browsed.conf:# BrowseProtocols none
/etc/cups/cups-browsed.conf:# BrowseAllow cups.example.com
/etc/cups/cups-browsed.conf:# BrowseAllow 192.168.1.12
/etc/cups/cups-browsed.conf:# BrowseAllow 192.168.1.0/24
/etc/cups/cups-browsed.conf:# BrowseAllow 192.168.1.0/255.255.255.0
/etc/cups/cups-browsed.conf:# Use BrowsePoll to poll a particular CUPS server
/etc/cups/cups-browsed.conf:# BrowsePoll cups.example.com
/etc/cups/cups-browsed.conf:# BrowsePoll cups.example.com:631
/etc/cups/cups-browsed.conf:# BrowsePoll cups.example.com:631/version=1.1
grep: /etc/cups/cupsd.conf: Permission non accordée
/etc/cups/cupsd.conf.O:BrowseLocalProtocols dnssd
grep: /etc/cups/interfaces: est un dossier
grep: /etc/cups/ppd: est un dossier
grep: /etc/cups/printers.conf: Permission non accordée
grep: /etc/cups/printers.conf~: Permission non accordée
grep: /etc/cups/printers.conf.O: Permission non accordée
grep: /etc/cups/ssl: Permission non accordée
grep: /etc/cups/subscriptions.conf: Permission non accordée
grep: /etc/cups/subscriptions.conf.O: Permission non accordée

Pierre

Hors ligne

#5 Le 21/05/2014, à 21:15

tiramiseb

Re : [Résolu] NE PAS installer les imprimantes réseau automatiquement

Zut désolé, essaie plutôt avec sudo devant pour avoir le contenu de tous les fichiers...

sudo grep Browse /etc/cups/*

Hors ligne

#6 Le 22/05/2014, à 08:07

pierrepo

Re : [Résolu] NE PAS installer les imprimantes réseau automatiquement

Voili, voilou

└─ $ ▶ sudo grep Browse /etc/cups/*
/etc/cups/cups-browsed.conf:BrowseRemoteProtocols dnssd cups
/etc/cups/cups-browsed.conf:# BrowseLocalProtocols none
/etc/cups/cups-browsed.conf:# Settings of this directive apply to both BrowseRemoteProtocols and
/etc/cups/cups-browsed.conf:# BrowseLocalProtocols.
/etc/cups/cups-browsed.conf:# BrowseProtocols none
/etc/cups/cups-browsed.conf:# BrowseAllow cups.example.com
/etc/cups/cups-browsed.conf:# BrowseAllow 192.168.1.12
/etc/cups/cups-browsed.conf:# BrowseAllow 192.168.1.0/24
/etc/cups/cups-browsed.conf:# BrowseAllow 192.168.1.0/255.255.255.0
/etc/cups/cups-browsed.conf:# Use BrowsePoll to poll a particular CUPS server
/etc/cups/cups-browsed.conf:# BrowsePoll cups.example.com
/etc/cups/cups-browsed.conf:# BrowsePoll cups.example.com:631
/etc/cups/cups-browsed.conf:# BrowsePoll cups.example.com:631/version=1.1
/etc/cups/cupsd.conf:BrowseLocalProtocols dnssd
/etc/cups/cupsd.conf.O:BrowseLocalProtocols dnssd
grep: /etc/cups/interfaces: est un dossier
grep: /etc/cups/ppd: est un dossier
grep: /etc/cups/ssl: est un dossier

Hors ligne

#7 Le 22/05/2014, à 08:24

yeKcim

Re : [Résolu] NE PAS installer les imprimantes réseau automatiquement

Désolé pour le lag.

pierrepo → Ne t’excuse pas, c’est la moindre des choses de profiter de l’ouverture d’un topic qui nous concerne pour apporter un complément d’information. Et puis au moins je me sens moins seul…

tiramiseb → Même commande même résultat que pierrepo. Ça t’inspire quelque chose ?


Participer à un projet libre est un jeu... Et toi, à quoi tu joues ?
http://yeknan.free.fr

Hors ligne

#8 Le 22/05/2014, à 21:46

tiramiseb

Re : [Résolu] NE PAS installer les imprimantes réseau automatiquement

Ok, donc ce que je vous propose c'est d'éditer le fichier /etc/cups/cups-browsed.conf et de changer la ligne qui commence par "BrowseRemoteProtocols" en :

BrowseRemoteProtocols none

Pour éditer le fichier, vous pouvez utiliser la commande :

gksudo gedit /etc/cups/cups-browsed.conf

Ensuite, il faut relancer le démon en question :

sudo service cups-browsed restart

Hors ligne

#9 Le 22/05/2014, à 22:16

geo82

Re : [Résolu] NE PAS installer les imprimantes réseau automatiquement

pourquoi tu ne met pas simplement ton imprimante en favoris ? 

ou un clique droit sur chaque imprimante : propriété et décoche " activé"
puis propriété > onglet comportement  , décoche les cases : " activée ", "accepte les taches d'impression" ," partagée."

Car le jour où tu a un problème, et que tu dois installer une nouvelle imprimante ça va être la galère, et tu va devoir faire les manip mais à l'envers. ^^

Dernière modification par geo82 (Le 23/05/2014, à 00:45)


Ubuntu 17.04 / Zalman ZM-T2 Plus / GIGABYTE GA-H110M-DS2 DDR3 /Intel Core i5-6500 3.2GHz/ Radeon HD 7770, 8 GB Ram
geekOfLinux

Hors ligne

#10 Le 23/05/2014, à 07:39

pierrepo

Re : [Résolu] NE PAS installer les imprimantes réseau automatiquement

Bonjour,

@tiramiseb : cela n'a pas fonctionné, même après redémarrage…
J'ai même tenté d'enlever le # des lignes «# BrowseLocalProtocols none » et «# BrowseProtocols none »
J'ai aussi édité les fichiers « cups.conf » et « cups.conf.O » en remplaçant « BrowseLocalProtocols dnssd » par « BrowseLocalProtocols none »

--
Voici la copie du terminal après la modification proposée

pierre @ W209-PCP  ~
└─ $ ▶ gksudo gedit /etc/cups/cups-browsed.conf

(gedit:8742): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

(gedit:8742): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
pierre @ W209-PCP  ~
└─ $ ▶ sudo service cups-browsed restart
[sudo] password for pierre: 
cups-browsed stop/waiting
cups-browsed start/running, process 8785

Et, depuis, après …

pierre @ W209-PCP  ~
└─ $ ▶ sudo service cups-browsed restart
stop: Unknown instance: 
cups-browsed start/running, process 2913

Donc, on peut supposer qu'il s'est passé qqch… Pourtant, les imprimantes non désirées apparaissent encore.

--

@geo82 : avec mon portable, je me connecte sur deux réseaux distincts sur le premier je suis susceptible d'utiliser 2 imprimantes, sur le second 6. Je les ai toutes configurées manuellement. De toute façon, le système ne détectait pas les imprimantes qui intéressaient… au contraire, il détecte des imprimantes dont j'ignore totalement la localisation (sans doute un autre bâtiment).
Et ça m'agace qu'un logiciel ou OS fasse des choses que je n'ai pas demandé… c'est pour cette raison que j'étais « malheureux » avec Microsoft !

Pierre

Dernière modification par pierrepo (Le 23/05/2014, à 07:48)

Hors ligne

#11 Le 23/05/2014, à 07:56

yeKcim

Re : [Résolu] NE PAS installer les imprimantes réseau automatiquement

geo82 → Parce que c’est une tâche rébarbative à et casse-pied à faire pour plusieurs dizaines d’imprimantes


Participer à un projet libre est un jeu... Et toi, à quoi tu joues ?
http://yeknan.free.fr

Hors ligne

#12 Le 23/05/2014, à 08:03

yeKcim

Re : [Résolu] NE PAS installer les imprimantes réseau automatiquement

du coup je remarque également quelque chose d’étrange :

Capture_du_2014-05-23_08_58_43.png

il n’y a pas le même nombre d’imprimantes dans la boite de dialogue d’impression et dans la liste des imprimantes…


Participer à un projet libre est un jeu... Et toi, à quoi tu joues ?
http://yeknan.free.fr

Hors ligne

#13 Le 23/05/2014, à 08:50

pierrepo

Re : [Résolu] NE PAS installer les imprimantes réseau automatiquement

Pour ma part, dans la liste des imprimantes (copie de droite), je n'ai actuellement que celles que j'ai paramétrées manuellement. Je ne me souviens pas si les autres imprimantes ont quelquefois été présentes… peut-être…

Dans la boîte de dialogue (copie de gauche), c'est là que les imprimantes détectées automatiquement apparaissent et me gênent.

Hors ligne

#14 Le 02/06/2014, à 13:31

yeKcim

Re : [Résolu] NE PAS installer les imprimantes réseau automatiquement

Ça n’inspire personne d’autre ? Personne ne voit d’où cette différence peut venir ou comment la résoudre ?


Participer à un projet libre est un jeu... Et toi, à quoi tu joues ?
http://yeknan.free.fr

Hors ligne

#15 Le 10/04/2015, à 10:35

yeKcim

Re : [Résolu] NE PAS installer les imprimantes réseau automatiquement

Je constate que sur mint il y a le même probleme alors que sur une debian non. Les fichiers /etc/cups/cups-browsed.conf et /etc/cups/cupsd.conf semblent similaire sous debian et ubuntu (à part que debian commente ses fichiers de config !). Une idée ?


Participer à un projet libre est un jeu... Et toi, à quoi tu joues ?
http://yeknan.free.fr

Hors ligne

#16 Le 19/10/2015, à 13:45

yeKcim

Re : [Résolu] NE PAS installer les imprimantes réseau automatiquement

Solution trouvée par mon collègue Gardouille qui semble savoir mieux que moi chercher une information sur le net :

sudo nano /etc/cups/cups-browsed.conf

BrowseRemoteProtocols none

Ceci supprime bien les imprimantes dans la liste des imprimantes mais pas dans la boite de dialogue d’impression de firefox ou libreoffice. Pour que ces boites se comportent comme souhaité :

sudo nano /etc/avahi/avahi-daemon.conf

Ajouter dans la partie [server] :

enable-dbus=no

Redémarrer l’ordinateur. Si vous souhaitez une application immédiate :

sudo service avahi-daemon stop

Participer à un projet libre est un jeu... Et toi, à quoi tu joues ?
http://yeknan.free.fr

Hors ligne

#17 Le 10/11/2015, à 14:42

mikael8349

Re : [Résolu] NE PAS installer les imprimantes réseau automatiquement

Dans le solution de yeKcim (collègue Gardouille) il est fait mention de modifier le fichier /etc/avahi/avahi-daemon.conf en mettant enable-dbus=no , cela ne risque t'il pas d'impacter d'autre programmes ?

Hors ligne

#18 Le 10/11/2015, à 14:46

tiramiseb

Re : [Résolu] NE PAS installer les imprimantes réseau automatiquement

Si

Hors ligne

#19 Le 10/11/2015, à 16:33

mikael8349

Re : [Résolu] NE PAS installer les imprimantes réseau automatiquement

tiramiseb a écrit :

Si

Des exemples d'autres programmes impactés.
Il y a t-il une autre manière de faire qui n'aurai pas d’impact sur d'autre programme ?

Hors ligne

#20 Le 10/11/2015, à 16:42

tiramiseb

Re : [Résolu] NE PAS installer les imprimantes réseau automatiquement

aucune idée.

Hors ligne

#21 Le 10/11/2015, à 16:50

mikael8349

Re : [Résolu] NE PAS installer les imprimantes réseau automatiquement

tiramiseb a écrit :

aucune idée.

OK, merci quand même

Hors ligne