Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 13/06/2014, à 21:26

sleepygumbo

[Résolu] définir de façon permanente nomodeset

Bonsoir,
étant un fidèle d'ubuntu depuis quelque temps déjà, je me décide à l'installer sur mon nouvel ordi (voir config dans la signature), vierge d'OS.

J'ai préparé dans les règles de l'art un live USB à partir de l'usb creator de l'Ubuntu de mon laptop, ai désactivé le fast boot de mon nouvel ordi, et j'ai réussi à accéder au live après avoir fait le nomodeset. J'ai configuré mes partitions, tout ça, ai redémarré...et là, le drame : après l'écran de Grub, l'écran reste figé sur le violet.

Après avoir recherché des problèmes similaires dans le forum, j'ai essayé d'aller remettre le nomodeset, même le noapic et quelques autres choses, mais rien n'y fait.

Auriez-vous des pistes sur lesquelles m'orienter ?
Merci bien !

EDIT : après avoir refait une clé bootable, j'au accéder de nouveau à un live toujours après avoir ajouté le fameux "nomodeset". Par contre, j'aimerais définir ce "nomodeset" de façon permanente. J'ai donc fais un tour par là http://forum.ubuntu-fr.org/viewtopic.php?pid=3442570 mais je n'arrive ni à modifier le document grub (pas les permissions nécessaires...alors que j'ai modifié mon compte comme admin...mais en live ça doit pas marcher je suppose) ni à entrer les lignes de commandes (en root ça ne marche pas) ...
Je me suis documenté aussi ici http://askubuntu.com/questions/38780/ho … led-ubuntu mais quand je rentre le 'sudo update-grub', il me donne "error : failed to get canonical path of '/cow'- " ...
des idées ?

Dernière modification par sleepygumbo (Le 14/06/2014, à 11:15)


Config :
Intel i5, CM Gigabyte H97 D3H, CG MSI GeForce N750 Ti, SSD Samsung, HDD Segate

Hors ligne

#2 Le 13/06/2014, à 23:36

alca94

Re : [Résolu] définir de façon permanente nomodeset

Bonsoir
normalement vous faites
Dans le terminal (Ctrl + Alt + T) ou en console = faire au démarrage CTRL+ALT+F1

gksudo gedit /etc/default/grub

Et à la ligne:
     GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
Vous ajoutez l'option pour avoir:
     GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

Vous enregistrez et fermez puis

sudo update-grub

EDIT = Si vous êtes sur la version 14.04 il faut installer avant GKSUDO
en faisant

sudo apt-get install gksu

Dernière modification par alca94 (Le 13/06/2014, à 23:38)


POUR METTRE LES RETOURS DU "TERMINAL"  voir les explications sur ce post
https://forum.ubuntu-fr.org/viewtopic.p … #p17345641

Hors ligne

#3 Le 14/06/2014, à 00:16

Bougron

Re : [Résolu] définir de façon permanente nomodeset

Bonsoir.Je ne suis pas du tout sûr que la carte graphique  "GeForce N750 "  http://fr.msi.com/product/vga/N750_TF_1 … l#overview  soit une antiquité.

Hors ligne

#4 Le 14/06/2014, à 09:32

sleepygumbo

Re : [Résolu] définir de façon permanente nomodeset

J'ai essayé la solution de alca, et après avoir entré le "sudo apt-get install gksu", il me redit toujours "error : failed to get canonical path of '/cow'- ".

Pour l'instant, je ne peux toujours obtenir qu'une session live (après avoir entré le nomodeset), je n'arrive pas à installer à proprement dit Ubuntu : au redémarrage après la config de l'install sur le live, l'écran freeze.

Bougron : effectivement ma CG n'est pas du tout ancienne.
Est-ce que mon problème d'install viendrait de la CG ou autre chose ... ?

(edit) : je précise que sans clé live, j'accède au "menu" grub, mais que même en mettant le nomodeset je n'arrive pas à aller plus loin (écran violet). J'ai essayé le mode recovery, il déroule une série de ligne mais freeze également à un moment donné.

Dernière modification par sleepygumbo (Le 14/06/2014, à 10:01)


Config :
Intel i5, CM Gigabyte H97 D3H, CG MSI GeForce N750 Ti, SSD Samsung, HDD Segate

Hors ligne

#5 Le 14/06/2014, à 10:09

Tamarou

Re : [Résolu] définir de façon permanente nomodeset

je n'arrive pas à installer à proprement dit Ubuntu : au redémarrage après la config de l'install sur le live, l'écran freeze.

C'est à dire que quand même Ubuntu est installé, n'est ce pas ?
Dans ce cas, la clé live n'est plus utile. Quand tu arrives sur l'écran violet, peux-tu appuyer en même temps sur les touches Ctrl+Alt+F1 ? Tu devrais voir un écran noir avec un curseur qui te demande de te connecter. C'est cela ?

Après il faut faire les commandes données par Alca mais en ajoutant

sudo apt-get update

avant

sudo apt-get install gksu

et si cela ne fonctionne pas, on peut faire avec un autre outil.

Dernière modification par Tamarou (Le 14/06/2014, à 10:15)

En ligne

#6 Le 14/06/2014, à 10:33

sleepygumbo

Re : [Résolu] définir de façon permanente nomodeset

Oui, il semble que Ubuntu se soit installé. En revanche, le Ctrl+Alt+F1 sur l'écran violet ne donne rien.
Je rajoute qu'une fois sur deux, l'écran "menu" grub n'arrive pas à s'afficher, il y a juste un liseré violet à la périphérie de l'écran pendant 3s et puis un écran noir.
Mauvaise install d'Ubuntu (pourtant j'ai vérifié mon live USB) ou autre ?

Dernière modification par sleepygumbo (Le 14/06/2014, à 10:39)


Config :
Intel i5, CM Gigabyte H97 D3H, CG MSI GeForce N750 Ti, SSD Samsung, HDD Segate

Hors ligne

#7 Le 14/06/2014, à 10:51

Tamarou

Re : [Résolu] définir de façon permanente nomodeset

C'est un PC neuf et tu n'as pas de données dessus ? Ce serait aussi rapide de refaire l'installation.
Mais as-tu désactivé le secure boot dans l'uefi ?

Ce PC semble avoir deux cartes graphiques. Le composant Intel du processeur et la Nvidia !

On va commencer par simplifier cela.

Dernière modification par Tamarou (Le 14/06/2014, à 10:56)

En ligne

#8 Le 14/06/2014, à 10:56

sleepygumbo

Re : [Résolu] définir de façon permanente nomodeset

C'est effectivement un PC neuf sans données dessus. J'ai essayé de refaire l'installation, toujours les mêmes problèmes.
Le Secure boot est bien désactivé.
En live, il me faut activer le nomodeset, sinon l'écran freeze.


Config :
Intel i5, CM Gigabyte H97 D3H, CG MSI GeForce N750 Ti, SSD Samsung, HDD Segate

Hors ligne

#9 Le 14/06/2014, à 10:57

Tamarou

Re : [Résolu] définir de façon permanente nomodeset

Bon, une fois en live, donne le retour de la commande

lspci | grep VGA

Dernière modification par Tamarou (Le 14/06/2014, à 10:58)

En ligne

#10 Le 14/06/2014, à 10:59

sleepygumbo

Re : [Résolu] définir de façon permanente nomodeset

Voici le retour de la commande :
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)
01:00.0 VGA compatible controller: NVIDIA Corporation GM107 [GeForce GTX 750 Ti] (rev a2)

Dernière modification par sleepygumbo (Le 14/06/2014, à 11:00)


Config :
Intel i5, CM Gigabyte H97 D3H, CG MSI GeForce N750 Ti, SSD Samsung, HDD Segate

Hors ligne

#11 Le 14/06/2014, à 11:02

Tamarou

Re : [Résolu] définir de façon permanente nomodeset

C'est bien cela .
Pour simplifier le problème, je te propose d'aller dans l'uefi et fouiller partout pour trouver où désactiver la carte graphique nvidia. Ensuite tu redémarres et cela pourrait arranger les choses.

Pour une solution plus optimale, il faudra passer par cette doc.

Dernière modification par Tamarou (Le 14/06/2014, à 11:11)

En ligne

#12 Le 14/06/2014, à 11:14

sleepygumbo

Re : [Résolu] définir de façon permanente nomodeset

Ok, après avoir 'disabled' un machin du genre 'intel graphics' dans l'uefi, je suis sous Ubuntu, et pas en Live ! Miracle !
Je vais aller me documenter.
Merci Alca94, et Tamarou, je te remercie infiniment !! C'est grâce à des personnes comme vous que j'aime cette communauté !
Merci encore.
Je passe ce topic en résolu smile


Config :
Intel i5, CM Gigabyte H97 D3H, CG MSI GeForce N750 Ti, SSD Samsung, HDD Segate

Hors ligne

#13 Le 14/06/2014, à 11:16

Tamarou

Re : [Résolu] définir de façon permanente nomodeset

Parfait, mais tu as fait le contraire de ce que je te proposais. Donc en ce moment tu es sur la carte NVIDIA qui est plus performante que le composant Intel mais consomme bien plus.

Bonne suite.

Dernière modification par Tamarou (Le 14/06/2014, à 11:17)

En ligne