Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 11/08/2014, à 00:49

Antoine9000

[Abandon] Windows 8.1 + Ubuntu 14.04

Bonjour Ubuntu-fr,

J'essai depuis plusieurs jour d'installer Windows 8.1 et Ubuntu sur le même ordinateur. Voici ce que j'ai fais :

J'ai commencé par sauvegarder tous mes fichiers sur un disque dur externe puis formater mon disque dur interne. J'ai activé l'option UEFI dans mon BIOS, changé la table de partition (de MBR vers GPT) puis installé Windows 8. J'ai fais la mise à jour vers Windows 8.1 puis désactivé l'option fast boot.

J'ai ensuite installé Ubuntu 14.04 LTS à côté : j'ai réduis la partition Windows, créé une partition pour Ubuntu et une partition de partage entre ces deux systèmes d'exploitation. Ubunu s'est installé correctement mais quand je redémarre, windows démarre tout seul, pas de grub !

Je redémarre donc depuis mon LiveUSB, je lance boot-repair. Une fois terminé, il me dit qu'il y a eu des erreurs, voici le rapport :
http://paste.ubuntu.com/8008454/

Mon ordinateur est un portable vaio de juin 2012 (SVS1511C5E) livré avec Windows 7, mon BIOS est un InsydeH20 rev 3.7
Les résultats de ces commandes vous seront peut-être utile.

(parted) print                                                            
Model: ATA TOSHIBA MK5061GS (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number  Start   End     Size    File system     Name                          Flags
 1      1049kB  316MB   315MB   ntfs            Basic data partition          hidden, diag
 2      316MB   420MB   105MB   fat32           EFI system partition          boot
 3      420MB   555MB   134MB                   Microsoft reserved partition  msftres
 4      555MB   87.0GB  86.4GB  ntfs            Basic data partition          msftdata
 5      87.0GB  87.4GB  472MB   ntfs                                          hidden, diag
 6      87.4GB  88.5GB  1074MB  linux-swap(v1)
 7      88.5GB  174GB   85.9GB  ext4
 8      174GB   500GB   326GB   ntfs                                          msftdata
ubuntu@ubuntu:~$ mkdir Ubuntu
ubuntu@ubuntu:~$ sudo mount /dev/sda7 Ubuntu
ubuntu@ubuntu:~$ sudo chroot Ubuntu/
root@ubuntu:/# update-grub
/usr/sbin/grub-probe: error: cannot find a device for / (is /dev mounted?).

J'ai déjà essayé plein de choses, je continue de chercher. J'espère que vous pourrez m'aider !

Par avance merci,
Antoine

Edit :
N'ayant pas trouvé comment résoudre mon problème, j'ai choisi de tout réinstaller en legacy. Merci tout de même pour votre aide !

Dernière modification par Antoine9000 (Le 14/08/2014, à 20:24)

Hors ligne

#2 Le 11/08/2014, à 07:31

Benji59

Re : [Abandon] Windows 8.1 + Ubuntu 14.04

essaie le tuto sur cette page en bas de la page section 6.Contourner le démarrage forcé sur Windows 8 ca a parfaitement marché pour moi même si les manips peuvent être délicates.

Hors ligne

#3 Le 11/08/2014, à 10:42

Bougron

Re : [Abandon] Windows 8.1 + Ubuntu 14.04

Bonjour.
Je ne sais pas si les VIAO sont dans la liste qui oblige le changement de nom.
Dans l'attente du dépannage, Tu devrais pouvoir lancer ubuntu à partir de windows en t'aidant  de ce document http://forum.ubuntu-fr.org/viewtopic.php?pid=15030301
Le principe est de passer par la console de récupération.
D'après ce que j'ai vu de la documentation SONY, cela devrait aussi être possible en appuyant sur la touche F10 au démarrage de l'ordinateur.
Lorsque tu auras lancé ubuntu, fais la commande "sudo efibootmgr -v" afin de mieux voir le contenu exact car dans ton boot info , il manque des paramètres aux commandes (Fin du document). C'est peut-être simplement un problème de présentation. Tu as:
BootCurrent: 0001
Timeout: 2 seconds
BootOrder: 0002,0001,0000
Boot0002* ubuntu.

Souvent on a
Boot0000* ubuntu    HD(1,800,1dc800,c7c07251-2940-48ec-aa16-3daf40e5e394)File(\EFI\ubuntu\shimx64.efi)

Dernière modification par Bougron (Le 11/08/2014, à 10:51)

Hors ligne

#4 Le 11/08/2014, à 11:58

Antoine9000

Re : [Abandon] Windows 8.1 + Ubuntu 14.04

Bonjour et merci pour vos réponses !

Je n'arrive même pas à démarrer Ubuntu depuis Windows.. Quand j'arrive sur cet écran : http://www.hostingpics.net/viewer.php?i … 072704.png l'option "Utiliser un périphérique n'est pas là ! J'ai seulement les 3 autres options. J'ai l'impression que je n'ai aucun fichiers grub ou ubuntu dans la partition efi..

Je n'ai pas non plus accès à la console de récupération en appuyant sur F10 au démarrage. Je les ai tous essayés, seul F2 fonctionne il m'emmène dans le BIOS.

Je pense pouvoir atteindre mon installation d'Ubuntu en utilisant chroot depuis mon liveusb. Voici le résultat de la commande en utilisant chroot :

ubuntu@ubuntu:~$ mkdir ubuntu
ubuntu@ubuntu:~$ sudo mount /dev/sda7 ubuntu/
ubuntu@ubuntu:~$ sudo chroot ubuntu/
root@ubuntu:/# sudo efibootmgr -v
sudo: unable to resolve host ubuntu
Fatal: Couldn't open either sysfs or procfs directories for accessing EFI variables.
Try 'modprobe efivars' as root.
root@ubuntu:/# modprobe efivars
root@ubuntu:/# sudo efibootmgr -v
sudo: unable to resolve host ubuntu
Fatal: Couldn't open either sysfs or procfs directories for accessing EFI variables.
Try 'modprobe efivars' as root.

J'ai remarqué qu'au démarrage de mon liveusb, j'ai le message suivant :

Coult not open "\EFI\BOOT\fallback.efi": 14"

Mon installation étant toute neuve, il n'y a rien d'important dessus, ça ne me dérange pas de réinstaller Ubuntu si il le faut.

Dernière modification par Antoine9000 (Le 11/08/2014, à 12:08)

Hors ligne

#5 Le 11/08/2014, à 12:23

Bougron

Re : [Abandon] Windows 8.1 + Ubuntu 14.04

Pourquoi pas.  En une demie-heure, C'est fait.
Si tu avais téléchargé ubuntu avant le 23 juillet, recommences le téléchargement afin de disposer de la version 14.04.1
Enfin, comme tu as déjà un ubuntu d'installé, l'installateur va te proposer de le remplacer, Ne prends surtout pas cette option car c'est dans cette situation qu'il supprime windows. Prends bien le choix "autre chose"

Hors ligne

#6 Le 11/08/2014, à 12:30

Antoine9000

Re : [Abandon] Windows 8.1 + Ubuntu 14.04

J'ai téléchargé Ubuntu hier. J'ai peur que si je le réinstalle, je sois bloqué dans la même situation qu'actuellement.

Je dois choisir d'utiliser ma partition Ubuntu avec / comme point de montage puis ma partition de partage avec comme point de montage /media/Partage, c'est tout ?
Dois-je spécifier un point de montage pour la partition efi ou ça sera fait automatiquement ?

Hors ligne

#7 Le 11/08/2014, à 12:42

Bougron

Re : [Abandon] Windows 8.1 + Ubuntu 14.04

Oui tu dois choisir d'allouer la partition FAT32 au point de montage /boo/efi. C'est une obligation
Pour ta partition d'échange avec windows, Tu peux aussi la pré-affecter via l'installateur, Il te propose deux noms 'windows" ou "dos" C'est au choix Car il n'y a pas de différences. C'est probablement une astuce pour en créer deux.

L'installateur va râler car tu n'as pas de partition de swap. On s'en fout complètement, tu passes outre.

Dernière modification par Bougron (Le 11/08/2014, à 12:54)

Hors ligne

#8 Le 11/08/2014, à 13:23

Antoine9000

Re : [Abandon] Windows 8.1 + Ubuntu 14.04

Je peux formater ma partition ou Ubuntu est installé en ext4 avec comme point de montage /, pas de soucis.
J'ai déjà une partition swap de 1Go
Pour la partition partage, je n'ai pas  compris comment la pré-affecter avec l'installateur : je clique dessus, il ne me propose pas de l'utiliser en tant que "windows" ou "dos"
Je n'ai pas de partition en fat32. Juste une partition de type "efi", de 100Mo. Je clique dessus et il me propose juste de l'utiliser en tant que "EFI boot partition" (déjà sélectionné par défaut)

Je peux réinstaller en utilisant ces réglages mais j'ai peur que ça ne change rien..

Dois-je utiliser la partition efi comme partition fat32 et lui attribuer le point de montage /boot/efi ?

Je n'ai pas touché à "Device for boot loader installation", dois-je le faire pointer vers ma partition efi ? Par défaut il pointe vers mon disque dur (/dev/sda)

Dernière modification par Antoine9000 (Le 11/08/2014, à 13:25)

Hors ligne

#9 Le 11/08/2014, à 13:43

Bougron

Re : [Abandon] Windows 8.1 + Ubuntu 14.04

Mes réponses
Je peux formater ma partition ou Ubuntu est installé en ext4 avec comme point de montage /, pas de soucis.
======> Parfait
J'ai déjà une partition swap de 1Go
======> Je n'avais pas fait attention.
Pour la partition partage, je n'ai pas  compris comment la pré-affecter avec l'installateur : je clique dessus, il ne me propose pas de l'utiliser en tant que "windows" ou "dos"*
======> si elle est bien formatée en NFTS, lorsque tu l'alloues, Il te propose d'en faire une partition d'échange avec windows, Si tu dis oui, c'est à ce moment qu'il ouvre une fenêtre pour te demander de choisir le nom.
Je n'ai pas de partition en fat32. Juste une partition de type "efi", de 100Mo. Je clique dessus et il me propose juste de l'utiliser en tant que "EFI boot partition" (déjà sélectionné par défaut)
======> C'est de celle-la dont je parlais. Je n'avais pas retenu le bon nom.
Je peux réinstaller en utilisant ces réglages mais j'ai peur que ça ne change rien..
======> Je le crains aussi mais il peut y avoir une petite différence.

Dois-je utiliser la partition efi comme partition fat32 et lui attribuer le point de montage /boot/efi ?
======> Oui
Je n'ai pas touché à "Device for boot loader installation", dois-je le faire pointer vers ma partition efi ? Par défaut il pointe vers mon disque dur (/dev/sda)
======> La valeur par defaut est très bonne, de plus en EFI, quelque soit la valeur que tu mettes à cet endroit, elle n'est pas prise en compte, Cela pose un gros problème lorsque tu disposes de deux disques internes.

Dernière modification par Bougron (Le 11/08/2014, à 13:47)

Hors ligne

#10 Le 11/08/2014, à 14:10

Bougron

Re : [Abandon] Windows 8.1 + Ubuntu 14.04

Antoine9000 a écrit :

Bonjour Ubuntu-fr,
J'essaie depuis plusieurs jours d'installer Windows 8.
Je redémarre donc depuis mon LiveUSB, je lance boot-repair. Une fois terminé, il me dit qu'il y a eu des erreurs,
Par avance merci,
Antoine

Il est fort probable que ton installation donne le même problème.
E aucun cas, ne lances boot-repair pour faire des réparations en EFI. Dans certains cas, il aggrave la situation.
Contentes-toi de l'utiliser pour faire un boot-info.

Dernière modification par Bougron (Le 11/08/2014, à 14:12)

Hors ligne

#11 Le 11/08/2014, à 14:40

Antoine9000

Re : [Abandon] Windows 8.1 + Ubuntu 14.04

J'utilise donc les partitions suivantes :

swap de 1Go
ext4 de 80Go point de montage / que je formate
ntfs 300Go /windows
fat32 100Mo /boot/efi

Quand j'appuie sur install now, il me dit :

The partition table in use on your disk normally requires you to create a separate partition for boot loader code. This partition should be mark for use as an "EFI boot partition" and should be at least 35MB in size. Note that this is not the same as a partition mounted on /boot.

If you do not go back to the partitioning menu and correct this error, boot loader installation may fail later, although it may still be possible to install the boot loader to a partition.

J'installe quand même avec ces paramètres ?

Hors ligne

#12 Le 11/08/2014, à 14:51

Bougron

Re : [Abandon] Windows 8.1 + Ubuntu 14.04

Oui, installes quand même.
Je ne vois pas le rapport avec un disque EFI. ni avec notre problème.

Cependant http://askubuntu.com/questions/458947/s … -partition
indique qu'une cause est

Your problem is trying to install Ubuntu in legacy mode, instead of UEFI mode like Windows. Then you will be installing grub-efi, instead of grub-pc, and you will not need a 1M partition flagged with the grub-bios flag (needed bacause gpt partitioned disks do not have the room right after the Master Boot Block to store grub's core.img executable. Secure boot shouold not need to be turned off, unless your machine has specific problems, but if you can boot Windows with it off, it should make


Peux-tu indiquer depuis quel endroit tu as téléchargé la version ubuntu S'il te plait.

Dernière modification par Bougron (Le 11/08/2014, à 14:58)

Hors ligne

#13 Le 11/08/2014, à 14:58

Bougron

Re : [Abandon] Windows 8.1 + Ubuntu 14.04

Peux-tu indiquer depuis quel endroit tu as téléchargé la version ubuntu S'il te plait.

et surtout vérifier que dans ton bios tu es bien resté EFI et pas revenu LEGACY par accident.


Pour information, J'ai une piste pour le problème du dual boot qui est évoquée dans cette discussion au post #10
http://forum.ubuntu-fr.org/viewtopic.ph … #p14680121
que je résume ainsi 

Save and rename /mnt/boot-sav/sda1/EFI/Microsoft/Boot/bootmgfw.efi (/mnt/boot-sav/sda1/EFI/Microsoft/Boot/bkpbootmgfw.efi)
cp /mnt/boot-sav/sda8/boot/efi/EFI/ubuntu/grubx64.efi /mnt/boot-sav/sda1/EFI/Microsoft/Boot/bootmgfw.efi

dont je connais le principe, qui a été installé avec la version 14.04.0  qui a permis de faire un dual boot avec windows.
Tous ceux qui ont fait ce choix ont fonctionné. Lorsqu'ils ont installé la version 14.04.1, Ils ont perdus la possibilité de lancer windows en dual boot.

Ce problème est référencé pour les micros HP  dans la doc  suivante au chapitre 6 http://doc.ubuntu-fr.org/uefi

Je pense qu'il est sage d'utiliser boot-repair pour réaliser cette action.
Simplement dans le rapport boot-info que tu as fournis au début, Je n'ai pas vu cela.
Peut-être n'as-tu pas utilisé la bonne version de boot-repair  qui se trouve ici http://doc.ubuntu-fr.org/boot-repair
sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo sed 's/trusty/saucy/g' -i /etc/apt/sources.list.d/yannubuntu-boot-repair-trusty.list
sudo apt-get update
sudo apt-get install -y boot-repair && (boot-repair &)



(La suite de l'info arrive)

Dernière modification par Bougron (Le 11/08/2014, à 16:06)

Hors ligne

#14 Le 11/08/2014, à 16:04

Antoine9000

Re : [Abandon] Windows 8.1 + Ubuntu 14.04

J'ai téléchargé ubuntu-14.04-desktop-amd64.iso ici : http://www.ubuntu-fr.org/telechargement mais à la limite je peux le re télécharger et refaire un liveusb ça ne prendra pas très longtemps. J'ai l'impression que ça n'est pas la version 14.04.01

Oui je suis sûr que mon BIOS est bien en UEFI : mini_759035IMG0138.jpg

Au final je n'ai pas réinstallé Ubuntu, il me mettais deux autres messages d'erreur et me demandais si j'étais sûr de vouloir continuer

Dernière modification par Antoine9000 (Le 11/08/2014, à 16:13)

Hors ligne

#15 Le 11/08/2014, à 16:12

Bougron

Re : [Abandon] Windows 8.1 + Ubuntu 14.04

Télécharges ubuntu depuis le site http://releases.ubuntu.com/trusty/
Si tu n'as pas la même taille, cela vaut le coup de recommencer, et pour la partition /    tu choisis de la formater.
Je n'ai toujours pas compris pourquoi tu as eu le message d'alerte que tu m'as transmis.


P.S. Pour le contrôle du bios, Je te demandais seulement de vérifier par toi-même... Car ce fichu message de l'installateur m'inquiète.
Mais j'ai certainement la réponse, En avril 2014 on disait qu'il ne fallait pas prendre la version française car elle n'était pas certifiée EFI. Je ne sais pas si cela est encore vrai.

Dernière modification par Bougron (Le 11/08/2014, à 16:18)

Hors ligne

#16 Le 11/08/2014, à 16:14

Antoine9000

Re : [Abandon] Windows 8.1 + Ubuntu 14.04

Je suis déjà en train de le télécharger depuis ici : http://www.ubuntu.com/download/desktop/ … ture=amd64 dois-je annuler pour utiliser ton lien ?

J'ai bien installé boot-repair depuis le lien que tu as mis. Au lancement, il m'averti que boot-repair vient d'une source pour Ubuntu 13.10.

Dernière modification par Antoine9000 (Le 11/08/2014, à 16:17)

Hors ligne

#17 Le 11/08/2014, à 16:24

Bougron

Re : [Abandon] Windows 8.1 + Ubuntu 14.04

Je pense que cela pointe au même endroit et que tu devrais récupérer 1 028 653 056 octets.
OK pour boot-repair la version officielle 14.04 n'est toujours pas sortie d'où la présence d'un bidouillage.

Dernière modification par Bougron (Le 11/08/2014, à 16:38)

Hors ligne

#18 Le 11/08/2014, à 19:11

Antoine9000

Re : [Abandon] Windows 8.1 + Ubuntu 14.04

L'iso que j'ai récupéré fait exactement la même taille. Je viens de le réinstaller en utilisant les partitions suivantes :

swap de 1Go
ext4 de 80Go / que j'ai formaté
ntfs 300Go /windows
efi 100Mo j'ai sélectionné "use as EFI" ou quelque chose du genre.

Toujours pas de changement.. Voici le rapport de boot-repair http://paste.ubuntu.com/8018813/ (je n'ai pas lancé boot-repair, je n'ai fais que généré un rapport).

Dernière modification par Antoine9000 (Le 11/08/2014, à 19:15)

Hors ligne

#19 Le 11/08/2014, à 20:04

Bougron

Re : [Abandon] Windows 8.1 + Ubuntu 14.04

Bonsoir.

La génération est très curieuse

os-prober a bien détecté la présence des deux OS en ligne 517 et 518

=================== os-prober:
/dev/sda2@/efi/Microsoft/Boot/bootmgfw.efi:Windows Boot Manager:Windows:efi
/dev/sda7:Ubuntu 14.04.1 LTS (14.04):Ubuntu:linux


Mais nulle part, je ne vois de génération de la structure EFI.

Je pense que ce que je t'ai dis au post #3 pourrait malgré tout fonctionner

La piste que j'ai qu'il faut que tu vérifies
C'est de mettre un flag boot    Je pense que c'est sur la partition  sda2  ou la partition FAT32 (Je n'ai pas su voir si si le flag était positionné. (Juste un message disant de le mettre).
  Puis trouver le moyen de faire les commandes
                        sudo   grub-install
                        sudo  efibootmgr   -v

afin de voir des lignes montrant un choix de boot
qui sont du style

BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0000,0004,0001,2003,2001,2002
Boot0000* ubuntu    HD(2,96800,32000,de40e452-2c7c-4617-9b15-15b7ddf168d0)File(\EFI\ubuntu\shimx64.efi)
Boot0001* Ubuntu    HD(2,96800,32000,de40e452-2c7c-4617-9b15-15b7ddf168d0)File(\EFI\ubuntu\grubx64.efi)RC
Boot0004* Windows Boot Manager    HD(2,96800,32000,de40e452-2c7c-4617-9b15-15b7ddf168d0)File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=...................

Je suis obligé de m'absenter
=

Dernière modification par Bougron (Le 12/08/2014, à 01:02)

Hors ligne

#20 Le 11/08/2014, à 20:44

Bougron

Re : [Abandon] Windows 8.1 + Ubuntu 14.04

Suite..

Pour te connecter à Ubuntu, Tu peux utiliser le logiciel super grub2   Voir http://forum.ubuntu-fr.org/viewtopic.php?id=1287711
http://www.supergrubdisk.org/category/d … kdownload/

Hors ligne

#21 Le 12/08/2014, à 11:17

Bougron

Re : [Abandon] Windows 8.1 + Ubuntu 14.04

Bonjour.
Je me permets de revenir vers toi ce matin pour te demander un complément d'informations.
J'ai trouvé l'endroit où cela déraille. J'avais vu l'incident signalé, sans avoir compris que c'était la cause

Dans ton boot-info  on trouve cela ligne 578;
# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1
/boot/efi detected in the fstab of sda7: UUID=BCCA-9BF5   (sda2)
=================== UEFI/Legacy mode:
Unusual EFI: Please report this message to boot.repair@gmail.com
BIOS is EFI-compatible, and is setup in EFI-mode for this live-session.
SecureBoot disabled. (maybe sec-boot, Please report this message to boot.repair@gmail.com)

Normalement on devrait avoir embrayage sur la génération EFI tel vu par ailleurs.
#GRUB_INIT_TUNE="480 440 1"
/boot/efi detected in the fstab of sda3: UUID=FAC3-1EAB   (sda1)
efibootmgr -v
BootCurrent: 0010
Timeout: 0 seconds
BootOrder: 000E,000F,0002,000B,0006,0001,0010,0000
Boot0000* ubuntu    Vendor(99e275e7-75a0-4b37-a2e6-c5385e6c00cb,)

Je ne pense pas que la cause soit dans le fichier /etc/fstab.  Cependant si tu peux fournir son contenu afin de voir si par hasard.....
Par ailleurs, on aurait pu aussi avoir la ligne
"Presence of EFI/Boot file detected: /boot/efi/EFI/Boot/bootx64.efi"
On ne l'a pas, je reviens donc à l'interrogation, est-ce que le flag boot est positionné?

Dernière modification par Bougron (Le 12/08/2014, à 11:46)

Hors ligne

#22 Le 12/08/2014, à 13:46

Antoine9000

Re : [Abandon] Windows 8.1 + Ubuntu 14.04

Bonjour Bougron,

Merci pour tout le temps que tu as déjà passé à m'aider  smile.

Je n'arrive pas à faire ce que tu m'as dit au post #3 car au démarrage, seule la touche F2 fonctionne et elle permet d'accéder au BIOS, la touche F10 ne fonctionne pas. Je n'ai pas non plus accès à l'option "Utiliser un périphérique", l'option n'est pas présente.

J'ai exécuté les commades que tu m'a dites, je pense qu'elles n'ont pas fonctionné, je ne sais pas pourquoi :

ubuntu@ubuntu:~$ mkdir ubuntu
ubuntu@ubuntu:~$ sudo mount /dev/sda7 ubuntu/
ubuntu@ubuntu:~$ sudo chroot ubuntu/
root@ubuntu:/# sudo grub-install
sudo: unable to resolve host ubuntu
grub-install: error: /usr/lib/grub/i386-pc/modinfo.sh doesn't exist. Please specify --target or --directory.
root@ubuntu:/# sudo efibootmgr -v
sudo: unable to resolve host ubuntu
Fatal: Couldn't open either sysfs or procfs directories for accessing EFI variables.
Try 'modprobe efivars' as root.

Je pense ne pas m'être trompé de partition, j'ai fais ubuntu@ubuntu:~$ cp ubuntu/etc/fstab fstab depuis cette partition.

J'ai l'impression qu'il  y a déjà un flag boot sur la partition sda2 : mini_583126gparted.png

/etc/fstab :

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda7 during installation
UUID=12072da8-d829-4905-9dd6-1ccd728978fa /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda2 during installation
UUID=BCCA-9BF5  /boot/efi       vfat    defaults        0       1
# /windows was on /dev/sda8 during installation
UUID=692D59516B9BBC5D /windows        ntfs    defaults,umask=007,gid=46 0       0
# swap was on /dev/sda6 during installation
UUID=0ef2a542-354c-4695-8c4d-a44872ae00c6 none            swap    sw              0       0

Faut-il que je me connecte à Ubuntu en utilisant ta méthode et supergrub2 ou un chroot depuis mon liveusb est suffisant ?

J'ai essayé cette commande depuis la console de Windows en admin :

bcdedit /set "{bootmgr}" path \EFI\ubuntu\grubx64.efi

Il me répond que l'opération a été effectuée, je redémarre et rien n'a changé. J'ai l'impression que Windows ne trouve pas ce fichier car l'autocomplétion (avec la touche tab) ne fonctionne pas..

Dernière modification par Antoine9000 (Le 12/08/2014, à 14:11)

Hors ligne

#23 Le 12/08/2014, à 14:51

Antoine9000

Re : [Abandon] Windows 8.1 + Ubuntu 14.04

Je n'arrive pas à démarrer super grub2 en UEFI. Il ne démarre que quand UEFI n'est pas activé.. J'ai essayé avec les iso suivants :

- Super Grub2 Disk (Floppy, CD & USB in one) 2.00s2 (ISO)[Mirror #1]
- Super Grub2 Disk (Floppy, CD & USB in one) 2.00s2 [x86_64-efi] (ISO)[Mirror #1]

Hors ligne

#24 Le 12/08/2014, à 16:00

malbo

Re : [Abandon] Windows 8.1 + Ubuntu 14.04

Le premier des deux ISO que tu as cités est le bon. Il faut le graver sur un CD (ou un CD réinscriptible) avec la fonction "graver une image" du logiciel de gravure. Attention : ça ne marche pas si tu veux installer cet ISO sur une clé USB (chez moi, ça ne marche pas : je n'arrive pas à démarrer en mode EFI sur la clé USB). As-tu bien gravé un CD ?

Dernière modification par malbo (Le 12/08/2014, à 16:03)

Hors ligne

#25 Le 12/08/2014, à 16:19

Antoine9000

Re : [Abandon] Windows 8.1 + Ubuntu 14.04

Ah d'accord, j'essayais avec une clé USB. Je vais essayé avec un CD

Hors ligne