Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 14/09/2014, à 12:45

Bigan

Open sankoré sous ubuntu 14.04

Bonjour,

Sur le net j'ai trouvé cette astuce de Galin Richard
" manipuler des fichiers multimédia sous Sankoré 2.5.0/Ubuntu 14.04 provoque un gel total de l'application.

Modification nécessaire :
- ouvrir un terminal
- taper : sudo mv /usr/local/Open-Sankore-2.5.0/plugins/phonon_backend/phonon_gstreamer.so /usr/local/Open-Sankore-2.5.0/plugins/phonon_backend/phonon_gstreamer.so.ancien (sauvegarde de la bibliothèque fournie)
- taper : sudo ln -s /usr/lib/i386-linux-gnu/qt4/plugins/phonon_backend/phonon_gstreamer.so /usr/local/Open-Sankore-2.5.0/plugins/phonon_backend/phonon_gstreamer.so (lien vers la bibliothèque système)"

Sur une installation récente de la 14.04, après installation de phonon et open sankoré ces manipulations font que tout fonctionne, avec toutefois un bémol : les vidéos sont bleutées (sous sankoré uniquement). Le phénomène se produit sur un portable msi comme sur un NUC intel (tous deux core i5 haswell).

Quelqu'un aurait une idée ?...

N. B. : si phonon n'est pas installé impossible de lancer une vidéo ou un document sonore.

Hors ligne

#2 Le 15/09/2014, à 11:21

yann_001

Re : Open sankoré sous ubuntu 14.04

Bonjour.

Je ne connais pas Open-Sankoré, mais le problème puisque les vidéos ne sont bleutées qu'avec celui-ci, pourrait venir du pilote de sortie utilisé.
Regarde dans les préférences si il n'y a pas moyen d'en sélectionner un autre.

Hors ligne

#3 Le 13/11/2014, à 22:33

olnd

Re : Open sankoré sous ubuntu 14.04

Bonsoir,
Même remarque: couleur bleutée pour les vidéos.
Quelqu'un aurait une idée?
Petite précision pour le fichier phonon_gstreamer.so:
Il peut être ici: /usr/lib/i386-linux-gnu/qt4/plugins/phonon_backend/phonon_gstreamer.so
ou là: /usr/lib/x86_64-linux-gnu/qt4/plugins/phonon_backend/phonon_gstreamer.so
Autre demande: qui pourrait ajouter cette information ou ce "problème rencontré" à la page sankoré de la documentation? Cela faciliterait certainement la tâche des nouveaux installateurs du logiciel.

Hors ligne

#4 Le 17/12/2014, à 23:00

Bigan

Re : Open sankoré sous ubuntu 14.04

Le problème est résolu pour moi big_smile.
J'ai trouvé sur le site d'open sankoré la solution suivante qui fonctionne pour moi. Suite à mon post ci-dessus il convient de poursuivre en installant phonon-backend-vlc (à l'aide de synaptic) puis

sudo rm /usr/local/Open-Sankore-2.5.0/plugins/phonon_backend/phonon_gstreamer.so (supprimer le lien précédemment créer)

sudo ln -s /usr/lib/i386-linux-gnu/qt4/plugins/phonon_backend/phonon_vlc.so /usr/local/Open-Sankore-2.5.0/plugins/phonon_backend/phonon_gstreamer.so (créer le nouveau lien)

(si vous êtes en version 64 bits il convient de remplacer le répertoire i386-linux-gnu par x86_64-linux-gnu)

Hors ligne

#5 Le 18/12/2014, à 15:27

olnd

Re : Open sankoré sous ubuntu 14.04

Oui, mais il me semble que ça ne résout pas les problèmes de couleur des vidéos intégrées!
Tu fais les mêmes constats?

Hors ligne

#6 Le 19/12/2014, à 11:06

Bigan

Re : Open sankoré sous ubuntu 14.04

J'ai retrouvé les couleurs souhaitées, sinon je n'aurais pas signalé le problème comme résolu !

Bonne journée, cordialement.

Hors ligne

#7 Le 23/12/2014, à 19:56

olnd

Re : Open sankoré sous ubuntu 14.04

Oui, c'est effectivement tout bon
sankore.zendesk.com
Merci

Hors ligne

#8 Le 16/01/2016, à 13:06

strokkur

Re : Open sankoré sous ubuntu 14.04

Bonjour

Super astuce, j'avais le même problème avec ma version d'Opensankore, sous LinuxMint 17.1

Il suffit évidemment de remplacer dans la ligne de commande le n° de version d'OpenSankore ( dans mon cas 2.5.1 au lieu de 2.5.0)

Longue vie au libre !

Hors ligne