Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 02/03/2015, à 00:23

SadicSheep

probleme avec wizardpen et ma tablette graphique(huion h580)

Bonjour ou bonsoir...
j'ai eu une nouvelle tablette graphique y'a pas longtemps sauf qu'elle n'est pas compatible , j'ai pu voir que certaines personnes avait réussi à la faire fonctionner...mais moi je n'y arrive pas, j'ai même fait comme dans la documentation , au début tout ce passe bien mais lorsqu'il faut que je me rend dans le dossier "/etc/hal/fdi/policy/99-x11-wizardpen.fdi"  je ne le trouve pas...je suis perdu j'ai tout  essayé...peut être que j'ai pas bien fait quelque chose (car je suis encore debutante)...mais bon ...je ne veux vraiment pas retourné chez Windows (Ah ça non ! )...et je n'ai pas assez d'argent pour m'acheter une wacom ...

je suis sur ubuntu studio x86
et ma tablette c'est une Huion h580

Merci d'avance ~ <3

Hors ligne

#2 Le 02/03/2015, à 13:57

le cinglé_001

Re : probleme avec wizardpen et ma tablette graphique(huion h580)

Bonjour.

Il y a un pilote pour cette tablette. digimend-kernel-drivers.
Voir aussi : Huion H580 on Ubuntu 14.04.

#3 Le 02/03/2015, à 18:12

SadicSheep

Re : probleme avec wizardpen et ma tablette graphique(huion h580)

le cinglé_001 a écrit :

Bonjour.

Il y a un pilote pour cette tablette. digimend-kernel-drivers.
Voir aussi : Huion H580 on Ubuntu 14.04.

bonjour...j'ai essayé plusieurs fois mais ça ne fonctionne pas ça me met


shamanzodiac@shamanzodiac-1002HA:~$ cd /home/shamanzodiac/digimend-kernel-drivers-master
shamanzodiac@shamanzodiac-1002HA:~/digimend-kernel-drivers-master$ make
make -C /lib/modules/3.2.0-77-lowlatency-pae/build SUBDIRS=/home/shamanzodiac/digimend-kernel-drivers-master modules
make[1]: entrant dans le répertoire « /usr/src/linux-headers-3.2.0-77-lowlatency-pae »
  CC [M]  /home/shamanzodiac/digimend-kernel-drivers-master/hid-kye.o
/home/shamanzodiac/digimend-kernel-drivers-master/hid-kye.c: In function ‘kye_tablet_enable’:
/home/shamanzodiac/digimend-kernel-drivers-master/hid-kye.c:499:2: erreur: implicit declaration of function ‘hid_hw_request’ [-Werror=implicit-function-declaration]
/home/shamanzodiac/digimend-kernel-drivers-master/hid-kye.c: Hors de toute fonction :
/home/shamanzodiac/digimend-kernel-drivers-master/hid-kye.c:581:1: attention : la définition de données n'a pas de type ni de classe de stockage [enabled by default]
/home/shamanzodiac/digimend-kernel-drivers-master/hid-kye.c:581:1: attention : type defaults to ‘int’ in declaration of ‘module_hid_driver’ [-Wimplicit-int]
/home/shamanzodiac/digimend-kernel-drivers-master/hid-kye.c:581:1: attention : noms de paramètres (sans type) dans la déclaration de fonction [enabled by default]
/home/shamanzodiac/digimend-kernel-drivers-master/hid-kye.c:575:26: attention : ‘kye_driver’ defined but not used [-Wunused-variable]
cc1: some warnings being treated as errors
make[2]: *** [/home/shamanzodiac/digimend-kernel-drivers-master/hid-kye.o] Erreur 1
make[1]: *** [_module_/home/shamanzodiac/digimend-kernel-drivers-master] Erreur 2
make[1]: quittant le répertoire « /usr/src/linux-headers-3.2.0-77-lowlatency-pae »
make: *** [modules] Erreur 2
shamanzodiac@shamanzodiac-1002HA:~/digimend-kernel-drivers-master$ sudo make install
[sudo] password for shamanzodiac:
make -C /lib/modules/3.2.0-77-lowlatency-pae/build SUBDIRS=/home/shamanzodiac/digimend-kernel-drivers-master modules_install
make[1]: entrant dans le répertoire « /usr/src/linux-headers-3.2.0-77-lowlatency-pae »
  DEPMOD  3.2.0-77-lowlatency-pae
make[1]: quittant le répertoire « /usr/src/linux-headers-3.2.0-77-lowlatency-pae »
install -D -m 0644 digimend.conf /etc/depmod.d/digimend.conf
depmod -a
install hid-rebind /sbin/hid-rebind
install -m 0644 hid-rebind.rules /lib/udev/rules.d/70-hid-rebind.rules
udevadm control --reload

et je n'arrive pas a faire comme c'est indiqué dans le deuxieme lien...(je suis vraiment debutante désolée...)

Hors ligne

#4 Le 02/03/2015, à 22:47

le cinglé_001

Re : probleme avec wizardpen et ma tablette graphique(huion h580)

Bonsoir.

J'ai effectué quelques tests sur Ubuntu 12.04 32 et 64 bits, Ubuntu 12.04.5 et Ubuntu 14.04 32 et 64, et j'ai découvert que le driver ne pouvait être compilé sur Ubuntu 12.04 utilisant le noyau 3.2.0-xx.
Ça fonctionne sur une Ubuntu 12.04 qui utilise un noyau supérieur et sur la 14.04.

Donc tu as deux choix.

-1 Tu installes sur ta Ubuntu 12.04 un noyau supérieur comme c'est indiqué sur cette page.
Dans ton cas pour installer la dernière version du noyau disponible dans les dépôts d'Ubuntu 12.04, les commandes seront :

sudo apt-get install linux-generic-lts-trusty

et

sudo apt-get install xserver-xorg-lts-trusty

(ps : la commande xserver-xorg-lts-trusty suffit pour installer le tout noyau y compris mais il est préférable de le faire en deux fois)

ou

-2 Effectuer la mise à niveau vers Ubuntu 14.04.