Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 06/01/2008, à 17:58

Am0ry

Probleme avec Jack

Salut tout le monde,

Voila, je viens de passer sous linux et j'aimerai faire un peu de mao mais soucis....
J'arrive pas a faire marcher Jack sad
Il me dit ca :

16:50:18.989 Patchbay deactivated.
16:50:19.037 Statistics reset.
JACK tmpdir identified as [/dev/shm]
16:50:19.087 MIDI connection graph change.
16:50:19.258 MIDI connection change.
16:50:20.452 Startup script...
16:50:20.452 artsshell -q terminate
JACK tmpdir identified as [/dev/shm]
sh: artsshell: not found
16:50:20.656 Startup script terminated with exit status=32512.
16:50:20.656 JACK is starting...
16:50:20.656 /usr/bin/jackd -R -dalsa -dhw:0 -r44100 -p1024 -n3
16:50:20.660 JACK was started with PID=6810 (0x1a9a).
jackd 0.103.0
Copyright 2001-2005 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK compiled with System V SHM support.
cannot use real-time scheduling (FIFO at priority 10) [for thread -1209903440, from thread -1209903440] (1: Operation not permitted)
cannot create engine
16:50:21.066 JACK was stopped successfully.
16:50:21.067 Post-shutdown script...
16:50:21.067 killall jackd
jackd: no process killed
16:50:21.297 Post-shutdown script terminated with exit status=256.
16:50:22.678 Could not connect to JACK server as client. Please check the messages window for more info.
JACK tmpdir identified as [/dev/shm]
16:54:01.742 Startup script...
16:54:01.742 artsshell -q terminate
JACK tmpdir identified as [/dev/shm]
sh: artsshell: not found
16:54:01.963 Startup script terminated with exit status=32512.
16:54:01.963 JACK is starting...
16:54:01.963 /usr/bin/jackd -R -dalsa -dhw:0 -r44100 -p1024 -n3
16:54:01.972 JACK was started with PID=7081 (0x1ba9).
jackd 0.103.0
Copyright 2001-2005 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK compiled with System V SHM support.
cannot use real-time scheduling (FIFO at priority 10) [for thread -1210313040, from thread -1210313040] (1: Operation not permitted)
cannot create engine
16:54:01.978 JACK was stopped successfully.
16:54:01.979 Post-shutdown script...
16:54:01.979 killall jackd
jackd: no process killed
16:54:02.189 Post-shutdown script terminated with exit status=256.
16:54:04.101 Could not connect to JACK server as client. Please check the messages window for more info.
JACK tmpdir identified as [/dev/shm]
16:56:50.177 Startup script...
16:56:50.178 artsshell -q terminate
JACK tmpdir identified as [/dev/shm]
sh: artsshell: not found
16:56:50.381 Startup script terminated with exit status=32512.
16:56:50.381 JACK is starting...
16:56:50.381 /usr/bin/jackd -R -dalsa -dhw:0 -r44100 -p1024 -n3
16:56:50.385 JACK was started with PID=11527 (0x2d07).
jackd 0.103.0
Copyright 2001-2005 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK compiled with System V SHM support.
cannot use real-time scheduling (FIFO at priority 10) [for thread -1210329424, from thread -1210329424] (1: Operation not permitted)
cannot create engine
16:56:50.395 JACK was stopped successfully.
16:56:50.395 Post-shutdown script...
16:56:50.395 killall jackd
jackd: no process killed
16:56:50.607 Post-shutdown script terminated with exit status=256.
16:56:52.470 Could not connect to JACK server as client. Please check the messages window for more info.
JACK tmpdir identified as [/dev/shm]

Je comprends pas trop ou il est le probleme sad
J'ai installer ubuntu avec la distrib ubuntu studio en mode "audio" donc bon... neutral

#2 Le 08/01/2008, à 13:34

am0ry

Re : Probleme avec Jack

Pas d'idées ?? sad

#3 Le 09/01/2008, à 13:46

am0ry

Re : Probleme avec Jack

Quand je suis ce tuto :
http://doc.ubuntu-fr.org/jackd
Si je fais ca :

Autoriser les applications audio a utiliser le temps réel

Il faut modifier en tant qu'administrateur le fichier qui donne aux applications audio le droit d'acceder au temps réel.

Pour cela, ouvrez un terminal et : * si vous utilisez Ubuntu :

gksudo gedit /etc/security/limits.conf

* si vous utilisez KUbuntu :

kdesu kate /etc/security/limits.conf

Puis ajoutez à  la fin du fichier les lignes suivantes :

# Support Temps réel pour le groupe audio
@audio  -  rtprio   99
@audio  -  nice	    -10
@audio  -  memlock  250000

Attention : il vous faudra redémarrer (avec le noyau temps réel) pour que ces changements prennent effet.

Vous pourrez trouver plus d'infos sur la configuration de PAM sur le site de linuxmao

Au reboot, j'ai le droit a une erreur dans le demon gnome ou un truc du style, mon interface déconne de partout...
A quoi c'est du ?

#4 Le 28/01/2008, à 07:01

Baryton

Re : Probleme avec Jack

amory j'ai le même problème que toi et je sais vraiment pas quoi faire...

#5 Le 27/12/2008, à 01:00

hedgehog

Re : Probleme avec Jack

Bonjour ! smile

Je débute sous Ubuntu mais je crois avoir résolu ce problème, que j'avais aussi depuis deux jours, en croisant plusieurs réponses sur différents forums (dont ce topic hélas incomplet).
Je suis en Ubuntu 8.10 (enfin en Kubuntu  wink vu que j'ai installé aussi KDE pour voir ce que cela donnait).

J'ai tout d'abord tapé cette commande :

sudo gedit /etc/security/limits.conf

et saisi mon mot de passe

pour éditer le fichier limits.conf et y ajouter les lignes suivantes :

# Support Temps réel pour le groupe audio
@audio  -  rtprio   99
@audio  -  nice        -10
@audio  -  memlock  250000

Ce qui pour le moment revient à la solution du dessus, incomplète. sad

Je suis allé ensuite dans KUser, gestionnaire d'utilisateur de KDE, pour éditer mon compte, plus précisément les groupes auxquels j'appartiens pour m'ajouter dans le groupe audio (seul groupe auquel les lignes que nous avons ajoutées s'appliquent). C'est ce détail, je crois, que vous avez oublié !:P

Il faut ensuite redémarrer sa session pour que tout soit pris en compte.

Et là, j'ai pu cocher dans JACK Control l'option temps réel et faire démarrer Jackd sans soucis.:cool:

Reste à me confirmer que cela marche chez vous !:/

Dernière modification par hedgehog (Le 27/12/2008, à 16:25)


Cordialement,
Hedgehog

Hors ligne

#6 Le 26/04/2009, à 22:46

eilotshai

Re : Probleme avec Jack

Merci chez moi ca marche mais il m"écrit TR au lieu de RT c'est normal lol?

Hors ligne

#7 Le 27/04/2009, à 10:02

银河系

Re : Probleme avec Jack

Salut,

oui c'est normal TR pour Temps Réel en français - RT pour Real Time en Anglais, ton Jack control est juste en français tongue

Hors ligne

#8 Le 27/04/2009, à 15:28

gab38

Re : Probleme avec Jack

slt milkyway,

dans limits.conf, où faut-il placer les lignes:

# Support Temps réel pour le groupe audio
@audio  -  rtprio   99
@audio  -  nice        -10
@audio  -  memlock  250000

dsl je débute sous linux lol

#9 Le 27/04/2009, à 15:34

nubu

Re : Probleme avec Jack

a la fin, comme indiqué ici : http://doc.ubuntu-fr.org/jackd


Ubuntu 16.04.2 LTS 64 bits

Hors ligne

#10 Le 27/04/2009, à 15:54

gab38

Re : Probleme avec Jack

ok sa marche merci pour le lien nubu;)

#11 Le 27/04/2009, à 16:16

gab38

Re : Probleme avec Jack

est-ce que quelqu'un a essayer rosegarden avec Jack sous ubuntu 9.04 sur un eeepc 900
Pour les versions précédentes d'ubuntu jamais eu de souci entre jack et rosegarden
mais sous 9.04 il faut d'abord bien paramétrer Jack ensuite sa fonctionne mais un bug apparait au bout d'un moment :

Le sous-système JACK audio s'est arrêté où empêche Rosegarden de traiter l'audio.
Veuillez redémarrer Rosegarden pour continuer à travailler avec l'audio.
Si d'autres applications sont actuellement en fonctionnement, les arrêter peut améliorer les performances de Rosegarden.

Si quelqu'un a une solution
Cdlt

#12 Le 27/04/2009, à 22:31

银河系

Re : Probleme avec Jack

Salut Gab38,

ben en fait comme tu as du le comprendre, c'est que ça «décroche» au niveau de jack et du temps réel, la latence est donc trop basse pour que le son soit traité dans les temps souhaités, c'est à dire la latence.
C'est ce que tu vois apparaître en bas à droite dans l'interface de configuration de JackControl (Setup/Réglages). Comme tu peux le constater elle est en ms donc cela doit être très rapide, et tu es sur un eeePC, donc il faut que tu lui donnes plus de temps logiciel par rapport à ta config. Mais je sais que que certain(e)s arrivent à de bons résultats sur eeePC, le tout est de trouver le juste milieu niveau réglage et logiciels qui tournent en même temps wink
Pour se faire, commence par passer le Periods/Buffer ou Périodes/Tampon en francisé sur 3, ensuite si ça persiste augmente le Frames/Period ou Echantillons/Périodes en francisé.

Vérifie également que la fréquence d'échantillonnage ou Sample Rate corresponde à celui de ta carte son.

Tu devrais normalement avoir une amélioration avec tout ça, mais regarde aussi la doc sur LinuxMAO au sujet de JackControl : http://www.linuxmao.org/tikiwiki/tiki-i … e=Qjackctl

Ce site est vraiment la référence francophone pour tout ce qui est de faire de la musique sous GNU/Linux smile

Pense aussi à supprimer les services qui ne te servent à rien : http://doc.ubuntu-fr.org/systeme/services
Le but est d'avoir le moins de charge logiciel possible pour avoir plus de ressource et de réactivité pour le traitement audio.

Et bien sûr l'usage du noyau RT (si ce n'est pas déjà fait) frouni avec UbuntuStudio (et autres distrib orienté MAO) ou dans les dépôts est indispensable.

Voilà, j'espère sincèrement avoir pu t'aider.

Dernière modification par milkyway (Le 27/04/2009, à 22:58)

Hors ligne