Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 20/03/2015, à 07:53

malbo

Faut-il installer Ubuntu 14.04, 14.04.1 ou 14.04.2 ou 14.04.3 ?

La version la plus intéressante à installer est Ubuntu 14.04.1 pour deux raisons :
1) elle est corrigée des bogues qui affectaient la version de base 14.04
2) elle est maintenue jusqu'en Avril 2019 c'est à dire qu'elle vient avec le noyau 3.13.0-x et qu'elle restera avec les mises à jour de ce noyau 3.13.0-x assurées jusqu'en Avril 2019. Alors que les versions 14.04.2, 14.04.3 et 14.04.4 (à venir) ne seront maintenues que jusqu'en Août 2016 : voir graphique "14.04.x Ubuntu kernel Support Schedule" de la doc LTS Enablement Stack
Il y a un inconvénient pour ceux qui ont Windows 8 préinstallé : l'installateur de cette version 14.04.1 est bogué et impose une installation en "manuel" (choix "Autre chose" à l'étape 3 de l'installation) pour ne pas risquer un écrasement de Windows 8 à l'installation. Ce risque n'existe plus avec la version 14.04.2 et suivantes (le bug a été corrigé)
Si l'ordi n'est pas trop récent(*), ça vaut vraiment le coup d'envisager d'installer cette version Ubuntu 14.04.1. Je recommande ma recette pour faire une LiveUSB 14.04.1 64 bits : http://forum.ubuntu-fr.org/viewtopic.php?pid=16713311
Après essai en session Live (Essayer sans installer) pour vérifier si tout est OK avec cette version Ubuntu 14.04.1, on peut installer. Tuto recommandé pour ceux qui ont Windows 8 : http://libre.a.quimperle.perso.sfr.fr/2 … ndows.html
Ce tuto prend bien en compte le choix "Autre chose" évoqué plus haut ; il est donc sans danger pour Windows 8 

Dans quel cas est-il préférable de sélectionner la version 14.04.2 (ou supérieure) ? Réponse : dans le cas d'un ordi acheté tout récemment ou dans le courant de 2014 afin qu'il bénéficie de la meilleure prise en charge par Ubuntu

(*) si l'ordi est sorti sur le marché avant janvier 2014

Dernière modification par malbo (Le 25/08/2015, à 05:26)

Hors ligne

#2 Le 20/03/2015, à 08:04

Caribou22

Re : Faut-il installer Ubuntu 14.04, 14.04.1 ou 14.04.2 ou 14.04.3 ?

Bonjour,
Merci pour ces éclaircissements. J'ai d'autres questions :
- Si les versions 14.04.2, 14.04.3, 14.04.4 expire avant 2019. DU coup elles sont appelées versions LTS à tort ? C'est vraiment ambigu hmm
- Que se passe t'il si l'on a une 14.04.x 'plus maintenue" ?

Hors ligne

#3 Le 20/03/2015, à 08:32

malbo

Re : Faut-il installer Ubuntu 14.04, 14.04.1 ou 14.04.2 ou 14.04.3 ?

Caribou22 a écrit :

- Si les versions 14.04.2, 14.04.3, 14.04.4 expire avant 2019. DU coup elles sont appelées versions LTS à tort ? C'est vraiment ambigu hmm

Moi, je donne mon conseil dans le post #1, après on peut polémiquer à l'infini...

Caribou22 a écrit :

- Que se passe t'il si l'on a une 14.04.x 'plus maintenue" ?

Pour te répondre, je te prie de considérer ce qui s'est passé pour Ubuntu 12.04 au moment crucial de la fin du support des versions intermédiaires 12.04.2, 12.04.3 et 12.04.4 : c'est dans ce paragraphe de la doc mais je le colle ici :

 A partir du 7 Août 2014, le gestionnaire de mise à jour propose ce passage au HWE stack de Trusty par un message " New hardware support is available " et si on clique sur le bouton "install", ce message apparaît dans une fenêtre :

Your current Hardware Enablement Stack (HWE) is going out of support
on 2014-08-07.  After this date security updates for critical parts (kernel
and graphics stack) of your system will no longer be available.
For more information, please see:
http://wiki.ubuntu.com/1204_HWE_EOL

Il y a un bouton "Annuler" et un bouton "Mettre à niveau" en bas de la fenêtre. 

Moi je considère que si les mises à jour de sécurité du noyau sont arrêtées, je ne laisse pas en l'état et je fais au choix :
- ce qui est proposé là (c'est à dire la mise à niveau vers le dernier HWE stack)
- une installation toute neuve de la prochaine LTS

Hors ligne

#4 Le 22/03/2015, à 15:48

Elsimate

Re : Faut-il installer Ubuntu 14.04, 14.04.1 ou 14.04.2 ou 14.04.3 ?

Malbo a écrit :

2) elle est maintenue jusqu'en Avril 2019 c'est à dire qu'elle vient avec le noyau 3.13.0-x et qu'elle restera avec les mises à jour de ce noyau 3.13.0-x assurées jusqu'en Avril 2019

Bonjour, si je comprends bien, j'ai initialement installer la version 14.04 qui, suite aux mises à jour, est aujourd'hui devenu la "Distribution_Description = Ubuntu 14.04.02 LTS" :

ubuntu@Aspire:~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=14.04
DISTRIB_CODENAME=trusty
DISTRIB_DESCRIPTION="Ubuntu 14.04.2 LTS"

ubuntu@Aspire:~$ uname -r
3.13.0-46-generic

Le noyau sur lequel je tourne présentement (3.13.0_x ) restera le même jusqu'en 2019, et je suis sur une DISTRIB_RELEASE=14.04 supporter jusqu'en Avril 2019, vos propos n'ont rien à voir avec cette ligne  "DISTRIB_DESCRIPTION="Ubuntu 14.04.2 LTS" ?

Si on utilise l'iso de la 14.04.2 pour une nouvelle installation on aura une DISTRIB_RELEASE=14.04.02 qui ne sera supporter que jusqu'en Août 2016  et on tournera sur un noyau différent ?

Je dois procéder prochainement à une installation d'Ubuntu pour un ami et ce post tombe à point.

Merci pour les précisions. wink

Elsimate


- La loi est faite pour être appliquée avec jugement, y a que ceux qui en sont dépourvu qui l’applique à la lettre -

Hors ligne

#5 Le 22/03/2015, à 16:03

SilentStorm

Re : Faut-il installer Ubuntu 14.04, 14.04.1 ou 14.04.2 ou 14.04.3 ?

Quelque soit votre version, la distribution est supporté jusqu’à 2019.

Ce qui change c'est le support du noyau (juste le noyau) qui effectivement est moins long avec le 3.16 que la 3.13 mais tous le reste est bien maintenu jusqu’à 2019 au niveau des mises a jour de sécurité.


Vous n'avez donc pas a vous prendre la tête, vous pouvez partir directement sur la 14.04.2 si vous voulez, c'est juste que si vous la gardez jusqu’à 2019, les mises a jour de sécurité spécifique au kernel 3.16 s'arrèteront avant la fin par contre vous aurez toujours la dernière version de Firefox, les mises a jour de sécurité de LibreOffice 4.2 etc...

Dernière modification par SilentStorm (Le 22/03/2015, à 16:11)


Core I7 a 2.4 GHz / 16 Go de ram / SSD 512 Go + HDD 1 To (1.5 To) / GeForce 650m GT (pc portable)
OS : Linux Mint 17.1 (Cinnamon) - Debian 8 Jessie (Mate) - ArchLinux (Xfce)

Hors ligne

#6 Le 23/03/2015, à 07:32

malbo

Re : Faut-il installer Ubuntu 14.04, 14.04.1 ou 14.04.2 ou 14.04.3 ?

@Elsimate : l'information donnée par DISTRIB_DESCRIPTION n'est malheureusement d'aucune utilité pour savoir si on a un noyau 3.13 ou 3.16. Cette situation existait déjà pour la LTS précédente (voir mon post ici) et comme on pouvait le craindre, ça ne s'est pas amélioré.

Elsimate a écrit :

Si on utilise l'iso de la 14.04.2 pour une nouvelle installation on aura une DISTRIB_RELEASE=14.04.02 qui ne sera supporter que jusqu'en Août 2016  et on tournera sur un noyau différent ?

Oui, tu auras le noyau 3.16. Mais tu resteras avec DISTRIB_RELEASE=14.04 et DISTRIB_DESCRIPTION="Ubuntu 14.04.2 LTS". Si tu trouves ça merdique, tu n'es pas le seul.

Dernière modification par malbo (Le 23/03/2015, à 07:40)

Hors ligne

#7 Le 23/03/2015, à 09:19

SilentStorm

Re : Faut-il installer Ubuntu 14.04, 14.04.1 ou 14.04.2 ou 14.04.3 ?

malbo a écrit :

@Elsimate : l'information donnée par DISTRIB_DESCRIPTION n'est malheureusement d'aucune utilité pour savoir si on a un noyau 3.13 ou 3.16. Cette situation existait déjà pour la LTS précédente (voir mon post ici) et comme on pouvait le craindre, ça ne s'est pas amélioré.

Elsimate a écrit :

Si on utilise l'iso de la 14.04.2 pour une nouvelle installation on aura une DISTRIB_RELEASE=14.04.02 qui ne sera supporter que jusqu'en Août 2016  et on tournera sur un noyau différent ?

Oui, tu auras le noyau 3.16. Mais tu resteras avec DISTRIB_RELEASE=14.04 et DISTRIB_DESCRIPTION="Ubuntu 14.04.2 LTS". Si tu trouves ça merdique, tu n'es pas le seul.

Non ce n'est pas merdique, c'est la vérité : la 14.04.2 avec le noyau 3.16 reste une version a long terme jusqu’à 2019 !
c'est juste le noyau linux qui est supporté moins longtemps, tout le reste (environ 99% de votre système) est supporté jusqu’à 2019


Core I7 a 2.4 GHz / 16 Go de ram / SSD 512 Go + HDD 1 To (1.5 To) / GeForce 650m GT (pc portable)
OS : Linux Mint 17.1 (Cinnamon) - Debian 8 Jessie (Mate) - ArchLinux (Xfce)

Hors ligne

#8 Le 23/03/2015, à 09:22

Caribou22

Re : Faut-il installer Ubuntu 14.04, 14.04.1 ou 14.04.2 ou 14.04.3 ?

SilentStorm a écrit :

c'est juste le noyau linux qui est supporté moins longtemps, tout le reste (environ 99% de votre système) est supporté jusqu’à 2019

Bonjour,
Et question simple : Qu'est-ce que l'absence de support de ce 1% restant implique ? (Notamment au niveau de la sécurité. Cela veut dire que les éventuelles failles de sécurité du noyau ne seront plus corrigées ?)

Hors ligne

#9 Le 04/04/2015, à 08:23

Qid

Re : Faut-il installer Ubuntu 14.04, 14.04.1 ou 14.04.2 ou 14.04.3 ?

Caribou22 a écrit :
SilentStorm a écrit :

c'est juste le noyau linux qui est supporté moins longtemps, tout le reste (environ 99% de votre système) est supporté jusqu’à 2019

Bonjour,
Et question simple : Qu'est-ce que l'absence de support de ce 1% restant implique ? (Notamment au niveau de la sécurité. Cela veut dire que les éventuelles failles de sécurité du noyau ne seront plus corrigées ?)

Mais non  roll  roll  ... ... et le schéma est pourtant clair même si il ne donne plus de numéro :
il dit juste que si vous faites vos mises à jours correctement soit vous êtes sur la branche 3.13 et vous le gardez jusqu'à la fin
Soit vous êtes sur celle du 3.16 et lui sera mis à jour en août 2016 sauf que entre nous si je ne m'abuse en août 2016 la lts suivante sera sortie


"GNU/Linux c'est que du bon mais M$ Windows ce n'est pas si mal"
Référent technique d'un Groupe d'Utilisateur du Libre
plus d'info sur mon profil

Hors ligne

#10 Le 05/04/2015, à 06:58

Tohubohu

Re : Faut-il installer Ubuntu 14.04, 14.04.1 ou 14.04.2 ou 14.04.3 ?

Qid a écrit :

Mais non  roll  roll  ... ... et le schéma est pourtant clair même si il ne donne plus de numéro

Génial Qid, je viens d'apprendre un truc.
Champagne ! big_smile


« C'est en voyant un moustique se poser sur ses testicules qu'on réalise qu'on ne peut pas régler tous les problèmes par la violence. »
VOYAGER X8 Debian Jessie

Hors ligne

#11 Le 05/04/2015, à 09:44

Qid

Re : Faut-il installer Ubuntu 14.04, 14.04.1 ou 14.04.2 ou 14.04.3 ?

Tohubohu a écrit :
Qid a écrit :

Mais non  roll  roll  ... ... et le schéma est pourtant clair même si il ne donne plus de numéro

Génial Qid, je viens d'apprendre un truc.
Champagne ! big_smile

T'insinues quoi là ? Je suis pas sûr de bien saisir le sens de ton post
Moi en tous cas je maintiens que le schéma est mal compris et qu'il risque de faire circuler une salle idée fausse...
mais c'est vrais que ce ne serait pas la première ... là ou c'est dommage c'est quand comme c'est le cas dans cette discussion
ces idées fausses viennent de connaisseurs ... alors oui ça me fait réagir et souvent peut-être de façon disproportionnée
mais en même temps si t'as une solution miracle pour étouffer dans l'oeuf puisque là on a en plus cet avantage là je suis preneur...


"GNU/Linux c'est que du bon mais M$ Windows ce n'est pas si mal"
Référent technique d'un Groupe d'Utilisateur du Libre
plus d'info sur mon profil

Hors ligne

#12 Le 05/04/2015, à 10:11

Tohubohu

Re : Faut-il installer Ubuntu 14.04, 14.04.1 ou 14.04.2 ou 14.04.3 ?

Qid a écrit :

T'insinues quoi là ? Je suis pas sûr de bien saisir le sens de ton post

Je me suis relu et ça peut paraître sarcastique. Mais c'est pas l'intention, désolé.
J'ai vraiment appris quelque chose d'intéressant et d'important à savoir. Merci Qid.


« C'est en voyant un moustique se poser sur ses testicules qu'on réalise qu'on ne peut pas régler tous les problèmes par la violence. »
VOYAGER X8 Debian Jessie

Hors ligne

#13 Le 05/04/2015, à 11:19

Qid

Re : Faut-il installer Ubuntu 14.04, 14.04.1 ou 14.04.2 ou 14.04.3 ?

Tohubohu a écrit :
Qid a écrit :

T'insinues quoi là ? Je suis pas sûr de bien saisir le sens de ton post

Je me suis relu et ça peut paraître sarcastique. Mais c'est pas l'intention, désolé.
J'ai vraiment appris quelque chose d'intéressant et d'important à savoir. Merci Qid.

c'est tout ce que je voulais vérifier wink il n'y a pas de souci on est là pour ça pourvu de ne pas induire les nouveaux en erreur ...


"GNU/Linux c'est que du bon mais M$ Windows ce n'est pas si mal"
Référent technique d'un Groupe d'Utilisateur du Libre
plus d'info sur mon profil

Hors ligne

#14 Le 05/04/2015, à 11:32

Caribou22

Re : Faut-il installer Ubuntu 14.04, 14.04.1 ou 14.04.2 ou 14.04.3 ?

Qid a écrit :
Caribou22 a écrit :
SilentStorm a écrit :

c'est juste le noyau linux qui est supporté moins longtemps, tout le reste (environ 99% de votre système) est supporté jusqu’à 2019

Bonjour,
Et question simple : Qu'est-ce que l'absence de support de ce 1% restant implique ? (Notamment au niveau de la sécurité. Cela veut dire que les éventuelles failles de sécurité du noyau ne seront plus corrigées ?)

Mais non  roll  roll  ... ... et le schéma est pourtant clair même si il ne donne plus de numéro :
il dit juste que si vous faites vos mises à jours correctement soit vous êtes sur la branche 3.13 et vous le gardez jusqu'à la fin
Soit vous êtes sur celle du 3.16 et lui sera mis à jour en août 2016 sauf que entre nous si je ne m'abuse en août 2016 la lts suivante sera sortie

C'est ce que j'avais compris smile Mais si l'on est sur le noyau 3.16, que se passe t'il après aout 2016 si l'on reste sur cette LTS ? (que l'on fait rien en fait)
Problèmes de sécurité ?

Hors ligne

#15 Le 05/04/2015, à 12:39

Qid

Re : Faut-il installer Ubuntu 14.04, 14.04.1 ou 14.04.2 ou 14.04.3 ?

Caribou22 a écrit :

si l'on est sur le noyau 3.16, que se passe t'il après aout 2016 si l'on reste sur cette LTS ? (que l'on fait rien en fait)
Problèmes de sécurité ?

certain vont encore s'étonner que je sorte de mes gonds mais si le "on ne fait rien" sous entend quand même
que vous faites bien vos mise à jours normalement ce qui devrait toujours être le cas ! je ne vois pas ou est le problème ...
suffi de regarder le schéma équivalent de la 12.04 que je vais donc expliquer pour que les choses ne soit pas mal interprétées :

- la 12.04 était sortie en avril 2012 avec le kernel 3.2
- la 12.04.1 du mois d’août 2012 était encore avec le même kernel 3.2
- la 12.04.2 du mois de février 2013 elle par contre a été livrée en ISO avec le kernel 3.5 mais par mise à jour elle restait avec le premier kernel 3.2
- la 12.04.3 du mois d'août 2013 quant à elle était livrée en ISO avec le kernel 3.8
mais si vous arriviez dessus par mise a jour elle restait avec le kernel de la branche avec laquelle l'install avait été faite
- la 12.04.4 du mois de février 2014 quant à elle était livrée en ISO avec le kernel 3.11
mais si vous arriviez dessus par mise a jour elle restait avec le kernel de la branche avec laquelle l'install avait été faite
- enfin venait la 12.04.5 du mois d'août 2014 livrée avec le kernel 3.13 que ce soit en ISO ou par mise à jour
à partir du moment ou votre install d'origine n’était pas une 12.04 ou .1 si tel était le cas vous gardiez votre kernel 3.2 de départ

donc après transposition :

- la 14.04 était sortie en avril 2014 avec le kernel 3.13
- la 14.04.1 du mois d’août 2014 était encore avec le même kernel 3.13
- la 14.04.2 du mois de février 2015 elle par contre a été livrée en ISO avec le kernel 3.16 mais par mise à jour elle reste avec le premier kernel 3.13
- la 14.04.3 du mois d'août 2015 quant à elle sera livrée en ISO avec un kernel supérieur
mais si vous restez dans le circuit des mises a jour elle restera avec le kernel de la branche avec laquelle l'install avait été faite
- la 14.04.4 du mois de février 2016 quant à elle sera livrée en ISO avec un kernel supérieur différent
mais si vous arrivez dessus par mise a jour elle restera avec le kernel de la branche avec laquelle l'install avait été faite
- enfin viendra la 14.04.5 du mois d'août 2016 livrée avec un kernel encore supérieur que ce soit en ISO ou par mise à jour
à partir du moment ou votre install d'origine n’était pas une 14.04 ou .1 si tel était le cas vous garderez votre kernel 3.13 de départ

en passant après lecture de cette transcription des 2 schémas dévolution dans LTS mais qui resteront très certainement valide pour les suivante
merci de noté que le kernel des LTS.5 d'origine non LTS ou LTS.1 n'est rien de plus que le kernel de base de la LTS suivante
d'ailleurs pendant qu'on y est j'ai pas été vérifier mais par hasard le kernel de la 12.04.2 ne serait pas celui de la 12.10
et celui de la 12.04.3 celui de la 13.04 et pour finir celui de la 12.04.4 celui de la 13.10 ?

alors si effectivement par déduction c'est justement pour cette raison que les .2 3 et 4 ne sont donc pas des LTS comme je l'ai lu sur un autre sujet
excusez moi de trouver totalement réducteur de considérer une distribution juste d'après son kernel quand bien même une distribution sans kernel n'est rien

voilà sur ce je pense que grâce à ce post je vais pouvoir expliquer clairement sur l'autre sujet qui m'a amené ici ce qu'il en est réellement ...

Dernière modification par Qid (Le 05/04/2015, à 12:55)


"GNU/Linux c'est que du bon mais M$ Windows ce n'est pas si mal"
Référent technique d'un Groupe d'Utilisateur du Libre
plus d'info sur mon profil

Hors ligne

#16 Le 06/04/2015, à 07:59

malbo

Re : Faut-il installer Ubuntu 14.04, 14.04.1 ou 14.04.2 ou 14.04.3 ?

Qid a écrit :

- enfin venait la 12.04.5 du mois d'août 2014 livrée avec le kernel 3.13 que ce soit en ISO ou par mise à jour
à partir du moment ou votre install d'origine n’était pas une 12.04 ou .1 si tel était le cas vous gardiez votre kernel 3.2 de départ

Peut-être qu'il manque un bout de phrase dans cette partie-là mais moi je ne comprends pas ce que ça veut dire. Peux-tu détailler ?

Hors ligne

#17 Le 06/04/2015, à 08:50

Qid

Re : Faut-il installer Ubuntu 14.04, 14.04.1 ou 14.04.2 ou 14.04.3 ?

C'est mon retour à la ligne manuel qui joue des tours dans la compréhension de cette phrase ?


"GNU/Linux c'est que du bon mais M$ Windows ce n'est pas si mal"
Référent technique d'un Groupe d'Utilisateur du Libre
plus d'info sur mon profil

Hors ligne

#18 Le 06/04/2015, à 09:18

malbo

Re : Faut-il installer Ubuntu 14.04, 14.04.1 ou 14.04.2 ou 14.04.3 ?

Puisque tu ne comprends pas ce que je ne comprends pas, on va faire autrement : tu laisses entendre qu'après la sortie de 12.04.5 au mois d’août 2014, il y a eu passage au kernel 3.13 par mise à jour pour ceux qui avaient un noyau 3.5 ou 3.8 ou 3.11 mais ce n'est pas exact : ce passage s'est fait uniquement par mise à niveau (et pas par mise à jour) comme je l'ai expliqué dans le post #3

Dernière modification par malbo (Le 06/04/2015, à 09:20)

Hors ligne

#19 Le 06/04/2015, à 09:53

Qid

Re : Faut-il installer Ubuntu 14.04, 14.04.1 ou 14.04.2 ou 14.04.3 ?

malbo a écrit :

ce n'est pas exact : ce passage s'est fait uniquement par mise à niveau (et pas par mise à jour)

Ce jeu de mot me casse les pieds au plus haut au point tu peux pas savoir ...
une mise à jour juste par apt-get upgrade n'est jamais réellement complète... un upgrade ne devrait jamais aller sans un dist-upgrade...
pour rappel la différence entre les 2 est que le premier ne fait la mise à jour que des paquets "complets" alors que
le second fait aussi la mise à jour des paquets qui nécessite l'installation de paquet supplémentaire pour fonctionner
Sans compter que nous en temps que connaisseurs on sait faire la différence entre mise à niveau et migration mais pas les débutants de toutes évidences
Puisque dans la série idée fausse à combattre combien de fois j'ai lu que le dist-upgrade fait passer d'une version X à une version X+1 !?
donc oui moi j'ai pris le contrepied de raccourcir les choses en disant que la mise à jour se fait avec dist-upgrade ...
de toutes façons comme en plus c'est bien le dist-upgrade que fait l'interface graphique de gestion des mise à jour ...

Dernière modification par Qid (Le 06/04/2015, à 09:59)


"GNU/Linux c'est que du bon mais M$ Windows ce n'est pas si mal"
Référent technique d'un Groupe d'Utilisateur du Libre
plus d'info sur mon profil

Hors ligne

#20 Le 06/04/2015, à 10:13

jplemoine

Re : Faut-il installer Ubuntu 14.04, 14.04.1 ou 14.04.2 ou 14.04.3 ?

Qid a écrit :

Ce jeu de mot me casse les pieds au plus haut au point tu peux pas savoir ...

Sauf que ce n'est pas un jeu de mot mais une réalité....
Il faut savoir de quoi on parle : une mise à jour est une mise à jour (et il y en a de 2 types) et une mise à niveau est un mise à niveau.
Par contre, je pense qu'il y a HWE au milieu qui fait que l'on change de noyau en faisant une mise à jour (ce qui est quelque part contradictoire) si l'on a installé les X.Y.2 ou pour les version X.Y et X.Y.1 que l'on a installé le paquet qui va bien.
Donc, je suis d'accord avec malbo (enfin, je crois) : il vaut mieux installer une X.Y ou une X.Y.1 et garder le noyau LTS. Ce n'est que si l'on a besoin du noyau supérieur (prise en charge de matériel récent, par exemple) que l'on installera une X.Y.2 ou supérieur.
Si l'on installe HWE, on a une partie du système qui est sur un cycle non-LTS, il faudra donc faire bien attention de le garder à jour en fonction des versions.


Membre de l'ALDIL (Association Lyonnaise pour le Développement de l'Informatique Libre)
- En pro, après 20 ans de développement, administrateur Linux / Unix depuis Avril 2019.
- En privé, sous Ubuntu-Xubuntu depuis 2009.

En vacances du forum jusqu’à nouvel ordre

Hors ligne

#21 Le 06/04/2015, à 10:54

Qid

Re : Faut-il installer Ubuntu 14.04, 14.04.1 ou 14.04.2 ou 14.04.3 ?

jplemoine a écrit :

Si l'on installe HWE, on a une partie du système qui est sur un cycle non-LTS, il faudra donc faire bien attention de le garder à jour en fonction des versions.

Et c'est reparti... je ne dis pas que vous avez tort je dis juste qu'il faut adapter son discourt au public
pour éviter les embrouilles et les incompréhension qui bien souvent font naître des idées fausses ...
du coup ce genre de considération n'a que moyennement lieu d'être ...

d'autant que comme je l'ai dit soit tu fais ta mise à jour avec l'interface graphique de gestion des mises à jour qui en réalité équivaut à un dist-upgrade
soit comme la plupart d'entre nous tu la fais en ligne de commande avec upgrade et elle n'est pas complète alors qu'elle l'est avec un dist-upgrade

En tous cas ce n'est certainement pas le kernel qui défini la durée de vie d'une distribution ou en tous cas il est loin d'être le seul
donc quand bien même comme j'en ai émis l'hypothèse la 12.04.4 utiliserait le kernel de la 13.10 ce n'est pas pour ça que la 12.04.4 n'est plus une lts

Et sur le principe comme un système devrait toujours être à jour non seulement dans mon gul on ne tien pas du tout compte de vos considérations actuelles
mais on va même plus loin que ça en ne parlant pas de durée de vie des distributions puisque ce développement à 2 vitesses est moyenne compréhensible
quand on nous pose la question on répond en donnant la date de naissance de la prochaine et non la date de mort de la lts qu'on propose
c'est d'ailleurs comme ça aussi que si le cas se présente on préfèrera installer les X.10 précédent une LTS plutôt que les LTS qui ont déjà dépassé les 3/4 de leur vie
et ça je peux vous assurer que présenté comme on le fait c'est même presque une demande logique du public plutôt que notre choix réel

Pour résumer pour moi à vouloir trop comprendre vous vous compliquez la vie et en prime vous risquez donc de la compliquer aux nouveaux arrivants
Pour monsieur et madame Michu en temps que représentant dans la promotion de linux et du logiciel libre on se doit de rester simple et accessible


"GNU/Linux c'est que du bon mais M$ Windows ce n'est pas si mal"
Référent technique d'un Groupe d'Utilisateur du Libre
plus d'info sur mon profil

Hors ligne

#22 Le 06/04/2015, à 11:43

jplemoine

Re : Faut-il installer Ubuntu 14.04, 14.04.1 ou 14.04.2 ou 14.04.3 ?

Qid a écrit :

Pour monsieur et madame Michu en temps que représentant dans la promotion de linux et du logiciel libre on se doit de rester simple et accessible

Et donc pour rester simple : on installe la 14.04 ou la 14.04.1 et on fait les mises à jour. Et Ça ne revient pas au même qu'installer les 14.04.X suivantes.


Membre de l'ALDIL (Association Lyonnaise pour le Développement de l'Informatique Libre)
- En pro, après 20 ans de développement, administrateur Linux / Unix depuis Avril 2019.
- En privé, sous Ubuntu-Xubuntu depuis 2009.

En vacances du forum jusqu’à nouvel ordre

Hors ligne

#23 Le 06/04/2015, à 12:24

Qid

Re : Faut-il installer Ubuntu 14.04, 14.04.1 ou 14.04.2 ou 14.04.3 ?

jplemoine a écrit :

on installe la 14.04 ou la 14.04.1 et on fait les mises à jour. Et Ça ne revient pas au même qu'installer les 14.04.X suivantes.

J'abandonne... et je resterai avec ma question :
Mais alors pourquoi existe t'il des iso des .2 3 4 et 5 ?
Qu'on zappe les non lts ça oui effectivement
mais qu'on zappe les iso à jour des lts alors là par contre ...


"GNU/Linux c'est que du bon mais M$ Windows ce n'est pas si mal"
Référent technique d'un Groupe d'Utilisateur du Libre
plus d'info sur mon profil

Hors ligne

#24 Le 06/04/2015, à 12:39

Nicolas St

Re : Faut-il installer Ubuntu 14.04, 14.04.1 ou 14.04.2 ou 14.04.3 ?

Moi je reste en 3.13 si je veux moins toucher à mon système le moins possible, et cela rejoint quand même la philosophie des LTS.

Je suis passé en 3.16, puis revenu en 3.13 car j'avais des problèmes de dépendances après avoir "upgrader" de noyau.

#25 Le 10/04/2015, à 08:48

Blek85

Re : Faut-il installer Ubuntu 14.04, 14.04.1 ou 14.04.2 ou 14.04.3 ?

Bonjour à tous,

C'est M. Michu qui passe par là et vient vous dire bonjour et merci pour l'aide que vous apportez. wink

Effectivement, la différence entre les notions de mise à jour et de mise à niveau m'échappent un peu.

Pour essayer d'y voir un peu clair quant au niveau de ma distribution et de ses mises à... jour ou à niveau
je suis allé fouiller un peu dans ma mémoire et surtout dans celle de mon ordi :
− J'ai installé la version Xubuntu Voyager 14.04.3.
− La version d'Ubuntu renvoyée par le système est 14.04.2
− La version du noyau est 3.13.0-49-generic i686 (32 bit)
Les précisions sur ma version

Voyager 14.04.03 est basé sur XUbuntu 14.04.01 LTS Trusty Tahr qui aura pour cycle 2 ans avant la prochaine LTS et 3 ans de supports pour Xubuntu LTS, 5 pour l'officiel Ubuntu. Nouveautés : Voyager arrête les cycles courts de 6 mois pour la LTS de 2 ans avec correctifs et patchs à disposition pendant ces 2 années ou d'autres versions

je les ai obtenues ici (merci Rodofr)

Alors détendez-vous, le M. Michu que je suis n'est pas trop inquiet.
Mais ce fil va m'inciter à me documenter plus sérieusement sur les finesses des différentes méthodes d'acquisition d'améliorations du système.

Dernière modification par Blek85 (Le 10/04/2015, à 08:49)


CM MSI B75A-G43 (MS-7758) / Intel G2030 3 GHz / 4 Go Kingston DDR3 1333 MHz / NVIDIA GT620 / 2 HD 500 Go
Macros et API Apache OpenOffice 4.1.2 sous Xubuntu Voyager 14.04.04

Hors ligne