Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 30/09/2015, à 16:09

Thatoo

[Tutorial] Installation d'Ubuntu 14.04 sur Asus K501LX et V502LX

Avant de lire plus avant, merci de prendre en considération que mon ordinateur est la version persane du K501LX. C'est le V502LX. Les différences sont minimes je crois, comme par exemple le clavier, le mien est en persan et ne possède pas de rétro-éclairage, je ne peux donc pas vous aidez avec ça. Si des erreurs d'accents ce sont glissé dans ma traduction, merci de m'en excuser car je travaille avec un clavier irano-anglais (je me perds un peu dans les copier/coller).

J'ai installé Ubuntu 14.04 car je fais plus confiance à la LTS.

Pour installer la dernière version du pilote de la carte graphique nvidia, vous devez ajouter le PPA graphics-drivers/ppa à vos sources de logiciels .

sudo add-apt-repository -y ppa:xorg-edgers/ppa
sudo apt-get update

Ensuite,
Assurez vous que  bumblebee n'est pas installé, vérifiez dans synaptec et entrez aussi cette commande pour être certain

sudo apt-get purge bumblebee* primus libvdpau-va-gl1

Puis vous pouvez installer Prime

sudo apt-get install nvidia-prime mesa-utils vdpau-va-driver

Ensuite
Pour installer le pilote NVIDIA propriétaire, il est vivement recommandé d'utiliser le gestionnaire de pilotes propriétaires (voir ici https://doc.ubuntu-fr.org/nvidia#via_les_depots_ubuntu)
Sinon, vous entrez la commande suivante

sudo apt-get install nvidia-355

Puis, vous devez installer "nvidia-settings" avant de redémarrer

sudo apt-get install nvidia-settings
sudo reboot

Les deux cartes graphiques devraient fonctionner désormais. Vous pouvez changer de carte graphique dans le logiciel "Nvidia setting".
Vous pouvez aussi installer "prime-indicator", un raccourci mais je ne le recommande pas car il ne fait que fermer la session, ce qui suffit pour passer de Nvidia à Intel mais est insuffisant pour passer de Intel à Nvidia (ca bug). Il vaut mieux redémarrer.

sudo add-apt-repository ppa:kranich/cubuntu
sudo apt-get update
sudo apt-get install prime-indicator

Si vous ne pouvez pas contrôler la luminosité depuis les "Paramètres Systèmes", suivez ce qui suit.
(source : http://ubuntuforums.org/showthread.php?t=2028269 and http://itsfoss.com/fix-brightness-ubuntu-1310/)

Dans /etc/X11/xorg.conf
sudo gedit /etc/X11/xorg.conf

Ajoutez

Option "RegistryDwords" "EnableBrightnessControl=1"

en dessous de

Section "Device" 
    Identifier "nvidia" 
    Driver "nvidia" 
    BusID "PCI:4@0:0:0"

et, dans /usr/share/X11/xorg.conf.d/20-intel.conf

sudo gedit /usr/share/X11/xorg.conf.d/20-intel.conf

ajoutez

Section "Device" 
    Identifier "intel" 
    Driver "intel" 
    BusID "PCI:0@0:2:0" 
    Option "AccelMethod" "SNA" 
    Option "Backlight" "intel_backlight" 
EndSection

Pour ma part, le contrôle de la luminosité fonctionne dans les "Paramètres Systèmes", mais les raccourcis claviers (fn f5/f6) ne fonctionne pas. Vous pouvez les remplacer par super+f5/f6 en ajoutant vous même le raccourci.

sudo apt-get install xbacklight

Dans les raccourcis claviers, vous pouvez ajouter un raccourci lié à la commande suivante afin de diminuer la luminosité

xbacklight -dec 10

et un autre à la commande suivante pour accroître la luminosité

xbacklight -inc 10

Si vous souhaitez que la luminosité ne démarre pas au maximum, vous pouvez ajouter la commande suivante  dans les « applications au démarrage »,

xbacklight -set 40

(40 cest pour 40 % mais vous pouvez changer pour la valeur que vous souhaitez)

Pour que le raccourci clavier du wifi, le seul à ne pas fonctionner en plus des contrôles de la luminosité, suivez ce qui suit (source : http://forum.ubuntu-fr.org/viewtopic.php?id=1770081)

sudo gedit /etc/default/grub

Remplacez dans le fichier, la ligne suivante

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

par

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi="

Sauvegardez et ajoutez dans votre terminal la commande suivante pour mettre à jour le Grub

sudo update-grub

Redémarrez votre ordinateur et le raccourci claviers devrait fonctionner.

Pour que le "Touchpad" fonctionne, vous devez
soit
installer le pilote
sudo add-apt-repository ppa:hanipouspilot/focaltech-dkms
sudo apt-get update
sudo apt-get install focaltech-dkms
Then reboot, or do this to get things working instantly, as documented in README:
Code:
sudo modprobe -r psmouse
sudo modprobe psmouse

soit
mettre à jour le kernel
J'ai suivit ce tutoriel pour trouver la solution, https://forum.ubuntu-fr.org/viewtopic.php?id=1891911
mais c'est dans celui-la qu'on explique comment installer le nouveau kernel, pour ma part le kernel 4.1.6 : http://www.yourownlinux.com/2015/08/how … linux.html
Pour ma part, ça fonctionne plutôt bien! Il y a une petite erreur de conflit entre le kernel et le pilote de la carte graphique au démarrage mais rien de dramatique (ça devrait disparaître avec l'installation de futur kernel)
“Error parsing PCC subspaces from PCCT”

Dans les deux cas, ça fonctionne.
Cela dit, n’espérez pas le zoom ou la rotation avec vos deux doigts...
Le soucis le plus ennuyant pour l'heure c'est que le "Touchpad" ne répond plus après la mise en suspension de l'ordinateur. Il faut redémarrer l'ordinateur pour retrouver l'usage du "Touchpad"
Pourtant, avant la mise en suspension, il est possible de désactiver puis réactiver le "Touchpad" à l'aide du raccourci clavier fn/f9.

J'ai trouvé une solution à un problème similaire ici mais ça ne fonctionne pas complètement, voir résultat plus bas, http://ubuntuforums.org/showthread.php?t=2182922&page=2

il faut créer et ouvrir /etc/pm/sleep.d/0000trackpad

sudo gedit /etc/pm/sleep.d/0000trackpad

et ajouter

#!/bin/sh 
case "$1" in 
    suspend|hibernate) 
        modprobe -r psmouse; 
    resume|thaw) 
        modprobe psmouse; 
esac 

et sauver le fichier.
Maintenant, l'ordinateur refuse de se mettre en veille à cause du conflit avec le "Touchpad" donc vous ne perdrez plus l'utilisation de votre "Touchpad" mais ça signifie aussi que vous ne pouvez pas suspendre l’activité de votre ordinateur.
Des gens ont un problème similaire avec un clavier Elantech, https://bugs.launchpad.net/ubuntu/+sour … ug/1490130 .
Mon clavier est un Focaltech.
J'ai renseigné un bug ici https://bugs.launchpad.net/ubuntu/+sour … ug/1504445 et j'en parle sur ce forum, https://forum.ubuntu-fr.org/viewtopic.p … #p20704431 mais aussi sur un autre forum en anglais, http://ubuntuforums.org/showthread.php? … st13364663

Dernière modification par Thatoo (Le 09/10/2015, à 16:41)

Hors ligne