Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 07/07/2016, à 01:45

parazitenew

[Résolu] Impossible de me connecter en SFTP

Bonsoir,

Je suit ce TUTO pour créer un serveur sftp. J'utilise un laptop sous Ubuntu 16.04 comme serveur, et un desktop sous Windows 7 comme client. Le logiciel utilisé est FileZilla. Tout en LAN.

La partie FTP s'est bien déroulée. Je n'ai aucun problème à me connecter en FTP depuis Windows sur mon laptop ubuntu.

Là où ça se corse, c'est la partie SFTP. Lorsque j'essaye de me connecter ça ne marche pas.

Erreur :    Network error: Software caused connection abort
Erreur :    Impossible d'établir une connexion au serveur

J'ai essayé de passer en mode actif sur FileZilla:

Erreur :    Network error: Connection refused
Erreur :    Impossible d'établir une connexion au serveur

Lorsque j'essaye de me connecter depuis le serveur même (laptop)

Connection reset by peer
Impossible d'établir une connexion au serveur

Alors qu'en FTP ça marche toujours.

J'ai cherché sur le net une solution, rien de concluant. J'ai commencé à 16h00, il est 01h46, je suis claqué et je viens de dîner il y a 15 minutes.

Pouvez vous m'aider s'il vous plait?

Dernière modification par parazitenew (Le 09/07/2016, à 17:11)

Hors ligne

#2 Le 07/07/2016, à 08:12

alexandre958

Re : [Résolu] Impossible de me connecter en SFTP

Salut ça va?  Ce tutoriel à l'aire assez complet.
Si tu as le FTP c'est déjà ça de fait.

As tu remarqué que le sftp utilise le port 22 et non 21?
As tu changé les règles de ton firewall? Pour les afficher tu écris ça dans la console :

sudo iptables -L

Tu devait avoir 3 catégories qui sont vides et écrit entre parenthèse ACCEPT à côté de chaque catégorie.

Tu n'a oublié aucune ligne à decommenter?

Si tu n'a rien qui tourne sur ton laptop, l'as tu redémarrer
?

Dernière modification par alexandre958 (Le 07/07/2016, à 08:13)


May the 4th be with you

Hors ligne

#3 Le 07/07/2016, à 09:50

parazitenew

Re : [Résolu] Impossible de me connecter en SFTP

Bonjour,

J'ai essayé avec le port 22 naturellement. J'ai même tenté de changer de port, (en prenant soin de le modifier d'abord dans le fichier sshd_config), même chose.
iptables -L me m'affiche bien les 3 catégories avec (policy accepte).
Le pare-feu windows est désactivé. C'est celui de Kaspersky qui tourne. Même en le désactivant il m'est impossible de me connecter.
J'ai redémarré mon laptop, aucun changement.

Hors ligne

#4 Le 07/07/2016, à 09:58

Oni_Shadow

Re : [Résolu] Impossible de me connecter en SFTP

la connexion en SSH fonctionne-t-elle?


Rouillé

Hors ligne

#5 Le 07/07/2016, à 11:44

alexandre958

Re : [Résolu] Impossible de me connecter en SFTP

Salut,

Je viens de trouver cette discussion.
Regarde le 2 ème message il explique que le dossier doit être sous la propriété de root depuis la racine jusqu'au dossier.

http://ubuntuforums.org/showthread.php?t=1482005

Dernière modification par alexandre958 (Le 07/07/2016, à 11:44)


May the 4th be with you

Hors ligne

#6 Le 07/07/2016, à 12:55

jlmas

Re : [Résolu] Impossible de me connecter en SFTP

La connexion au FTP est fournie par le service VSFTPD sur le serveur ubuntu
La connexion au SFTP est fournie par le service SSHD  sur le serveur ubuntu

Ce sont deux services totalement différents qui ne sont pas a l'écoute sur le même port.

Pour faire fonctionner un  serveur SFTP sous ubuntu, la seule chose à faire est celle ci

sudo apt-get install openssh-server

Le reste du tuto c'est de la configuration, mais avant de configurer il faut tester.
A partir de Windows avec putty (ftp://ftp.chiark.greenend.org.uk/users/ … /putty.exe), tu te connectes avec ton utilisateur ubuntu et ton mot de passe ubuntu. Si ça ne fonctionne pas tu as un soucis de réseau, et il y a fort à parier que ça ne vienne pas d'Ubuntu.

Commence par ça, ensuite on pourra t'aider sur la configuration plus fine

Hors ligne

#7 Le 07/07/2016, à 17:34

parazitenew

Re : [Résolu] Impossible de me connecter en SFTP

Bonjour,

Merci pour vos réponses.

J'ai testé le SSH depuis mon desktop (Ubuntu virutel avec Vmware Workstation), je ne pouvais me connecter qu'avec un seul compte, le mien, le principal.Les deux autres comptes que j'ai crée pour les besoins du tuto ne pouvaient pas y accéder. ça m'a mit la puce à l'oreille, les deux comptes de teste sont Chroot (comme le tuto l'a préconisé). En désactivant le Chroot rien n'a changé. J'ai remis alors comme c'était. Et j'ai compris que ce paramètre n'affecte que le FTP et non le SFTP, comme l'a dit Jlmas, ceux sont deux services différents. Je comprends mieux.

Ensuite, j'ai lu le message d'Alexandre. C'était bien ça. En mettant comme sur le tuto:

krizna@leela:~$ sudo chown root /home/john
krizna@leela:~$ sudo mkdir /home/john/www
krizna@leela:~$ sudo chown john:ftpaccess /home/john/www

J'ai pu accéder au serveur en SFTP avec FileZilla, mais toujours pas en SSH.

ssh michou@192.168.1.4 -p 222
michou@192.168.1.4's password:
This service allows sftp connections only.
Connection to 192.168.1.4 closed.

Je ne sais pas si c'est très grave. Il reste tout de même des ambiguïtés.

En donnant les droits du dossier /home/michou à root, l'utilisateur michou ne peut rien y écrire, il peut juste voir son contenu. Quel est l'intérêt? Puisque le dossier /home lui même appartient à root, pourquoi sommes nous obligé de crée un autre dossier à l'intérieur même de /home/michou. Comme sur le tuto, pourquoi aller jusqu'à créer un dossier www pour que john puisse travailler? Pourquoi ne pas simplement donner john à john? C'est le SFTP qui fonctionne ainsi?

Autre chose d'étrange:

ls -l
drwx r-x r-x 2 root ftpaccess 4096 Juil. 7 16:42 kadour
drwx r-x r-x 3 root ftpaccess 4096 Juil. 7 16:36 michou

Le répertoire /home/michou et /home/kadour sont bien propriétés de root, néanmoins toute personne faisant partie du groupe ftpaccess peut y lire des fichiers d'après les droits d'accès (r-x), donc logiquement le voir. Mais ce n'est pas le cas.

Hors ligne

#8 Le 07/07/2016, à 19:37

Elder

Re : [Résolu] Impossible de me connecter en SFTP

Salut,
Le fait que le ssh "normal" ne fonctionne pas vient de la directive :

ForceCommand internal-sftp

et du fait que tes utilisateurs n'ont pas de shell de connexion (/usr/sbin/nologin)
Personnellement je préfère utiliser /bin/false et ne pas modifier /etc/shells.

Dans ton cas on peut voir que les utilisateurs sont dans le même groupe avec des droits en lecture, donc il est théoriquement possible pour un utilisateur de lire le contenu du dossier d'un autre utilisateur et ce qui peut être lu peut être copié (bon ssh fait un chroot donc normalement chaque utilisateur tombe dans son dossier utilisateur et ne peut pas descendre plus bas).
Personnellement je préfère utiliser la syntaxe suivante dans /etc/ssh/sshd_config:

Match Group sftpusers
         ChrootDirectory ~/sftp_files/
         ForceCommand internal-sftp -l INFO -f AUTH # les options de la commande ne sont pas obligatoire, c'est pour ajouter des info dans les logs
         AllowTCPForwarding no
         X11Forwarding no
                          

Dans mon cas les dossier utilisateurs (/home/user) appartiennent à root:root et les dossier sftp_files à chaque utilisateurs individuellement.
Je me pose une question : Ftp étant une passoire et sftp sécurisé pourquoi les faire atterrir au même endroit ?

@+
Elder

Hors ligne

#9 Le 07/07/2016, à 23:17

parazitenew

Re : [Résolu] Impossible de me connecter en SFTP

Bonsoir,

@Elder, oui en théorie les utilisateurs du groupe ftpaccess peuvent voir les répertoires des uns et des autres mais ce n'est pas le cas. J'ai pu y remédié en mettant ceci dans /etc/ssh/sshd_config:

ChrootDirectory /home

Le problème qui s'en est suivi, est que les utilisateurs peuvent lire et exécuter des fichiers à partir du répertoire de l'utilisateur principal, pour y remédier j'ai juste enlevé les droits:

chmod o-rx /home/imed

Le répertoire est visible sur FileZilla mais les utilisateurs ne peuvent pas voir ce qu'il y a dedans.

Pour ta question, je m'étais mis en tête de bloquer l'accès aux utilisateurs au serveur via le protocole FTP. J'ai pu le faire en ajoutant leur noms dans:

/etc/ftpusers

smile

Hors ligne