Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#51 Le 08/08/2016, à 16:09

superjp

Re : [Résolu] pas de wifi avec une carte realtek RTL8723be

bon je viens de faire les mises à jour mais toujours rien je te remercie pour les efforts fait pour trouver les solutions, c aussi pour ça que sur un autre post je demandais si il existait des clés wifi  usb compatible à l’installation d'ubuntu " https://forum.ubuntu-fr.org/viewtopic.p … #p21567079 " mais ça à l'aire dans énerver certain je pensais ma demande utile pour moi et d'autre personne ayant des problèmes de wifi

Hors ligne

#52 Le 08/08/2016, à 16:20

Naziel

Re : [Résolu] pas de wifi avec une carte realtek RTL8723be

Tu as essayé le petit edit du message précédent?
J'en propose d'autres:

sudo modprobe -r rtl8723be
sudo modprobe rtl8723be fwlps=0 ips=0 ant_sel=2
sudo modprobe -r rtl8723be
sudo modprobe rtl8723be fwlps=0 ips=0 ant_sel=1
sudo modprobe -r rtl8723be
sudo modprobe rtl8723be ant_sel=2

J'avais pas vu l'autre post.
Cette carte wifi pose beaucoup de problèmes mais tu as un supplément agaçant par rapport aux autres: le module acer_wmi maintenant désactivé

Dernière modification par Naziel (Le 08/08/2016, à 16:35)

Hors ligne

#53 Le 08/08/2016, à 16:28

superjp

Re : [Résolu] pas de wifi avec une carte realtek RTL8723be

de toute façon je te remercie on a déja avancé avant j'avais rien, tu as vu comment que ce module était activé ?

Hors ligne

#54 Le 08/08/2016, à 16:33

Naziel

Re : [Résolu] pas de wifi avec une carte realtek RTL8723be

lsmod liste les modules activés, rtl8723be y est. Sinon, lspci -k montre que rtl8723be est utilisé pour la carte wifi. Et pour le module acer_wmi, j'ai compris que c'était un conflit quand tu as parlé du bouton grisé et que la carte était bloquée logiciellement même après l'avoir débloquée. J'ai remis des paramètres à tester sur le message précédent.

Dernière modification par Naziel (Le 08/08/2016, à 16:34)

Hors ligne

#55 Le 08/08/2016, à 16:42

superjp

Re : [Résolu] pas de wifi avec une carte realtek RTL8723be

Oui j'ai vu et fait mais toujours rien écoute je vais pas te prendre plus de temps c déjà très sympa que penses tu d'une clé usb wifi?

Hors ligne

#56 Le 08/08/2016, à 16:52

Naziel

Re : [Résolu] pas de wifi avec une carte realtek RTL8723be

Ça va forcément poser moins de difficultés que cette carte wifi. Après, je connais pas trop ce qui existe comme clés wifi, mais je te conseille vivement avant d'en acheter une de vérifier qu'elle est compatible avec linux (c'est pas écrit sur la boite mais cette page par exemple en donne une liste https://doc.ubuntu-fr.org/wifi_liste_carte)

Hors ligne

#57 Le 08/08/2016, à 17:13

superjp

Re : [Résolu] pas de wifi avec une carte realtek RTL8723be

Ok super merci pour votre aide

Hors ligne

#58 Le 10/08/2016, à 20:01

metalux

Re : [Résolu] pas de wifi avec une carte realtek RTL8723be

Bonsoir,
Il y a un P.P.A. à essayer en dernier recours:

sudo add-apt-repository ppa:hanipouspilot/rtlwifi
sudo apt-get update
sudo apt-get install  rtlwifi-new-dkms

Redémarrer ensuite la machine.
A combiner avec les différentes options (fwlps=0, ant_sel=2, etc...) afin de voir si la situation s'améliore.

Hors ligne

#59 Le 10/08/2016, à 20:57

superjp

Re : [Résolu] pas de wifi avec une carte realtek RTL8723be

Metalux incroyable ça fonctionne j'ai fait juste ta procédure sans rien faire d'autre derrière, plus qu'as regarder la stabilitée de la réception du signal ( pas de coupure ) en attendant un GRAND MERCI big_smile

Dernière modification par superjp (Le 10/08/2016, à 21:05)

Hors ligne

#60 Le 10/08/2016, à 22:09

metalux

Re : [Résolu] pas de wifi avec une carte realtek RTL8723be

Avais-tu compilé le module selon la procédure indiquée par xubu1957 ici?
Si oui, je pense qu'il aurait dû fonctionner sauf si tu as redémarré au lieu de recharger le module avec modprobe et que par malchance, tu as fais la mise à jour juste avant et qu'il y avait une nouvelle version du noyau.
En effet, la compilation doit être faite à chaque changement de noyau, et par expérience ça devient assez pénible à la longue quand il y a une maj du noyau tous les 15  jours. Aussi dans un cas pareil, soit il faut installer un noyau qui supporte cette carte nativement, encore faut-il qu'il existe, soit faire appel à Dkms qui compile automatiquement le module au changement de noyau.
Cette version étant Dkms, ce P.P.A. est à privilégier sur la compilation manuelle.
Si j'avais su je te l'aurais fais tester avant car j'avais le lien au chaud mais comme je n'avais pas testé moi-même et pris le temps de me renseigner sur le sérieux de ce P.P.A., je m'étais abstenu.
Je dois installer un HP avec cette carte qui n'a aucun signal, aussi ton expérience me servira. Sur mon Pc avec la même carte, seul fwlps=0 a été nécessaire. Comme quoi, elle est capricieuse mais une fois trouvé ce qu'il faut, j'en suis très satisfait. J'espère qu'il en sera de même pour toi.
Dis nous ce qu'il en est d'ici quelques jours, ça servira à la communauté.

Hors ligne

#61 Le 10/08/2016, à 22:21

superjp

Re : [Résolu] pas de wifi avec une carte realtek RTL8723be

j'ai des déconnections  de temps en temps et elle se reconnecte quand penses tu? mais maintenant j’accède au réseau et sur internet

Hors ligne

#62 Le 10/08/2016, à 22:25

Naziel

Re : [Résolu] pas de wifi avec une carte realtek RTL8723be

Génial!
Bravo metalux!

Hors ligne

#63 Le 10/08/2016, à 22:26

metalux

Re : [Résolu] pas de wifi avec une carte realtek RTL8723be

Commence par fwlps=0 seul.

Hors ligne

#64 Le 10/08/2016, à 22:44

superjp

Re : [Résolu] pas de wifi avec une carte realtek RTL8723be

du coup j'ai plus internet

Hors ligne

#65 Le 10/08/2016, à 23:02

metalux

Re : [Résolu] pas de wifi avec une carte realtek RTL8723be

Pas normal ça, fwlps=0 empêche la carte de se mettre en veille et évite de ce fait les déconnexions. Au pire ça ne fonctionne pas mais de là à ne plus avoir d'internet, j'ai du mal à tout comprendre.
Quand tu dis que tu n'as plus internet, est-ce que la box est toujours visible dans l'applet de Network-manager?

Hors ligne

#66 Le 10/08/2016, à 23:04

superjp

Re : [Résolu] pas de wifi avec une carte realtek RTL8723be

oui

Hors ligne

#67 Le 10/08/2016, à 23:06

metalux

Re : [Résolu] pas de wifi avec une carte realtek RTL8723be

Et tu n'arrives pas à te connecter à partir de là?

Hors ligne

#68 Le 10/08/2016, à 23:08

superjp

Re : [Résolu] pas de wifi avec une carte realtek RTL8723be

oui

Hors ligne

#69 Le 10/08/2016, à 23:11

superjp

Re : [Résolu] pas de wifi avec une carte realtek RTL8723be

et je réessaye #58

Hors ligne

#70 Le 10/08/2016, à 23:20

metalux

Re : [Résolu] pas de wifi avec une carte realtek RTL8723be

Non, pas besoin. A la réponse #58, il s'agit de l'ajout d'un dépôt et de l'installation du module dkms. Si il est installé, plus de besoin de le faire.
Essaye en retirant l'option fwlps=0, si ça fonctionnait avant, pas de raison que ça ne le fait plus.
Il restera à trouver les bonnes options pour stabiliser ta connexion mais à cette heure-ci je ne vais plus être de bon conseil roll.

Hors ligne

#71 Le 10/08/2016, à 23:28

superjp

Re : [Résolu] pas de wifi avec une carte realtek RTL8723be

ok moi aussi j'ai les yeux qui tombe mais comment tu fais pour retirer l'option fwlps

Hors ligne

#72 Le 10/08/2016, à 23:41

metalux

Re : [Résolu] pas de wifi avec une carte realtek RTL8723be

Comment l'as-tu ajoutée? Si c'est par le fichier /etc/modprobe.d/rtl8723be.conf tu le supprimes simplement:

sudo rm  /etc/modprobe.d/rtl8723be.conf

Si c'est de cette façon: sudo modprobe -r rtl8723be fwlps=0 tu passes les commandes:

sudo modprobe -r rtl8723be
sudo modprobe rtl8723be

En principe tu reviendras sur la configuration par défaut.

Hors ligne

#73 Le 11/08/2016, à 12:29

superjp

Re : [Résolu] pas de wifi avec une carte realtek RTL8723be

Bon avec la dernier manipulation j'ai de nouveau internet, je pense que j'ai du faire l'idiot quelque part smile

Hors ligne

#74 Le 11/08/2016, à 13:20

metalux

Re : [Résolu] pas de wifi avec une carte realtek RTL8723be

@superjp
Peux-tu poster le contenu de ton fichier de configuration?

cat /etc/modprobe.d/rtl8723be.conf

Ainsi que:

 systool -v -m rtl8723be

je reste quasi convaincu que si tu as des déconnexions, c'est ta carte qui se met en veille, problème courant avec le module rtl8723be.
Je profite pour mettre un petit tuto ci-dessous pour expliquer comment tester en live pour ceux qui liraient cette discussion:

TUTORIEL
Pour le Pc que je dois installer, j'ai testé en live suivant la procédure suivante sans passer par une connexion Ethernet. Ceci peut-être utile pour tous ceux qui sont confronté au même cas afin de pouvoir faire différents tests avant même d'installer.
1-Télécharger à partir d'un autre Pc le .deb du module----> Cliquez ici
2-Le mettre sur une clef USB
3-Démarrez le Pc avec le wifi non fonctionnel avec un Live. Installer le Deb présent sur la clef avec la commande:

sudo dpkg -i rtlwifi-new-dkms_0.10_all.deb

Bien ouvrir le terminal dans le dossier où se trouve le Deb, sinon il ne le trouvera pas. Plus simplement, l'installer en graphique avec l'application disponible sur le live ( testé avec Gdebi qui était présent par défaut sur Ubuntu Mate)
4-A partir de là, j'ai pu tester les différentes options, ant_sel=2 étant celle qui m'a permis d'avoir une connexion.
Entre chaque test, il faut décharger et recharger le module. Dans l'exemple du Pc qui m'a servi de test:

sudo modprobe -r rtl8723be
sudo modprobe rtl8723be ant_sel=2

Une fois trouvé la/les bonne(s) option(s), il faudra rendre cela permanent après l'installation en passant par le fichier de configuration. Toujours basé sur cet exemple, une fois l'installation réalisée, installer le Deb, passer la commande suivante en adaptant les options à votre cas, les plus courantes étant ant_sel=2 et fwlps=0 :

echo "options rtl8723be ant_sel=2" | sudo tee /etc/modprobe.d/rtl8723be.conf

relancer le module:

sudo modprobe -r rtl8723be
sudo modprobe rtl8723be

Maintenant vous pouvez installer le P.P.A. qui permettra d'avoir la mise à jour de rtlwifi-new-dkms_0.10 si une nouvelle version voyait le jour.
Si malgré tout vous n'avez toujours pas de connexions, je vous invite à relire l'intégralité de cette discussion et ouvrir votre propre discussion si vous n'y arrivez toujours pas.

Hors ligne

#75 Le 11/08/2016, à 14:51

superjp

Re : [Résolu] pas de wifi avec une carte realtek RTL8723be

Super tuto ça va en aider plus d'un
le résultat :

 ~ $ cat /etc/modprobe.d/rtl8723be.conf
options rtl8723be fwlps=0
combe@combe-HP-Pavilion-x360-Convertible ~ $ systool -v -m rtl8723be
Module = "rtl8723be"

  Attributes:
    coresize            = "135168"
    initsize            = "0"
    initstate           = "live"
    refcnt              = "0"
    srcversion          = "00619764255210776FAB54D"
    taint               = "OE"
    uevent              = <store method only>

  Parameters:
    ant_sel             = "0"
    debug               = "1"
    disable_watchdog    = "N"
    fwlps               = "N"
    ips                 = "Y"
    msi                 = "N"
    swenc               = "N"
    swlps               = "N"

  Sections:
    .bss                = "0x0000000000000000"
    .data               = "0x0000000000000000"
    .data.unlikely      = "0x0000000000000000"
    .exit.text          = "0x0000000000000000"
    .gnu.linkonce.this_module= "0x0000000000000000"
    .init.text          = "0x0000000000000000"
    .note.gnu.build-id  = "0x0000000000000000"
    .parainstructions   = "0x0000000000000000"
    .rodata             = "0x0000000000000000"
    .rodata.str1.1      = "0x0000000000000000"
    .rodata.str1.8      = "0x0000000000000000"
    .strtab             = "0x0000000000000000"
    .symtab             = "0x0000000000000000"
    .text               = "0x0000000000000000"
    __mcount_loc        = "0x0000000000000000"
    __param             = "0x0000000000000000"
    __verbose           = "0x0000000000000000"

combe@combe-HP-Pavilion-x360-Convertible ~ $ 

Hors ligne