Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 02/01/2017, à 22:30

Clémentt

Installation de pdfedit [résolu]

Bonjour,

Je souhaiterai installer pdfedit, je suis actuellement sous Xubuntu 16.04. J'ai suivi quelque instruction à cette adresse (http://askubuntu.com/questions/538966/h … untu-14-04) mais je n'arrive pas installer les paquets libmng1 libqt3-mt qui sont apparemment nécessaire pour l’installation de pdfedit.

voilà la réponse lorsque je tente de les installer.

clement@clement-X555LN:~$ sudo apt-get install libmng1 libqt3-mt
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet libmng1
E: Impossible de trouver le paquet libqt3-mt
clement@clement-X555LN:~$ gksudo gedit /etc/apt/sources.list

j'ai aussi rajouté cette ligne dans le fichier sources.list

# libqt3-mnt
deb http://old-releases.ubuntu.com/ubuntu lucid main

Auriez vous une solution ?

Merci de votre aide !

Clémentt

Dernière modification par Clémentt (Le 04/01/2017, à 22:49)

Hors ligne

#2 Le 03/01/2017, à 02:26

abelthorne

Re : Installation de pdfedit [résolu]

Tu peux commencer par supprimer la ligne que tu as ajoutée dans le sources.list, étant donné que :
1) Il vaut mieux éviter d'ajouter des dépôts pour une ancienne version d'Ubuntu à moins de savoir ce qu'on fait. Pour des dépôts tiers, ça peut passer dans certains cas (en étudiant bien ce qu'ils contiennent) mais pour les dépôts principaux, c'est à proscrire.
2) Les dépôts Lucid n'existent plus, c'est une version qui date de plus de six ans. Même s'ils sont archivés, leur contenu est complètement obsolète.

Si tu veux installer des vieux paquets, il faut le faire un par un, pas ajouter des dépôts complets.

Il y a encore pdfedit, libqt3-mt dans les dépôts Precise (12.04), tu peux essayer de les récupérer et les installer depuis là :
- libmng1
- libqt3-mt
- pdfedit

En bas de chaque page, tu as des liens pour chaque architecture, prends ce qui correspond à ton système (amd64 pour du 64 bits ou i386 pour du 32 bits). Installe d'abord les dépendances avant PDFedit.

Hors ligne

#3 Le 03/01/2017, à 02:58

Toobuntu

Re : Installation de pdfedit [résolu]

Bonjour et bonne année

Il va peut être être nécessaire de compiler Qt3 si tu es sur Xenial neutral

Tu pourras suivre cette exemple
http://rivendell.tryphon.org/wiki/Ubunt … alling_QT3


Ubuntu 18.04 , 16.04 , 14.04, 12.04, 10.04 , 8.04, 6.06
Sur galere PC : HP ENVY 17 J107SF jack :/ , bluetooth :/ , EFI qui est une calamité , son à configurer :/ Wifi rtl3290 :/
Les vignettes des fichiers geogebra 4, 5, 6 : https://framadrive.org/s/jcr6wjY0IAsZh9u
Zsync est ton ami : https://doc.ubuntu-fr.org/zsync

Hors ligne

#4 Le 03/01/2017, à 23:23

Clémentt

Re : Installation de pdfedit [résolu]

Bonjour,

Tout d'abord merci de vos réponses.
Tu vas trouver ma question bête abelthorne mais quand je clic sur les liens que tu as mis, puis sur le lien correspondant à mon architecture, je tombe sur ça

/usr/lib/x86_64-linux-gnu/libmng.so.1
/usr/lib/x86_64-linux-gnu/libmng.so.1.1.0.10
/usr/share/doc/libmng1/README
/usr/share/doc/libmng1/changelog.Debian.gz
/usr/share/doc/libmng1/copyright

mais je ne sais pas quoi en faire.. je n'est jamais installé de paquet isolé comme ça et je débute sur linux, pardonnez mon ignorance hmm

En tout cas merci de m'aider c'est sympa !

Clémentt

Hors ligne

#5 Le 03/01/2017, à 23:29

abelthorne

Re : Installation de pdfedit [résolu]

Ah, j'ai l'impression que ça t'ouvre le paquet avec le gestionnaire d'archives au lieu de l'installeur. Je ne sais pas ce qu'il y a de dispo sur Xubuntu pour ça. Si tu fais un clic droit sur un paquet, tu devrais avoir une option pour choisir un autre logiciel pour l'ouvrir : est-ce que tu as par exemple un machin qui s'appelle "installeur de paquets GDebi" ?

Dernière modification par abelthorne (Le 03/01/2017, à 23:31)

Hors ligne

#6 Le 03/01/2017, à 23:50

Clémentt

Re : Installation de pdfedit [résolu]

Je l'ai mis entre balise code mais ça n'ouvre pas la console hein c'est juste pour plus de lisibilité.
Je ne peut pas sélectionner d'application pour ouvrir ce paquet.. hmm

Hors ligne

#7 Le 03/01/2017, à 23:52

abelthorne

Re : Installation de pdfedit [résolu]

Bon, installe-le au cas où il ne le soit pas :

sudo apt-get install gdebi

Une fois que c'est fait, il devrait apparaître dans les logiciels possibles pour ouvrir ce type de fichiers.

Hors ligne

#8 Le 03/01/2017, à 23:58

Clémentt

Re : Installation de pdfedit [résolu]

je l'ai installé, mais je ne vois toujours pas comment ouvrir les fichiers avec.. rien n'a réellement changé.. hmm

Hors ligne

#9 Le 04/01/2017, à 00:02

abelthorne

Re : Installation de pdfedit [résolu]

Si tu affiches les propriétés du fichier, il n'y a pas un onglet qui permet de choisir les applications associées à ce type de fichier ?

Hors ligne

#10 Le 04/01/2017, à 00:10

Clémentt

Re : Installation de pdfedit [résolu]

Mais en fait je n'ai pas vraiment de fichier.. rien ne se télécharge, il y a juste les lignes que j'ai envoyé tout à l'heure sur la page du site, ça donne ça http://packages.ubuntu.com/fr/precise/a … 1/filelist

Hors ligne

#11 Le 04/01/2017, à 00:16

abelthorne

Re : Installation de pdfedit [résolu]

Ah, j'avais mal compris, j'ai cru que tu avais téléchargé les paquets et que lorsque tu les ouvrais ça te donnais une liste des fichiers inclus dedans (via le gestionnaire d'archives) au lieu de les installer.

Pour les télécharger, il faut cliquer sur le nom de l'archi dans le tableau (amd64 ou i386), pas sur "liste des fichiers", ce qui va t'amener à une liste de miroirs pour les télécharger.

Hors ligne

#12 Le 04/01/2017, à 00:24

Clémentt

Re : Installation de pdfedit [résolu]

Aaaaah excuse moi ! j'avais pas compris ! désolé !
Bon du coup je l'ai ouvert avec Gdebi mais il ne veut pas s'installer correctement.. il me m'affiche

"Erreur : la dépendance ne peut être satisfaite : liblcms1 (>=1.15-1)"

en rouge dans la fenêtre de Gdebi.

Hors ligne

#13 Le 04/01/2017, à 00:43

abelthorne

Re : Installation de pdfedit [résolu]

C'est une dépendance dont il a besoin, il y en aura peut-être d'autres. Donc téléchargement du paquet liblcms1, à installer avant les autres :
- liblcms1

C'est possible que tu finisses par tomber sur un paquet qui ne peut pas être installé parce qu'il veut une dépendance à une version précise et que celle des dépôts actuels diffère, auquel cas il faudra passer à une méthode plus compliquée pour installer PDFedit (compilation, installation manuelle, etc. comme dans le lien de Toobuntu). Là, on teste la méthode simple qui consiste à installer des vieux paquets mais comme beaucoup sont interdépendants, ça peut ne pas aboutir à cause de conflits avec les dépôts actuels.

Hors ligne

#14 Le 04/01/2017, à 22:29

Clémentt

Re : Installation de pdfedit [résolu]

J'ai réussi à tout installer ! Merci beaucoup !

Bonne soirée ! smile

Hors ligne

#15 Le 26/08/2017, à 10:09

Brunod

Re : Installation de pdfedit [résolu]

Clémentt a écrit :

J'ai réussi à tout installer ! Merci beaucoup !

Bonne soirée ! smile

Bravo !
Pourrais-tu préciser quelle méthode tu as suivie ? Celle d'abelthorne ou une recompilation de Toobuntu ?


Windows est un système d'exploitation de l'homme par l'ordinateur. Linux, c'est le contraire...
39 pc linux convertis

Hors ligne