Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 31/01/2017, à 13:41

malbo

Rolling HWE Stacks pour 16.04

Ce titre est pompé de cette page "Rolling HWE Stacks for 16.04". On y voit que pour une justification d'épuisement des équipes de développement pour maintenir les HWE stack façon 12.04 et 14.04, on va passer pour 16.04 à un passage en continu et automatique d'un HWE stack au suivant.
La page en question pointe un gros défaut de l'ancien système (celui qui a sévi pour 12.04 et 14.04) : il imposait un passage obligatoire au dernier HWE stack. C'est à dire que pour Ubuntu 16.04 (EDIT le 6 nov 2017 : je voulais écrire "14.04"), il fallait passer obligatoirement au HWE stack 14.04.5 après Août 2016 (sauf pour ceux qui n'étaient pas embarqués dans le système des HWE stack parce qu'ils étaient resté avec le noyau 3.13). De ce point de vue, c'est sûr que le passage est plus souple.
Moi je ne suis pas du tout convaincu que cette nouvelle politique des HWE stack soit meilleure que l'ancienne. Je continuerai de conseiller à chaque fois que c'est possible d'installer la version sans HWE stack comme je l'ai fait pour les LTS 12.04 et 14.04.

Dernière modification par malbo (Le 06/11/2017, à 07:25)

Hors ligne

#2 Le 31/01/2017, à 14:52

Rufus T. Firefly

Re : Rolling HWE Stacks pour 16.04

De toutes façons, si un ordinateur est déjà parfaitement géré par une version donnée du noyau, il n'y a aucune justification évidente pour passer à une version plus récente. Au contraire, on a régulièrement des exemples où une telle mise à niveau se traduit par l'apparition de problèmes jusqu'à présent inexistants (vidéo, wifi...) !

Donc ces HWE stack ne devraient concerner que des ordinateurs si récents qu'ils ne sont pas encore entièrement pris en charge. Dans ce cas, on peut espérer qu'un noyau plus récent améliorera les choses.

Personnellement, je pense que ce type d'ordinateur dernier cri ne représente qu'une très petite partie du parc et donc qu'imposer à tous une politique qui ne concerne que cette minorité n'est pas une bonne idée. D'autant qu'il y a certainement d'autres possibilités (chez Debian, on a les noyaux les plus récents dans les dépôts backports, s'ils s'avèrent utiles)...

Dernière modification par Rufus T. Firefly (Le 31/01/2017, à 14:53)


La provocation est une façon de remettre la réalité sur ses pieds. (Bertolt Brecht)
Il n'y a pas de route royale pour la science et ceux-là seulement ont chance d'arriver à ses sommets lumineux qui ne craignent pas de se fatiguer à gravir ses sentiers escarpés. (Karl Marx)
Il est devenu plus facile de penser la fin du monde que la fin du capitalisme

Hors ligne

#3 Le 31/01/2017, à 15:36

malbo

Re : Rolling HWE Stacks pour 16.04

Rufus T. Firefly a écrit :

Donc ces HWE stack ne devraient concerner que des ordinateurs si récents qu'ils ne sont pas encore entièrement pris en charge.

Tu as raison d'employer le conditionnel. Parce que pour les LTS précédentes 12.04 et 14.04, la version proposée en téléchargement dépendait du moment où on la téléchargeait comme expliqué dans l'introduction de la doc LTS Enablement Stack :

Avec le LTS Enablement Stack, une distribution Ubuntu LTS n'est plus limitée à la version du noyau Linux fournie à sa sortie. Suivant la date à laquelle on l'a installée, on va se retrouver avec un noyau et le serveur graphique Xorg de version plus récente. 

De ce fait, pour installer Ubuntu dans un vieil ordi on pouvait télécharger la version avec HWE alors que la version sans HWE (qui correspond à ce paragraphe 1.2 Installer sans étape de version LTS) était préférable.
Je ne sais pas encore si ça va continuer sur le même principe pour 16.04 mais j'imagine que oui.

EDIT : oui, ça va continuer sur le même principe comme on peut voir dans la partie "ga-16.04" du doc :

Desktop images will only offer the latest HWE kernel beginning with 16.04.2. 

L'innocent qui va installer la 16.04 après la sortie de 16.04.2 va télécharger la version "courante" 16.04 et va monter sans le savoir dans le petit train "Rolling HWE Stacks" avec ses étapes de version.

Dernière modification par malbo (Le 31/01/2017, à 18:13)

Hors ligne

#4 Le 08/02/2017, à 12:05

malbo

Re : Rolling HWE Stacks pour 16.04

A la veille de la sortie officielle de 16.04.2, j'ai voulu tester le HWE stack.
Voici l'extrait du paragraphe "Ubuntu 16.04 LTS - Xenial Xerus" de la doc LTSEnablementStack :

Desktop

Installing the HWE stack on a desktop is simple:

 sudo apt-get install --install-recommends xserver-xorg-hwe-16.04 

ça m'a paru tellement simple que j'ai voulu l'essayer (*) dans mon install Ubuntu 16.04 (machine virtuelle VirtualBox). Le résultat est visible dans cet extrait du fichier /var/log/apt/history.log de mon Ubuntu 16.04 :

Start-Date: 2017-02-08  07:50:09
Commandline: apt-get install --install-recommends xserver-xorg-hwe-16.04
Requested-By: malbo (1000)
Install: xserver-xorg-video-qxl-hwe-16.04:amd64 (0.1.4-3ubuntu3~16.04.1, automatic), xserver-xorg-video-vesa-hwe-16.04:amd64 (1:2.3.4-1build2~16.04.1, automatic), linux-headers-4.8.0-35:amd64 (4.8.0-35.40~16.04.1, automatic), linux-image-generic-hwe-16.04:amd64 (4.8.0.35.7, automatic), xserver-xorg-video-amdgpu-hwe-16.04:amd64 (1.1.2-1~16.04.1, automatic), linux-generic-hwe-16.04:amd64 (4.8.0.35.7, automatic), linux-image-4.8.0-35-generic:amd64 (4.8.0-35.40~16.04.1, automatic), linux-image-extra-4.8.0-35-generic:amd64 (4.8.0-35.40~16.04.1, automatic), xserver-xorg-input-synaptics-hwe-16.04:amd64 (1.8.3-1ubuntu1~16.04.1, automatic), xserver-xorg-hwe-16.04:amd64 (1:7.7+13ubuntu4~16.04.2), xserver-xorg-video-all-hwe-16.04:amd64 (1:7.7+13ubuntu4~16.04.2, automatic), xserver-xorg-video-fbdev-hwe-16.04:amd64 (1:0.4.4-1build5~16.04.1, automatic), linux-headers-4.8.0-35-generic:amd64 (4.8.0-35.40~16.04.1, automatic), xserver-xorg-video-vmware-hwe-16.04:amd64 (1:13.1.0-2ubuntu3~16.04.1, automatic), xserver-xorg-video-intel-hwe-16.04:amd64 (2:2.99.917+git20160706-1ubuntu1~16.04.1, automatic), xserver-xorg-core-hwe-16.04:amd64 (2:1.18.4-1ubuntu6.1~16.04.1, automatic), xserver-xorg-input-wacom-hwe-16.04:amd64 (1:0.33.0-0ubuntu1~16.04.1, automatic), xserver-xorg-input-evdev-hwe-16.04:amd64 (1:2.10.2-1ubuntu1~16.04.1, automatic), linux-headers-generic-hwe-16.04:amd64 (4.8.0.35.7, automatic), xserver-xorg-video-nouveau-hwe-16.04:amd64 (1:1.0.12-2~16.04.1, automatic), xserver-xorg-input-all-hwe-16.04:amd64 (1:7.7+13ubuntu4~16.04.2, automatic), xserver-xorg-video-radeon-hwe-16.04:amd64 (1:7.7.1-1~16.04.1, automatic), xserver-xorg-video-ati-hwe-16.04:amd64 (1:7.7.1-1~16.04.1, automatic)
Remove: xserver-xorg-input-all:amd64 (1:7.7+13ubuntu3), xserver-xorg-input-synaptics:amd64 (1.8.2-1ubuntu3), xserver-xorg:amd64 (1:7.7+13ubuntu3), xserver-xorg-video-qxl:amd64 (0.1.4-3ubuntu3), xserver-xorg-video-vesa:amd64 (1:2.3.4-1build2), xserver-xorg-video-nouveau:amd64 (1:1.0.12-1build2), xserver-xorg-video-amdgpu:amd64 (1.1.0-1), xserver-xorg-core:amd64 (2:1.18.4-0ubuntu0.2), xserver-xorg-video-fbdev:amd64 (1:0.4.4-1build5), xserver-xorg-input-wacom:amd64 (1:0.32.0-0ubuntu3), xserver-xorg-input-vmmouse:amd64 (1:13.1.0-1ubuntu2), xserver-xorg-video-intel:amd64 (2:2.99.917+git20160325-1ubuntu1.2), xserver-xorg-video-vmware:amd64 (1:13.1.0-2ubuntu3), xserver-xorg-input-evdev:amd64 (1:2.10.1-1ubuntu2), xserver-xorg-video-all:amd64 (1:7.7+13ubuntu3), xserver-xorg-video-ati:amd64 (1:7.7.0-1), xserver-xorg-video-radeon:amd64 (1:7.7.0-1)
End-Date: 2017-02-08  07:57:49

On peut constater qu'il n'y a pas eu d'embrouille (un fois n'est pas coutume) : cette unique commande d'installation de xserver-xorg-hwe-16.04 a entraîné l'installation de linux-image-generic-hwe-16.04, linux-generic-hwe-16.04 et linux-headers-generic-hwe-16.04

(*) dans les sources de mise à jour, onglet "options de développement", j'ai dû cocher la case "Mises à jour en préversion (xenial-proposed)" parce que la sortie du HWE stack de 16.04 n'est pas encore officielle

Dernière modification par malbo (Le 05/04/2017, à 17:48)

Hors ligne

#5 Le 08/02/2017, à 12:35

Rufus T. Firefly

Re : Rolling HWE Stacks pour 16.04

Quand on voit tous les problèmes qu'on rencontre avec la vidéo, je trouve que ce truc est vraiment une très mauvaise idée... Quand ça fonctionne bien, il vaut mieux ne plus y toucher.


La provocation est une façon de remettre la réalité sur ses pieds. (Bertolt Brecht)
Il n'y a pas de route royale pour la science et ceux-là seulement ont chance d'arriver à ses sommets lumineux qui ne craignent pas de se fatiguer à gravir ses sentiers escarpés. (Karl Marx)
Il est devenu plus facile de penser la fin du monde que la fin du capitalisme

Hors ligne

#7 Le 08/02/2017, à 18:20

Rufus T. Firefly

Re : Rolling HWE Stacks pour 16.04

Toutes les histoires de pilotes, bien sûr, et de double gpu...


La provocation est une façon de remettre la réalité sur ses pieds. (Bertolt Brecht)
Il n'y a pas de route royale pour la science et ceux-là seulement ont chance d'arriver à ses sommets lumineux qui ne craignent pas de se fatiguer à gravir ses sentiers escarpés. (Karl Marx)
Il est devenu plus facile de penser la fin du monde que la fin du capitalisme

Hors ligne

#8 Le 08/02/2017, à 18:26

GammaDraconis

Re : Rolling HWE Stacks pour 16.04

En parlant de HWE Stack, la 16.04.2 sort... demain !

Sinon je pense que c'est une bonne chose si ils font un changement automatique du noyau pour ceux qui ont activé HWE déjà parce-que pour ceux qui reste avec le noyau d'origine HWE (donc le 4.4 pour la 16.04) ça ne change rien et pour ceux qui utilise le dernier noyau, ça leur permet d'avoir toujours les mises a jour de sécurité du noyau tout en ayant un noyau qui change a chaque nouvelle sous-version LTS.


Dell XPS 13 version 2019 (9380) : i7-8565U / 16 Go de ram / 1 To SSD M2 Nvme / Intel Graphic UHD 620 (Ubuntu 18.04/GS & ArchLinux/KDE)
Tour : AMD Ryzen 7 2700X Octo-Core/16T 3.7GHz, 32 Go Ram - 1 To SSD + 4 To HDD - GeForce 2060RTX 6Go) : Ubuntu/Arch/w10
Mon script de post-install pour la 18.04 : https://forum.ubuntu-fr.org/viewtopic.php?id=2026344

Hors ligne

#9 Le 08/02/2017, à 18:35

Rufus T. Firefly

Re : Rolling HWE Stacks pour 16.04

Ça, c'est une question de point de vue. Moi j'aurais plutôt tendance à penser qu'à chaque nouveau noyau il y a de nouvelles failles et qu'elles ne seront jamais corrigées, faute de temps avant la sortie du suivant...


La provocation est une façon de remettre la réalité sur ses pieds. (Bertolt Brecht)
Il n'y a pas de route royale pour la science et ceux-là seulement ont chance d'arriver à ses sommets lumineux qui ne craignent pas de se fatiguer à gravir ses sentiers escarpés. (Karl Marx)
Il est devenu plus facile de penser la fin du monde que la fin du capitalisme

Hors ligne

#10 Le 08/02/2017, à 18:43

GammaDraconis

Re : Rolling HWE Stacks pour 16.04

Quand il y a un nouveau noyau sous la LTS, en réalité il n'est pas du tout nouveau, il provient de la dernière version d'Ubuntu (y compris a court terme) donc il y a déjà eu pleins de correctif.

Par exemple si on prend l'exemple de la 16.04.2 qui aura le 4.8, c'est tout simplement le 4.8 issu de la 16.10 (sortie en Octobre 2016) et depuis il y a eu plusieurs correctif de sécurité (4.8.0-30, (4.8.0-32, 4.8.0-34 etc...). Au finale quand vous recevez un nouveau noyau sur une LTS, ça fait déjà plusieurs mois qu'ils sont testé et pas seulement pour les développeurs mais aussi a grand échelle puisque diffusé dans les versions a court terme.

Et pis si vraiment vous voulez un noyau unique pour un maximum de stabilité au niveau de la gestion du matériel, ya une distribution parfaite pour ça que vous connaissez bien et qui commence par un D.

Dernière modification par GammaDraconis (Le 08/02/2017, à 18:45)


Dell XPS 13 version 2019 (9380) : i7-8565U / 16 Go de ram / 1 To SSD M2 Nvme / Intel Graphic UHD 620 (Ubuntu 18.04/GS & ArchLinux/KDE)
Tour : AMD Ryzen 7 2700X Octo-Core/16T 3.7GHz, 32 Go Ram - 1 To SSD + 4 To HDD - GeForce 2060RTX 6Go) : Ubuntu/Arch/w10
Mon script de post-install pour la 18.04 : https://forum.ubuntu-fr.org/viewtopic.php?id=2026344

Hors ligne

#11 Le 08/02/2017, à 19:06

Rufus T. Firefly

Re : Rolling HWE Stacks pour 16.04

Oui, mais tous les posts qui commencent par "Ecran noir après une mise à jour..." ou "Plus de wifi après une mise à jour...", "Plus de son après une mise à jour..." et autres du même tonneau ? Mais ce serait mieux au niveau de la sécurité ?
On a le droit d'y croire...


La provocation est une façon de remettre la réalité sur ses pieds. (Bertolt Brecht)
Il n'y a pas de route royale pour la science et ceux-là seulement ont chance d'arriver à ses sommets lumineux qui ne craignent pas de se fatiguer à gravir ses sentiers escarpés. (Karl Marx)
Il est devenu plus facile de penser la fin du monde que la fin du capitalisme

Hors ligne

#12 Le 08/02/2017, à 19:16

lucmars

Re : Rolling HWE Stacks pour 16.04

Cela ressemble à du rolling release. Bon pourquoi pas tant que cela n'a pas de conséquences pour migrer d'une lts à l'autre.

Mais si cela conditionne la-dite migration, Canonical bousille là une pratique simple qu'était la lts.

Moi-même avec ma 140402, je ne sais si je dois d'abord installer le stack avant de migrer vers la 160401 ou si la migration s'en occupe.

Je veux dire qu'en l'état la communication vers l'utilisateur(trice) est à chier et anxiogène.

Hors ligne

#13 Le 08/02/2017, à 20:05

malbo

Re : Rolling HWE Stacks pour 16.04

lucmars,
Tu n'as pas à installer ni à désinstaller quelque stack que ce soit pour faire ta mise à niveau de Trusty vers Xenial. Tu peux même avoir entassé plusieurs stacks de Trusty (ça pourrait arriver), tu n'as pas à faire le ménage avant (je détaille ça dans le "nota" en bas de ce post)

Hors ligne

#14 Le 08/02/2017, à 20:37

moko138

Re : Rolling HWE Stacks pour 16.04

GammaDraconis a écrit :

pour ceux qui reste avec le noyau d'origine HWE (donc le 4.4 pour la 16.04) ça ne change rien et pour ceux qui utilise le dernier noyau, ça leur permet d'avoir toujours les mises a jour de sécurité du noyau tout en ayant un noyau qui change a chaque nouvelle sous-version LTS.

Attention aux confusions !!!

1) Les 16.04.0 et 16.04.1 NE sont PAS dotées d'origine de HWE.

2) Les 16.04.0 et 16.04.1 d'origine bénéficient, tout en gardant le noyau 4.4, des mêmes corrections de sécurité que les versions HWE.


%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#15 Le 08/02/2017, à 20:53

GammaDraconis

Re : Rolling HWE Stacks pour 16.04

Il n'y a aucune confusion, je sais très bien que les version .0 et .1 ne sont pas doté d'origine de HWE, ce n'est qu'a partir de la .2 qu'il y a un changement de version du noyau et de xorg.


Dell XPS 13 version 2019 (9380) : i7-8565U / 16 Go de ram / 1 To SSD M2 Nvme / Intel Graphic UHD 620 (Ubuntu 18.04/GS & ArchLinux/KDE)
Tour : AMD Ryzen 7 2700X Octo-Core/16T 3.7GHz, 32 Go Ram - 1 To SSD + 4 To HDD - GeForce 2060RTX 6Go) : Ubuntu/Arch/w10
Mon script de post-install pour la 18.04 : https://forum.ubuntu-fr.org/viewtopic.php?id=2026344

Hors ligne

#16 Le 09/02/2017, à 10:02

malbo

Re : Rolling HWE Stacks pour 16.04

EDIT le 22 févr. 2017 : je n'arrive plus à faire fonctionner la procédure de ce post. J'invite ceux qui voudraient supprimer le HWE stack de 16.04 à suivre la procédure du post #20

Expérimental : procédure provisoire pour passer de 16.04.2 à 16.04.1.
L'essai est fait dans une machine virtuelle VirtualBox (c'est la suite de mon essai du post #4). Les noyaux de la famille 4.4.0.x ont été supprimés pour ne laisser qu'un noyau de la famille 4.8.0-x.
1) passer la commande suivante :

sudo apt install linux-generic linux-headers-generic linux-image-generic

Cette commande doit installer un noyau de la famille 4.4.0.x

2) redémarrage sur l'entrée pour le noyau 4.4.0.x dans les options avancées du menu Grub et passage des 3 commandes suivantes en laissant à chacune le temps de s'accomplir :

sudo apt purge xserver-xorg-hwe-16.04

puis :

sudo apt autoremove

et enfin :

apt install ubuntu-desktop

explication : il a fallu réinstaller ubuntu-desktop parce que la purge de xserver-xorg-hwe-16.04 avait entraîné la suppression de ubuntu-desktop

On peut voir l'effet de ces 3 commandes dans cet extrait du fichier /var/log/apt/history.log :

Start-Date: 2017-02-09  09:59:07
Commandline: apt purge xserver-xorg-hwe-16.04
Requested-By: malbo (1000)
Purge: ubuntu-desktop:amd64 (1.361), xserver-xorg-hwe-16.04:amd64 (1:7.7+13ubuntu4~16.04.2), xorg:amd64 (1:7.7+13ubuntu3)
End-Date: 2017-02-09  09:59:10

Start-Date: 2017-02-09  10:00:01
Commandline: apt autoremove
Requested-By: malbo (1000)
Remove: xserver-xorg-video-qxl-hwe-16.04:amd64 (0.1.4-3ubuntu3~16.04.1), xserver-xorg-video-vesa-hwe-16.04:amd64 (1:2.3.4-1build2~16.04.1), xserver-common:amd64 (2:1.18.4-0ubuntu0.2), linux-image-generic-hwe-16.04:amd64 (4.8.0.35.7), xserver-xorg-video-amdgpu-hwe-16.04:amd64 (1.1.2-1~16.04.1), linux-generic-hwe-16.04:amd64 (4.8.0.35.7), xfonts-utils:amd64 (1:7.7+3), xserver-xorg-input-synaptics-hwe-16.04:amd64 (1.8.3-1ubuntu1~16.04.1), libxatracker2:amd64 (12.0.6-0ubuntu0.16.04.1), x11-apps:amd64 (7.7+5+nmu1ubuntu1), xinit:amd64 (1.3.4-3ubuntu0.1), x11-session-utils:amd64 (7.7+2), xserver-xorg-video-all-hwe-16.04:amd64 (1:7.7+13ubuntu4~16.04.2), xserver-xorg-video-fbdev-hwe-16.04:amd64 (1:0.4.4-1build5~16.04.1), xserver-xorg-video-vmware-hwe-16.04:amd64 (1:13.1.0-2ubuntu3~16.04.1), libxfont1:amd64 (1:1.5.1-1), xserver-xorg-video-intel-hwe-16.04:amd64 (2:2.99.917+git20160706-1ubuntu1~16.04.1), xserver-xorg-core-hwe-16.04:amd64 (2:1.18.4-1ubuntu6.1~16.04.1), xserver-xorg-input-wacom-hwe-16.04:amd64 (1:0.33.0-0ubuntu1~16.04.1), xfonts-base:amd64 (1:1.0.4+nmu1), xserver-xorg-input-evdev-hwe-16.04:amd64 (1:2.10.2-1ubuntu1~16.04.1), linux-headers-generic-hwe-16.04:amd64 (4.8.0.35.7), xserver-xorg-video-nouveau-hwe-16.04:amd64 (1:1.0.12-2~16.04.1), libxvmc1:amd64 (2:1.0.9-1ubuntu1), xserver-xorg-input-all-hwe-16.04:amd64 (1:7.7+13ubuntu4~16.04.2), xserver-xorg-video-radeon-hwe-16.04:amd64 (1:7.7.1-1~16.04.1), xfonts-encodings:amd64 (1:1.0.4-2), xfonts-scalable:amd64 (1:1.0.3-1.1), xserver-xorg-video-ati-hwe-16.04:amd64 (1:7.7.1-1~16.04.1)
End-Date: 2017-02-09  10:00:25

Start-Date: 2017-02-09  10:01:56
Commandline: apt install ubuntu-desktop
Requested-By: malbo (1000)
Install: xserver-xorg-input-all:amd64 (1:7.7+13ubuntu3, automatic), xserver-xorg-input-synaptics:amd64 (1.8.2-1ubuntu3, automatic), xserver-xorg:amd64 (1:7.7+13ubuntu3, automatic), xserver-xorg-video-qxl:amd64 (0.1.4-3ubuntu3, automatic), xserver-xorg-video-vesa:amd64 (1:2.3.4-1build2, automatic), xserver-xorg-video-nouveau:amd64 (1:1.0.12-1build2, automatic), xserver-xorg-video-amdgpu:amd64 (1.1.0-1, automatic), xserver-common:amd64 (2:1.18.4-0ubuntu0.2, automatic), xserver-xorg-core:amd64 (2:1.18.4-0ubuntu0.2, automatic), xserver-xorg-video-fbdev:amd64 (1:0.4.4-1build5, automatic), xfonts-utils:amd64 (1:7.7+3, automatic), ubuntu-desktop:amd64 (1.361), libxatracker2:amd64 (12.0.6-0ubuntu0.16.04.1, automatic), x11-apps:amd64 (7.7+5+nmu1ubuntu1, automatic), xinit:amd64 (1.3.4-3ubuntu0.1, automatic), xserver-xorg-input-wacom:amd64 (1:0.32.0-0ubuntu3, automatic), x11-session-utils:amd64 (7.7+2, automatic), xserver-xorg-input-vmmouse:amd64 (1:13.1.0-1ubuntu2, automatic), xserver-xorg-video-intel:amd64 (2:2.99.917+git20160325-1ubuntu1.2, automatic), libxfont1:amd64 (1:1.5.1-1, automatic), xserver-xorg-video-vmware:amd64 (1:13.1.0-2ubuntu3, automatic), xserver-xorg-input-evdev:amd64 (1:2.10.1-1ubuntu2, automatic), xserver-xorg-video-all:amd64 (1:7.7+13ubuntu3, automatic), xserver-xorg-video-ati:amd64 (1:7.7.0-1, automatic), xorg:amd64 (1:7.7+13ubuntu3, automatic), xserver-xorg-video-radeon:amd64 (1:7.7.0-1, automatic), xfonts-base:amd64 (1:1.0.4+nmu1, automatic), libxvmc1:amd64 (2:1.0.9-1ubuntu1, automatic), xfonts-encodings:amd64 (1:1.0.4-2, automatic), xfonts-scalable:amd64 (1:1.0.3-1.1, automatic)
End-Date: 2017-02-09  10:02:32

3) suppression du noyau indésirable 4.8.0-x par la Méthode depuis un terminal sauf que le doc explique comment supprimer les vieux noyaux alors qu'ici je supprime le noyau le plus récent :

Start-Date: 2017-02-09  10:08:17
Commandline: apt purge linux-headers-4.8.0-35 linux-headers-4.8.0-35-generic linux-image-4.8.0-35-generic linux-image-extra-4.8.0-35-generic
Requested-By: malbo (1000)
Purge: linux-headers-4.8.0-35:amd64 (4.8.0-35.40~16.04.1), linux-image-4.8.0-35-generic:amd64 (4.8.0-35.40~16.04.1), linux-image-extra-4.8.0-35-generic:amd64 (4.8.0-35.40~16.04.1), linux-headers-4.8.0-35-generic:amd64 (4.8.0-35.40~16.04.1)
End-Date: 2017-02-09  10:11:05

4) Après cela, le démarrage par défaut de l'ordi se fait sur le noyau 4.4.0.x

Dernière modification par malbo (Le 22/02/2017, à 09:56)

Hors ligne

#17 Le 10/02/2017, à 10:25

malbo

Re : Rolling HWE Stacks pour 16.04

La sortie de Ubuntu 16.04.2 prévue le 9 février 2017(*) n'a pas eu lieu. Aux dernières nouvelles, ce pourrait être pour aujourd'hui vendredi 10 février ou plus raisonnablement pour lundi 13 février (source)

(*) c'est la date qui figure actuellement dans la ReleaseSchedule de Xenial qui porte la mention suivante en bas de page : "last edited 2017-01-31 19:24:36 by adconrad"

Dernière modification par malbo (Le 10/02/2017, à 10:30)

Hors ligne

#18 Le 10/02/2017, à 20:33

GammaDraconis

Re : Rolling HWE Stacks pour 16.04

ça fait depuis hier qu'on est en 16.04.2...

Vérifie par toi même tu verras que tu es déjà en 16.04.2 :

lsb_release -a

Après oui ils ont pas encore généré un iso spéciale pour la 16.04.2 par contre on le trouve quand même au niveau des dailybuild, par exemple pour Ubuntu : http://cdimage.ubuntu.com/xenial/daily-live/current/

Dernière modification par GammaDraconis (Le 10/02/2017, à 20:34)


Dell XPS 13 version 2019 (9380) : i7-8565U / 16 Go de ram / 1 To SSD M2 Nvme / Intel Graphic UHD 620 (Ubuntu 18.04/GS & ArchLinux/KDE)
Tour : AMD Ryzen 7 2700X Octo-Core/16T 3.7GHz, 32 Go Ram - 1 To SSD + 4 To HDD - GeForce 2060RTX 6Go) : Ubuntu/Arch/w10
Mon script de post-install pour la 18.04 : https://forum.ubuntu-fr.org/viewtopic.php?id=2026344

Hors ligne

#19 Le 17/02/2017, à 06:54

malbo

Re : Rolling HWE Stacks pour 16.04

Enfin, on peut télécharger le torrent de 16.04.2 64 bits : http://releases.ubuntu.com/16.04.2/ubun … so.torrent
La date de sortie de 16.04.2 a été mise à jour (16 Février au lieu de 9 Février) dans la ReleaseSchedule de Xenial.

Dernière modification par malbo (Le 17/02/2017, à 07:04)

Hors ligne

#20 Le 20/02/2017, à 19:35

malbo

Re : Rolling HWE Stacks pour 16.04

Procédure provisoire pour passer de 16.04.2 à 16.04.1 ("provisoire" parce qu'il n'y a pas de procédure officielle - à la date où j'écris - pour faire cette opération mais ça pourrait bien exister un jour...). Je suis parti d'une installation toute neuve de Ubuntu 16.04.2 réalisée à partir de l'ISO ubuntu-16.04.2-desktop-amd64.iso

1) Depuis la session en cours de Ubuntu 16.04.2 :

- commande pour installer le noyau 4.4 :

sudo apt install linux-generic linux-headers-generic linux-image-generic

J'ai pompé toute la suite de la procédure sur le tuto Install / Remove Hardware Enablement Stacks in Ubuntu 16.04 du site ubuntuhandbook.org

- commande pour désinstaller la daube "hwe-16.04" :

sudo apt remove xserver-xorg-core-hwe-16.04 xserver-xorg-input-all-hwe-16.04 linux-generic-hwe-16.04 xserver-xorg-video-all-hwe-16.04

- autre commande :
sudo apt install xserver-xorg-core
EDIT le 22 févr. 2017 : j'ai viré cette commande qui ne sert à rien parce que le paquet xserver-xorg-core sera installé automatiquement par la commande d'après
- une dernière pour la route : (EDIT le 21 févr. 2017 : j'ai enlevé les deux paquets ":i386" du tuto qui n'ont rien à faire là selon moi)
sudo apt install ubuntu-desktop xserver-xorg libgl1-mesa-dri:i386 libgl1-mesa-glx:i386

sudo apt install ubuntu-desktop xserver-xorg

2) redémarrage de l'ordi et sélection de l'entrée de Grub pour le noyau 4.4 (au lieu du noyau par défaut 4.8)
Désinstallation du (ou des noyaux 4.8) en suivant la doc 4.3 Méthode depuis un terminal

Toutes ces commandes et leur résultat sont dans cet extrait du fichier /var/log/apt/history.log (ce que j'ai collé ci-dessous, c'est le résultat de la manip refaite le 22 févr. 2017) :

Start-Date: 2017-02-22  11:28:19
Commandline: apt install linux-generic linux-headers-generic linux-image-generic
Requested-By: malbo (1000)
Install: linux-headers-generic:amd64 (4.4.0.64.68), linux-image-generic:amd64 (4.4.0.64.68), linux-headers-4.4.0-64:amd64 (4.4.0-64.85, automatic), linux-image-4.4.0-64-generic:amd64 (4.4.0-64.85, automatic), linux-image-extra-4.4.0-64-generic:amd64 (4.4.0-64.85, automatic), linux-headers-4.4.0-64-generic:amd64 (4.4.0-64.85, automatic), linux-generic:amd64 (4.4.0.64.68)
End-Date: 2017-02-22  11:34:33

Start-Date: 2017-02-22  11:36:19
Commandline: apt remove xserver-xorg-core-hwe-16.04 xserver-xorg-input-all-hwe-16.04 linux-generic-hwe-16.04 xserver-xorg-video-all-hwe-16.04
Requested-By: malbo (1000)
Remove: xserver-xorg-video-qxl-hwe-16.04:amd64 (0.1.4-3ubuntu3~16.04.1), xserver-xorg-video-vesa-hwe-16.04:amd64 (1:2.3.4-1build2~16.04.1), xserver-xorg-video-amdgpu-hwe-16.04:amd64 (1.1.2-1~16.04.1), linux-generic-hwe-16.04:amd64 (4.8.0.39.10), ubuntu-desktop:amd64 (1.361), xserver-xorg-input-synaptics-hwe-16.04:amd64 (1.8.3-1ubuntu1~16.04.1), xserver-xorg-hwe-16.04:amd64 (1:7.7+13ubuntu4~16.04.2), xserver-xorg-video-all-hwe-16.04:amd64 (1:7.7+13ubuntu4~16.04.2), xserver-xorg-video-fbdev-hwe-16.04:amd64 (1:0.4.4-1build5~16.04.1), xserver-xorg-video-vmware-hwe-16.04:amd64 (1:13.1.0-2ubuntu3~16.04.1), xorg:amd64 (1:7.7+13ubuntu3), xserver-xorg-video-intel-hwe-16.04:amd64 (2:2.99.917+git20160706-1ubuntu1~16.04.1), xserver-xorg-core-hwe-16.04:amd64 (2:1.18.4-1ubuntu6.1~16.04.1), xserver-xorg-input-wacom-hwe-16.04:amd64 (1:0.33.0-0ubuntu1~16.04.1), xserver-xorg-input-evdev-hwe-16.04:amd64 (1:2.10.2-1ubuntu1~16.04.1), xserver-xorg-video-nouveau-hwe-16.04:amd64 (1:1.0.12-2~16.04.1), xserver-xorg-input-all-hwe-16.04:amd64 (1:7.7+13ubuntu4~16.04.2), xserver-xorg-video-radeon-hwe-16.04:amd64 (1:7.7.1-1~16.04.1), xserver-xorg-video-ati-hwe-16.04:amd64 (1:7.7.1-1~16.04.1)
End-Date: 2017-02-22  11:36:37

Start-Date: 2017-02-22  11:39:03
Commandline: apt install ubuntu-desktop xserver-xorg
Requested-By: malbo (1000)
Install: xserver-xorg-input-all:amd64 (1:7.7+13ubuntu3, automatic), xserver-xorg-input-synaptics:amd64 (1.8.2-1ubuntu3, automatic), xserver-xorg:amd64 (1:7.7+13ubuntu3), xserver-xorg-video-qxl:amd64 (0.1.4-3ubuntu3, automatic), xserver-xorg-video-vesa:amd64 (1:2.3.4-1build2, automatic), xserver-xorg-video-nouveau:amd64 (1:1.0.12-1build2, automatic), xserver-xorg-video-amdgpu:amd64 (1.1.0-1, automatic), xserver-xorg-core:amd64 (2:1.18.4-0ubuntu0.2, automatic), xserver-xorg-video-fbdev:amd64 (1:0.4.4-1build5, automatic), ubuntu-desktop:amd64 (1.361), xserver-xorg-input-wacom:amd64 (1:0.32.0-0ubuntu3, automatic), xserver-xorg-input-vmmouse:amd64 (1:13.1.0-1ubuntu2, automatic), xserver-xorg-video-intel:amd64 (2:2.99.917+git20160325-1ubuntu1.2, automatic), xserver-xorg-video-vmware:amd64 (1:13.1.0-2ubuntu3, automatic), xserver-xorg-input-evdev:amd64 (1:2.10.1-1ubuntu2, automatic), xserver-xorg-video-all:amd64 (1:7.7+13ubuntu3, automatic), xserver-xorg-video-ati:amd64 (1:7.7.0-1, automatic), xorg:amd64 (1:7.7+13ubuntu3, automatic), xserver-xorg-video-radeon:amd64 (1:7.7.0-1, automatic)
End-Date: 2017-02-22  11:39:27

Start-Date: 2017-02-22  11:48:41
Commandline: apt remove linux-headers-4.8.0-36 linux-headers-4.8.0-36-generic linux-headers-4.8.0-39 linux-headers-4.8.0-39-generic linux-headers-generic-hwe-16.04 linux-image-4.8.0-36-generic linux-image-4.8.0-39-generic linux-image-extra-4.8.0-36-generic linux-image-extra-4.8.0-39-generic linux-image-generic-hwe-16.04 linux-signed-generic-hwe-16.04 linux-signed-image-4.8.0-36-generic linux-signed-image-4.8.0-39-generic linux-signed-image-generic-hwe-16.04
Requested-By: malbo (1000)
Remove: linux-headers-4.8.0-36:amd64 (4.8.0-36.36~16.04.1), linux-headers-4.8.0-39:amd64 (4.8.0-39.42~16.04.1), linux-signed-image-4.8.0-36-generic:amd64 (4.8.0-36.36~16.04.1), linux-image-generic-hwe-16.04:amd64 (4.8.0.39.10), linux-signed-generic-hwe-16.04:amd64 (4.8.0.39.10), linux-image-4.8.0-36-generic:amd64 (4.8.0-36.36~16.04.1), linux-signed-image-4.8.0-39-generic:amd64 (4.8.0-39.42~16.04.1), linux-image-extra-4.8.0-36-generic:amd64 (4.8.0-36.36~16.04.1), linux-signed-image-generic-hwe-16.04:amd64 (4.8.0.39.10), linux-image-4.8.0-39-generic:amd64 (4.8.0-39.42~16.04.1), linux-headers-4.8.0-36-generic:amd64 (4.8.0-36.36~16.04.1), linux-image-extra-4.8.0-39-generic:amd64 (4.8.0-39.42~16.04.1), linux-headers-4.8.0-39-generic:amd64 (4.8.0-39.42~16.04.1), linux-headers-generic-hwe-16.04:amd64 (4.8.0.39.10)
End-Date: 2017-02-22  11:53:24

Dernière modification par malbo (Le 22/02/2017, à 13:03)

Hors ligne

#21 Le 20/02/2017, à 20:18

lucmars

Re : Rolling HWE Stacks pour 16.04

J'en reviens au défaut de communication :
Au quoi bon ces HWE_stack pour la majorité si on ne communique pas en quoi ils peuvent être utile et/ou facultatif (au pire impératif) ?

Exemple : avec ma 140402, si je temporise la mise à niveau vers la 160401, j'ai iconifié une proposition d'installe du HWE mais sans autre précisions qu'une url wiki (sans compter la localisation).

C'est bien beau d'enquiller les releases de 6 mois et d'en faire du HWE, mais si on n'en donne pas la couleur, à quoi bon ? Où plutôt à qui s'adresse-t-on ? Et si on ne s'adresse pas à tous, alors pourquoi pas un autre canal (un dépot spécifique au HWE_stack par exemple).

Hors ligne

#22 Le 16/07/2017, à 17:33

malbo

Re : Rolling HWE Stacks pour 16.04

La version 16.04.3 n'est pas sortie officiellement (*) mais on peut tester (c'est pas pour les novices) un peu en avance en installant hwe-16.04-edge.
Je pars d'une installation de Ubuntu 16.04.1 (équipée de noyaux de la famille 4.4.0-x) et je passe la commande suivante :

sudo apt-get install --install-recommends linux-generic-hwe-16.04-edge xserver-xorg-hwe-16.04

Quand tout est fait et installé, voilà ce que ça donne dans /var/log/apt/history.log :

Start-Date: 2017-07-16  15:21:08
Commandline: apt-get install --install-recommends linux-generic-hwe-16.04-edge xserver-xorg-hwe-16.04
Requested-By: malbo (1000)
Install: xserver-xorg-video-qxl-hwe-16.04:amd64 (0.1.4-3ubuntu3~16.04.1, automatic), xserver-xorg-video-vesa-hwe-16.04:amd64 (1:2.3.4-1build2~16.04.1, automatic), linux-headers-4.8.0-58:amd64 (4.8.0-58.63~16.04.1, automatic), linux-generic-hwe-16.04-edge:amd64 (4.10.0.26.19), linux-image-generic-hwe-16.04:amd64 (4.8.0.58.29, automatic), xserver-xorg-video-amdgpu-hwe-16.04:amd64 (1.1.2-1~16.04.1, automatic), linux-generic-hwe-16.04:amd64 (4.8.0.58.29, automatic), linux-image-4.10.0-26-generic:amd64 (4.10.0-26.30~16.04.1, automatic), xserver-xorg-input-synaptics-hwe-16.04:amd64 (1.8.3-1ubuntu1~16.04.1, automatic), linux-image-4.8.0-58-generic:amd64 (4.8.0-58.63~16.04.1, automatic), xserver-xorg-hwe-16.04:amd64 (1:7.7+13ubuntu4~16.04.2), xserver-xorg-video-all-hwe-16.04:amd64 (1:7.7+13ubuntu4~16.04.2, automatic), xserver-xorg-video-fbdev-hwe-16.04:amd64 (1:0.4.4-1build5~16.04.1, automatic), linux-image-extra-4.8.0-58-generic:amd64 (4.8.0-58.63~16.04.1, automatic), xserver-xorg-video-vmware-hwe-16.04:amd64 (1:13.1.0-2ubuntu3~16.04.1, automatic), linux-headers-4.8.0-58-generic:amd64 (4.8.0-58.63~16.04.1, automatic), xserver-xorg-video-intel-hwe-16.04:amd64 (2:2.99.917+git20160706-1ubuntu1~16.04.1, automatic), xserver-xorg-core-hwe-16.04:amd64 (2:1.18.4-1ubuntu6.1~16.04.1, automatic), xserver-xorg-input-wacom-hwe-16.04:amd64 (1:0.33.0-0ubuntu1~16.04.1, automatic), linux-headers-4.10.0-26:amd64 (4.10.0-26.30~16.04.1, automatic), xserver-xorg-input-evdev-hwe-16.04:amd64 (1:2.10.2-1ubuntu1~16.04.1, automatic), linux-headers-generic-hwe-16.04:amd64 (4.8.0.58.29, automatic), xserver-xorg-video-nouveau-hwe-16.04:amd64 (1:1.0.12-2~16.04.1, automatic), linux-image-extra-4.10.0-26-generic:amd64 (4.10.0-26.30~16.04.1, automatic), xserver-xorg-input-all-hwe-16.04:amd64 (1:7.7+13ubuntu4~16.04.2, automatic), xserver-xorg-video-radeon-hwe-16.04:amd64 (1:7.7.1-1~16.04.1, automatic), linux-headers-generic-hwe-16.04-edge:amd64 (4.10.0.26.19, automatic), linux-headers-4.10.0-26-generic:amd64 (4.10.0-26.30~16.04.1, automatic), xserver-xorg-video-ati-hwe-16.04:amd64 (1:7.7.1-1~16.04.1, automatic), linux-image-generic-hwe-16.04-edge:amd64 (4.10.0.26.19, automatic)
Remove: xserver-xorg-input-all:amd64 (1:7.7+13ubuntu3), xserver-xorg-input-synaptics:amd64 (1.8.2-1ubuntu3), xserver-xorg:amd64 (1:7.7+13ubuntu3), xserver-xorg-video-qxl:amd64 (0.1.4-3ubuntu3), xserver-xorg-video-vesa:amd64 (1:2.3.4-1build2), xserver-xorg-video-nouveau:amd64 (1:1.0.12-1build2), xserver-xorg-video-amdgpu:amd64 (1.1.2-0ubuntu0.16.04.1), xserver-xorg-core:amd64 (2:1.18.4-0ubuntu0.2), xserver-xorg-video-fbdev:amd64 (1:0.4.4-1build5), xserver-xorg-input-wacom:amd64 (1:0.32.0-0ubuntu3), xserver-xorg-input-vmmouse:amd64 (1:13.1.0-1ubuntu2), xserver-xorg-video-intel:amd64 (2:2.99.917+git20160325-1ubuntu1.2), xserver-xorg-video-vmware:amd64 (1:13.1.0-2ubuntu3), xserver-xorg-input-evdev:amd64 (1:2.10.1-1ubuntu2), xserver-xorg-video-all:amd64 (1:7.7+13ubuntu3), xserver-xorg-video-ati:amd64 (1:7.7.0-1), xserver-xorg-video-radeon:amd64 (1:7.7.0-1)
End-Date: 2017-07-16  15:33:02

Avant install, j'avais seulement des noyaux de la famille 4.4.0-x et après ça, je me retrouve avec les noyaux 4.8.0-58 et 4.10.0-26. Je ne sais pas trop si c'est normal ou pas que j'aie un noyau de la famille 4.8.0.x : je m'attendais seulement à avoir le noyau 4.10.0-26. Au redémarrage, le démarrage par défaut est bien sur le noyau 4.10.0-26

(*) sortie prévue pour le 3 Août 2017 d'après la ReleaseSchedule (last edited 2017-05-26)

Dernière modification par malbo (Le 16/07/2017, à 17:46)

Hors ligne

#23 Le 17/07/2017, à 15:28

freechelmi

Re : Rolling HWE Stacks pour 16.04

A ce sujet , bizarre qu'il n'y ait pas un xorg-edge ? du coup on peut avoir un noyau N+2 ou N+3 avec un xorg N+1 ?

Hors ligne

#24 Le 17/07/2017, à 16:09

moko138

Re : Rolling HWE Stacks pour 16.04

freechelmi a écrit :

A ce sujet , bizarre qu'il n'y ait pas un xorg-edge ? du coup on peut avoir un noyau N+2 ou N+3 avec un xorg N+1 ?

Ce n'est pas ainsi que je comprends le history.log ci-dessus :

Start-Date: 2017-07-16  15:21:08
Commandline: apt-get install --install-recommends
linux-generic-hwe-16.04-edge   xserver-xorg-hwe-16.04
(...)
Install: xserver-xorg-video-qxl-hwe-16.04:amd64 (0.1.4-3ubuntu3~16.04.1, automatic), (...)

Remove: (...), xserver-xorg-video-qxl:amd64 (0.1.4-3ubuntu3) (...)

Maintenant, je n'empêche personne d'essayer :

apt-get install --install-recommends linux-generic-hwe-16.04-edge

voire

apt-get install --no-install-recommends linux-generic-hwe-16.04-edge

%NOINDEX%
Un utilitaire méconnu : ncdu

Hors ligne

#25 Le 17/07/2017, à 16:24

Caribou22

Re : Rolling HWE Stacks pour 16.04

Bonjour,
Pour moi, une version ne pourrait tout simplement pas être qualifiée de stable avec un noyau en Rolling et donc une compatibilité matérielle au petit bonheur la chance.
C'est plus clair pour Debian : la stable reste stable sans évolution du noyau, et en cas d'incompatibilité c'est à l'utilisateur d'installer manuellement un noyau plus récent via le dépôt backports.

Ubuntu se disperse et dépense tellement d'énergie inutilement je trouve. Je perçoit l'abandon d'Unity comme un début de conscience de cette problématique. Je pense que le mieux serait qu'à terme, les versions non-LTS soient abandonnées et que les LTS, leurs noyaux et le LTSEnablementStack soient gérés plus intelligemment.

Dernière modification par Caribou22 (Le 17/07/2017, à 16:27)

Hors ligne