Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 02/04/2017, à 12:03

fazpedro

[Résolu] Pas de boot ASPIRE ES1 331

Bonjour,

j'ai installé ubuntu sur mon ordinateur portable de marque : ACER ASPIRE ES1-332-C96A
J'ai d'abord mis un mot de passe de sécurité, pour pouvoir avoir accès au choix de démarrage (touche F12), enlevé le "security boot", et ensuite installé ubuntu...
mais ensuite, lors du re-démarrage, voici le message obtenu : "No bootable device" ! et rien si je fais "F12"... (le Boot Manager est vide...)
j'ai lu sur les forums qu'il fallait indiquer dans le bios en "legacy" mais je ne retrouve pas dans le bios cet élément

Dans le BIOS : onglet SECURITY
Secure boot mode : Custom
Current TPM(TCM) State : installed
Change TPM(TCM) State : Enabled
Clear TPM(TCM) : Clear
Secure boot : Enabled

Avez-vous une idée pour que le boot se fasse bien sur ubuntu ?
Merci d'avance

PS : on ne peut pas mettre de photos qui sont sur mon disque dur dans la discussion ?

Dernière modification par fazpedro (Le 10/04/2017, à 21:15)

Hors ligne

#2 Le 02/04/2017, à 12:09

Bougron

Re : [Résolu] Pas de boot ASPIRE ES1 331

Hors ligne

#3 Le 02/04/2017, à 12:43

fazpedro

Re : [Résolu] Pas de boot ASPIRE ES1 331

Merci Bougron,
j'avais déjà lu mais le souci est que je n'ai pas dans mon BIOS cette partie dans l'onglet Security : "select an uefi as trusted for executing"
donc je ne vois pas comment faire ?
merci,

Hors ligne

#4 Le 02/04/2017, à 14:32

Bougron

Re : [Résolu] Pas de boot ASPIRE ES1 331

Peux-tu faire quelques photos de ton bios    que tu postera dans un site de partage de photos par exemple http://www.hostingpics.net/
Peux-tu faire un boot-info avec ton support d'installation https://doc.ubuntu-fr.org/tutoriel/boot-info

Une méthode alternative existe en installant REFIND et sgbd2r.
Si tu n'as pas windows dans ton micro, tu peux tester cette façon de faire https://forum.ubuntu-fr.org/viewtopic.p … #p21702214
Si tu as windows, on verra au vu du boot-info, ce qu'il convient de faire.

Dernière modification par Bougron (Le 02/04/2017, à 14:49)

Hors ligne

#5 Le 02/04/2017, à 15:01

fazpedro

Re : [Résolu] Pas de boot ASPIRE ES1 331

Hors ligne

#6 Le 02/04/2017, à 15:12

Bougron

Re : [Résolu] Pas de boot ASPIRE ES1 331

tentes la solution de namutu   et fais un boot-info si elle ne marche pas.

Hors ligne

#7 Le 02/04/2017, à 15:42

fazpedro

Re : [Résolu] Pas de boot ASPIRE ES1 331

Voici le résultat de boot-info :
http://paste2.org/FPmxGIN0

Hors ligne

#8 Le 02/04/2017, à 17:43

Bougron

Re : [Résolu] Pas de boot ASPIRE ES1 331

Tu n'as pas tellement raconté le raté d'installation de refind
Le peu que le boot-info permet de voir semble dire que ubuntu a bien été installé
=================== efibootmgr -v
BootCurrent: 0003
Timeout: 0 seconds
BootOrder: 0001,2001,2002,2003
Boot0000* Unknown Device:     HD(1,GPT,22d123e8-5b8b-4b92-87c2-bef8e31bf69d,0x800,0x100000)/File(EFIubuntushimx64.efi)RC
Boot0001* Windows Boot Manager    HD(1,GPT,22d123e8-5b8b-4b92-87c2-bef8e31bf69d,0x800,0x100000)/File(EFIMicrosoftBootbootmgfw.efi)RC
Boot0002* Unknown Device:     HD(1,GPT,22d123e8-5b8b-4b92-87c2-bef8e31bf69d,0x800,0x100000)/File(EFIubuntushimx64.efi)RC
Boot0003* USB HDD: SanDisk SanDisk Cruzer    PciRoot(0x0)/Pci(0x15,0x0)/USB(3,0)/Unit(0)/HD(1,MBR,0x4294967284,0x800,0x1dd97ff)RC
Boot0004* ubuntu    HD(1,GPT,22d123e8-5b8b-4b92-87c2-bef8e31bf69d,0x800,0x100000)/File(EFIubuntushimx64.efi)
Boot2001* EFI USB Device    RC
Boot2002* EFI DVD/CDROM    RC
Boot2003* EFI Network    RC

et lorsque le bios met en route avec EFI/ubuntu/shimx64.efi il est bien détecté mais transformé en unknowm
et que ton ordinateur semble bridé pour booter uniquement avec le fichierEFI/Microsoft/Bootbootmgfw.efi qui n'existe peut-être pas.
C'est pour cela que je t'ai proposé de mettre refind dans ce fichier

1) Booter  de nouveau avec la live-usb
2) choisir     "essayer avant d'installer"
3) mettre le clavier en français "setxkbmap fr"
4) Installation de REFIND :

sudo apt-add-repository ppa:rodsmith/refind
sudo apt-get update 
sudo apt-get install refind

5)Après l'installation copier REFIND  dans microsoft.

sudo cp /boot/efi/EFI/refind/refind_x64.efi   /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi

6) et booter pour vérifier

Dernière modification par Bougron (Le 02/04/2017, à 17:51)

Hors ligne

#9 Le 02/04/2017, à 19:47

fazpedro

Re : [Résolu] Pas de boot ASPIRE ES1 331

Voici le message d'erreur pour Refind :

** (appstreamcli:4621): CRITICAL **: Error while moving old database out of the way.
AppStream cache update failed.
Reading package lists... Done
xubuntu@xubuntu:~$ sudo apt-get install refind
Reading package lists... Done
Building dependency tree       
Reading state information... Done
refind is already the newest version (0.10.5-0ppa1).
0 upgraded, 0 newly installed, 0 to remove and 118 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] Y
Setting up refind (0.10.5-0ppa1) ...
Installing rEFInd to the ESP...
dpkg: error processing package refind (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 refind
E: Sub-process /usr/bin/dpkg returned an error code (1)
xubuntu@xubuntu:~$ 

xubuntu@xubuntu:~$ sudo cp /boot/efi/EFI/refind/refind_x64.efi   /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi
cp: cannot stat '/boot/efi/EFI/refind/refind_x64.efi': No such file or directory

Hors ligne

#10 Le 02/04/2017, à 22:04

Bougron

Re : [Résolu] Pas de boot ASPIRE ES1 331

Bonsoir
Je ne comprends pas trop la cause de l'échec.  Par comparaison

u16041@u16041:~$ sudo apt-get install refind
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les NOUVEAUX paquets suivants seront installés :
  refind
0 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 3 353 ko dans les archives.
Après cette opération, 4 820 ko d'espace disque supplémentaires seront utilisés.
0% [En cours]
Réception de:1 http://ppa.launchpad.net/rodsmith/refind/ubuntu xenial/main amd64 refind amd64 0.10.5-0ppa1 [3 353 kB]
3 353 ko réceptionnés en 2min 18s (24,3 ko/s)                                                                                                 
Préconfiguration des paquets...
Sélection du paquet refind précédemment désélectionné.
(Lecture de la base de données... 249113 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../refind_0.10.5-0ppa1_amd64.deb ...
Dépaquetage de refind (0.10.5-0ppa1) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.5-1) ...
Traitement des actions différées (« triggers ») pour doc-base (0.10.7) ...
Paramétrage de refind (0.10.5-0ppa1) ...
Installing rEFInd to the ESP...
u16041@u16041:~$ 

Il est possible que la vraie cause soit

** (appstreamcli:4621): CRITICAL **: Error while moving old database out of the way.
Traitement de 1 fichier de documentation ajouté…

qui semble connue https://bugs.launchpad.net/ubuntu/+sour … ug/1601971

Tout simplement parceque cela pose un problème sur une clé USB

Dans ce cas, il va falloir booter avec SGB2D  https://forum.ubuntu-fr.org/viewtopic.p … #p21700060 pour installer REFIND dans une session opérationnelle
http://www.supergrubdisk.org/super-grub2-disk/   Je pense qu'il faut de SGB2D soit installé sur un CDROM et pas une clé USB
voir une mode de fabrication https://forum.ubuntu-fr.org/viewtopic.php?id=1287711

Dernière modification par Bougron (Le 02/04/2017, à 22:19)

Hors ligne

#11 Le 03/04/2017, à 08:03

fazpedro

Re : [Résolu] Pas de boot ASPIRE ES1 331

Je n'ai pas de lecteur CD,
il n'y a pas un autre moyen ? roll

Hors ligne

#12 Le 03/04/2017, à 20:39

Bougron

Re : [Résolu] Pas de boot ASPIRE ES1 331

Bonsoir.

On va s'en tirer de cette façon  je l'espère.
Dans la journée, j'ai réalisé que la méthode installait certainement dans le  LIVE USB et non dans le EMMC2!
On va donc faire en sorte que cela ne se reproduise plus.
1) Booter  de nouveau avec la live-usb
2) Choisir     "Essayer avant d'installer"
3) Mettre le clavier en français  avec la commande "setxkbmap fr".  Cela sera certainement à frapper de cette façon  "setxkb,qp fr"
4) Se mettre dans la session ubuntu qui  vient d'être installée,   
  Cela serait le "Pérou" si une commande simple le permettait!!!!   Donc je vais te fournir une collection de commandes. J'espère qu'elles seront bonnes.   S'il y  a des erreurs, tu transmets.

             sudo mount    -v   /dev/mmcblk0p2     /mnt       
             sudo mount --bind /dev /mnt/dev
             sudo mount --bind /sys /mnt/sys
             sudo mount --bind /run  /mnt/run
             sudo mount --bind /proc /mnt/proc
             sudo mount --bind /run/resolvconf /mnt/run/resolvconf      
             sudo chroot  /mnt mount -t devpts devpts /dev/pts           
             sudo chroot  /mnt     

Avec cette dernière commande, tu dois être dans le ubuntu installé.
5) Vérifier que la connexion internet fonctionne

            ping     -c 5    8.8.8.8
            ping     -c 5   google.com   

6) Installer REFIND.

sudo apt-add-repository ppa:rodsmith/refind
sudo apt-get update 
sudo apt-get install refind

7) Indiquer que refind remplace windows.
J'espère que c'est cette commande

sudo cp /boot/efi/EFI/refind/refind_x64.efi   /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi

si rien n'est reconnu, on va faire en quelques étapes

sudo   umount  /dev/mmcblk0p1 
sudo      mount /dev/mmcblk0p1    /mnt
sudo cp     /mnt/EFI/refind/refind_x64.efi   /mnt/EFI/Microsoft/Boot/bootmgfw.efi

A bientôt ou à demain soir.

Dernière modification par Bougron (Le 03/04/2017, à 21:00)

Hors ligne

#13 Le 04/04/2017, à 18:07

fazpedro

Re : [Résolu] Pas de boot ASPIRE ES1 331

Bonjour,
il a bien installé refind
mais lors du boot (menu refind ok), j'ai choisi grubx65.efi et rien ne se passe...
Voici le message :

root@xubuntu:/# sudo cp /boot/efi/EFI/refind/refind_x64.efi   /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi
sudo: unable to resolve host xubuntu
cp: cannot stat '/boot/efi/EFI/refind/refind_x64.efi': No such file or directory
root@xubuntu:/# 

mon boot-info :
http://paste2.org/XcsZ8bPy

Hors ligne

#14 Le 04/04/2017, à 20:01

Bougron

Re : [Résolu] Pas de boot ASPIRE ES1 331

peux-tu dire s'il propose des fichiers de boot qui n'appartiennent pas à la partition Fat32.
si oui, c'est l'un de ceux-la qu'il faut choisir.

Ce n'est pas la peine de choisir grubx64.efi ni shimx64.efi

j'ai vu que ton bios était sécurisé, si refind ne marche pas,  tu pourras déactiver le mode securisé et tu lanceras un boot-repair qui devrait installer grubx64 au lieu de shimx64.
tu referas un boot-info. et une tentative de boot.

et tu referas les commandes

sudo   umount  /dev/mmcblk0p1 
sudo      mount /dev/mmcblk0p1    /mnt
sudo  ls  -ls   /mnt/EFI
sudo  ls   -ls   /mnt/efi

Dernière modification par Bougron (Le 04/04/2017, à 20:10)

Hors ligne

#15 Le 04/04/2017, à 20:37

fazpedro

Re : [Résolu] Pas de boot ASPIRE ES1 331

Après avoir fait ces opérations et un redémarrage :
au boot, j'ai le message d'erreur :

EFI\Microsoft\Boot\Grubx64.efi Not Found
EFI\BOOT\grubx64.efi

après j'ai fait les commandes ci-dessus :

xubuntu@xubuntu:~$ sudo   umount  /dev/mmcblk0p1
umount: /dev/mmcblk0p1: not mounted
xubuntu@xubuntu:~$ sudo      mount /dev/mmcblk0p1    /mnt
xubuntu@xubuntu:~$ sudo  ls  -ls   /mnt/EFI
total 20
4 drwxr-xr-x 2 root root 4096 Apr  4 21:19 Boot
4 drwxr-xr-x 3 root root 4096 Apr  4 18:54 Microsoft
4 drwxr-xr-x 5 root root 4096 Apr  4 18:15 refind
4 drwxr-xr-x 2 root root 4096 Apr  4 18:15 tools
4 drwxr-xr-x 3 root root 4096 Apr  4 17:55 ubuntu
xubuntu@xubuntu:~$ sudo  ls   -ls   /mnt/efi
total 20
4 drwxr-xr-x 2 root root 4096 Apr  4 21:19 Boot
4 drwxr-xr-x 3 root root 4096 Apr  4 18:54 Microsoft
4 drwxr-xr-x 5 root root 4096 Apr  4 18:15 refind
4 drwxr-xr-x 2 root root 4096 Apr  4 18:15 tools
4 drwxr-xr-x 3 root root 4096 Apr  4 17:55 ubuntu
xubuntu@xubuntu:~$ 

Boot-info :
http://paste2.org/8WCHFLOw

on va y arriver, non ? roll

Merci Bougron de ton aide big_smile

Hors ligne

#16 Le 04/04/2017, à 21:49

Bougron

Re : [Résolu] Pas de boot ASPIRE ES1 331

On va y arriver.
Ton micro semble vouloir booter en mode non sécurisé sur un fichier spécifique q'on va creer.

sudo   umount  /dev/mmcblk0p1 
sudo      mount /dev/mmcblk0p1    /mnt
sudo   mkdir  /mnt/EFI/Microsoft/Boot
sudo   cp   /mnt/EFI/ubuntu/grubx64.efi  /mnt/EFI/Microsoft/Boot/Grubx64.efi
sudo   cp   /mnt/EFI/ubuntu/grubx64.efi  /mnt/EFI/Boot/grubx64.efi

et reboot

Dernière modification par Bougron (Le 04/04/2017, à 22:07)

Hors ligne

#17 Le 04/04/2017, à 21:59

fazpedro

Re : [Résolu] Pas de boot ASPIRE ES1 331

Voici ce que ca donne :

xubuntu@xubuntu:~$ sudo   umount  /dev/mmcblk0p1
umount: /dev/mmcblk0p1: not mounted
xubuntu@xubuntu:~$ sudo      mount /dev/mmcblk0p1    /mnt
xubuntu@xubuntu:~$ sudo   mkdir   /mnt/efi/boot
mkdir: cannot create directory ‘/mnt/efi/boot’: File exists
xubuntu@xubuntu:~$ sudo  ls   -ls   /mnt/efi
total 20
4 drwxr-xr-x 2 root root 4096 Apr  4 22:54 Boot
4 drwxr-xr-x 3 root root 4096 Apr  4 18:54 Microsoft
4 drwxr-xr-x 5 root root 4096 Apr  4 18:15 refind
4 drwxr-xr-x 2 root root 4096 Apr  4 18:15 tools
4 drwxr-xr-x 3 root root 4096 Apr  4 17:55 ubuntu
xubuntu@xubuntu:~$ 

Hors ligne

#18 Le 04/04/2017, à 22:08

Bougron

Re : [Résolu] Pas de boot ASPIRE ES1 331

j'ai fini de mettre les commandes

Hors ligne

#19 Le 04/04/2017, à 22:16

fazpedro

Re : [Résolu] Pas de boot ASPIRE ES1 331

après ces commandes,
il boote...j'ai plus de message d'erreur.. mais il reste sur le logo d'Acer sad
on doit pas être loin...

Hors ligne

#20 Le 04/04/2017, à 22:34

fazpedro

Re : [Résolu] Pas de boot ASPIRE ES1 331

Si ça peut aider, j'ai fait la commande ci-dessous :
Merci

xubuntu@xubuntu:~$ sudo efibootmgr -v
BootCurrent: 0003
Timeout: 0 seconds
BootOrder: 0001,2001,2002,2003
Boot0000* Unknown Device: 	HD(1,GPT,3f7264e6-734a-4f82-bc2a-daaa0a94d631,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot0001* Windows Boot Manager	HD(1,GPT,3f7264e6-734a-4f82-bc2a-daaa0a94d631,0x800,0x100000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0002* Unknown Device: 	HD(1,GPT,3f7264e6-734a-4f82-bc2a-daaa0a94d631,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot0003* USB HDD: SanDisk SanDisk Cruzer	PciRoot(0x0)/Pci(0x15,0x0)/USB(3,0)/Unit(0)/HD(1,MBR,0x4294967284,0x800,0x1dd97ff)RC
Boot0004* ubuntu	HD(1,GPT,3f7264e6-734a-4f82-bc2a-daaa0a94d631,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)
Boot2001* EFI USB Device	RC
Boot2002* EFI DVD/CDROM	RC
Boot2003* EFI Network	RC

Hors ligne

#21 Le 04/04/2017, à 22:37

Bougron

Re : [Résolu] Pas de boot ASPIRE ES1 331

on est au même niveau que l'autre discussion résolue par refind

On va y arriver.

sudo   umount  /dev/mmcblk0p1 
sudo      mount /dev/mmcblk0p1    /mnt
sudo   ls    -ls    /mnt/EFI/refind
sudo   cp   /mnt/EFI/refind/refind_x64.efi  /mnt/EFI/Microsoft/Boot/Grubx64.efi
sudo   cp   /mnt/EFI/refind/refind_x64.efi  /mnt/EFI/Boot/grubx64.efi

et reboot

Hors ligne

#22 Le 05/04/2017, à 17:29

fazpedro

Re : [Résolu] Pas de boot ASPIRE ES1 331

Alors le boot se fait,
j'ai le menu refind :
j'ai essayé les plusieurs choix possibles mais ce n'est pas concluant sad

EFI\ubuntu\fbx64.efi    >>>>>    Redémarre
EFI\ubuntu\mmx64.efi   >>>>>    Menu Shym puis rien
EFI\ubuntu\grubx64.efi   >>>>>    Rien
EFI\refind\refind_x64.efi   >>>>>    MENU mais avec les même choix que ci-dessus et même résultat sauf dernière ligne :
EFI\Boot\Grubx64.efi >>>>>>>
là il boot mais sur le \boot\vmzlinz-48.0-46-generic.efi.signed from ext4
et ensuite un message d'erreur :
Kernel panic... CPU not tainted...

Merci de ta patience roll

Dernière modification par fazpedro (Le 05/04/2017, à 17:29)

Hors ligne

#23 Le 05/04/2017, à 17:46

Bougron

Re : [Résolu] Pas de boot ASPIRE ES1 331

fazpedro a écrit :

Alors le boot se fait,
j'ai le menu refind :
là il boot mais sur le \boot\vmzlinz-48.0-46-generic.efi.signed from ext4
et ensuite un message d'erreur :
Kernel panic... CPU not tainted...
Merci de ta patience roll

Bonjour

essaies de dire la totalité des messages  car je crois que cela ne va pas être si facile http://unix.stackexchange.com/questions … ted-kernel
The kernel may become tainted for any of several reasons, including (but not limited to) the following:
   - The use of a proprietary (or non-GPL-compatible) kernel module—this is the most common cause of tainted kernels and usually results from loading proprietary NVIDIA or AMD video drivers
   - The use of staging drivers, which are part of the kernel source code but are not fully tested
    -The use of out-of-tree modules that are not included with the Linux kernel source code
    Forcible loading or unloading of a kernel module (such as forcibly inserting a module not inuxbuilt for the current version of the kernel)
  -  The use of an SMP (multiprocessor) kernel on certain unsupported uniprocessor CPUs, primarily older AMD Athlon processors
    - Overriding of the ACPI DSDT, sometimes needed to correct for power-management bugs (see here for details)
  -  Certain critical error conditions, such as machine check exceptions and kernel oopses
  -  Certain serious bugs in the system firmware (BIOS, UEFI) which the kernel must work around


Je note pour plus tard que cet ordinateur connaît linux donc il faudra faire la commande
sudo efibootmgr --create --disk /dev/mmcblk0 --Part 1 --label "ubuntu"  --loader "\\EFI\linux\BOOTX64.efi"
http://community.acer.com/t5/Linux/Aspi … d-p/467519

Intel   Processor Type    Celeron    Processor Model   N3350

Dernière modification par Bougron (Le 05/04/2017, à 18:16)

Hors ligne

#24 Le 05/04/2017, à 18:12

fazpedro

Re : [Résolu] Pas de boot ASPIRE ES1 331

Voici le résultat :

xubuntu@xubuntu:~$ setxkbmap fr
xubuntu@xubuntu:~$ sudo mount    -v   /dev/mmcblk0p2     /mnt
mount: /dev/mmcblk0p2 mounted on /mnt.
xubuntu@xubuntu:~$ sudo mount    -v   /dev/mmcblk0p2     /mnt
mount: /dev/mmcblk0p2 is already mounted or /mnt busy
       /dev/mmcblk0p2 is already mounted on /mnt
xubuntu@xubuntu:~$ sudo mount --bind /dev /mnt/dev
xubuntu@xubuntu:~$ sudo mount --bind /sys /mnt/sys
xubuntu@xubuntu:~$ sudo mount --bind /run  /mnt/run
xubuntu@xubuntu:~$ sudo mount --bind /proc /mnt/proc
xubuntu@xubuntu:~$ sudo mount --bind /run/resolvconf /mnt/run/resolvconf
xubuntu@xubuntu:~$ sudo chroot  /mnt mount -t devpts devpts /dev/pts
xubuntu@xubuntu:~$ sudo chroot  /mnt     
root@xubuntu:/# sudo apt-add-repository ppa:rodsmith/refind
sudo: unable to resolve host xubuntu

 A graphical boot manager for EFI- and UEFI-based computers, such as all Intel-based Macs and recent (most 2011 and later) PCs.
 More info: https://launchpad.net/~rodsmith/+archive/ubuntu/refind
Press [ENTER] to continue or ctrl-c to cancel adding it
gpg: keyring `/tmp/tmpjcamlpme/secring.gpg' created
gpg: keyring `/tmp/tmpjcamlpme/pubring.gpg' created
gpg: requesting key 9122E0C2 from hkp server keyserver.ubuntu.com
gpg: /tmp/tmpjcamlpme/trustdb.gpg: trustdb created
gpg: key 9122E0C2: public key "Launchpad PPA for Roderick Smith" imported
gpg: Total number processed: 1
gpg:               imported: 1  (RSA: 1)
OK
root@xubuntu:/# sudo apt-get update
sudo: unable to resolve host xubuntu
Hit:1 http://fr.archive.ubuntu.com/ubuntu xenial InRelease
Get:2 http://fr.archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]                                     
Get:3 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]                                      
Hit:4 http://ppa.launchpad.net/rodsmith/refind/ubuntu xenial InRelease                                          
Get:5 http://fr.archive.ubuntu.com/ubuntu xenial-backports InRelease [102 kB]                                   
Fetched 306 kB in 1s (252 kB/s)                                                              
Reading package lists... Done
root@xubuntu:/# sudo apt-get install refind
sudo: unable to resolve host xubuntu
Reading package lists... Done
Building dependency tree       
Reading state information... Done
refind is already the newest version (0.10.5-0ppa1).
The following package was automatically installed and is no longer required:
  shim
Use 'sudo apt autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 107 not upgraded.
root@xubuntu:/# sudo cp /boot/efi/EFI/refind/refind_x64.efi   /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi
sudo: unable to resolve host xubuntu
cp: cannot stat '/boot/efi/EFI/refind/refind_x64.efi': No such file or directory
root@xubuntu:/# sudo cp /boot/efi/EFI/ubuntu/shimx64.efi   /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi
sudo: unable to resolve host xubuntu
cp: cannot stat '/boot/efi/EFI/ubuntu/shimx64.efi': No such file or directory
root@xubuntu:/# sudo cp /boot/EFI/ubuntu/xgrub64.efi   /boot/EFI/Microsoft/Boot/bootmgfw.efi
sudo: unable to resolve host xubuntu
cp: cannot stat '/boot/EFI/ubuntu/xgrub64.efi': No such file or directory
root@xubuntu:/# 
root@xubuntu:/# sudo   cp   /mnt/EFI/refind/refind_x64.efi  /mnt/EFI/Microsoft/Boot/grubx64.efi
sudo: unable to resolve host xubuntu
cp: cannot stat '/mnt/EFI/refind/refind_x64.efi': No such file or directory
root@xubuntu:/#  sudo   cp   /mnt/EFI/refind/refind_x64.efi  /mnt/EFI/Boot/grubx64.efi
sudo: unable to resolve host xubuntu
cp: cannot stat '/mnt/EFI/refind/refind_x64.efi': No such file or directory
root@xubuntu:/#  sudo   cp   /mnt/EFI/refind/refind_x64.efi  /mnt/EFI/Boot/grubx64.efi
sudo: unable to resolve host xubuntu
cp: cannot stat '/mnt/EFI/refind/refind_x64.efi': No such file or directory
root@xubuntu:/# sudo efibootmgr --create --disk /dev/mmcblk0 --Part 1 --label "ubuntu"  --loader "\\EFI\linux\BOOTX64.efi"
sudo: unable to resolve host xubuntu
efibootmgr: unrecognized option '--Part'
efibootmgr version 0.12
usage: efibootmgr [options]
	-a | --active         sets bootnum active
	-A | --inactive       sets bootnum inactive
	-b | --bootnum XXXX   modify BootXXXX (hex)
	-B | --delete-bootnum delete bootnum (hex)
	-c | --create         create new variable bootnum and add to bootorder
	-C | --create-only	create new variable bootnum and do not add to bootorder
	-D | --remove-dups	remove duplicate values from BootOrder
	-d | --disk disk       (defaults to /dev/sda) containing loader
	-e | --edd [1|3|-1]   force EDD 1.0 or 3.0 creation variables, or guess
	-E | --device num      EDD 1.0 device number (defaults to 0x80)
	-g | --gpt            force disk with invalid PMBR to be treated as GPT
	-i | --iface name     create a netboot entry for the named interface
	-l | --loader name     (defaults to \EFI\redhat\grub.efi)
	-L | --label label     Boot manager display label (defaults to "Linux")
	-n | --bootnext XXXX   set BootNext to XXXX (hex)
	-N | --delete-bootnext delete BootNext
	-o | --bootorder XXXX,YYYY,ZZZZ,...     explicitly set BootOrder (hex)
	-O | --delete-bootorder delete BootOrder
	-p | --part part        (defaults to 1) containing loader
	-q | --quiet            be quiet
	-t | --timeout seconds  set boot manager timeout waiting for user input.
	-T | --delete-timeout   delete Timeout.
	-u | --unicode | --UCS-2  pass extra args as UCS-2 (default is ASCII)
	-v | --verbose          print additional information
	-V | --version          return version and exit
	-w | --write-signature  write unique sig to MBR if needed
	-@ | --append-binary-args file  append extra args from file (use "-" for stdin)
	-h | --help             show help/usage
root@xubuntu:/# sudo efibootmgr --create --disk /dev/mmcblk0 --Part 1 --label "ubuntu"  --loader "\\EFI\linux\BOOTX64.efi"
sudo: unable to resolve host xubuntu
efibootmgr: unrecognized option '--Part'
efibootmgr version 0.12
usage: efibootmgr [options]
	-a | --active         sets bootnum active
	-A | --inactive       sets bootnum inactive
	-b | --bootnum XXXX   modify BootXXXX (hex)
	-B | --delete-bootnum delete bootnum (hex)
	-c | --create         create new variable bootnum and add to bootorder
	-C | --create-only	create new variable bootnum and do not add to bootorder
	-D | --remove-dups	remove duplicate values from BootOrder
	-d | --disk disk       (defaults to /dev/sda) containing loader
	-e | --edd [1|3|-1]   force EDD 1.0 or 3.0 creation variables, or guess
	-E | --device num      EDD 1.0 device number (defaults to 0x80)
	-g | --gpt            force disk with invalid PMBR to be treated as GPT
	-i | --iface name     create a netboot entry for the named interface
	-l | --loader name     (defaults to \EFI\redhat\grub.efi)
	-L | --label label     Boot manager display label (defaults to "Linux")
	-n | --bootnext XXXX   set BootNext to XXXX (hex)
	-N | --delete-bootnext delete BootNext
	-o | --bootorder XXXX,YYYY,ZZZZ,...     explicitly set BootOrder (hex)
	-O | --delete-bootorder delete BootOrder
	-p | --part part        (defaults to 1) containing loader
	-q | --quiet            be quiet
	-t | --timeout seconds  set boot manager timeout waiting for user input.
	-T | --delete-timeout   delete Timeout.
	-u | --unicode | --UCS-2  pass extra args as UCS-2 (default is ASCII)
	-v | --verbose          print additional information
	-V | --version          return version and exit
	-w | --write-signature  write unique sig to MBR if needed
	-@ | --append-binary-args file  append extra args from file (use "-" for stdin)
	-h | --help             show help/usage
root@xubuntu:/# sudo efibootmgr --create --disk /dev/mmcblk0 --p --label "ubuntu"  --loader "\\EFI\linux\BOOTX64.efi"
sudo: unable to resolve host xubuntu
invalid numeric value --label
root@xubuntu:/# sudo efibootmgr --create --disk /dev/mmcblk0 --p1 --label "ubuntu"  --loader "\\EFI\linux\BOOTX64.efi"
sudo: unable to resolve host xubuntu
efibootmgr: unrecognized option '--p1'
efibootmgr version 0.12
usage: efibootmgr [options]
	-a | --active         sets bootnum active
	-A | --inactive       sets bootnum inactive
	-b | --bootnum XXXX   modify BootXXXX (hex)
	-B | --delete-bootnum delete bootnum (hex)
	-c | --create         create new variable bootnum and add to bootorder
	-C | --create-only	create new variable bootnum and do not add to bootorder
	-D | --remove-dups	remove duplicate values from BootOrder
	-d | --disk disk       (defaults to /dev/sda) containing loader
	-e | --edd [1|3|-1]   force EDD 1.0 or 3.0 creation variables, or guess
	-E | --device num      EDD 1.0 device number (defaults to 0x80)
	-g | --gpt            force disk with invalid PMBR to be treated as GPT
	-i | --iface name     create a netboot entry for the named interface
	-l | --loader name     (defaults to \EFI\redhat\grub.efi)
	-L | --label label     Boot manager display label (defaults to "Linux")
	-n | --bootnext XXXX   set BootNext to XXXX (hex)
	-N | --delete-bootnext delete BootNext
	-o | --bootorder XXXX,YYYY,ZZZZ,...     explicitly set BootOrder (hex)
	-O | --delete-bootorder delete BootOrder
	-p | --part part        (defaults to 1) containing loader
	-q | --quiet            be quiet
	-t | --timeout seconds  set boot manager timeout waiting for user input.
	-T | --delete-timeout   delete Timeout.
	-u | --unicode | --UCS-2  pass extra args as UCS-2 (default is ASCII)
	-v | --verbose          print additional information
	-V | --version          return version and exit
	-w | --write-signature  write unique sig to MBR if needed
	-@ | --append-binary-args file  append extra args from file (use "-" for stdin)
	-h | --help             show help/usage
root@xubuntu:/# sudo efibootmgr --create --disk /dev/mmcblk0 --p --label "ubuntu"  --loader "\\EFI\linux\BOOTX64.efi"
sudo: unable to resolve host xubuntu
invalid numeric value --label
root@xubuntu:/# sudo efibootmgr --create --disk /dev/mmcblk0 --p --label "ubuntu"  --loader "\\EFI\linux\BOOTX64.efi"
sudo: unable to resolve host xubuntu
invalid numeric value --label
root@xubuntu:/# sudo efibootmgr --create --disk /dev/mmcblk0 --p --label 'ubuntu'  --loader "\\EFI\linux\BOOTX64.efi"
sudo: unable to resolve host xubuntu
invalid numeric value --label
root@xubuntu:/# sudo efibootmgr --create --disk /dev/mmcblk0 --p --label "ubuntu"  --loader "\\EFI\linux\BOOTX64.efi"
sudo: unable to resolve host xubuntu
invalid numeric value --label
root@xubuntu:/# 

Hors ligne

#25 Le 05/04/2017, à 18:27

Bougron

Re : [Résolu] Pas de boot ASPIRE ES1 331

Là,  on ne se comprend plus

Pour le moment, Tu réussis parfaitement a booter avec refind mais le programme de mise en route  du grub  ne marche pas très bien.
C'est cela qu'il faut qu'on traite
    en premier on va regarder la version de bios.    Et s'il est à jour

Pour plus tard, on pourra reprendre cette commande en vérifiant qu'il n'y a pas d'erreurs de codif et en faisant en amont ce qu'il faut

mkdir  /EFI/linux
cp      /EFI/ubuntu/grubx64.efi     /EFI/linux/BOOTX64.efi
 efibootmgr --create --disk /dev/mmcblk0 --part 1 --label "ubuntu"  --loader "\EFI\linux\BOOTX64.efi"

Dernière modification par Bougron (Le 05/04/2017, à 18:32)

Hors ligne