Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 09/06/2017, à 07:21

Compte anonymisé

[Résolu] Systmd-resolve à 100%

Bonjour.

Suite à l'upgrade vers 17.04 , j'ai bien entendu été obligé de réactiver l'interface ethernet dans le fichier /usr/lib/NetworkManager/conf.d/10-globally-managed-devices.conf

unmanaged-devices=*,except:type:wifi,except:type:wwan,except:type:ethernet

Cependant, un bug assez cocasse est apparu. Voici le scénario :
Au démarrage de la machine, le message obscur classique "Un problème logiciel a été détecté" sans détails supplémentaires sur la message-box . Outre le fait qu'il faille aller chercher les informations supplémentaires avec la lampe de mineur,  le souci vient de systemd-resolved qui crashe puis pédale à 100% dans le vide.
Résultat : pas de DNS.
Pour régler ce bug, je suis manuellement obligé d'éditer le fichier /etc/resolv.conf et virer le 127.0.0.53 que NetworkManager me cale d'office pour 8.8.8.8  ; puis de redémarrer systemd-resolved en le tuant  façon bourrin dans htop. 1 minute plus tard, la machine retrouve un comportement normal, mais au redémarrage de la machine, rebelote, je me retrouve avec 127.0.0.53 dans /etc/resolv.conf.

Pourquoi ?
Et comment en finir avec ces manipulations grotesques alors que sous Debian et Archlinux avec NetworkManager, je n'ai aucun problème.

Dernière modification par Compte anonymisé (Le 10/06/2017, à 07:56)

#2 Le 09/06/2017, à 09:58

F50

Re : [Résolu] Systmd-resolve à 100%

Yo smile

Désactive ce service et reboot.

Je t'avais demandé il y a quelques semaines si tu avais ce service lancé, tu m'avais dis ; non, alors que chez moi il l'était et faisait des problèmes après une grosse màj (Antergos) ! Désactivé et reboot puis, plus de souci.

P.S. Je ne sais plus a quoi il sert mais si mes souvenirs sont bons, les networks managers font le même boulot donc, doublon = merdier.


O. Wilde: Il me semble parfois que Dieu, en créant l’homme, ait quelque peu surestimé ses capacités.
U. Eco: "Internet? Ha dato diritto di parola agli imbecilli: ............... È l'invasione degli imbecilli"

Hors ligne

#3 Le 09/06/2017, à 20:07

Compte anonymisé

Re : [Résolu] Systmd-resolve à 100%

F50 a écrit :

Je t'avais demandé il y a quelques semaines si tu avais ce service lancé, tu m'avais dis ; non, alors que chez moi il l'était et faisait des problèmes après une grosse màj (Antergos) ! Désactivé et reboot puis, plus de souci.

Je n'en ai pô le souvenir.
Cependant je l'ai désactivé mais il se réactive à la va que je t'embrouille , toujours en me réécrivant "nameserver 127.0.0.53" dans /etc/resolv.conf. Bon cela peut à la rigueur être accepté mais bien entendu, les concepteurs de ce truc là ont eu la délicatesse de permettre à ce service d'ajouter un DNS dans /etc/resolv.conf ; au lieu d'effacer les existants et d'en réécrire un au pif roll
Bah ils l'ont voulu comme ça, ben moi je fais ceci :

/lib/systemd/system/systemd-resolved.service.d/resolvconf.conf a écrit :

giadmin@gi-asshole-ubuntu:~$ nano /lib/systemd/system/systemd-resolved.service.d/resolvconf.conf
giadmin@gi-asshole-ubuntu:~$ cat /lib/systemd/system/systemd-resolved.service.d/resolvconf.conf
# When resolved is in use, it must be brought up before we consider networking
# available because otherwise there is a window where DNS resolution doesn't
# work.
[Unit]
Before=network-online.target

# tell resolvconf about resolved's builtin DNS server, so that DNS servers
# picked up via networkd are respected when using resolvconf, and that software
# like Chrome that does not do NSS (libnss-resolve) still gets proper DNS
# resolution; do not remove the entry after stop though, as that leads to
# timeouts on shutdown via the resolvconf hooks (see LP: #1648068)
[Service]
ExecStartPost=+/bin/sh -c '[ ! -e /run/resolvconf/enable-updates ] || echo "nameserver 127.0.0.53 212.27.40.241" | /sbin/resolvconf -a systemd-resolved'
ReadWritePaths=-/run/resolvconf

puis vous voyez ce service qui redémarre tout seul ? Pareil, je lui dit de ne plus redémarrer.

/lib/systemd/system/systemd-resolved.service a écrit :

#  This file is part of systemd.
#
#  systemd is free software; you can redistribute it and/or modify it
#  under the terms of the GNU Lesser General Public License as published by
#  the Free Software Foundation; either version 2.1 of the License, or
#  (at your option) any later version.

[Unit]
Description=Network Name Resolution
Documentation=man:systemd-resolved.service(8)
Documentation=http://www.freedesktop.org/wiki/Software/systemd/resolved
Documentation=http://www.freedesktop.org/wiki/Software/systemd/writing-network-configuration-managers
Documentation=http://www.freedesktop.org/wiki/Software/systemd/writing-resolver-clients
After=systemd-networkd.service network.target

# On kdbus systems we pull in the busname explicitly, because it
# carries policy that allows the daemon to acquire its name.
Wants=org.freedesktop.resolve1.busname
After=org.freedesktop.resolve1.busname

[Service]
Type=notify
Restart=always never
RestartSec=0
ExecStart=/lib/systemd/systemd-resolved
WatchdogSec=3min
CapabilityBoundingSet=CAP_SETUID CAP_SETGID CAP_SETPCAP CAP_CHOWN CAP_DAC_OVERRIDE CAP_FOWNER CAP_NET_RAW CAP_NET_BIND_SERVICE
PrivateTmp=yes
PrivateDevices=yes
ProtectSystem=full
ProtectHome=yes
ProtectControlGroups=yes
ProtectKernelTunables=yes
MemoryDenyWriteExecute=yes
RestrictRealtime=yes
RestrictAddressFamilies=AF_UNIX AF_NETLINK AF_INET AF_INET6
SystemCallFilter=~@clock @cpu-emulation @debug @keyring @module @mount @obsolete @raw-io

[Install]
WantedBy=multi-user.target

Pour l'instant, il ne râle plus sa bile avec "Un problème logiciel a été détecté" ( Merci captain obvious avec les ventilos à fond, je n'avais pas remarqué roll ) .
C'est dingue ces trucs là, ça me fait tellement pitié que je n'ai même pas envie de remonter ce bug qui de toutes façons leur sera incompréhensible car ce doit être un comportement normal de réécrire sans ton avis des fichers de conf système neutral .

#4 Le 09/06/2017, à 20:51

murph

Re : [Résolu] Systmd-resolve à 100%

jojo81 a écrit :

Pourquoi ?
Et comment en finir avec ces manipulations grotesques alors que sous Debian et Archlinux avec NetworkManager, je n'ai aucun problème.

Pourquoi ? Je n'en sais rien.
Par contre si tu veux que ton resolv.conf ne soit plus modifié par NetworkManager ou autre chose tu peux le rendre "immutable".

sudo chattr +i resolv.conf

Pour le rendre à nouveau modifiable

sudo chattr -i resolv.conf

Eric Zemmour est un interlocuteur avec lequel ce qui faisait le génie français, je pense aux débats dans les salons littéraires d'avant 1789, est encore possible. (M Onfray)
If you can't answer a man's arguments, all is not lost; you can still call him vile names. (EG Hubbard)
La réalité dépasse la fission.

Hors ligne

#5 Le 09/06/2017, à 20:53

Compte anonymisé

Re : [Résolu] Systmd-resolve à 100%

murph : le problème ne semble pas venir de network-manager qui a les bons DNS , contrairement à systemd-resolved.

Dernière modification par Compte anonymisé (Le 09/06/2017, à 20:54)

#6 Le 10/06/2017, à 05:48

F50

Re : [Résolu] Systmd-resolve à 100%

Par quelle commande désactives-tu systemd-resolved ?


O. Wilde: Il me semble parfois que Dieu, en créant l’homme, ait quelque peu surestimé ses capacités.
U. Eco: "Internet? Ha dato diritto di parola agli imbecilli: ............... È l'invasione degli imbecilli"

Hors ligne

#7 Le 10/06/2017, à 07:00

Compte anonymisé

Re : [Résolu] Systmd-resolve à 100%

systemctl stop systemd-resolved
systemctl disable systemd-resolved

Les deux n'ont aucun impact, le service redémarre.

Mais bon, faut croire que ma manipulation d'hier a amélioré qu'une seul truc : il n'y a plus de crash. ou pas, il vient de nouveau de crash mad .
Cependant, systemd-resolved continue à pomper 100% sur un thread.

Dernière modification par Compte anonymisé (Le 10/06/2017, à 07:11)

#8 Le 10/06/2017, à 07:42

F50

Re : [Résolu] Systmd-resolve à 100%


O. Wilde: Il me semble parfois que Dieu, en créant l’homme, ait quelque peu surestimé ses capacités.
U. Eco: "Internet? Ha dato diritto di parola agli imbecilli: ............... È l'invasione degli imbecilli"

Hors ligne

#9 Le 10/06/2017, à 07:48

Compte anonymisé

Re : [Résolu] Systmd-resolve à 100%

J'ai trouvé. big_smile

cat /etc/NetworkManager/NetworkManager.conf
[main]
plugins=ifupdown,keyfile,ofono
#dns=dnsmasq

[ifupdown]
managed=false

que j'ai transformé en

giadmin@gi-asshole-ubuntu:~$ cat /etc/NetworkManager/NetworkManager.conf
[main]
plugins=ifupdown,keyfile,ofono
dns=default

[ifupdown]
managed=false

puis j'ai supprimé /etc/resolv.conf , redémarré et maintenant non seulement j'ai mes bons DNS sans dnsmasq ou le cache plus bizzaroïdes les uns que les autresn mais en plus, yapu 100% d'occupation de thread sur systemd-resolved .


https://askubuntu.com/questions/907246/ … -in-ubuntu

Dernière modification par Compte anonymisé (Le 10/06/2017, à 07:55)