Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 20/09/2017, à 09:20

francoisrathelot

Installation HP Officejet 3831 [RESOLU]

Bonjour, j'ai installé sous xubuntu 14.04 ma nouvelle imprimante officejet 3831.
Elle a été reconnu sous officejet 3830.
Elle imprime parfaitement.
Par contre le scanner n'est pas reconnu.
J'ai installé HPLIP mais l'imprimante n'est pas trouvé.
Tout fonctionne parfaitement sous windows XP mais je voudrais rester sous xubuntu.
J'ai besoin d'aide
Merci

Dernière modification par francoisrathelot (Le 20/09/2017, à 12:06)

Hors ligne

#2 Le 20/09/2017, à 09:47

Caribou22

Re : Installation HP Officejet 3831 [RESOLU]

Bonjour smile

Je vois ici qu'il faut au minimum hplip 3.15.7 http://hplipopensource.com/hplip-web/mo … eries.html

Peux-tu nous donner ta version de hplip avec cette commande :

apt-cache policy hplip

Je suppose qu'elle est trop ancienne et qu'il va falloir passer sur une plus récente. A confirmer wink

Edit : apparemment tu as la 3.14.3 dans Xubuntu 14.04 : https://launchpad.net/ubuntu/trusty/+package/hplip

Dernière modification par Caribou22 (Le 20/09/2017, à 09:48)

Hors ligne

#3 Le 20/09/2017, à 10:21

francoisrathelot

Re : Installation HP Officejet 3831 [RESOLU]

Voici la réponse à la commande :
Installé : 3.14.3-0ubuntu3.4
  Candidat : 3.14.3-0ubuntu3.4
Table de version :
*** 3.14.3-0ubuntu3.4 0
        500 http://fr.archive.ubuntu.com/ubuntu/ trusty-updates/main i386 Packages
        500 http://security.ubuntu.com/ubuntu/ trusty-security/main i386 Packages
        100 /var/lib/dpkg/status
     3.14.3-0ubuntu3 0
        500 http://fr.archive.ubuntu.com/ubuntu/ trusty/main i386 Packages

Apparement la versio est effectivement trop ancienne.
Comment fait on pour installer la nouvelle version?

Hors ligne

#4 Le 20/09/2017, à 10:31

Caribou22

Re : Installation HP Officejet 3831 [RESOLU]

Bingo smile

Alors je pense qu'il faut d'abord désinstaller ta version actuelle de hplip.
La procédure pour ensuite installer la dernière version est ici : https://doc.ubuntu-fr.org/hplip#install … on_d_hplip

C'est un script qui s'exécute dans ton terminal, mais la procédure est bien expliquée. Si tu as des question ou un blocage, reviens vers moi wink (Je l'ai fait chez quelqu'un il y a quelques temps.)

Hors ligne

#5 Le 20/09/2017, à 11:04

francoisrathelot

Re : Installation HP Officejet 3831 [RESOLU]

J'ai désinstallé l'ancienne version, j'ai téléchargé la nouvelle version das mon répertoire téléchargement, j'ai tapé dans le terminal : sh hplip-*.run
et il me répond : sh: 0: Can't open hplip-*.run

Hors ligne

#6 Le 20/09/2017, à 11:09

Caribou22

Re : Installation HP Officejet 3831 [RESOLU]

Ah, il faut que le terminal soit dans le dossier où se situe le fichier que tu as téléchargé. Par défaut, le terminal est dans ton dossier personnel.
Pour l'ouvrir dans ton dossier téléchargement dans Xfce (l'environnement de Xubuntu), fais un clic droit dans le dossier en question, puis "ouvrir un terminal ici."
Puis ça devrait marcher si tu ré-essaye wink

Hors ligne

#7 Le 20/09/2017, à 11:41

francoisrathelot

Re : Installation HP Officejet 3831 [RESOLU]

Effectivement le programme c'est lancé.
J'ai suivi les instructions du post et j'ai eu le résultat suivant :
warning: Missing REQUIRED dependency: python-devel (Python devel - Python development files)


CHECKING FOR NETWORK CONNECTION
-------------------------------
Network connection present.


RUNNING PRE-PACKAGE COMMANDS
----------------------------
sudo dpkg --configure -a (Pre-depend step 1)
sudo apt-get install --yes --force-yes -f (Pre-depend step 2)
sudo apt-get update (Pre-depend step 3)
OK


DEPENDENCY AND CONFLICT RESOLUTION
----------------------------------
Running 'sudo apt-get install --assume-yes python-dev'
Please wait, this may take several minutes...
HPLIP-3.14.3 exists, this may conflict with the new one being installed.
Do you want to ('i'= Remove and Install*, 'q'= Quit)?    :i
Starting uninstallation...


Cela fait maintenant plus de 35 mn qu'il travaille.
j'attend

Hors ligne

#8 Le 20/09/2017, à 11:45

Caribou22

Re : Installation HP Officejet 3831 [RESOLU]

Tu avais désinstallé ta version de hplip avant ?

Hors ligne

#9 Le 20/09/2017, à 11:47

francoisrathelot

Re : Installation HP Officejet 3831 [RESOLU]

oui avec la logiteque ubuntu

Hors ligne

#10 Le 20/09/2017, à 11:49

Caribou22

Re : Installation HP Officejet 3831 [RESOLU]

Il me semble que ça m'avait fait le coup aussi. Ferme le terminal et relance si ça traine trop longtemps, et tu ne devrais plus avoir ce blocage.

Hors ligne

#11 Le 20/09/2017, à 12:02

francoisrathelot

Re : Installation HP Officejet 3831 [RESOLU]

Ça fonctionne!!!!
Merci pour votre rapidité, patience et compétences .

Hors ligne