Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 20/07/2018, à 15:17

Alain128

wol non persistant : pas de "/etc/rc.local" [RESOLU]

Bonjour,
suirte à une mise à jour, je suis sous 18.04, mon wol ne fonctionne plus. J'ai lu la doc et le forum, j'arrive à le réactiver mais une seule fois.
La manipulation ne persistant pas il faut la faire à chaque démarrage. Or la doc demande de modifier /etc/rc.local en ajoutant /sbin/ethtool -s eth0 wol g qui est bien la commande me faisant fonctionnel le wol.
Le problème est que /etc/rc.local n'est plus utilisé dans 18.04 et je connais pas son remplaçant. Mettre la ligne en question en démarrage comme une application ne fonctionne pas car il faut etre sudo.
De l'aide s'il vous plait?

Dernière modification par Alain128 (Le 20/07/2018, à 16:50)

Hors ligne

#2 Le 20/07/2018, à 16:25

ylag

Re : wol non persistant : pas de "/etc/rc.local" [RESOLU]

Salut,

Sous Ubuntu 18.04 qui utilise systemd pour lancer le système, tu pourrais créer un service systemd activant automatiquement le WOL au démarrage.
En gros, il faut créer un fichier *.service dans /etc/systemd/system que tu pourrais nommer par exemple: wol.service contenant ces lignes:

[Unit]
Description="Lancer WOL"

[Service]
Type=oneshot
ExecStart=/sbin/ethtool -s eth0 wol g

[Install]
WantedBy=multi-user.target

ATTENTION!!! Le nom de ton interface ethernet n'est probablement pas eth0. Vérifie à l'aide de la commande ifconfig ou ip a, et remplace dans le sript la valeur eth0 par la bonne, s'il y a lieu. Par exemple, chez-moi l'interface éthernet se nomme enp4s0
J'utilise un tel script pour faire exactement le contraire: désactiver le wol au démarrage, et ça semble fonctionner nickel...

Donc, faire:

sudo nano /etc/systemd/system/wol.service

...colle dans la fenêtre qui s'ouvre le contenu du script c-i-haut mentionné avec, bien sur, le bon nom renseigné pour ton interface.
Note que tu peux utiliser un autre éditeur que nano, si tu préfères...

Une fois le fichier créé et enregistré sur ton disque, faire:

sudo systemctl enable wol.service

Le WOL devrait être actif au prochain démarrage.

Note que tu peux faire:

sudo systemctl start wol.service

...pour lancer le service sans avoir à redémarrer. La commande enable est toutefois nécessaire pour que le service se lance automatiquement à chaque démarrage.
La page de la doc relative à la création de services sous systemd: https://doc.ubuntu-fr.org/creer_un_service_avec_systemd

Si ça ne fonctionne pas selon ton désir, pour revenir à l'état précédent faire:

sudo systemctl disable wol.service

...et enlève ensuite le fichier créé:

sudo rm /etc/systemd/system/wol.service

Quant à rc.local sur Ubuntu 18.04, il faut l'activer à la main, voir cette doc (en englais, par contre...):
How to Enable /etc/rc.local with Systemd

A+

Dernière modification par ylag (Le 20/07/2018, à 16:55)

Hors ligne

#3 Le 20/07/2018, à 16:49

Alain128

Re : wol non persistant : pas de "/etc/rc.local" [RESOLU]

Merci, c'est exactement ce que je cherchais. Et oui pour moi enp5s0 au lieu de eth0

Hors ligne

#4 Le 20/07/2018, à 16:53

ylag

Re : wol non persistant : pas de "/etc/rc.local" [RESOLU]

Salut,

+1 smile

Si ça fonctionne à ta satisfaction, passe ton sujet en [RÉSOLU]...

A+

Hors ligne

#5 Le 17/05/2019, à 16:06

xubu1957

Re : wol non persistant : pas de "/etc/rc.local" [RESOLU]

Bonjour,

@ylag

Une idée pour cette nouvelle discussion > wol non fonctionnel depuis 19.04

Merci d'avance. wink


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne