Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 23/08/2018, à 21:46

DjDeViL

[RESOLU] Doom 4 Steam beta Error

Bonjour,

Je voulais tester la nouvelle beta de steam qui permet de jouer à des jeux windows sous Linux.

Donc j'ai installé DOOM 4 après être passé en steam beta, j'ai téléchargé les 70 Go comme si c'était un jeux Linux par défaut.

Je voulais le lancer et évidemment paf ERROR:


Voilà ce que j'ai:

Configured log listener print-redirect tags
Added structured log listener print-redirect
Added structured log listener mp-cloud-gobbler
2018-08-23T21:34:49.165+02:00 LOG: Process started
Added structured log listener aws-kinesis-logger
Winsock Initialized
------ Initializing File System ------
Current search path:
    - C:/users/steamuser/Saved Games/id Software/DOOM/base/
    - Z:/home/djdevil/.steam/steam/steamapps/common/DOOM/base/
------ File System initialized.
------ Command Line ------
 Z:\home\djdevil\.steam\steam\steamapps\common\DOOM\DOOMx64.exe vlk
2018-08-23T21:34:49.170+02:00 LOG: Command Line: Z:\home\djdevil\.steam\steam\steamapps\common\DOOM\DOOMx64.exe vlk
------ CPU Information ------
    1 CPU package, 6 physical cores, 12 logical cores
    3200 MHz    AMD CPU with MMX & SSE & SSE2 & SSE3 & SSSE3 & SSE41 & SSE42 & AVX & HTT
    65536 kB 1st level cache, 524288 kB 2nd level cache, 8388608 kB 3rd level cache
    16032 MB System Memory
initializing resource container gameresources.resources
initializing resource container gameresources.patch
idLib::SetProduction( PROD_PRODUCTION )
------- Initializing renderSystem --------
PreliminaryRenderSetup
---registered window class
---registered fake window class
---registered context window class
X..WGL_EXT_swap_control_tear not found
unknown error: 0x578
FATAL ERROR: wglCreateContextAttribsARB failed
Dumped console text to C:\users\steamuser\Saved Games\id Software\DOOM\base\ErrorLog_08-23-2018__09-34-50pm.txt.

idRenderSystem::Shutdown()
Shutting down OpenGL subsystem

***************************
FATAL ERROR: wglCreateContextAttribsARB failed

***************************

Je suis sous Ubuntu 18.04 (kernel 4.18.4)

lspci | grep VGA
08:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480] (rev e7)
djdevil@Ryzen1600:~$ glxinfo | grep "OpenGL version"
OpenGL version string: 3.1 Mesa 18.1.6 - padoka PPA

J'avais lu qu'il fallait au minimum Mesa 18.1 ce que j'ai donc si qq un sait m'aider je suis preneur big_smile

Dernière modification par DjDeViL (Le 27/08/2018, à 20:26)

Hors ligne

#2 Le 23/08/2018, à 21:57

xubu1957

Re : [RESOLU] Doom 4 Steam beta Error

Bonjour,

Je suis sous Ubuntu 18.04 (kernel 4.18.4)

Tu as un noyau futuriste si l'on se base sur la table officielle > linux-headers-generic.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#3 Le 23/08/2018, à 22:14

DjDeViL

Re : [RESOLU] Doom 4 Steam beta Error

Bah j'utilise

https://doc.ubuntu-fr.org/ubuntu_kernel_upgrade_utility

comme tu peux le voir:

1535055240-capture-du-2018-08-23-22-12-02.png

Tu crois que cela peut poser problème ?

Dernière modification par DjDeViL (Le 23/08/2018, à 22:15)

Hors ligne

#4 Le 23/08/2018, à 22:19

xubu1957

Re : [RESOLU] Doom 4 Steam beta Error

Tu peux tester avec le noyau de base ?


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#5 Le 23/08/2018, à 22:29

DjDeViL

Re : [RESOLU] Doom 4 Steam beta Error

djdevil@Ryzen1600:~$ uname -r
4.15.0-32-generic
djdevil@Ryzen1600:~$ uname -a
Linux Ryzen1600 4.15.0-32-generic #35-Ubuntu SMP Fri Aug 10 17:58:07 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
djdevil@Ryzen1600:~$ cat /proc/version
Linux version 4.15.0-32-generic (buildd@lgw01-amd64-039) (gcc version 7.3.0 (Ubuntu 7.3.0-16ubuntu3)) #35-Ubuntu SMP Fri Aug 10 17:58:07 UTC 2018
djdevil@Ryzen1600:~$ uname -mr
4.15.0-32-generic x86_64
djdevil@Ryzen1600:~$ lsb_release -af
Usage: lsb_release [options]

lsb_release: error: no such option: -f
djdevil@Ryzen1600:~$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 18.04.1 LTS
Release:	18.04
Codename:	bionic
djdevil@Ryzen1600:~$ 

Cela doit être le noyau d'origine, je vais tester smile

J'ai la même chose roll

Dernière modification par DjDeViL (Le 23/08/2018, à 22:30)

Hors ligne

#6 Le 23/08/2018, à 22:38

xubu1957

Re : [RESOLU] Doom 4 Steam beta Error

Je ne connais pas les inter-dépendances avec steam.

J'ai vu ce message > forum.ubuntu-fr.org/viewtopic.php?pid=21958573#p21958573


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#7 Le 23/08/2018, à 22:40

DjDeViL

Re : [RESOLU] Doom 4 Steam beta Error

yep j'ai vu ça aussi, j'hésite de passer sous Ubuntu 18.10 mais je pense que c'est encore un peu tôt hmm

Hors ligne

#8 Le 23/08/2018, à 22:44

xubu1957

Re : [RESOLU] Doom 4 Steam beta Error

Et installer une version 18.10, en plus de ta version habituelle ?

A la mode d'erresse > forum.ubuntu-fr.org/viewtopic.php?pid=21957768#p21957768


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#9 Le 23/08/2018, à 22:52

DjDeViL

Re : [RESOLU] Doom 4 Steam beta Error

Comme tu peux le voir:

J'ai une partition / pour la base Ubuntu
avec w10 en dual boot SSD
1535057420-capture-du-2018-08-23-22-49-45.png

DD à part pour le /home
1535057420-capture-du-2018-08-23-22-50-04.png

Donc faudrait que je crée une autre partition dans la SSD pour Ubuntu 18.10 ?

Hors ligne

#10 Le 23/08/2018, à 23:01

xubu1957

Re : [RESOLU] Doom 4 Steam beta Error

Je n'ai jamais géré ce type d'installation, je reste sur une version 16.04.1 LTS avec les noyaux 4.4.

Tu auras des conseils plus avisés, d'autres membres du forum.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#11 Le 23/08/2018, à 23:26

DjDeViL

Re : [RESOLU] Doom 4 Steam beta Error

Tu es un Unity addict tongue

Hors ligne

#12 Le 23/08/2018, à 23:35

xubu1957

Re : [RESOLU] Doom 4 Steam beta Error

Je suis sur xubuntu donc sur xfce mais pas sur unity.

Et  > Nos bureaux Xfce (Xubuntu, Voyager, Ubuntu Studio...) tongue


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#13 Le 24/08/2018, à 22:21

DjDeViL

Re : [RESOLU] Doom 4 Steam beta Error

Je n'aime pas trop xfce même si Voyager niveau design est vraiment bien pour du xfce qui n'a rien à envier à Gnome mais je préfère Gnome et même Cinnamon

Je viens de passer sous Ubuntu 18.10 et j'ai la même erreur hmm

djdevil@Ryzen1600:~$ glxinfo | grep "OpenGL version"
OpenGL version string: 3.1 Mesa 18.1.5
djdevil@Ryzen1600:~$ uname -r
4.17.0-7-generic

Aucun PPA, l'installation de base de la 18.10 d'aujourd'hui qui fonctionne pas mal du tout pour une alpha / beta cool

Mais je ne sais pas jouer à Doom pour le moment sad

Dernière modification par DjDeViL (Le 24/08/2018, à 22:24)

Hors ligne

#14 Le 27/08/2018, à 10:33

WATTT

Re : [RESOLU] Doom 4 Steam beta Error

Bonjour,

DOOM requiert pour OpenGL une version d'OpenGL en profil de comptatibilité 4.3. Mesa 18.1 ne supporte que OpenGL 3.1 avec ce profile. Mesa 18.2, qui n'est pas encore sortie, supporte la version 4.4. Une possibilité est de mettre à jour Mesa avec la version instable du PPA padoka.

Une autre possibilité est d'utiliser Vulkan au lieu d'OpenGL. D'abord installe les drivers vulkan avec

sudo apt-get install mesa_vulkan_drivers

Ensuite, Clique droit sur le jeu -> Propriétés ->  propriétés de lancement et mets

+r_renderAPI 1

Config: AMD Ryzen 2600 (6c/12t, 3.4GHz), 16Go DDR4, AMD RX 570 4Go
Laptop: Thinkpad E460, Intel i5 6200U (2c/4t), 12Go DDR3L, AMD R7 M360 (dGPU)

Hors ligne

#15 Le 27/08/2018, à 11:46

DjDeViL

Re : [RESOLU] Doom 4 Steam beta Error

Merci WATTT pour les précisions, je ne savais même pas que c'est seulement à Mesa 18.2 que Opengl 4 sera supporté yikes (je comprends mieux pourquoi Phoronix dis que c'est une version majeure important que tout le monde attend big_smile) heureusement que j'ai pu faire Serious SAM 3 BFE avec Mesa 18.1 (PPA padoka) cool

Je voulais tester Vulkan mais le paquet n'est pas dispo sous la 18.10

djdevil@Ryzen1600:~$ sudo apt-get install mesa_vulkan_drivers
[sudo] Mot de passe de djdevil : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet mesa_vulkan_drivers

Question à part, tu as une configuration Full AMD ta RX 570 avec un Phenom II j'en avais un il y a longtemps le 925 (400 Mhz en moins), mon frère a un athlon 860k Fm2+ avec 16 DDR3 2400 OC, il a pour le moment une R9 280 (j'avais une HD 7950 v2), je suis passé à une RX 580 et le CPU avait du mal à gérer niveau jeux (CPU Limited), j'ai changé pour un Ryzen 1600 cool

Mais pour mon frère il est tjrs en Fm2+ et je voulais lui mettre une RX 470 (modèle Custom Asus) en lieu et place de la R9 280 et comme tu as encore un plus vieux CPU, je voulais savoir si tu ne sens pas le CPU Limited c'est pour jouer en Full HD smile

Moi je l'ai senti avec ma RX 580 8G Nitro+ (la seule dipo durant le black friday) sous windows 10 dans Call of Duty WWII (durant la campagne) et sous Ubuntu avec Deus EX (le dernier) en changeant de CPU j'ai doublé les FPS en testant le PPA Padoka Stable qui était déjà en Mesa 18.1 (j'ai changé mon CPU fin mai).

C'est rare de trouver qq un Full AMD c'est pour ça tongue

Dernière modification par DjDeViL (Le 27/08/2018, à 11:47)

Hors ligne

#16 Le 27/08/2018, à 12:50

GammaDraconis

Re : [RESOLU] Doom 4 Steam beta Error

Je rappelle que les jeux Windows sous linux avec la nouvelle version de Steam ça reste de l'émulation (avec Wine) donc ça ne fonctionnera pas systématiquement, ça serai trop simple sinon !
Par exemple je peux déjà te dire que les jeux qui ont un système anti-triche comme PUBG ne peuvent pas fonctionner sous linux en émulation.

En faite le jeux Windows qui fonctionnent bien sur la nouvelle version de Steam en émulation sont des jeux qui fonctionnaient déjà correctement en les émulant soi même avec Wine/PoL

Dernière modification par GammaDraconis (Le 27/08/2018, à 12:52)


Discussion sur mon script de post-install pour Ubuntu 20.04LTS : https://forum.ubuntu-fr.org/viewtopic.php?id=2026344
Lien direct script : https://github.com/simbd/Ubuntu_20.04LTS_PostInstall
Démo vidéo (peertube) : https://video.ploud.fr/videos/watch/fb7 … 0d252ed2db

Hors ligne

#17 Le 27/08/2018, à 16:07

WATTT

Re : [RESOLU] Doom 4 Steam beta Error

Erreur de ma part, pour Vulkan, c'est

mesa-vulkan-drivers

Avec des tirets, pas des underscores.

Sinon, oui, le CPU limite clairement lors des jeux, je ne compte pas le garder éternellement. C'est particulièrement visible sous Linux, où la charge CPU est généralement plus importante. Par exemple, j'ai souvent un peu moins de 10 FPS en fin de partie sous Civ 6 à cause de ça. Ca créée également pas mal de stutter.

GammaDraconis a écrit :

Je rappelle que les jeux Windows sous linux avec la nouvelle version de Steam ça reste de l'émulation (avec Wine) donc ça ne fonctionnera pas systématiquement, ça serai trop simple sinon !
Par exemple je peux déjà te dire que les jeux qui ont un système anti-triche comme PUBG ne peuvent pas fonctionner sous linux en émulation.

En faite le jeux Windows qui fonctionnent bien sur la nouvelle version de Steam en émulation sont des jeux qui fonctionnaient déjà correctement en les émulant soi même avec Wine/PoL

DOOM avait à l'origine un DRM qui empêchait l'execution du jeu avec Wine. Il a été supprimé par la suite. L'impact de wine sur les performances avec DOOM est faible car les APIs utilisées (OpenGL et Vulkan) sont natives à Linux.
Le battleroyale de Fortnite fonctionnait avec wine avant qu'ils n'introduisent un anticheat incompatible.


Config: AMD Ryzen 2600 (6c/12t, 3.4GHz), 16Go DDR4, AMD RX 570 4Go
Laptop: Thinkpad E460, Intel i5 6200U (2c/4t), 12Go DDR3L, AMD R7 M360 (dGPU)

Hors ligne

#18 Le 27/08/2018, à 20:22

DjDeViL

Re : [RESOLU] Doom 4 Steam beta Error

GG WATT

Cela fonctionne, j'ai pu lancer le jeux cool

sudo apt install mesa-vulkan-drivers

Puis dans les propriétés du jeux:

+r_renderAPI 1

Comme ici smile

1535394165-capture.png

Dernière modification par DjDeViL (Le 22/10/2018, à 12:00)

Hors ligne