Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 13/02/2019, à 19:12

jamesbad000

[Résolu]Problème synchronisation de l'horloge sur kubuntu 18.04.02

Bonjour,

Depuis un moment (et probablement depuis l'origine de mon installation) j'ai noté que mon horloge ne se remettait pas à jour automatiquement.
l'option "Définir automatiquement la date et l"heure" est pourtant bien coché. Et si je la décoche, puis coche à nouveau elle rattrape le temps perdu.

Je note dans l'aide du panneau
"If you check Set date and time automatically this module will use systemd to fetch date and time."

Mais plus loin ça semble dire que ce n'est pas ça qui va régler mon problème.
"This is not sufficient, however, for maintaining an accurate clock in the long run. This is useful for occasionally setting the time on machines that do not have full-time network access, such as laptops."

Néanmoins, je cherche un service lié au mot clock et en trouve un désactivé (essayé time aussi, mais là rien)

$ sudo service --status-all | grep clock
 [ - ]  hwclock.sh

sudo service  hwclock.sh status
● hwclock.service
   Loaded: masked (/dev/null; bad)
   Active: inactive (dead)

Je tente de le démarrer et là, ça couine un truc dont le sens m'échappe. (Mais cohérent avec ce qu'il affiche sur la première ligne de statut)

$ sudo service  hwclock.sh start
Failed to start hwclock.service: Unit hwclock.service is masked.

Edit: En creusant je vois que mon problème viendrait de l'absence du paquet ntp. Je l'ai installé, on verra si ça règle le problème

Dernière modification par jamesbad000 (Le 17/02/2019, à 14:42)


L'espace et le temps sont les modes par lesquels nous pensons, et non les conditions dans lesquelles nous vivons. (Signé Albert)

Hors ligne

#2 Le 13/02/2019, à 19:36

grandtoubab

Re : [Résolu]Problème synchronisation de l'horloge sur kubuntu 18.04.02

Salut
Plus besoin de ntp depuis systemd
https://bidouilledebian.wordpress.com/2 … oge-du-pc/


Linux tout seul sur HP Pavilion DV7 et Acer Aspire T650, Canon MG3650 en wifi
Debian 10 Buster Gnome/Xorg, Gnome/Wayland, Weston/Wayland
https://bidouilledebian.wordpress.com/
ON M'A VU DANS LE VERCORS, SAUTER A L'ELASTIQUE..... J'AI DANS LES BOTTES DES MONTAGNES DE QUESTIONS....

Hors ligne

#3 Le 13/02/2019, à 20:36

jamesbad000

Re : [Résolu]Problème synchronisation de l'horloge sur kubuntu 18.04.02

Ok alors ça semble être effectivement le choix standard sur kde 18.04. Je trouve les services, mais l'un n'est pas activé automatiquement.

Je désintalle ntp et reboot pour y voir plus clair. Ensuite

fredk1804@MirageK1804:~$ systemctl status time*
● timers.target - Timers
   Loaded: loaded (/lib/systemd/system/timers.target; static; vendor preset: enabled)
   Active: active since Wed 2019-02-13 19:15:09 CET; 1min 9s ago
     Docs: man:systemd.special(7)

févr. 13 19:15:09 MirageK1804 systemd[1]: Reached target Timers.

● time-sync.target - System Time Synchronized
   Loaded: loaded (/lib/systemd/system/time-sync.target; static; vendor preset: enabled)
   Active: active since Wed 2019-02-13 19:15:08 CET; 1min 10s ago
     Docs: man:systemd.special(7)

Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.
fredk1804@MirageK1804:~$ systemctl status systemd-timesyncd.service -l
● systemd-timesyncd.service - Network Time Synchronization
   Loaded: loaded (/lib/systemd/system/systemd-timesyncd.service; disabled; vendor preset: enabled)
   Active: inactive (dead)
     Docs: man:systemd-timesyncd.service(8)

un service n'est pas démarré automatiquement, et lorsque je vais cocher / décocher "Définir automatiquement la date et l"heure", le service s'active.

fredk1804@MirageK1804:~$ systemctl status systemd-timesyncd.service -l
● systemd-timesyncd.service - Network Time Synchronization
   Loaded: loaded (/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: enabled)
   Active: active (running) since Wed 2019-02-13 19:16:30 CET; 6s ago
     Docs: man:systemd-timesyncd.service(8)
 Main PID: 2166 (systemd-timesyn)
   Status: "Synchronized to time server [2001:67c:1560:8003::c8]:123 (ntp.ubuntu.com)."
    Tasks: 2 (limit: 4915)
   CGroup: /system.slice/systemd-timesyncd.service
           └─2166 /lib/systemd/systemd-timesyncd

févr. 13 19:16:30 MirageK1804 systemd[1]: Starting Network Time Synchronization...
févr. 13 19:16:30 MirageK1804 systemd[1]: Started Network Time Synchronization.
févr. 13 19:16:31 MirageK1804 systemd-timesyncd[2166]: Synchronized to time server [2001:67c:1560:8003::c8]:1

Reste à comprendre pourquoi ?

Le  man de systemd-timesyncd.service m'amène à regarder :

fredk1804@MirageK1804:~$ sudo timedatectl status
[sudo] Mot de passe de fredk1804 : 
                      Local time: mer. 2019-02-13 19:29:52 CET
                  Universal time: mer. 2019-02-13 18:29:52 UTC
                        RTC time: mer. 2019-02-13 18:29:51
                       Time zone: Europe/Paris (CET, +0100)
       System clock synchronized: yes
systemd-timesyncd.service active: yes
                 RTC in local TZ: no

edit: l'affichage ci-dessus est après désactivation/réactivation de la syncrho via interface graphique. tel qu'expliqué plus haut...


Ce qui ne m'éclaire guère...

Edit : je note la même situation avec la même version installée dans une VM

edit2 :

sudo timedatectl set-ntp true

ne change rien à l'affaire, et ne démarre même pas le service, ni n'envoie le moindre message... Et code retour 0
la même si je met yes à la place de true. Par contre fuck déclenche une réaction et code retour 1.

edit3: Je vais voir sur un Ubuntu 18.04:
- Le service démarre bien tout seul
- la commande timedatectl set-ntp false/true arrête et démarre bien le service.
- le fichier de config /etc/systemd/timesyncd.conf est identique entre les 2 distributions (tout les paramètres en commentaire)

Dernière modification par jamesbad000 (Le 15/02/2019, à 00:19)


L'espace et le temps sont les modes par lesquels nous pensons, et non les conditions dans lesquelles nous vivons. (Signé Albert)

Hors ligne

#4 Le 14/02/2019, à 14:52

grandtoubab

Re : [Résolu]Problème synchronisation de l'horloge sur kubuntu 18.04.02

par défaut , sans conf, le serveur de temps est défini à la compilation
évr. 13 19:16:31 MirageK1804 systemd-timesyncd[2166]: Synchronized to time server [2001:67c:1560:8003::c8]:1

Dans ton cas acces à Canonical en ipv6
https://www.ip-tracker.org/locator/ip-l … 0:8003::c8

pour avoir le détail des infos de synchronisation

timedatectl show-timesync --all

ou

timedatectl timesync-status

Dernière modification par grandtoubab (Le 14/02/2019, à 15:18)


Linux tout seul sur HP Pavilion DV7 et Acer Aspire T650, Canon MG3650 en wifi
Debian 10 Buster Gnome/Xorg, Gnome/Wayland, Weston/Wayland
https://bidouilledebian.wordpress.com/
ON M'A VU DANS LE VERCORS, SAUTER A L'ELASTIQUE..... J'AI DANS LES BOTTES DES MONTAGNES DE QUESTIONS....

Hors ligne

#5 Le 14/02/2019, à 23:52

jamesbad000

Re : [Résolu]Problème synchronisation de l'horloge sur kubuntu 18.04.02

Hello,

grandtoubab a écrit :

pour avoir le détail des infos de synchronisation

timedatectl show-timesync --all

ou

timedatectl timesync-status

Ces options ne fonctionnent pas chez moi. Voilà ce que j'ai en stock :

timedatectl -h
timedatectl [OPTIONS...] COMMAND ...

Query or change system time and date settings.

  -h --help                Show this help message
     --version             Show package version
     --no-pager            Do not pipe output into a pager
     --no-ask-password     Do not prompt for password
  -H --host=[USER@]HOST    Operate on remote host
  -M --machine=CONTAINER   Operate on local container
     --adjust-system-clock Adjust system clock when changing local RTC mode

Commands:
  status                   Show current time settings
  set-time TIME            Set system time
  set-timezone ZONE        Set system time zone
  list-timezones           Show known time zones
  set-local-rtc BOOL       Control whether RTC is in local time
  set-ntp BOOL             Enable or disable network time synchronization
fredk1804@MirageK1804:~$

En fait je pense qu'il doit y avoir un problème de synchronisation avec un autre service lors du démarrage du système

Après le démarrage du système timedatectl indique que le service systemd-timesyncd.service est actif

fredk1804@MirageK1804:~$ timedatectl  status     
                      Local time: jeu. 2019-02-14 20:43:45 CET
                  Universal time: jeu. 2019-02-14 19:43:45 UTC
                        RTC time: jeu. 2019-02-14 19:43:45
                       Time zone: Europe/Paris (CET, +0100)
       System clock synchronized: no
systemd-timesyncd.service active: yes
                 RTC in local TZ: no

alors qu'il ne l'est pas

fredk1804@MirageK1804:~$ systemctl status systemd-timesyncd.service -l
● systemd-timesyncd.service - Network Time Synchronization
   Loaded: loaded (/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: enabled)
   Active: inactive (dead)
     Docs: man:systemd-timesyncd.service(8)

"timedatectl  set-ntp true" n'y change rien comme vu plus au

edit : et dans le journal, après démarrage, tout semble pourtant s'être déroulé normalement.

14/02/2019 20:44	polkitd(authority=local)	Registered Authentication Agent for unix-process:2087:11788 (system bus name :1.64 [/usr/bin/pkttyagent --notify-fd 5 --fallback], object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale fr_FR.UTF-8)
14/02/2019 20:44	dbus-daemon	[system] Activating via systemd: service name='org.freedesktop.timedate1' unit='dbus-org.freedesktop.timedate1.service' requested by ':1.65' (uid=1000 pid=2087 comm="timedatectl set-ntp true " label="unconfined")
14/02/2019 20:44	systemd	Starting Time & Date Service...
14/02/2019 20:44	dbus-daemon	[system] Successfully activated service 'org.freedesktop.timedate1'
14/02/2019 20:44	systemd	Started Time & Date Service.
14/02/2019 20:44	polkitd(authority=local)	Unregistered Authentication Agent for unix-process:2087:11788 (system bus name :1.64, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale fr_FR.UTF-8) (disconnected from bus)

Après une demande d'arrêt il apparait bien inactif.

fredk1804@MirageK1804:~$ timedatectl  set-ntp false
fredk1804@MirageK1804:~$ timedatectl  status       
                      Local time: jeu. 2019-02-14 20:45:06 CET
                  Universal time: jeu. 2019-02-14 19:45:06 UTC
                        RTC time: jeu. 2019-02-14 19:45:05
                       Time zone: Europe/Paris (CET, +0100)
       System clock synchronized: no
systemd-timesyncd.service active: no
                 RTC in local TZ: no

et ensuite on peut refaire une demande de démarrage qui fonctionne. Le status du serveur est cohérent, et la synchro d'horloge active...

fredk1804@MirageK1804:~$ timedatectl  set-ntp true

fredk1804@MirageK1804:~$ timedatectl  status      
                      Local time: jeu. 2019-02-14 20:45:18 CET
                  Universal time: jeu. 2019-02-14 19:45:18 UTC
                        RTC time: jeu. 2019-02-14 19:45:18
                       Time zone: Europe/Paris (CET, +0100)                                                     
       System clock synchronized: yes
systemd-timesyncd.service active: yes
                 RTC in local TZ: no

fredk1804@MirageK1804:~$ systemctl status systemd-timesyncd.service -l
● systemd-timesyncd.service - Network Time Synchronization
   Loaded: loaded (/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: enabled)
   Active: active (running) since Thu 2019-02-14 20:45:13 CET; 24s ago
     Docs: man:systemd-timesyncd.service(8)
 Main PID: 2159 (systemd-timesyn)
   Status: "Synchronized to time server [2001:67c:1560:8003::c7]:123 (ntp.ubuntu.com)."
    Tasks: 2 (limit: 4915)
   CGroup: /system.slice/systemd-timesyncd.service
           └─2159 /lib/systemd/systemd-timesyncd

févr. 14 20:45:13 MirageK1804 systemd[1]: Starting Network Time Synchronization...
févr. 14 20:45:13 MirageK1804 systemd[1]: Started Network Time Synchronization.
févr. 14 20:45:13 MirageK1804 systemd-timesyncd[2159]: Synchronized to time server [2001:67c:1560:8003::c7]:123 

Mais à ce stade je suis dans l'incapacité totale d'analyser plus en avant, vue ma maigre connaissance de systemd.
Ca me semble d'autant plus difficile à analyser si tous les paramètres sont définis à la compilations.

est-ce le cas aussi pour l'ordonnancement du démarrage des services ?

Je crois que je vais finir par ajouter les commandes d'arrêt / redémarrage dans mon script d'ouverture de session en attendant mieux...

Dernière modification par jamesbad000 (Le 15/02/2019, à 00:10)


L'espace et le temps sont les modes par lesquels nous pensons, et non les conditions dans lesquelles nous vivons. (Signé Albert)

Hors ligne

#6 Le 15/02/2019, à 12:17

grandtoubab

Re : [Résolu]Problème synchronisation de l'horloge sur kubuntu 18.04.02

jamesbad000 a écrit :

Hello,

grandtoubab a écrit :

pour avoir le détail des infos de synchronisation

timedatectl show-timesync --all

ou

timedatectl timesync-status

Ces options ne fonctionnent pas chez moi. Voilà ce que j'ai en stock :

Et oui encore une fois Ubuntu se montre inférieur à Debian

debian:~$ timedatectl timesync-status
       Server: 145.238.203.10 (ntp.obspm.fr)
Poll interval: 8min 32s (min: 32s; max 34min 8s)
         Leap: normal
      Version: 4
      Stratum: 2
    Reference: 91EECB0E
    Precision: 1us (-23)
Root distance: 30.692ms (max: 5s)
       Offset: -25.045ms
        Delay: 29.175ms
       Jitter: 29.441ms
 Packet count: 4
    Frequency: +49,075ppm

Au démarrage

debian:~$ systemd-analyze blame | grep time
           316ms systemd-timesyncd.service
            64ms user-runtime-dir@1001.service

Dans le journal

journalctl | grep time

entre autres

févr. 15 11:03:20 debian NetworkManager[2282]: <info>  [1550225000.3586] NetworkManager (version 1.14.4) is starting... (for the first time)
févr. 15 11:03:20 debian systemd[1]: Started RealtimeKit Scheduling Policy Service.
févr. 15 11:03:21 debian bluetoothd[2274]: src/adapter.c:btd_adapter_new() Discoverable timeout: 180 seconds
févr. 15 11:03:21 debian bluetoothd[2274]: src/adapter.c:btd_adapter_new() Pairable timeout: 0 seconds
févr. 15 11:03:28 debian NetworkManager[2282]: <info>  [1550225008.9799] dhcp4 (wlp3s0b1): activation: beginning transaction (timeout in 45 seconds)
févr. 15 11:03:30 debian NetworkManager[2282]: <info>  [1550225010.0377] dhcp4 (wlp3s0b1):   lease time 86400
févr. 15 11:03:31 debian bluetoothd[2274]: src/adapter.c:btd_adapter_new() Discoverable timeout: 180 seconds
févr. 15 11:03:31 debian bluetoothd[2274]: src/adapter.c:btd_adapter_new() Pairable timeout: 0 seconds
févr. 15 11:03:43 debian systemd-timesyncd[1876]: Synchronized to time server 145.238.203.10:123 (ntp.obspm.fr).

Dernière modification par grandtoubab (Le 15/02/2019, à 12:55)


Linux tout seul sur HP Pavilion DV7 et Acer Aspire T650, Canon MG3650 en wifi
Debian 10 Buster Gnome/Xorg, Gnome/Wayland, Weston/Wayland
https://bidouilledebian.wordpress.com/
ON M'A VU DANS LE VERCORS, SAUTER A L'ELASTIQUE..... J'AI DANS LES BOTTES DES MONTAGNES DE QUESTIONS....

Hors ligne

#7 Le 17/02/2019, à 14:41

jamesbad000

Re : [Résolu]Problème synchronisation de l'horloge sur kubuntu 18.04.02

Alors, en examinant les paramètres du service, au milieu de la masse je trouve

fredk1804@MirageK1804:~$ systemctl  show  systemd-timesyncd.service 
(...)
ConflictedBy=virtualbox-guest-utils.service

Service qui tombe aussitôt après avoir démarré, car il est vraisemblablement fait pour tourner dans une VM et non dans son hote.

fredk1804@MirageK1804:~$ systemctl  status virtualbox-guest-utils.service
● virtualbox-guest-utils.service - Virtualbox guest utils
   Loaded: loaded (/lib/systemd/system/virtualbox-guest-utils.service; enabled; vendor preset: enabled)
   Active: inactive (dead)
Condition: start condition failed at Sun 2019-02-17 12:37:56 CET; 46min ago
           └─ ConditionVirtualization=oracle was not met

Probablement ai-je installé le paquet virtualbox-guest-utils  par erreur, et en plus fait cohabiter un paquet ubuntu avec un paquet oracle...
En attendant d'éclaircir ce point je désactive le démarrage automatique du fâcheux

fredk1804@MirageK1804:~$ sudo systemctl  disable virtualbox-guest-utils.service
Synchronizing state of virtualbox-guest-utils.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install disable virtualbox-guest-utils
fredk1804@MirageK1804:~$ systemctl  show  virtualbox-guest-utils.service | grep -i unit
UnitFileState=disabled
UnitFilePreset=enabled

Et au démarrage suivant tout est revenu à la normale

fredk1804@MirageK1804:~$ systemctl status systemd-timesyncd.service
● systemd-timesyncd.service - Network Time Synchronization
   Loaded: loaded (/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: enabled)
   Active: active (running) since Sun 2019-02-17 13:30:42 CET; 6s ago
     Docs: man:systemd-timesyncd.service(8)
 Main PID: 4953 (systemd-timesyn)
   Status: "Synchronized to time server [2001:67c:1560:8003::c7]:123 (ntp.ubuntu.com)."
    Tasks: 2 (limit: 4915)
   CGroup: /system.slice/systemd-timesyncd.service
           └─4953 /lib/systemd/systemd-timesyncd

févr. 17 13:30:42 MirageK1804 systemd[1]: Starting Network Time Synchronization...
févr. 17 13:30:42 MirageK1804 systemd[1]: Started Network Time Synchronization.
févr. 17 13:30:42 MirageK1804 systemd-timesyncd[4953]: Synchronized to time server [2001:67c:1560:8003::c7]:123 
fredk1804@MirageK1804:~$ timedatectl status
                      Local time: dim. 2019-02-17 13:31:04 CET
                  Universal time: dim. 2019-02-17 12:31:04 UTC
                        RTC time: dim. 2019-02-17 12:31:04
                       Time zone: Europe/Paris (CET, +0100)
       System clock synchronized: yes
systemd-timesyncd.service active: yes
                 RTC in local TZ: no

Et dans la Vm c'est vboxadd-service.service, qui lui reste bien actif, et neutralise systemd-timesyncd.service.
Mais c'est potentiellement normal, car c'est virtualbox qui prend en charge cette fonctionnalité de synchronisation d'horloge si j'ai bien compris...


L'espace et le temps sont les modes par lesquels nous pensons, et non les conditions dans lesquelles nous vivons. (Signé Albert)

Hors ligne