Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 10/05/2019, à 08:51

Tamarou

[Résolu] gnome-terminal -e

Bonjour,
Je voudrais utiliser l'équivalent de la commande suivante avec gnome-terminal :

xterm -hold -e "ma-commande"

Mais je ne trouve pas la bonne syntaxe tongue
La lecture du man ne m'a pas avancé et pourtant un message d'erreur devrait me mettre sur la voie :

L’option « -e » est obsolète et pourrait être supprimée dans une prochaine version de gnome-terminal.
# Utilisez « --  » pour marquer la fin des options et placez la ligne de commande à exécuter ensuite.

Comment utiliser ce "--" ?

Dernière modification par Tamarou (Le 10/05/2019, à 13:38)

Hors ligne

#2 Le 10/05/2019, à 10:17

michel_04

Re : [Résolu] gnome-terminal -e

Bonjour,


Ce que je comprends :

xterm -hold -e -- "ma-commande"

A+


:D
Comment Poser Les Questions De Manière Intelligente - Trouver de l'aide grâce au Groupe des Parrains Linux - Le Pacte des Gnous - l'Almanet doLys de nam1962 et ses amis
PCs sous Debian Stable & Debian Sid.

Hors ligne

#3 Le 10/05/2019, à 10:37

Tamarou

Re : [Résolu] gnome-terminal -e

Oui, ça fonctionne bien avec xterm. Mais pas avec gnome terminal.

Je viens de contourner avec deux étapes au lieu d'une :

gnome-terminal -e /chemin-vers-le-script-qui-contient-la-commande

Là ça fonctionne, mais pas si je veux lancer la commande directement.

Hors ligne

#4 Le 10/05/2019, à 11:32

kamaris

Re : [Résolu] gnome-terminal -e

gnome-terminal -- "ma-commande"

Par contre pour le « -hold », je ne sais pas s'il existe un équivalent.

Hors ligne

#5 Le 10/05/2019, à 12:02

Tamarou

Re : [Résolu] gnome-terminal -e

Cela aussi je l'avais essayé :

gnome-terminal -- "ls /"
# _g_io_module_get_default: Found default implementation dconf (DConfSettingsBackend) for ‘gsettings-backend’
# watch_fast: "/org/gnome/desktop/interface/" (establishing: 0, active: 0)
# watch_fast: "/org/gnome/settings-daemon/peripherals/mouse/" (establishing: 0, active: 0)
# watch_fast: "/org/gnome/desktop/sound/" (establishing: 0, active: 0)
# watch_fast: "/org/gnome/desktop/privacy/" (establishing: 0, active: 0)
# watch_fast: "/org/gnome/desktop/wm/preferences/" (establishing: 0, active: 0)
# watch_fast: "/org/gnome/settings-daemon/plugins/xsettings/" (establishing: 0, active: 0)
# watch_fast: "/org/gnome/desktop/a11y/" (establishing: 0, active: 0)
# watch_established: "/org/gnome/desktop/interface/" (establishing: 1)
# watch_established: "/org/gnome/settings-daemon/peripherals/mouse/" (establishing: 1)
# watch_established: "/org/gnome/desktop/sound/" (establishing: 1)
# watch_established: "/org/gnome/desktop/privacy/" (establishing: 1)
# watch_established: "/org/gnome/desktop/wm/preferences/" (establishing: 1)
# watch_established: "/org/gnome/settings-daemon/plugins/xsettings/" (establishing: 1)
# watch_established: "/org/gnome/desktop/a11y/" (establishing: 1)
# _g_io_module_get_default: Found default implementation gvfs (GDaemonVfs) for ‘gio-vfs’
# watch_fast: "/org/gnome/terminal/legacy/" (establishing: 0, active: 0)
# unwatch_fast: "/org/gnome/terminal/legacy/" (active: 0, establishing: 1)
# watch_established: "/org/gnome/terminal/legacy/" (establishing: 0)

l y a eu une erreur lors de la création du processus fils pour ce terminal
L’exécution du processus fils « ls / » a échoué (Aucun fichier ou dossier de ce type)

Hors ligne

#6 Le 10/05/2019, à 12:05

kamaris

Re : [Résolu] gnome-terminal -e

Sans les guillemets. Par contre, puisqu'il n'y a pas d'option « -hold », ton gnome-terminal ne persistera pas.

Hors ligne

#7 Le 10/05/2019, à 13:03

credenhill

Re : [Résolu] gnome-terminal -e

hello

gnome-terminal -- bash -c "ma-commande; bash"

Hors ligne

#8 Le 10/05/2019, à 13:13

kamaris

Re : [Résolu] gnome-terminal -e

Oui, il semble qu'il faille recourir à ce genre d'astuce, qui néanmoins n'a pas le même effet qu'une option « -hold », laquelle ne relance pas un nouveau process bash mais se contente de laisser la fenêtre où s'est exécutée « ma-commande » ouverte.
Une alternative est apparemment (je n'ai pas essayé) de créer un profil en cochant l'option « When command exits: Hold the terminal open », et d'exécuter ensuite gnome-terminal avec ce profil : cf. https://stackoverflow.com/questions/446 … -execution
Accessoirement, on peut noter que la page de manuel de gnome-terminal est assez misérable. On peut accéder à une liste plus complète d'options par

gnome-terminal --help-all

Hors ligne

#9 Le 10/05/2019, à 13:36

Tamarou

Re : [Résolu] gnome-terminal -e

credenhill a écrit :

hello

gnome-terminal -- bash -c "ma-commande; bash"

Effectivement, de cette façon ça fonctionne bien.

Merci beaucoup aux intervenants avec une mention spéciale à credenhill

Hors ligne