Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 19/06/2019, à 13:51

Tiganou22

Aucun adaptateur wi-fi trouvé

Bonjour, je reviens sur le forum car j'ai de nouveau un problème avec ma clé wifi (usb).
Pour l'historique :
A l'installation de linux il y a quelques mois mon adaptateur usb wifi ne fonctionnait pas.
Ma clé :

ID 0bda:a811 Realtek Semiconductor Corp.

Sur les conseils d'un membre du forum j'ai exécuté les commandes suivantes

sudo apt-get install linux-headers-generic build-essential git
git clone https://github.com/abperiasamy/rtl8812AU_8821AU_linux.git
cd rtl8812AU_8821AU_linux
make
sudo make install
sudo modprobe rtl8812au

Et cela a fonctionné.

Il y a quelques semaines. La clé a cessé de fonctionné sans raison (pas de mises à jour). En retappant les mêmes lignes de commandes ça a remarché.

Mais voilà le problème : depuis une semaine de nouveau plus de wifi (Aucun adaptateur wi-fi trouvé) et cette fois les lignes de commande ci-dessus ni changent rien.

Je ne sais plus bien quoi tenter. La clé fonctionne bien sous windows (dual-boot).

Infos utiles :
ubuntu 18.04.2 sur mon ordinateur fixe ACER Aspire XC-705 en dual boot avec windows 10.
clé usb wifi essentiel b (acheté chez boulanger)

Wifi check :

[code]

>>    cat /etc/lsb-release 

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=18.04
DISTRIB_CODENAME=bionic
DISTRIB_DESCRIPTION="Ubuntu 18.04.2 LTS"

>>    lsusb 

Bus 002 Device 002: ID 8087:8000 Intel Corp. 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8008 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 003: ID 1058:0810 Western Digital Technologies, Inc. My Passport Ultra (WDBZFP)
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 006: ID 0fce:71eb Sony Ericsson Mobile Communications AB 
Bus 003 Device 004: ID 03f0:a407 Hewlett-Packard 
Bus 003 Device 003: ID 0c45:760b Microdia 
Bus 003 Device 002: ID 0bda:a811 Realtek Semiconductor Corp. 
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

>>    lspci -k -nn | grep -A 3 -i net 

02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 11)
	Subsystem: Acer Incorporated [ALI] RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [1025:0750]
	Kernel driver in use: r8169
	Kernel modules: r8169

>>    sudo lshw -C network 

  *-network
       description: Ethernet interface
       produit: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       fabriquant: Realtek Semiconductor Co., Ltd.
       identifiant matériel: 0
       information bus: pci@0000:02:00.0
       nom logique: eno1
       version: 11
       numéro de série: d8:cb:8a:1a:1a:e8
       taille: 10Mbit/s
       capacité: 1Gbit/s
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168g-2_0.0.1 02/06/13 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       ressources: irq:18 portE/S:e000(taille=256) mémoire:f7c00000-f7c00fff mémoire:f0000000-f0003fff
  *-network
       description: Ethernet interface
       identifiant matériel: 1
       nom logique: enp0s20u9
       numéro de série: 62:bc:24:71:97:1f
       fonctionnalités: ethernet physical
       configuration: broadcast=yes driver=rndis_host driverversion=22-Aug-2005 firmware=RNDIS device ip=192.168.42.180 link=yes multicast=yes

>>    lsmod | sort 

aesni_intel           200704  0
aes_x86_64             20480  1 aesni_intel
ahci                   40960  1
autofs4                40960  2
cdc_ether              16384  1 rndis_host
cfg80211              667648  0
coretemp               16384  0
crc32_pclmul           16384  0
crct10dif_pclmul       16384  0
cryptd                 24576  3 crypto_simd,ghash_clmulni_intel,aesni_intel
crypto_simd            16384  1 aesni_intel
drm                   458752  16 drm_kms_helper,i915
drm_kms_helper        172032  1 i915
enclosure              16384  1 ses
fb_sys_fops            16384  1 drm_kms_helper
ghash_clmulni_intel    16384  0
glue_helper            16384  1 aesni_intel
gpio_ich               16384  0
hid                   122880  3 usbhid,hid_redragon,hid_generic
hid_generic            16384  0
hid_redragon           16384  0
i2c_algo_bit           16384  1 i915
i915                 1740800  26
input_leds             16384  0
intel_cstate           20480  0
intel_pch_thermal      16384  0
intel_powerclamp       16384  0
intel_rapl             20480  0
intel_rapl_perf        16384  0
ip_tables              28672  0
irqbypass              16384  1 kvm
joydev                 24576  0
kvm                   626688  1 kvm_intel
kvm_intel             208896  0
libahci                32768  1 ahci
lp                     20480  0
lpc_ich                24576  0
mac_hid                16384  0
mei                    98304  1 mei_me
mei_me                 40960  0
mii                    16384  2 r8169,usbnet
Module                  Size  Used by
parport                49152  3 parport_pc,lp,ppdev
parport_pc             36864  0
pcbc                   16384  0
ppdev                  20480  0
r8169                  86016  0
rndis_host             16384  0
sch_fq_codel           20480  3
scsi_transport_sas     40960  1 ses
ses                    20480  0
snd                    81920  23 snd_hda_codec_generic,snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_pcm,snd_rawmidi
snd_hda_codec         126976  4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek
snd_hda_codec_generic    73728  1 snd_hda_codec_realtek
snd_hda_codec_hdmi     49152  1
snd_hda_codec_realtek   106496  1
snd_hda_core           81920  5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek
snd_hda_intel          40960  6
snd_hwdep              20480  1 snd_hda_codec
snd_pcm                98304  4 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_core
snd_rawmidi            32768  1 snd_seq_midi
snd_seq                65536  2 snd_seq_midi,snd_seq_midi_event
snd_seq_device         16384  3 snd_seq,snd_seq_midi,snd_rawmidi
snd_seq_midi           16384  0
snd_seq_midi_event     16384  1 snd_seq_midi
snd_timer              32768  2 snd_seq,snd_pcm
soundcore              16384  1 snd
syscopyarea            16384  1 drm_kms_helper
sysfillrect            16384  1 drm_kms_helper
sysimgblt              16384  1 drm_kms_helper
uas                    24576  0
usbhid                 49152  0
usbnet                 45056  2 rndis_host,cdc_ether
usb_storage            69632  2 uas
video                  45056  1 i915
wmi                    24576  1 wmi_bmof
wmi_bmof               16384  0
x86_pkg_temp_thermal    16384  0
x_tables               40960  1 ip_tables
[/code]
[code]

>>    iwconfig 


>>    ifconfig -a 

eno1: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether d8:cb:8a:1a:1a:e8  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

enp0s20u9: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.42.180  netmask 255.255.255.0  broadcast 192.168.42.255
        inet6 fe80::1a4e:a736:ad86:255a  prefixlen 64  scopeid 0x20<link>
        ether 62:bc:24:71:97:1f  txqueuelen 1000  (Ethernet)
        RX packets 5603  bytes 4269751 (4.2 MB)
        RX errors 6  dropped 0  overruns 0  frame 6
        TX packets 4934  bytes 821890 (821.8 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Boucle locale)
        RX packets 128709  bytes 9178166 (9.1 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 128709  bytes 9178166 (9.1 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0


>>    sudo iwlist scan 


>>    uname -r -m 

4.18.0-21-generic x86_64

>>    cat /etc/network/interfaces 

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

>>    nm-tool 


>>    nmcli dev wifi 


>>    nmcli connection list (< 15.04) ou nmcli connection show (>= 15.04) 

NAME                 UUID                                  TYPE      DEVICE    
Connexion filaire 1  a82e3cb9-483b-35d9-b973-fc69c1cee210  ethernet  enp0s20u9 
Connexion filaire 2  f7c1eb33-5ce2-3d00-8d96-b7f1e256b3d2  ethernet  --        
Nokia 1              2f9a4bb7-6f70-48b6-a771-6817e9bd8730  wifi      --        
SFR-6a88             86cefadd-7fac-4bff-af1e-35c0493873c0  wifi      --        
SFR-6e98             f30c2d33-626f-454a-b5c3-90b4179c65c4  wifi      --        
SFR-6e98_5GHz        52a93653-3795-4cb8-b2c1-0052383d48d0  wifi      --        
Xperia XA1_58f4      c1e9ba5b-aa1f-495c-b02f-c3cd3db4abdc  wifi      --        

>>    nmcli connection status 


>>    sudo rfkill list 

[/code]

Si quelqu'un a une idée, merci !

Hors ligne

#2 Le 19/06/2019, à 13:54

xubu1957

Re : Aucun adaptateur wi-fi trouvé

Bonjour,

Un retour avec :

sudo modprobe rtl8812au

?


Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

Hors ligne

#3 Le 19/06/2019, à 13:56

Tiganou22

Re : Aucun adaptateur wi-fi trouvé

Bonjour,
Voilà la réponse :

tiganou@tiganou-Aspire-XC-705:~$ sudo modprobe rtl8812au
[sudo] Mot de passe de tiganou : 
modprobe: ERROR: could not insert 'rtl8812au': Exec format error

Hors ligne

#4 Le 19/06/2019, à 13:58

NicoApi73

Re : Aucun adaptateur wi-fi trouvé

Bonjour,

Fais :

sudo apt install dkms
sudo modprobe -r rtl8812au
cd ~/rtl8812AU_8821AU_linux
make clean
sudo make -f Makefile.dkms install

Donne tous les retours, de la commande au prompt de retour.

puis

sudo modprobe -a rtl8812au

(idem, donne le retour)

Hors ligne

#5 Le 19/06/2019, à 14:03

Tiganou22

Re : Aucun adaptateur wi-fi trouvé

Voilà ce que j'obtiens

tiganou@tiganou-Aspire-XC-705:~$ sudo apt install dkms
[sudo] Mot de passe de tiganou : 
Désolé, essayez de nouveau.
[sudo] Mot de passe de tiganou : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
dkms est déjà la version la plus récente (2.3-3ubuntu9.2).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 6 non mis à jour.
tiganou@tiganou-Aspire-XC-705:~$ sudo modprobe -a rtl8812au
modprobe: ERROR: could not insert 'rtl8812au': Exec format error
tiganou@tiganou-Aspire-XC-705:~$ 

A propos, le terminal ne me laisse pas taper mon mot de passe, il affiche directement

Désolé, essayez de nouveau.

C'est seulement à la deuxième ligne que je peux le taper. C'est grave ?

Hors ligne

#6 Le 19/06/2019, à 14:05

NicoApi73

Re : Aucun adaptateur wi-fi trouvé

@xubu : je pense qu'il y a eu une mise à jour, unattended-upgrades est particulièrement actif sur la 18.04. Le driver n'a pas été installé avec dkms
En plus, c'est une 18.04.2, avec un noyau 4.18.0-21

Hors ligne

#7 Le 19/06/2019, à 14:07

NicoApi73

Re : Aucun adaptateur wi-fi trouvé

Il me faut surtout le retour de ces commandes là. Ce que tu as mis au #5, c'est que dkms est installé et que tu n'arrives pas à insérer le driver dans le noyau...

Tape les commandes une par une...

sudo modprobe -r rtl8812au
cd ~/rtl8812AU_8821AU_linux
make clean
sudo make -f Makefile.dkms install

Dernière modification par NicoApi73 (Le 19/06/2019, à 14:07)

Hors ligne

#8 Le 19/06/2019, à 14:08

xubu1957

Re : Aucun adaptateur wi-fi trouvé

@Nico

Je vois :

6 non mis à jour.

Il n'est pas triste ce pilote > wifi_chipset_realtek_rtl8812au


Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

Hors ligne

#9 Le 19/06/2019, à 14:11

Tiganou22

Re : Aucun adaptateur wi-fi trouvé

Avec les commandes une par une :

tiganou@tiganou-Aspire-XC-705:~$ sudo modprobe -r rtl8812au
[sudo] Mot de passe de tiganou : 
tiganou@tiganou-Aspire-XC-705:~$ cd ~/rtl8812AU_8821AU_linux
tiganou@tiganou-Aspire-XC-705:~/rtl8812AU_8821AU_linux$ make clean
make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.18.0-21-generic/build M=/home/tiganou/rtl8812AU_8821AU_linux clean
make[1] : on entre dans le répertoire « /usr/src/linux-headers-4.18.0-21-generic »
  CLEAN   /home/tiganou/rtl8812AU_8821AU_linux/.tmp_versions
  CLEAN   /home/tiganou/rtl8812AU_8821AU_linux/Module.symvers
make[1] : on quitte le répertoire « /usr/src/linux-headers-4.18.0-21-generic »
tiganou@tiganou-Aspire-XC-705:~/rtl8812AU_8821AU_linux$ sudo make -f Makefile.dkms install
make clean
make[1] : on entre dans le répertoire « /home/tiganou/rtl8812AU_8821AU_linux »
make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.18.0-21-generic/build M=/home/tiganou/rtl8812AU_8821AU_linux clean
make[2] : on entre dans le répertoire « /usr/src/linux-headers-4.18.0-21-generic »
make[2] : on quitte le répertoire « /usr/src/linux-headers-4.18.0-21-generic »
make[1] : on quitte le répertoire « /home/tiganou/rtl8812AU_8821AU_linux »
mkdir -p '/usr/src/rtl8812au-4.3.14'
cp -r dkms.conf Kconfig Makefile.dkms Makefile platform core hal include os_dep '/usr/src/rtl8812au-4.3.14'
cp Makefile '/usr/src/rtl8812au-4.3.14/Makefile'
sed 's/#MODULE_VERSION#/4.3.14/' dkms.conf > '/usr/src/rtl8812au-4.3.14/dkms.conf'
dkms add -m rtl8812au -v 4.3.14 2>/dev/null || true

Creating symlink /var/lib/dkms/rtl8812au/4.3.14/source ->
                 /usr/src/rtl8812au-4.3.14

DKMS: add completed.
dkms build -m rtl8812au -v 4.3.14

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area...
make -j4 KERNELRELEASE=4.18.0-21-generic KVER=4.18.0-21-generic...........
cleaning build area...

DKMS: build completed.
dkms install -m rtl8812au -v 4.3.14

rtl8812au:
Running module version sanity check.

Good news! Module version v4.3.14_13455.20150212_BTCOEX20150128-51 for rtl8812au.ko
exactly matches what is already found in kernel 4.18.0-21-generic.
DKMS will not replace this module.
You may override by specifying --force.

depmod.......

DKMS: install completed.
tiganou@tiganou-Aspire-XC-705:~/rtl8812AU_8821AU_linux$ 

Hors ligne

#10 Le 19/06/2019, à 14:14

NicoApi73

Re : Aucun adaptateur wi-fi trouvé

Fais maintenant

sudo modprobe -a rtl8812au

Hors ligne

#11 Le 19/06/2019, à 14:15

Tiganou22

Re : Aucun adaptateur wi-fi trouvé

Toujours pareil :

tiganou@tiganou-Aspire-XC-705:~/rtl8812AU_8821AU_linux$ sudo modprobe -a rtl8812au
modprobe: ERROR: could not insert 'rtl8812au': Exec format error
tiganou@tiganou-Aspire-XC-705:~/rtl8812AU_8821AU_linux$ 

Hors ligne

#12 Le 19/06/2019, à 14:28

NicoApi73

Re : Aucun adaptateur wi-fi trouvé

Je pense que ça vient du noyau.

Peux tu donner :

dpkg -l | grep -Ei "linux-(g|h|i|lo|mo|si|t)" | grep -v ^rc | sort -k3 | tr -s " " | cut -d" " -s -f1,2,3,4 | column -s" " -t ;

Hors ligne

#13 Le 19/06/2019, à 14:34

Tiganou22

Re : Aucun adaptateur wi-fi trouvé

Voilà ce que cela donne

tiganou@tiganou-Aspire-XC-705:~$ dpkg -l | grep -Ei "linux-(g|h|i|lo|mo|si|t)" | grep -v ^rc | sort -k3 | tr -s " " | cut -d" " -s -f1,2,3,4 | column -s" " -t ;
ii  binutils-x86-64-linux-gnu              2.30-21ubuntu1~18.04.1  amd64
ii  linux-headers-generic                  4.15.0.51.53            amd64
ii  linux-headers-4.15.0-51                4.15.0-51.55            all
ii  linux-headers-4.15.0-51-generic        4.15.0-51.55            amd64
ii  linux-headers-4.18.0-20                4.18.0-20.21~18.04.1    all
ii  linux-modules-4.18.0-20-generic        4.18.0-20.21~18.04.1    amd64
ii  linux-modules-extra-4.18.0-20-generic  4.18.0-20.21~18.04.1    amd64
ii  linux-headers-4.18.0-20-generic        4.18.0-20.21~18.04.1    amd64
ii  linux-image-4.18.0-20-generic          4.18.0-20.21~18.04.1    amd64
ii  linux-headers-4.18.0-21                4.18.0-21.22~18.04.1    all
ii  linux-modules-4.18.0-21-generic        4.18.0-21.22~18.04.1    amd64
ii  linux-modules-extra-4.18.0-21-generic  4.18.0-21.22~18.04.1    amd64
ii  linux-headers-4.18.0-21-generic        4.18.0-21.22~18.04.1    amd64
ii  linux-image-4.18.0-21-generic          4.18.0-21.22~18.04.1    amd64
ii  linux-generic-hwe-18.04                4.18.0.21.71            amd64
ii  linux-headers-generic-hwe-18.04        4.18.0.21.71            amd64
ii  linux-image-generic-hwe-18.04          4.18.0.21.71            amd64
tiganou@tiganou-Aspire-XC-705:~$ 

Hors ligne

#14 Le 19/06/2019, à 14:37

NicoApi73

Re : Aucun adaptateur wi-fi trouvé

ok, reboot ton pc, fais apparaître grub et boot sur le 4.18.0-20 et dis nous si la clé fonctionne.

Hors ligne

#15 Le 19/06/2019, à 14:38

Tiganou22

Re : Aucun adaptateur wi-fi trouvé

Pardon je n'ai pas compris ce que je dois faire.
Faire apparaitre grub ?

Hors ligne

#16 Le 19/06/2019, à 14:47

NicoApi73

Re : Aucun adaptateur wi-fi trouvé

Es tu en dual-boot sur cette machine?

Hors ligne

#17 Le 19/06/2019, à 14:49

Tiganou22

Re : Aucun adaptateur wi-fi trouvé

oui avec windows 10

Hors ligne

#18 Le 19/06/2019, à 14:54

NicoApi73

Re : Aucun adaptateur wi-fi trouvé

Donc grub apparaît au début, quand tu démarres ta machine, te permettant de choisir entre Ubuntu et Windows.

Plutôt que de choisir Windows ou Ubuntu, choisis Options pour Ubuntu (ou quelque chose du genre). Ca va t'ouvrir une autre page et tu vas sélectionner dedans la version avec le noyau 4.18.0-20, qui ne contient dedans ni recovery, ni upstart.

Démarre dessus et dis nous si la clé fonctionne.

Hors ligne

#19 Le 19/06/2019, à 15:06

Tiganou22

Re : Aucun adaptateur wi-fi trouvé

Je n'ai de pas de grub.

Au démarrage de l'ordi, je peux appuyer sur F12 pour choisir sur quel disque je boot, j'ai 3 choix :
P0 : WDC WD20EZRX-22D8PB0 (celui là lance ubuntu)
Windows Boot Manager
P1 : MATSHITA DVD-RAM UJ8HC

Le grub n'apparait pas quand je lance le disque qui contient linux. (le grub doit ressembler à l'écran d'accueil quand on boot sur une live usb, il y a alors différents choix, enfin j'imagine...).
Quand je boot sur P0, Linux se lance sans proposer aucun choix.

A noter, à l'installation, j'ai eu des problème avec le boot. Mon ordi était en mode EFI.

Hors ligne

#20 Le 19/06/2019, à 15:09

Tiganou22

Re : Aucun adaptateur wi-fi trouvé

Sinon, Connaissez-vous simplement une clé usb wifi qui fonctionnerait sans problème ? Je peux en racheter une.
Je ne veux pas vous ennuyer toute l'après-midi...

Hors ligne

#21 Le 19/06/2019, à 15:20

NicoApi73

Re : Aucun adaptateur wi-fi trouvé

Personnellement, tu ne m'ennuies pas. Je laisserai le soin à xubu de répondre à ta question.

Tu choisis ton OS en passant par le bios et effectivement dans ce cas grub, n'apparaît pas. Il est même possible que tes OS ne soient pas dans le même mode (EFI/Legacy).

Pour faire apparaître grub, tout de suite après avoir appuyé sur F12 et validé Ubuntu, tu appuies sur MAJ ou ECHAP (plusieurs fois) et là, grub va apparaître. Si ubuntu se lance c'est que tu n'as pas été assez rapide.

Dans grub, tu choisis Options pour Ubuntu (ou quelque chose du genre). Ca va t'ouvrir une autre page et tu vas sélectionner dedans la version avec le noyau 4.18.0-20, qui ne contient dedans ni recovery, ni upstart.

Hors ligne

#22 Le 19/06/2019, à 15:28

Tiganou22

Re : Aucun adaptateur wi-fi trouvé

C'est gentil.
Mission accomplie! En redémarrant sut le 4-18-0-20 le wifi fonctionne !
Merci beaucoup !!

Au prochain redémarrage, l'ordinateur va-t-il rebooter automatiquement sur cette version du noyau ? ou faut-il configurer quelque chose pour qu'il choisisse la version 4-18-0-20 au lieu de la 4-18-0-21 ?

Hors ligne

#23 Le 19/06/2019, à 15:32

NicoApi73

Re : Aucun adaptateur wi-fi trouvé

Ca confirme que ça vient du noyau. Peux tu essayé avec le noyau 40.15.0-51?

Si ça ne fonctionne pas , reste dans cette session et on va essayé de le compiler pour ce noyau.

Mon idée est la suivante : si ça fonctionne sur le noyau 4.15, il faudrait que tu rebascules sur cette série, qui est stable et qui est celle de la 18.04.1 (maintenu pendant 5 ans)

EDIT : pour expliquer pourquoi je t'ai fait d'abord testé sur le 4.18.0-20, c'est parce que je pense qu'il y a eu un changement de version de noyau et que c'est celui que tu avais précédemment. Je voulais donc vérifier avant tout que dans la configuration précédente ta clé fonctionne toujours.

Dernière modification par NicoApi73 (Le 19/06/2019, à 15:34)

Hors ligne

#24 Le 19/06/2019, à 15:42

Tiganou22

Re : Aucun adaptateur wi-fi trouvé

Dans les options de Grub, je n'ai que 4 choix :
*Ubuntu avec Linux 4.18.0-21 generic
Ubuntu avec Linux 4.18.0-21 generic (recovery mode)
Ubuntu avec Linux 4.18.0-20 generic
Ubuntu avec Linux 4.18.0-20 generic (recovery mode)

Pas de noyau 40.15.0-51...

Je suis toujours dans la version 4.18.0-20 generic

Hors ligne

#25 Le 19/06/2019, à 16:23

NicoApi73

Re : Aucun adaptateur wi-fi trouvé

Le problème, c'est que le 4.18.0-20 va dégager à la prochaine mise à jour noyau et je ne sais pas le protéger...

Hors ligne