Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 08/08/2020, à 13:08

Argoç

Stellarium-git v0.20.2

Bonjour à tous,

J'ai téléchargé la dernière version du logiciel Stellarium-git sur l'Ubuntu Software, mais il ne peut-être lancé. Des solutions ? Merci par avance pour vos retours.

argo@Argos:~$ snap run stellarium-daily.stellarium
This application failed to start because it could not find or load the Qt platform plugin "wayland-egl"
in "".

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb.

Reinstalling the application may fix this problem.
Abandon (core dumped)
argo@Argos:~$ 

Hors ligne

#2 Le 08/08/2020, à 14:36

Korak

Re : Stellarium-git v0.20.2

Bonjour,

Tu as vraiment besoin de la version 0.20.2 ?

Ce logiciel est disponible en version 0.19.3 dans Synaptic sous Ubuntu 20.04.1 et il s'installe et fonctionne parfaitement.

En cochant le paquet Stellarium dans Synaptic puis en cliquant sur le bouton Appliquer, celui-ci m'a demandé si je désire installé aussi d'autres paquets dont le nom de certains commence par libqt5. Ce que j'ai accepté.

Bref, il te manque des paquets concernant QT. Maintenant, il faut savoir lesquels et là je bloque.

Dernière modification par Korak (Le 08/08/2020, à 14:36)


OS: Ubuntu 22.04 64 bits (avec Unity) + Windows 10 64 bits en dualboot (BIOS UEFI, Secure Boot activé et table de partitions GPT)
PC portable HP Pavilion 17-f055nb: Processeur: AMD A8-6410 APU   Cartes graphiques: AMD Radeon R5 Graphics + R7 M260   Mémoire vive: 12 Go RAM
Je suis Parrain-Linux

Hors ligne

#3 Le 08/08/2020, à 14:39

inbox

Re : Stellarium-git v0.20.2

Salut,

A tout hasard, que donnent ces commandes ?

dpkg -l | grep libwayland-egl1
echo $XDG_SESSION_TYPE

A+

Dernière modification par inbox (Le 08/08/2020, à 14:44)


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#4 Le 08/08/2020, à 15:12

Argoç

Re : Stellarium-git v0.20.2

@Korak: Salut, merci de ton retour )) j'aimerais bien comprendre le problème oui. Si ça se situe au niveau du logiciel, ça me permettrait également de faire remonter l'info aux développeurs via les avis de l'Ubuntu Store :-)

@Inbox: Salut inbox, voici les retours de commandes:

argo@Argos:~$ dpkg -l | grep libwayland-egl1
ii  libwayland-egl1:amd64                      1.18.0-1                              amd64        wayland compositor infrastructure - EGL library
argo@Argos:~$ echo $XDG_SESSION_TYPE
wayland
argo@Argos:~$ 

Dernière modification par Argoç (Le 08/08/2020, à 15:13)

Hors ligne

#5 Le 08/08/2020, à 15:20

Korak

Re : Stellarium-git v0.20.2

Sur mon PC :

be@be-HP-Pavilion-17-Notebook-PC:~$ dpkg -l | grep libwayland-egl1
ii  libwayland-egl1:amd64                      1.18.0-1                                   amd64        wayland compositor infrastructure - EGL library
ii  libwayland-egl1:i386                       1.18.0-1                                   i386         wayland compositor infrastructure - EGL library
be@be-HP-Pavilion-17-Notebook-PC:~$ echo $XDG_SESSION_TYPE
x11
be@be-HP-Pavilion-17-Notebook-PC:~$

Bon ok, j'utilise Ubuntu 20.04.1 64 bits et Unity. D'où la différence.
Mais bon QT doit pouvoir être installé pour faire fonctionner Stellarium quand même.


OS: Ubuntu 22.04 64 bits (avec Unity) + Windows 10 64 bits en dualboot (BIOS UEFI, Secure Boot activé et table de partitions GPT)
PC portable HP Pavilion 17-f055nb: Processeur: AMD A8-6410 APU   Cartes graphiques: AMD Radeon R5 Graphics + R7 M260   Mémoire vive: 12 Go RAM
Je suis Parrain-Linux

Hors ligne

#6 Le 08/08/2020, à 15:53

Argoç

Re : Stellarium-git v0.20.2

Je suis également sur Ubuntu 20.04.1 LTS mais l'environnement de bureau par défaut sur cette version c'est GNOME.

Hors ligne

#7 Le 08/08/2020, à 16:00

Korak

Re : Stellarium-git v0.20.2

Korak a écrit :

Mais bon QT doit pouvoir être installé pour faire fonctionner Stellarium quand même.

Tu as regardé du côté de QT ?


OS: Ubuntu 22.04 64 bits (avec Unity) + Windows 10 64 bits en dualboot (BIOS UEFI, Secure Boot activé et table de partitions GPT)
PC portable HP Pavilion 17-f055nb: Processeur: AMD A8-6410 APU   Cartes graphiques: AMD Radeon R5 Graphics + R7 M260   Mémoire vive: 12 Go RAM
Je suis Parrain-Linux

Hors ligne

#8 Le 08/08/2020, à 16:27

Argoç

Re : Stellarium-git v0.20.2

Oui j'ai regardé sur Synaptic, mais comme toi je cale sur le paquet à installer... il faudrait pouvoir trouver la source du problème à travers l'invite de commande, mais ça je ne sais pas faire, et je n'ai pas envie d'y aller au petit bonheur  la chance en installant n'importe quoi sans savoir ce que je fais :-))

Hors ligne

#9 Le 08/08/2020, à 16:46

inbox

Re : Stellarium-git v0.20.2

@Argoç,

Tu es donc connecté avec une session Wayland au lieu de x11. Pour le bureau et une grande partie des application, cela ne pose pas de problème. Je pense que dans le cas de Stellarium, il te faille te connecter en X11. Je pense à cela, car dans les données techniques de Stellarium, en paquet, est indiqué :

interface::x11

Pour changer le type de connexion de session, le choix se fait après avoir choisi le nom d'utilisateur, sur la fenêtre de connexion. Une fois l'utilisateur choisi, en bas à droite, tu vois une petite roue, tu cliques dessus et tu sélectionnes une session "Ubuntu", pas celle ou est indiqué "Wayland". Dans ce cas, Stellarium devrait fonctionner.

[Edit] J'ai continuer à rechercher le message «This application failed to start because it could not find or load the Qt platform plugin "wayland-egl"
in "".». J'ai trouvé un autre problème, avec une autre application en snap qui rencontre le même problème. Il semple que ce soit un oubli lors de la fabrication du snap Stellarium.
L'explication en anglais :

I finally fixed this by deploying the libs needed by wayland-egl plugin:

The lib "libQt5WaylandClient.so.5" should be included in the deployed package which used by the plugin.

En français :

J'ai finalement corrigé cela en déployant les librairies nécessaires au plugin wayland-egl :

La librairie "libQt5WaylandClient.so.5" devrait être incluse dans le paquet déployé qui est utilisé par le plugin.

Dernière modification par inbox (Le 08/08/2020, à 17:05)


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#10 Le 09/08/2020, à 13:20

Argoç

Re : Stellarium-git v0.20.2

Merci Inbox ! J'ai installé "libQt5WaylandClient.so.5" a partir de GNOME Packets, mais ça n'a rien changé en restant en mode wayland. En revanche, oui, en repassant en mode simple Ubuntu la dernière version de Stellarium fonctionne très bien. Je ne pas pas le sujet en résolu à cause de ce problème de Packet, à voir si quelqu'un arrive à trouver le bon pour résoudre le problème sur wayland...

En tout cas merci encore, et à toi également korak :-)

Hors ligne

#11 Le 09/08/2020, à 15:54

inbox

Re : Stellarium-git v0.20.2

Je n'ai pas dit que l'installation du paquet "libQt5WaylandClient.so.5" réglerait le problème. J'ai dit qu'il manque la librairie contenant ce fichier dans le Snap de Stellarium.

Il faut donc que l'empaqueteur (packageur ?) du Snap devrait l'intégrer pour que cela fonctionne sous Wayland. Tu peut donc indiquer sur le site Github ce qui ne fonctionne pas et la solution possible à y apporter. Dans le cas contraire, le prochain Snap aura toujours le même problème.

Suis-je plus clair dans mon explication ? smile

Si oui, je pense que tu peux passer le titre de ton sujet en "Résolu". Ceci permettra à d'autres de contourner le problème en attendant la correction du Snap.

Dernière modification par inbox (Le 09/08/2020, à 15:56)


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne