Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 24/10/2020, à 09:13

simon34

[résolu] problème affichage du bureau

Bonjour
j'essaye d'installer Xubuntu 20.04 LTS sur un portable LENOVO IdeaPad S145 à la place de Mint (qui avait l'air de fonctionner mais on me l'a installé par défaut alors que ce n'était pas le système demandé)
Le test en live USB montre des problèmes d'affichage du bureau (décalage de lignes en escalier) qui le rend quasi illisible
https://i.ibb.co/0sQDFVq/20201024-081407.jpg
L'installation normale donne le même problème mais uniquement une fois connecté (à l'invite de connection : pas de problème cf ci-dessous)
https://i.ibb.co/rx4V1P5/20201024-081954.jpg
Le test en live USB avec le mode "safe graphics" avait l'air de fonctionner correctement.
Mais l'installation en mode safe graphics donne au final le même résultat : le bureau est illisible.
J'ai fait les mises à jour et à l'installation j'ai bien coché installer les logiciels tiers...
Une idée pour résoudre ce problème ?


Modération : merci d'utiliser des images de petite taille (300x300) ou des miniatures pointant sur ces images (Des hébergeurs comme Toile Libre ou TDCT'Pix le permettent).

Dernière modification par simon34 (Le 06/11/2020, à 10:12)


Xubuntu 20.04 LTS sur plusieurs PC et portables, et Ubuntu Studio 20.04 sur un portable

Hors ligne

#2 Le 24/10/2020, à 10:23

zephirin

Re : [résolu] problème affichage du bureau

Dans le menu Grub au démarrage dans le menu sélectionne  "Advanced options" change de noyau si tu en as plusieurs ou prend le même estampillé "recovey mode" et teste en faisant aussi les mises à jour sur ce noyau.

Dernière modification par zephirin (Le 24/10/2020, à 10:27)


AIO tactile 27" Samsung  i5 8GB DDR3 W10 - tour Antec Asus P5GCMX1333 W10
iMac 27" fin 2009 i5 750 16GBssd2TB cg512HighSierra - 2 MacBookAir 13" 2014 & 2017 i5 8GB ssd120 Big Sur - Macmini i7 2,3GHz mi 2012 - 16GB ddr3 ssd1TB Catalina écran 27" - MacBookPro mi 2012 8GB DDR3 Catalina
Tour Gam i5  overclocké 4,4GHz 16GB ddr3 ssd1T GTX1060 6GB W10  27"
Dell Optiplex SX280 P IV 2.8 2GB Xub 18.04 32bit

Hors ligne

#3 Le 25/10/2020, à 08:07

simon34

Re : [résolu] problème affichage du bureau

Bonjour
merci pour la réponse
j'ai essayé avec l'autre noyau (5.4.0.26 au lieu de 5.4.0.52) mais même résultat
j'ai essayé en recovery mode de "réparer les paquets" et il a fait une mise à jour mais même résultat

par contre, truc de dingue, j'ai voulu essayer un autre écran en HDMI : quand je le branche (sans qu'il soit allumé ni connecté sur secteur) l'afffichage sur le portable devient correct ! et si je le débranche il redevient illisible... WTF ?
La bonne nouvelle c'est que comme ça je peux accéder aux paramètres, terminal etc. Mais ce n'est pas une solution durable...
Une autre idée ?


Xubuntu 20.04 LTS sur plusieurs PC et portables, et Ubuntu Studio 20.04 sur un portable

Hors ligne

#4 Le 25/10/2020, à 08:17

xubu1957

Re : [résolu] problème affichage du bureau

Bonjour,

Montre, en te servant du Retour utilisable de commande :

lspci -vnn | grep -A12 '\''[030[02]\]' | grep -Ei "vga|3d|display|kernel"

_ _ _

Regarde aussi ce fil > [Résolu] Ubuntu 18.04-Pbms d'install avec Lenovo IdeaPad S145-14IWL

Dernière modification par xubu1957 (Le 25/10/2020, à 08:26)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#5 Le 25/10/2020, à 08:44

simon34

Re : [résolu] problème affichage du bureau

ça donne ça :

fnelr8@fnelr-8:~$ lspci -vnn | grep -A12 '\''[030[02]\]' | grep -Ei "vga|3d|display|kernel"
00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Stoney [Radeon R2/R3/R4/R5 Graphics] [1002:98e4] (rev ea) (prog-if 00 [VGA controller])
	Kernel driver in use: amdgpu
	Kernel modules: amdgpu
fnelr8@fnelr-8:~$

Xubuntu 20.04 LTS sur plusieurs PC et portables, et Ubuntu Studio 20.04 sur un portable

Hors ligne

#6 Le 25/10/2020, à 08:50

zephirin

Re : [résolu] problème affichage du bureau

Visiblement problème graphique.

Essaye de changer (baisser ou augmenter) ta résolution.


AIO tactile 27" Samsung  i5 8GB DDR3 W10 - tour Antec Asus P5GCMX1333 W10
iMac 27" fin 2009 i5 750 16GBssd2TB cg512HighSierra - 2 MacBookAir 13" 2014 & 2017 i5 8GB ssd120 Big Sur - Macmini i7 2,3GHz mi 2012 - 16GB ddr3 ssd1TB Catalina écran 27" - MacBookPro mi 2012 8GB DDR3 Catalina
Tour Gam i5  overclocké 4,4GHz 16GB ddr3 ssd1T GTX1060 6GB W10  27"
Dell Optiplex SX280 P IV 2.8 2GB Xub 18.04 32bit

Hors ligne

#7 Le 25/10/2020, à 09:38

simon34

Re : [résolu] problème affichage du bureau

Merci
l'écran fait 15''6 et actuellement je suis en 1366x768 (c'est le max proposé et l'affichage est parfait à condition d'avoir un autre écran branché)
si je passe en 1280x720, c'est assez moche, mais ça reste lisible quand je débranche l'autre écran...
pas top non plus
ce serait un bug ?

Dernière modification par simon34 (Le 25/10/2020, à 10:18)


Xubuntu 20.04 LTS sur plusieurs PC et portables, et Ubuntu Studio 20.04 sur un portable

Hors ligne

#8 Le 25/10/2020, à 11:34

xubu1957

Re : [résolu] problème affichage du bureau

Montre aussi :

xrandr

_ _ _

Regarde > Résolutions d'écrans, avec des exemples dans le message #7.

_ _ _

> wikipedia.org/wiki/Définition d'écran

Dernière modification par xubu1957 (Le 25/10/2020, à 11:35)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#9 Le 25/10/2020, à 12:16

zephirin

Re : [résolu] problème affichage du bureau

Essaye le driver propriétaire (s'il est proposé).

https://doc.ubuntu-fr.org/_media/nvidia … tok=56aefa

Dernière modification par zephirin (Le 25/10/2020, à 12:20)


AIO tactile 27" Samsung  i5 8GB DDR3 W10 - tour Antec Asus P5GCMX1333 W10
iMac 27" fin 2009 i5 750 16GBssd2TB cg512HighSierra - 2 MacBookAir 13" 2014 & 2017 i5 8GB ssd120 Big Sur - Macmini i7 2,3GHz mi 2012 - 16GB ddr3 ssd1TB Catalina écran 27" - MacBookPro mi 2012 8GB DDR3 Catalina
Tour Gam i5  overclocké 4,4GHz 16GB ddr3 ssd1T GTX1060 6GB W10  27"
Dell Optiplex SX280 P IV 2.8 2GB Xub 18.04 32bit

Hors ligne

#10 Le 25/10/2020, à 14:00

simon34

Re : [résolu] problème affichage du bureau

Voici ce que donne xrandr

fnelr8@fnelr-8:~$ xrandr
Screen 0: minimum 320 x 200, current 1440 x 900, maximum 16384 x 16384
eDP connected 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 193mm
   1366x768      60.06*+
   1280x720      60.06  
   1024x768      60.06  
   800x600       60.06  
   640x480       60.06  
HDMI-A-0 connected 1440x900+0+0 (normal left inverted right x axis y axis) 408mm x 255mm
   1440x900      59.89*+
   1280x1024     75.02    60.02  
   1280x960      60.00  
   1280x800      59.89  
   1152x864      75.00  
   1280x720      59.89  
   1024x768      75.03    70.07    60.00  
   832x624       74.55  
   800x600       75.00    60.32    56.25  
   640x480       75.00    59.94  
   720x400       70.08  
fnelr8@fnelr-8:~$

Xubuntu 20.04 LTS sur plusieurs PC et portables, et Ubuntu Studio 20.04 sur un portable

Hors ligne

#11 Le 25/10/2020, à 14:39

simon34

Re : [résolu] problème affichage du bureau

Je ne vois pas comment trouver le pilote propriétaire. Déjà je ne suis pas bien sur de comprendre quel est le nom de la carte graphique entre Stoney [Radeon R2/R3/R4/R5 Graphics] et Advanced Micro Devices, Inc. [AMD/ATI] et [1002:98e4] (rev ea)

sur le site de AMD Drivers il n'y a rien qui corresponde https://www.amd.com/en/support
je ne sais pas si c'est une R5 series et si c'est le cas ils demandent si c'est une R5 400, 300 ou 200... aucune idée !
de toutes façons j'ai lu que

https://linuxconfig.org/amd-radeon-ubuntu-20-04-driver-installation a écrit :

At the time of writing, the proprietary drivers haven't been released for Ubuntu 20.04 yet. Once that happens the article will be updated accordingly.

j'aurais peut-etre pas du installer la 20.04...

sur cet autre site https://devicehunt.com/view/type/pci/ve … evice/98E4 ils proposent un pilote pour une carte "Radeon R2/R3/R4/R5 Graphics" [1002:98e4], pour ubuntu 18.04 mais ça fait 305.71 Mo et ça me parait moyennement digne de confiance

Dernière modification par simon34 (Le 25/10/2020, à 15:26)


Xubuntu 20.04 LTS sur plusieurs PC et portables, et Ubuntu Studio 20.04 sur un portable

Hors ligne

#12 Le 25/10/2020, à 15:06

simon34

Re : [résolu] problème affichage du bureau

en suivant ce tuto : https://linuxconfig.org/amd-radeon-ubun … stallation
j’ai testé

fnelr8@fnelr-8:~$ dmesg | grep -i amdgpu
[    3.345398] [drm] amdgpu kernel modesetting enabled.
[    3.347752] amdgpu 0000:00:01.0: remove_conflicting_pci_framebuffers: bar 0: 0xe0000000 -> 0xefffffff
[    3.347754] amdgpu 0000:00:01.0: remove_conflicting_pci_framebuffers: bar 2: 0xf0000000 -> 0xf07fffff
[    3.347756] amdgpu 0000:00:01.0: remove_conflicting_pci_framebuffers: bar 5: 0xf0c00000 -> 0xf0c3ffff
[    3.347759] fb0: switching to amdgpudrmfb from EFI VGA
[    3.352227] amdgpu 0000:00:01.0: vgaarb: deactivate vga console
[    3.354889] amdgpu 0000:00:01.0: kfd not supported on this ASIC
[    3.355056] amdgpu 0000:00:01.0: VRAM: 1024M 0x000000F400000000 - 0x000000F43FFFFFFF (1024M used)
[    3.355058] amdgpu 0000:00:01.0: GART: 1024M 0x000000FF00000000 - 0x000000FF3FFFFFFF
[    3.369638] [drm] amdgpu: 1024M of VRAM memory ready
[    3.369641] [drm] amdgpu: 3072M of GTT memory ready.
[    3.404215] amdgpu: [powerplay] hwmgr_sw_init smu backed is smu8_smu
[    3.461960] snd_hda_intel 0000:00:01.1: bound 0000:00:01.0 (ops amdgpu_dm_audio_component_bind_ops [amdgpu])
[    3.639766] fbcon: amdgpudrmfb (fb0) is primary device
[    3.639869] amdgpu 0000:00:01.0: fb0: amdgpudrmfb frame buffer device
[    3.690811] [drm] Initialized amdgpu 3.35.0 20150101 for 0000:00:01.0 on minor 0
[  624.066745] audit: type=1400 audit(1603608048.974:28): apparmor="ALLOWED" operation="open" profile="libreoffice-soffice" name="/usr/share/libdrm/amdgpu.ids" pid=2021 comm="soffice.bin" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0
[  625.360934] audit: type=1400 audit(1603608050.270:29): apparmor="ALLOWED" operation="open" profile="libreoffice-soffice" name="/usr/share/libdrm/amdgpu.ids" pid=2038 comm="soffice.bin" requested_mask="r" denied_mask="r" fsuid=1000 ouid=0
fnelr8@fnelr-8:~$ 

pas sur de tout comprendre mais ça parle de conflit et de kfd not supported…
J’aurais besoin d’un traducteur !

Dernière modification par simon34 (Le 25/10/2020, à 15:11)


Xubuntu 20.04 LTS sur plusieurs PC et portables, et Ubuntu Studio 20.04 sur un portable

Hors ligne

#13 Le 25/10/2020, à 15:08

simon34

Re : [résolu] problème affichage du bureau

toujours en suivant cette page https://linuxconfig.org/amd-radeon-ubun … stallation
J’ai ajouté le PPA suivant et faire un upgrade

sudo add-apt-repository ppa:oibaf/graphics-drivers
sudo apt update && sudo apt -y upgrade

redémarré et... toujours aucun changement

Dernière modification par simon34 (Le 25/10/2020, à 15:11)


Xubuntu 20.04 LTS sur plusieurs PC et portables, et Ubuntu Studio 20.04 sur un portable

Hors ligne

#14 Le 25/10/2020, à 16:16

xubu1957

Re : [résolu] problème affichage du bureau


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#15 Le 26/10/2020, à 07:13

simon34

Re : [résolu] problème affichage du bureau

voici ce que ça donne :

fnelr8@fnelr-8:~$ sudo lshw -c display
[sudo] Mot de passe de fnelr8 : 
  *-display                 
       description: VGA compatible controller
       produit: Stoney [Radeon R2/R3/R4/R5 Graphics]
       fabricant: Advanced Micro Devices, Inc. [AMD/ATI]
       identifiant matériel: 1
       information bus: pci@0000:00:01.0
       version: ea
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration : driver=amdgpu latency=0
       ressources : irq:32 mémoire:e0000000-efffffff mémoire:f0000000-f07fffff portE/S:1000(taille=256) mémoire:f0c00000-f0c3ffff mémoire:c0000-dffff
fnelr8@fnelr-8:~$ 

Quelqu'un avait le meme problème que moi : https://askubuntu.com/questions/1071343 … phics-card
Radeon R2/R3/R4/R5 Graphics n'est pas un nom de carte valide...

et si j'en crois cette discussion https://www.reddit.com/r/Amd/comments/b … for_linux/, mieux vaut éviter Radeon sous linux...

Dernière modification par simon34 (Le 26/10/2020, à 07:37)


Xubuntu 20.04 LTS sur plusieurs PC et portables, et Ubuntu Studio 20.04 sur un portable

Hors ligne

#16 Le 26/10/2020, à 07:15

xubu1957

Re : [résolu] problème affichage du bureau

Bonjour,

Montre aussi :

dpkg -l | grep -v ^ii

_ _ _

Regarde cette réponse > [RESOLU] 2 écrans avec 2 résolutions et 2 échelles différentes

Dernière modification par xubu1957 (Le 26/10/2020, à 07:23)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#17 Le 26/10/2020, à 07:55

simon34

Re : [résolu] problème affichage du bureau

Bonjour
voici :

fnelr8@fnelr-8:~$ dpkg -l | grep -v ^ii
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                                   Version                               Architecture Description
+++-=====================================-=====================================-============-=======================================================================================================================
fnelr8@fnelr-8:~$ 

Xubuntu 20.04 LTS sur plusieurs PC et portables, et Ubuntu Studio 20.04 sur un portable

Hors ligne

#18 Le 26/10/2020, à 08:12

simon34

Re : [résolu] problème affichage du bureau

il n'y a pas grand chose dans Paramètres > affichage (paramètres et disposition des écrans)
et notamment il n'y a pas de modes "mise à l'échelle fractionnaire" ou "joindre les écrans" ou du moins ce n'est pas explicite, il y a une fenetre avec un schéma des écrans qu'on peut déplacer à la souris, et s'ils sont l'un sur l'autre, l'image est tronquée sur l'écran du portable, et s'ils sont cote à cote, l'image est correcte sur l'écran du portable. Mais dès que je débranche l'écran secondaire, c'est toujours brouillé...


Xubuntu 20.04 LTS sur plusieurs PC et portables, et Ubuntu Studio 20.04 sur un portable

Hors ligne

#19 Le 26/10/2020, à 08:35

xubu1957

Re : [résolu] problème affichage du bureau

Je trouve ces pages :

> github.com/RadeonOpenCompute/ROCm/issues/259

> github.com/RadeonOpenCompute/ROCm/issues/539

Il semble y avoir une relation avec le CPU.  Mais ce n'est pas dans mes compétences.

cat /proc/cpuinfo

_ _ _

Montre aussi :

dmesg | grep "amdgpu\|drm"

repris dans > [Solved] Radeon RX 5700 XT, freezes when starting Xorg

Dernière modification par xubu1957 (Le 26/10/2020, à 08:59)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#20 Le 26/10/2020, à 09:23

simon34

Re : [résolu] problème affichage du bureau

voilà

fnelr8@fnelr-8:~$ cat /proc/cpuinfo
processor	: 0
vendor_id	: AuthenticAMD
cpu family	: 21
model		: 112
model name	: AMD A6-9225 RADEON R4, 5 COMPUTE CORES 2C+3G
stepping	: 0
microcode	: 0x6006705
cpu MHz		: 1748.394
cache size	: 1024 KB
physical id	: 0
siblings	: 2
core id		: 0
cpu cores	: 2
apicid		: 16
initial apicid	: 0
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm constant_tsc rep_good acc_power nopl nonstop_tsc cpuid extd_apicid aperfmperf pni pclmulqdq monitor ssse3 fma cx16 sse4_1 sse4_2 movbe popcnt aes xsave avx f16c lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs xop skinit wdt lwp fma4 tce nodeid_msr tbm perfctr_core perfctr_nb bpext ptsc mwaitx cpb hw_pstate ssbd ibpb vmmcall fsgsbase bmi1 avx2 smep bmi2 xsaveopt arat npt lbrv svm_lock nrip_save tsc_scale vmcb_clean flushbyasid decodeassists pausefilter pfthreshold avic v_vmsave_vmload vgif overflow_recov
bugs		: fxsave_leak sysret_ss_attrs null_seg spectre_v1 spectre_v2 spec_store_bypass
bogomips	: 5190.20
TLB size	: 1536 4K pages
clflush size	: 64
cache_alignment	: 64
address sizes	: 48 bits physical, 48 bits virtual
power management: ts ttp tm 100mhzsteps hwpstate cpb eff_freq_ro acc_power [13]

processor	: 1
vendor_id	: AuthenticAMD
cpu family	: 21
model		: 112
model name	: AMD A6-9225 RADEON R4, 5 COMPUTE CORES 2C+3G
stepping	: 0
microcode	: 0x6006705
cpu MHz		: 1802.199
cache size	: 1024 KB
physical id	: 0
siblings	: 2
core id		: 1
cpu cores	: 2
apicid		: 17
initial apicid	: 1
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm constant_tsc rep_good acc_power nopl nonstop_tsc cpuid extd_apicid aperfmperf pni pclmulqdq monitor ssse3 fma cx16 sse4_1 sse4_2 movbe popcnt aes xsave avx f16c lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs xop skinit wdt lwp fma4 tce nodeid_msr tbm perfctr_core perfctr_nb bpext ptsc mwaitx cpb hw_pstate ssbd ibpb vmmcall fsgsbase bmi1 avx2 smep bmi2 xsaveopt arat npt lbrv svm_lock nrip_save tsc_scale vmcb_clean flushbyasid decodeassists pausefilter pfthreshold avic v_vmsave_vmload vgif overflow_recov
bugs		: fxsave_leak sysret_ss_attrs null_seg spectre_v1 spectre_v2 spec_store_bypass
bogomips	: 5190.20
TLB size	: 1536 4K pages
clflush size	: 64
cache_alignment	: 64
address sizes	: 48 bits physical, 48 bits virtual
power management: ts ttp tm 100mhzsteps hwpstate cpb eff_freq_ro acc_power [13]

fnelr8@fnelr-8:~$ 

et

fnelr8@fnelr-8:~$ dmesg | grep "amdgpu\|drm"
[    1.786201] systemd[1]: Starting Load Kernel Module drm...
[    1.822458] systemd[1]: modprobe@drm.service: Succeeded.
[    1.822823] systemd[1]: Finished Load Kernel Module drm.
[    3.090083] [drm] amdgpu kernel modesetting enabled.
[    3.096146] amdgpu 0000:00:01.0: remove_conflicting_pci_framebuffers: bar 0: 0xe0000000 -> 0xefffffff
[    3.096149] amdgpu 0000:00:01.0: remove_conflicting_pci_framebuffers: bar 2: 0xf0000000 -> 0xf07fffff
[    3.096151] amdgpu 0000:00:01.0: remove_conflicting_pci_framebuffers: bar 5: 0xf0c00000 -> 0xf0c3ffff
[    3.096154] fb0: switching to amdgpudrmfb from EFI VGA
[    3.100622] amdgpu 0000:00:01.0: vgaarb: deactivate vga console
[    3.101298] [drm] initializing kernel modesetting (STONEY 0x1002:0x98E4 0x17AA:0x3F1A 0xEA).
[    3.120445] [drm] register mmio base: 0xF0C00000
[    3.120448] [drm] register mmio size: 262144
[    3.120457] [drm] add ip block number 0 <vi_common>
[    3.120458] [drm] add ip block number 1 <gmc_v8_0>
[    3.120459] [drm] add ip block number 2 <cz_ih>
[    3.120460] [drm] add ip block number 3 <gfx_v8_0>
[    3.120461] [drm] add ip block number 4 <sdma_v3_0>
[    3.120462] [drm] add ip block number 5 <powerplay>
[    3.120464] [drm] add ip block number 6 <dm>
[    3.120465] [drm] add ip block number 7 <uvd_v6_0>
[    3.120465] [drm] add ip block number 8 <vce_v3_0>
[    3.120467] [drm] add ip block number 9 <acp_ip>
[    3.120471] amdgpu 0000:00:01.0: kfd not supported on this ASIC
[    3.120541] [drm] UVD is enabled in physical mode
[    3.120543] [drm] VCE enabled in VM mode
[    3.120597] [drm] vm size is 64 GB, 2 levels, block size is 10-bit, fragment size is 9-bit
[    3.120604] amdgpu 0000:00:01.0: VRAM: 1024M 0x000000F400000000 - 0x000000F43FFFFFFF (1024M used)
[    3.120606] amdgpu 0000:00:01.0: GART: 1024M 0x000000FF00000000 - 0x000000FF3FFFFFFF
[    3.120610] [drm] Detected VRAM RAM=1024M, BAR=1024M
[    3.120611] [drm] RAM width 64bits UNKNOWN
[    3.131625] [drm] amdgpu: 1024M of VRAM memory ready
[    3.131629] [drm] amdgpu: 3072M of GTT memory ready.
[    3.131658] [drm] GART: num cpu pages 262144, num gpu pages 262144
[    3.131696] [drm] PCIE GART of 1024M enabled (table at 0x000000F400401000).
[    3.185161] amdgpu: [powerplay] hwmgr_sw_init smu backed is smu8_smu
[    3.186919] [drm] Found UVD firmware Version: 1.43 Family ID: 15
[    3.186940] [drm] UVD ENC is disabled
[    3.194395] [drm] Found VCE firmware Version: 52.0 Binary ID: 3
[    3.391190] [drm] DM_PPLIB: values for Engine clock
[    3.391194] [drm] DM_PPLIB:	 200000
[    3.391194] [drm] DM_PPLIB:	 300000
[    3.391195] [drm] DM_PPLIB:	 400000
[    3.391196] [drm] DM_PPLIB:	 464520
[    3.391196] [drm] DM_PPLIB:	 514290
[    3.391197] [drm] DM_PPLIB:	 576000
[    3.391197] [drm] DM_PPLIB:	 654550
[    3.391197] [drm] DM_PPLIB:	 685720
[    3.391199] [drm] DM_PPLIB: Validation clocks:
[    3.391199] [drm] DM_PPLIB:    engine_max_clock: 68572
[    3.391200] [drm] DM_PPLIB:    memory_max_clock: 106600
[    3.391201] [drm] DM_PPLIB:    level           : 8
[    3.391203] [drm] DM_PPLIB: values for Display clock
[    3.391203] [drm] DM_PPLIB:	 300000
[    3.391204] [drm] DM_PPLIB:	 400000
[    3.391204] [drm] DM_PPLIB:	 496560
[    3.391205] [drm] DM_PPLIB:	 626090
[    3.391205] [drm] DM_PPLIB:	 685720
[    3.391205] [drm] DM_PPLIB:	 757900
[    3.391206] [drm] DM_PPLIB:	 800000
[    3.391206] [drm] DM_PPLIB:	 847060
[    3.391207] [drm] DM_PPLIB: Validation clocks:
[    3.391208] [drm] DM_PPLIB:    engine_max_clock: 68572
[    3.391208] [drm] DM_PPLIB:    memory_max_clock: 106600
[    3.391208] [drm] DM_PPLIB:    level           : 8
[    3.391210] [drm] DM_PPLIB: values for Memory clock
[    3.391210] [drm] DM_PPLIB:	 667000
[    3.391210] [drm] DM_PPLIB:	 1066000
[    3.391211] [drm] DM_PPLIB: Validation clocks:
[    3.391211] [drm] DM_PPLIB:    engine_max_clock: 68572
[    3.391212] [drm] DM_PPLIB:    memory_max_clock: 106600
[    3.391212] [drm] DM_PPLIB:    level           : 8
[    3.428368] [drm] Display Core initialized with v3.2.48!
[    3.428622] snd_hda_intel 0000:00:01.1: bound 0000:00:01.0 (ops amdgpu_dm_audio_component_bind_ops [amdgpu])
[    3.446045] [drm] SADs count is: -2, don't need to read it
[    3.474331] [drm] SADs count is: -2, don't need to read it
[    3.475874] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[    3.475876] [drm] Driver supports precise vblank timestamp query.
[    3.503248] [drm] UVD initialized successfully.
[    3.604199] [drm] VCE initialized successfully.
[    3.607958] [drm] fb mappable at 0x1DF86F000
[    3.607961] [drm] vram apper at 0x1DF000000
[    3.607962] [drm] size 5324800
[    3.607963] [drm] fb depth is 24
[    3.607963] [drm]    pitch is 5888
[    3.608751] fbcon: amdgpudrmfb (fb0) is primary device
[    3.608866] amdgpu 0000:00:01.0: fb0: amdgpudrmfb frame buffer device
[    3.668207] [drm] Initialized amdgpu 3.35.0 20150101 for 0000:00:01.0 on minor 0
[ 3827.063128] [drm] SADs count is: -2, don't need to read it
[ 5037.306793] [drm] SADs count is: -2, don't need to read it
fnelr8@fnelr-8:~$ 

Xubuntu 20.04 LTS sur plusieurs PC et portables, et Ubuntu Studio 20.04 sur un portable

Hors ligne

#21 Le 26/10/2020, à 11:55

simon34

Re : [résolu] problème affichage du bureau

je me suis fait une clé multisystem et j'ai essayé (sans installer) :
- mate : même problème y compris quand je branche l'autre écran (obligé d'éteindre brutalement l'ordinateur)
- ubuntu studio : même problème y compris quand je branche l'autre écran (obligé d'éteindre brutalement l'ordinateur)
- xubuntu  : en session live le branchement du second écran ne résoud pas le pb d'affichage (obligé d'éteindre brutalement l'ordinateur)

Dernière modification par simon34 (Le 27/10/2020, à 09:10)


Xubuntu 20.04 LTS sur plusieurs PC et portables, et Ubuntu Studio 20.04 sur un portable

Hors ligne

#22 Le 26/10/2020, à 14:47

simon34

Re : [résolu] problème affichage du bureau

Avec une vieille clé d'installation d'Xubuntu 18.04 j'ai réinstallé cette ancienne version. Et là, pas de problème d'affichage !
Donc il y a bien une régression avec la 20.04...


Xubuntu 20.04 LTS sur plusieurs PC et portables, et Ubuntu Studio 20.04 sur un portable

Hors ligne

#23 Le 26/10/2020, à 17:41

zephirin

Re : [résolu] problème affichage du bureau

Problème de driver dans le noyau ?


Si ça marche restes en là.


AIO tactile 27" Samsung  i5 8GB DDR3 W10 - tour Antec Asus P5GCMX1333 W10
iMac 27" fin 2009 i5 750 16GBssd2TB cg512HighSierra - 2 MacBookAir 13" 2014 & 2017 i5 8GB ssd120 Big Sur - Macmini i7 2,3GHz mi 2012 - 16GB ddr3 ssd1TB Catalina écran 27" - MacBookPro mi 2012 8GB DDR3 Catalina
Tour Gam i5  overclocké 4,4GHz 16GB ddr3 ssd1T GTX1060 6GB W10  27"
Dell Optiplex SX280 P IV 2.8 2GB Xub 18.04 32bit

Hors ligne

#24 Le 27/10/2020, à 08:45

simon34

Re : [résolu] problème affichage du bureau

Bonjour
je n'ai pas trop le choix à vrai dire, mais ça ne me satisfait pas étant donné que c'est un PC tout neuf censé être compatible avec Linux... En plus la 18.04 n'est plus maintenue désormais...
j'aimerais bien comprendre l'origine du problème et savoir s'il y a une chance qu'il soit résolu dans l'avenir, ou si je rapporte le PC au vendeur en lui demandant de me fournir un matériel vraiment compatible avec Linux. Mais dans ce cas il faudrait que je comprenne exactement ce qui cloche.
J'aimerais aussi faire remonter le problème aux développeurs, mais je ne sais pas trop quoi leur dire sur le plan technique


Xubuntu 20.04 LTS sur plusieurs PC et portables, et Ubuntu Studio 20.04 sur un portable

Hors ligne

#25 Le 27/10/2020, à 08:49

xubu1957

Re : [résolu] problème affichage du bureau

Bonjour,

simon34 a écrit :

En plus la 18.04 n'est plus maintenue désormais...

Support jusqu'en avril 2021, pour Xubuntu > § 0.0.1 bionic#periode_de_maintenance


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne